PDA

View Full Version : How to uninstall vncserver on SUSE Server?



gorrilv
12-Dec-2016, 12:02
Hi Forum,

Please give me a hint where to post this question if it is not SAP-spesific for this forum.

I have an Azure server With SUSE Linux SLES 11 SP4, for SAP Solution Manager on SAP HANA.
I am not able to Connect to the server With xrdp any longer, probably because I installed vncserver, which interfers With the interaction of xrdp and tightvnc. I am far from experienced in SUSE, so I hope you will bear over With the mistakes I've made, and help me get xrdp to work again.

Originally xrdp and vnc was installed like this:
sudo /usr/bin/zypper install thightvnc

Refreshing service 'cloud_update'.
Loading repository data...
Reading installed packages...
'vnc' not found in package names. Trying capabilities.
Resolving package dependencies...

The following NEW package is going to be installed:
tightvnc

1 new package to install.
Overall download size: 222.0 KiB. After the operation, additional 587.0 KiB
will be used.
Continue? [y/n/? shows all options] (y): y
Retrieving package tightvnc-1.3.9-81.15.1.x86_64 (1/1), 222.0 KiB (587.0 KiB unpacked)
Retrieving: tightvnc-1.3.9-81.15.1.x86_64.rpm [done]
Installing: tightvnc-1.3.9-81.15.1 [done]
Starting xrdp to be able to run x:
sudo /etc/init.d/xrdp start

Had to add an endpoint in Azure portal on port 3389. Tried to connect to the port sapssb5681.cloudapp.net:3389 from rdp client and logged in as sapadm.
Since we are having some issues with the TWM window manager, we install gnome-session with the following command:
sudo /usr/bin/zypper install gnome-session
Refreshing service 'cloud_update'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW packages are going to be installed:
gnome-session gnome-session-lang

2 new packages to install.
Overall download size: 466.0 KiB. After the operation, additional 1.7 MiB will
be used.
Continue? [y/n/? shows all options] (y): y
Retrieving package gnome-session-lang-2.28.0-3.11.9.x86_64 (1/2), 224.0 KiB (977.0 KiB unpacked)
Retrieving: gnome-session-lang-2.28.0-3.11.9.x86_64.rpm [done]
Retrieving package gnome-session-2.28.0-3.11.9.x86_64 (2/2), 242.0 KiB (742.0 KiB unpacked)
Retrieving: gnome-session-2.28.0-3.11.9.x86_64.rpm [done]
Installing: gnome-session-lang-2.28.0-3.11.9 [done]
Installing: gnome-session-2.28.0-3.11.9 [done]


Then I attempted to install vncserver (thought it would be wise to have it in Place in case SAP Support needed to Connect). Unfortunately, I did it like this:

Downloaded https://www.realvnc.com/download/vnc/linux/VNC-5.3.2-Linux-x64-ANY.tar.gz and copied to /tmp.
As user root (sudo su – root) unpacked the file to /tmp:
gunzip VNC-5.3.2-Linux-x64-ANY.tar.gz
tar xvf VNC-5.3.2-Linux-x64-ANY.tar

Installed VNC Server:
./vncinstall
...
Installed init script for VNC Server in Service Mode daemon
Start and stop the service with:
/etc/init.d/vncserver-x11-serviced (start|stop)
Use chkconfig to start or stop the service at boot time.

Installed init script for VNC Server in Virtual Mode daemon
Start and stop the service with:
/etc/init.d/vncserver-virtuald (start|stop)
Use chkconfig to start or stop the service at boot time.

Set VNC Server to start at server start:
sapssb:/tmp/VNC-5.3.2-Linux-x64 # chkconfig vncserver-virtuald
vncserver-virtuald off
sapssb:/tmp/VNC-5.3.2-Linux-x64 # chkconfig vncserver-virtuald on
insserv: Service network is missed in the runlevels 4 to use service omid
insserv: Service syslog is missed in the runlevels 4 to use service vncserver-virtuald
sapssb:/tmp/VNC-5.3.2-Linux-x64 # chkconfig vncserver-virtuald
vncserver-virtuald on

I have not been able to uninstall this Component. I have tried the ubuntu way (http://askubuntu.com/questions/653321/how-to-uninstall-real-vnc-in-ubuntu-14-04), but it did not work to install deb and use dpkg to uninstall. I cannot use rpm either.

I have tried turning vncserver off and reboot server:
chkconfig vncserver-virtuald off
But unfortunately, this is not enough to get xrdp to start working again.

Error when logging on to xrdp (manual transcription):

Connection Log
connecting to sesman ip 127.0.0.1 port 3350
sesman Connect ok
sending login info to session manager, please wait...
xrdp_mm_process_login_response: login successful for displa(...)
started connecting
Connection to 127.0.0.1 5910
error - problem Connecting

Kind regards,
Gørril

smflood
13-Dec-2016, 19:25
On 12/12/16 11:04, gorrilv wrote:

> Please give me a hint where to post this question if it is not
> SAP-spesific for this forum.
>
> I have an Azure server With SUSE Linux SLES 11 SP4, for SAP Solution
> Manager on SAP HANA.
> I am not able to Connect to the server With xrdp any longer, probably
> because I installed vncserver, which interfers With the interaction of
> xrdp and tightvnc. I am far from experienced in SUSE, so I hope you will
> bear over With the mistakes I've made, and help me get xrdp to work
> again.

I thought RDP and VNC used different ports so not sure why one would
impact on the other but ...

> Originally xrdp and vnc was installed like this:
> sudo /usr/bin/zypper install thightvnc
>
> Refreshing service 'cloud_update'.
> Loading repository data...
> Reading installed packages...
> 'vnc' not found in package names. Trying capabilities.
> Resolving package dependencies...
>
> The following NEW package is going to be installed:
> tightvnc
>
> 1 new package to install.
> Overall download size: 222.0 KiB. After the operation, additional 587.0
> KiB
> will be used.
> Continue? [y/n/? shows all options] (y): y
> Retrieving package tightvnc-1.3.9-81.15.1.x86_64 (1/1), 222.0 KiB (587.0
> KiB unpacked)
> Retrieving: tightvnc-1.3.9-81.15.1.x86_64.rpm [done]
> Installing: tightvnc-1.3.9-81.15.1 [done]
> Starting xrdp to be able to run x:
> sudo /etc/init.d/xrdp start
>
> Had to add an endpoint in Azure portal on port 3389. Tried to connect to
> the port sapssb5681.cloudapp.net:3389 from rdp client and logged in as
> sapadm.
> Since we are having some issues with the TWM window manager, we install
> gnome-session with the following command:
> sudo /usr/bin/zypper install gnome-session
> Refreshing service 'cloud_update'.
> Loading repository data...
> Reading installed packages...
> Resolving package dependencies...
>
> The following NEW packages are going to be installed:
> gnome-session gnome-session-lang
>
> 2 new packages to install.
> Overall download size: 466.0 KiB. After the operation, additional 1.7
> MiB will
> be used.
> Continue? [y/n/? shows all options] (y): y
> Retrieving package gnome-session-lang-2.28.0-3.11.9.x86_64 (1/2), 224.0
> KiB (977.0 KiB unpacked)
> Retrieving: gnome-session-lang-2.28.0-3.11.9.x86_64.rpm [done]
> Retrieving package gnome-session-2.28.0-3.11.9.x86_64 (2/2), 242.0 KiB
> (742.0 KiB unpacked)
> Retrieving: gnome-session-2.28.0-3.11.9.x86_64.rpm [done]
> Installing: gnome-session-lang-2.28.0-3.11.9 [done]
> Installing: gnome-session-2.28.0-3.11.9 [done]
>
>
> Then I attempted to install vncserver (thought it would be wise to have
> it in Place in case SAP Support needed to Connect). Unfortunately, I did
> it like this:
>
> Downloaded
> https://www.realvnc.com/download/vnc/linux/VNC-5.3.2-Linux-x64-ANY.tar.gz
> and copied to /tmp.
> As user root (sudo su � root) unpacked the file to /tmp:
> gunzip VNC-5.3.2-Linux-x64-ANY.tar.gz
> tar xvf VNC-5.3.2-Linux-x64-ANY.tar
>
> Installed VNC Server:
> ./vncinstall
> ...
> Installed init script for VNC Server in Service Mode daemon
> Start and stop the service with:
> /etc/init.d/vncserver-x11-serviced (start|stop)
> Use chkconfig to start or stop the service at boot time.
>
> Installed init script for VNC Server in Virtual Mode daemon
> Start and stop the service with:
> /etc/init.d/vncserver-virtuald (start|stop)
> Use chkconfig to start or stop the service at boot time.
>
> Set VNC Server to start at server start:
> sapssb:/tmp/VNC-5.3.2-Linux-x64 # chkconfig vncserver-virtuald
> vncserver-virtuald off
> sapssb:/tmp/VNC-5.3.2-Linux-x64 # chkconfig vncserver-virtuald on
> insserv: Service network is missed in the runlevels 4 to use service
> omid
> insserv: Service syslog is missed in the runlevels 4 to use service
> vncserver-virtuald
> sapssb:/tmp/VNC-5.3.2-Linux-x64 # chkconfig vncserver-virtuald
> vncserver-virtuald on
>
> I have not been able to uninstall this Component. I have tried the
> ubuntu way
> (http://askubuntu.com/questions/653321/how-to-uninstall-real-vnc-in-ubuntu-14-04),
> but it did not work to install deb and use dpkg to uninstall. I cannot
> use rpm either.

Since you didn't install RealVNC server via deb or rpm you can't remove
a deb or rpm.

What you'll need to do is unpick what the vncinstall script did. Please
can you post the output from 'ls -lart /usr/bin/*vnc* /usr/lib/vnc
/usr/share/man/*vnc* /usr/share/vnc /usr/lib/cups/vnc' and 'rpm -qa *vnc*'.

> I have tried turning vncserver off and reboot server:
> chkconfig vncserver-virtuald off
> But unfortunately, this is not enough to get xrdp to start working
> again.
>
> Error when logging on to xrdp (manual transcription):
>
> Connection Log
> connecting to sesman ip 127.0.0.1 port 3350
> sesman Connect ok
> sending login info to session manager, please wait...
> xrdp_mm_process_login_response: login successful for displa(...)
> started connecting
> Connection to 127.0.0.1 5910
> error - problem Connecting

I think first thing is to remove the RealVNC server software you
installed by hand. Then we can review what is or isn't working.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------