PDA

View Full Version : SLES 11 SP4 Issue Using Zypper Update on ESXI 6.0



william1
15-Dec-2016, 15:41
Hi,

I did a new install of SLES 11 SP4. After running command
zypper addrepo http://download.opensuse.org/distribution/11.4/repo/oss/ oss to add the repo, I run into errors when using command zypper update. Below is the section when the error happens


Installing: libmpc2-0.8.2-9.1 [done]
Installing: lockdev-1.0.3_git201003141408-7.1 [error]
Installation of lockdev-1.0.3_git201003141408-7.1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Usage: chkstat [--set] [--noheader] [[--examine file] ...] [ [--files filelist] ...] permission-file ...
error: %post(lockdev-1.0.3_git201003141408-7.1.x86_64) scriptlet failed, exit status 1


Abort, retry, ignore? [a/r/i] (a):




Im currently running the OS in ESXI 6.0. Would you know what would cause the above issue?

Regards,


William

malcolmlewis
15-Dec-2016, 16:16
On Thu 15 Dec 2016 02:44:01 PM CST, william1 wrote:

Hi,

I did a new install of SLES 11 SP4. After running command
zypper addrepo http://download.opensuse.org/distribution/11.4/repo/oss/
oss to add the repo, I run into errors when using command zypper update.
Below is the section when the error happens


Installing: libmpc2-0.8.2-9.1 [done]
Installing: lockdev-1.0.3_git201003141408-7.1 [error]
Installation of lockdev-1.0.3_git201003141408-7.1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed:
Usage: chkstat [--set] [--noheader] [[--examine file] ...] [ [--files
filelist] ...] permission-file ...
error: %post(lockdev-1.0.3_git201003141408-7.1.x86_64) scriptlet failed,
exit status 1


Abort, retry, ignore? [a/r/i] (a):




I_m currently running the OS in ESXI 6.0. Would you know what would
cause the above issue?

Regards,


William




Hi
The openSUSE 11.4 release is NOT the same as SLES 11 SP4 and will break
your system as you have discovered, remove the repo ;)

If you register the system with a registration code it will add the
online repositories....

You can always grab a free 60 day eval code?

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-41-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

william1
15-Dec-2016, 16:41
Thank you malcolmlewis for share your response.