PDA

View Full Version : Raspberry wifi setup issue



asodhi
03-Jan-2017, 14:50
Hi Team,

I am trying to setup wifi network for my raspberry pi.

After this setup:
hciattach /dev/ttyAMA0 bcm43xx 921600
bcm43xx_init
Flash firmware /lib/firmware/BCM43430A1.hcd
Set Controller UART speed to 921600 bit/s
Device setup complete

After hciconfig hci0 up
Hcitool scan shows scanning....

doesn't show anything.

Kindly suggest.

cheers,
Ashish

smflood
03-Jan-2017, 16:03
On 03/01/17 13:54, asodhi wrote:

> I am trying to setup wifi network for my raspberry pi.
>
> After this setup:
> hciattach /dev/ttyAMA0 bcm43xx 921600
> bcm43xx_init
> Flash firmware /lib/firmware/BCM43430A1.hcd
> Set Controller UART speed to 921600 bit/s
> Device setup complete
>
> After hciconfig hci0 up
> Hcitool scan shows scanning....
>
> doesn't show anything.

Since your first line enables the Bluetooth controller are you trying to
set up a wireless (not wifi) network over Bluetooth?

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

malcolmlewis
03-Jan-2017, 16:10
On Tue 03 Jan 2017 01:54:02 PM CST, asodhi wrote:

Hi Team,

I am trying to setup wifi network for my raspberry pi.

After this setup:
hciattach /dev/ttyAMA0 bcm43xx 921600
bcm43xx_init
Flash firmware /lib/firmware/BCM43430A1.hcd
Set Controller UART speed to 921600 bit/s
Device setup complete

After hciconfig hci0 up
Hcitool scan shows scanning....

doesn't show anything.

Kindly suggest.

cheers,
Ashish




Hi
The device your trying to connect to via bluetooth is discoverable?

I tested here and works fine...



hciattach /dev/ttyAMA0 bcm43xx 921600
bcm43xx_init
Flash firmware /lib/firmware/BCM43430A1.hcd
Set Controller UART speed to 921600 bit/s
Device setup complete

hciconfig hci0 up

hciconfig
hci0: Type: BR/EDR Bus: UART
BD Address: XX:XX:XX:XX:XX:XX ACL MTU: 1021:8 SCO MTU: 64:1
UP RUNNING PSCAN
RX bytes:1357 acl:0 sco:0 events:73 errors:0
TX bytes:1185 acl:0 sco:0 commands:73 errors:0

hcitool scan
Scanning ...
58:A2:XX:XX:XX:XX LG Phone
A0:02:XX:XX:XX:XX Fire HD
68:96:XX:XX:XX:XX iPhone 5S


--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-41-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

asodhi
03-Jan-2017, 17:30
Hi Simon,

Thanks for your reply.

I am new to raspberry Pi.
I am trying to setup my wireless network adapter to connect to wifi network.
Please suggest

cheers,
Ashish

malcolmlewis
03-Jan-2017, 22:38
On Tue 03 Jan 2017 04:34:02 PM CST, asodhi wrote:

Hi Simon,

Thanks for your reply.

I am new to raspberry Pi.
I am trying to setup my wireless network adapter to connect to wifi
network.
Please suggest

cheers,
Ashish




Hi
Are you running the desktop, or just from the command line?

If the desktop, there should be an icon on the panel to click and show
network connections?

Else if using wicked, rather than NetworkManager then this can be
configure via the tool called YaST, then select System and then Network
Settings, here you should see you wireless device and can edit it from
here...

http://thumbnails117.imagebam.com/52430/030091524297524.jpg (http://www.imagebam.com/image/030091524297524)

http://thumbnails117.imagebam.com/52430/bbb757524297526.jpg (http://www.imagebam.com/image/bbb757524297526)

http://thumbnails117.imagebam.com/52430/9b437f524297527.jpg (http://www.imagebam.com/image/9b437f524297527)

http://thumbnails117.imagebam.com/52430/a2b322524297528.jpg (http://www.imagebam.com/image/a2b322524297528)

http://thumbnails117.imagebam.com/52430/37d885524297530.jpg (http://www.imagebam.com/image/37d885524297530)

Also note if not using dhcp, you do need to set the hostname/dns
servers and also the default gateway. If not using ipv6, then suggest
disabling from the 'global' tab.

I use the command line and yast, in the desktop GUI it's called YaST2.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

asodhi
04-Jan-2017, 15:18
Hi Malcolm,

I am using the desktop (GUI) and it is showing "network service disabled" and I am not able to see any option to choose the wireless networks there

please suggest

malcolmlewis
04-Jan-2017, 15:41
Hi Malcolm,

I am using the desktop (GUI) and it is showing "network service disabled" and I am not able to see any option to choose the wireless networks there

please suggest
Hi
So start up YaST and get to the network settings as indicated above, then in the 'Global' tab select the NetworkManager option as opposed to wicked service. I'm guessing in the first tab that opens you see both devices present?

asodhi
05-Jan-2017, 14:19
Hi Malcolm,

Yes, I see both the devices in the network tab
220

However in the GUI it only shows "Network service disabled" there is no icon to make this service enabled.

I am able to connect to the network through wired connection but no icon to enable wifi

Please suggest.

malcolmlewis
05-Jan-2017, 19:36
Hi
So if you click onthe tab to the left of 'overview' Global Settings, is it wicked or Network Manager, if wicked, select Network Manager, save and check your settings again on the GUI.