View Full Version : Evolution - EWS - not stable

21-Jan-2017, 22:28
Connection to Exchange seems to be not stable, depending on updates etc. You can find issues thourgh the years. Even it is a great tool - not in doubt, for professional use it need to be stable.

My problem seems to either be suddently solved or temporary not stable. I think it happens after update.

It seems this solution worked.
Thanks for a bug report. I think this is related to changes in [1], though the effect should be to show more items, rather than less. Could you try the following test, please? The bug depends on server content, thus it might not be visible for other users. Test steps:
a) close evolution
b) go to
where are stored all your remote calendars (those from EWS and maybe others,
if you've configured more. Delete the cache folder for the EWS calendar,
thus it'll refetch all your calendar items from scratch, or delete just
the keys.xml file from respective folder(s). The EWS folders can be recognized
by a long subfolder name, similar to message IDs in mailer, if you ever
noticed (those in "Receiving message ...").
c) open a terminal and run there this command:
$ EWS_DEBUG=2 /usr/libexec/evolution-calendar-factory -w &>log.txt
The process should be closed before b) ideally, but if you run gnome-shell,
then it's not possible, because it'll run the evolution-calendar-factory
process automatically.
d) Run evolution, switch to calendar and check what you'll see when the fetch
is done.
e) When it seems done, close evolution again, and then stop the factory from
step c), by pressing Ctrl+C. If there are missing any events, the log.txt
file will show them or why they are missing, thus check its content and search
for a meeting summary you miss, whether it's there or not. Note the log.txt
file will be larger during fetching, thus you can check whether it's done
also by its size changes.

Note the log contains RAW communication between evolution and the Exchange server, and even it doesn't expose your server password, then it shows all the private information like the server address and all the items it found. It is not good to share it in public, but please keep it, in case of more information needed from it.

Thanks in advance.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=670217
.................................................. .................................................. .................................................. ...............
I did this - cleaned the cache and now it seems to work again.

Automatic Reply
27-Jan-2017, 06:30

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- Open a service request: https://www.suse.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot..

Good luck!

Your SUSE Forums Team

28-Jan-2017, 21:27
...no, I use it to support others that may search for help and stor my own experiences. So, don't worry