PDA

View Full Version : SUSE Manager 3: virtual-host-gatherer and HTTP proxy



timstein
02-Feb-2017, 08:39
Hello,

Iím trying to get the virtual-host-gatherer up and running but as soon as I configure a HTTP proxy server via "Admin -> Setup Wizard -> HTTP Proxy" the gatherer fails with the following error:

2017-02-02 08:15:02,354 gatherer.modules.VMware - ERROR: HTTPSConnectionPool(host=HostnameRemoved', port=443): Max retries exceeded with url: //sdk/vimServiceVersions.xml (Caused by ProxyError('Cannot connect to proxy.', error('Tunnel connection failed: 502 Bad Gateway',)))
2017-02-02 08:15:02,355 gatherer.modules.VMware - ERROR: Could not connect to the specified host using specified username and password.
2017-02-02 08:15:02,356 root - WARNING: Scanning finished
Unfortunately there is no way of configuring proxy exceptions via the web interface and we need the proxy for mirroring the channels.

Any help is appreciated.

Thanks and regards
Tim

kwk
03-Feb-2017, 10:30
Proxy handling in Linux is a bit cumbersome, sorry for that.

Please also set the proxy via YaST and try again.

timstein
03-Feb-2017, 10:49
Thanks for your answer!

Please also set the proxy via YaST and try again.
I already did but unfortunately with no success.

In the meantime I found a workaround for this problem:

Disable the HTTP proxy via "Admin -> Setup Wizard -> HTTP Proxy"
Restart SUSE Manager
Enable the HTTP proxy via "Admin -> Setup Wizard -> HTTP Proxy"

This makes virtual-host-gatherer, the SCC synchronization and spacewalk-repo-sync working.

However, a solution that survives a restart/reboot would be very convenient.

timstein
03-Mar-2017, 12:40
We opened a SR at SUSE.