PDA

View Full Version : SLES 12 SP1 zypper update will not install update.



mikenash
07-Feb-2017, 20:11
Greetings, I was performing an update that ended with a message stating some packages will not be installed. I ran an update against one of the packages and received the following results. I need an explanation of the message and directions on how to proceed.
linux140:/mnt/suse/s390x # zypper update PackageKit-backend-zypp
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: PackageKit-backend-zypp-0.8.16-15.1.s390x requires libzypp.so.1519()(64bit), but this requirement cannot be provided
uninstallable providers: libzypp-15.21.1-7.1.s390x[SLES12SP1-Update]
libzypp-15.21.4-10.2.s390x[SLES12SP1-Update]
libzypp-15.22.0-19.1.s390x[SLES12SP1-Update]
libzypp-15.22.2-25.1.s390x[SLES12SP1-Update]
libzypp-15.23.1-30.1.s390x[SLES12SP1-Update]
libzypp-15.19.5-1.14.s390x[mnt]
Solution 1: Following actions will be done:
deinstallation of libyui-ncurses-pkg6-2.46.1-3.4.s390x
deinstallation of libyui-qt-pkg6-2.44.7-3.2.s390x
Solution 2: do not install PackageKit-backend-zypp-0.8.16-15.1.s390x
Solution 3: break PackageKit-backend-zypp-0.8.16-15.1.s390x by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c):

malcolmlewis
07-Feb-2017, 23:01
On Tue 07 Feb 2017 07:14:02 PM CST, mikenash wrote:

Greetings, I was performing an update that ended with a message stating
some packages will not be installed. I ran an update against one of the
packages and received the following results. I need an explanation of
the message and directions on how to proceed.
Code:
--------------------
linux140:/mnt/suse/s390x # zypper update PackageKit-backend-zypp
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: PackageKit-backend-zypp-0.8.16-15.1.s390x requires
libzypp.so.1519()(64bit), but this requirement cannot be provided
uninstallable providers: libzypp-15.21.1-7.1.s390x[SLES12SP1-Update]
libzypp-15.21.4-10.2.s390x[SLES12SP1-Update]
libzypp-15.22.0-19.1.s390x[SLES12SP1-Update]
libzypp-15.22.2-25.1.s390x[SLES12SP1-Update]
libzypp-15.23.1-30.1.s390x[SLES12SP1-Update]
libzypp-15.19.5-1.14.s390x[mnt] Solution 1: Following actions will be
done: deinstallation of libyui-ncurses-pkg6-2.46.1-3.4.s390x
deinstallation of libyui-qt-pkg6-2.44.7-3.2.s390x
Solution 2: do not install PackageKit-backend-zypp-0.8.16-15.1.s390x
Solution 3: break PackageKit-backend-zypp-0.8.16-15.1.s390x by
ignoring some of its dependencies
Choose from above solutions by number or cancel [1/2/3/c] (c):
--------------------




Hi
So [mnt] is the install media? Do you have the online pool active as
well, if so disable the install media.

You haven't changed any of the repo priorities at all, all are set to
refresh?

Also look at zypper se -t patch....
--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

mikenash
08-Feb-2017, 15:10
Greetings Malcolm, thank you for your response. On /mnt is a copy of the SLES12 SP1 repository. I also connect the SLES12 SP1 Update repository. When I drop the /mnt repository I receive 1 less package that will not be updated. I enable both repositories and they are set to refresh.
linux140:~ # zypper ref -s
All services have been refreshed.
Repository 'SLES12SP1-Update' is up to date.
Repository 'mnt' is up to date.
All repositories have been refreshed. There is a lot of output from the command "zypper se -t patch
linux140:~ # zypper se -t patch
Loading repository data...
Reading installed packages...

S | Name | Summary | Type
--+----------------------------------+---------------------------------------------------------------------------------------+------
i | SUSE-SLE-SERVER-12-SP1-2015-1001 | Security update for MozillaFirefox | patch
i | SUSE-SLE-SERVER-12-SP1-2015-1016 | Security update for bind | patch
i | SUSE-SLE-SERVER-12-SP1-2015-1022 | Security update for xfsprogs | patch
i | SUSE-SLE-SERVER-12-SP1-2015-1027 | Security update for grub2 | patch
i | SUSE-SLE-SERVER-12-SP1-2015-828 | Recommended update for avahi | patch
| SUSE-SLE-SERVER-12-SP1-2015-830 | Recommended update for cmake | patch
i | SUSE-SLE-SERVER-12-SP1-2015-846 | Security update for libsndfile | patch
| SUSE-SLE-SERVER-12-SP1-2015-857 | Recommended update for git | patch
i | SUSE-SLE-SERVER-12-SP1-2015-862 | Recommended update for acl | patch
i | SUSE-SLE-SERVER-12-SP1-2015-863 | Recommended update for tar | patch
i | SUSE-SLE-SERVER-12-SP1-2015-867 | Recommended update for libseccomp | patch
i | SUSE-SLE-SERVER-12-SP1-2015-869 | Recommended update for libksba | patch
i | SUSE-SLE-SERVER-12-SP1-2015-870 | Security update for xscreensaver | patch
| SUSE-SLE-SERVER-12-SP1-2015-890 | Security update for LibVNCServer | patch
| SUSE-SLE-SERVER-12-SP1-2015-913 | Recommended update for ImageMagick | patch
| SUSE-SLE-SERVER-12-SP1-2015-920 | Security update for java-1_7_1-ibm | patch
i | SUSE-SLE-SERVER-12-SP1-2015-922 | Security update for gpg2 | patch
| SUSE-SLE-SERVER-12-SP1-2015-934 | Security update for strongswan | patch
i | SUSE-SLE-SERVER-12-SP1-2015-946 | Security update for gdk-pixbuf | patch
i | SUSE-SLE-SERVER-12-SP1-2015-954 | Security update for openssl | patch
| SUSE-SLE-SERVER-12-SP1-2015-965 | Security update for java-1_8_0-ibm | patch
| SUSE-SLE-SERVER-12-SP1-2015-977 | Recommended update for clamav | patch
i | SUSE-SLE-SERVER-12-SP1-2015-979 | Recommended update for ntp | patch
| SUSE-SLE-SERVER-12-SP1-2015-983 | Recommended update for tgt | patch
i | SUSE-SLE-SERVER-12-SP1-2015-985 | Security update for the Linux Kernel | patch
i | SUSE-SLE-SERVER-12-SP1-2015-991 | Recommended update for libselinux | patch
i | SUSE-SLE-SERVER-12-SP1-2015-992 | Security update for krb5 | patch
i | SUSE-SLE-SERVER-12-SP1-2015-996 | Security update for ldb, samba, talloc, tdb, tevent | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1003 | Security update for MozillaFirefox, MozillaFirefox-branding-SLE, mozilla-nspr, mozi-> | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1004 | Security update for the Linux Kernel | patch
| SUSE-SLE-SERVER-12-SP1-2016-1007 | Security update for qemu | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1012 | Security update for the Linux Kernel | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1014 | Recommended update for haveged | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1017 | Recommended update for openldap2 | patch
| SUSE-SLE-SERVER-12-SP1-2016-1018 | Recommended update for libcpuset | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1021 | Security update for glibc | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1022 | Recommended update for cups | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1026 | Recommended update for timezone | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1028 | Recommended update for findutils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1029 | Recommended update for w3m | patch
| SUSE-SLE-SERVER-12-SP1-2016-1032 | Recommended update for systemtap | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1036 | Recommended update for xinit | patch
i | SUSE-SLE-SERVER-12-SP1-2016-104 | Security update for tiff | patch
| SUSE-SLE-SERVER-12-SP1-2016-1041 | Security update for ImageMagick | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1048 | Security update for dhcp | patch
| SUSE-SLE-SERVER-12-SP1-2016-1051 | Recommended update for libsolv, libzypp, zypper | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1055 | Recommended update for krb5 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1056 | Recommended update for kexec-tools | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1063 | Recommended update for yast2-network | patch
| SUSE-SLE-SERVER-12-SP1-2016-1067 | Security update for apache2 | patch
| SUSE-SLE-SERVER-12-SP1-2016-1080 | Recommended update for libica2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1083 | Recommended update for glu | patch
| SUSE-SLE-SERVER-12-SP1-2016-1084 | Recommended update for bootcycle | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1085 | Recommended update for strace | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1086 | Recommended update for crash | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1087 | Recommended update for supportutils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1090 | Recommended update for automake | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1091 | Recommended update for mozjs17 | patch
| SUSE-SLE-SERVER-12-SP1-2016-1094 | Recommended update for smt | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1095 | Recommended update for tigervnc | patch
| SUSE-SLE-SERVER-12-SP1-2016-1100 | Recommended update for ledmon | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1103 | Recommended update for aaa_base | patch
| SUSE-SLE-SERVER-12-SP1-2016-1106 | Recommended update for wayland | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1110 | Recommended update for permissions | patch
| SUSE-SLE-SERVER-12-SP1-2016-1111 | Recommended update for ipsec-tools | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1115 | Recommended update for psmisc | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1117 | Recommended update for gnome-nettool | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1123 | Security update for libarchive | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1124 | Recommended update for libxcb | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1126 | Recommended update for kmod | patch
i | SUSE-SLE-SERVER-12-SP1-2016-113 | Security update for rsync | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1138 | Recommended update for dbus-1 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-114 | Security update for bind | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1141 | Security update for sqlite3 | patch
| SUSE-SLE-SERVER-12-SP1-2016-1145 | Recommended update for openCryptoki | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1147 | Recommended update for dracut | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1149 | Recommended update for gcc48 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1150 | Recommended update for release-notes-sles | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1152 | Recommended update for binutils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1158 | Recommended update for resource-agents | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1159 | Recommended update for hwinfo | patch
| SUSE-SLE-SERVER-12-SP1-2016-1162 | Recommended update for emacs | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1166 | Recommended update for gdb | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1168 | Recommended update for aaa_base | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1169 | Recommended update for sssd | patch
i | SUSE-SLE-SERVER-12-SP1-2016-117 | Security update for libxml2 | patch
| SUSE-SLE-SERVER-12-SP1-2016-1184 | Security update for squid | patch
| SUSE-SLE-SERVER-12-SP1-2016-1186 | Security update for java-1_7_0-openjdk | patch
| SUSE-SLE-SERVER-12-SP1-2016-1187 | Security update for java-1_8_0-openjdk | patch
| SUSE-SLE-SERVER-12-SP1-2016-1192 | Recommended update for nss_ldap | patch
| SUSE-SLE-SERVER-12-SP1-2016-1193 | Recommended update for wayland | patch
| SUSE-SLE-SERVER-12-SP1-2016-1202 | Recommended update for udhcp | patch
| SUSE-SLE-SERVER-12-SP1-2016-1203 | Recommended update for python-sip | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1205 | Recommended update for rpm | patch
| SUSE-SLE-SERVER-12-SP1-2016-1208 | Security update for libvirt | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1209 | Recommended update for btrfsmaintenance | patch
i | SUSE-SLE-SERVER-12-SP1-2016-121 | Recommended update for gnome-settings-daemon | patch
| SUSE-SLE-SERVER-12-SP1-2016-1210 | Recommended update for smt | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1211 | Recommended update for grub2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1212 | Recommended update for p11-kit | patch
i | SUSE-SLE-SERVER-12-SP1-2016-122 | Recommended update for release-notes-sles | patch
| SUSE-SLE-SERVER-12-SP1-2016-1222 | Security update for ImageMagick | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1228 | Security update for libidn | patch
| SUSE-SLE-SERVER-12-SP1-2016-1239 | Security update for ctags | patch
i | SUSE-SLE-SERVER-12-SP1-2016-124 | Security update for the Linux Kernel | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1240 | Recommended update for gtk3 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1245 | Security update for python | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1246 | Security update for the Linux Kernel | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1247 | Security update for cracklib | patch
| SUSE-SLE-SERVER-12-SP1-2016-1248 | Recommended update for postgresql-init | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1252 | Recommended update for timezone | patch
| SUSE-SLE-SERVER-12-SP1-2016-1253 | Recommended update for openvpn | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1254 | Security update for MozillaFirefox | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1257 | Security update for krb5 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1258 | Recommended update for nfs-utils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1259 | Recommended update for libpcap | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1263 | Security update for dosfstools | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1267 | Security update for rsync | patch
| SUSE-SLE-SERVER-12-SP1-2016-1271 | Security update for xerces-c | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1277 | Recommended update for libbluray | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1292 | Security update for libstorage | patch
| SUSE-SLE-SERVER-12-SP1-2016-1293 | Security update for tomcat | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1294 | Security update for fontconfig | patch
| SUSE-SLE-SERVER-12-SP1-2016-130 | Recommended update for sapconf | patch
| SUSE-SLE-SERVER-12-SP1-2016-1302 | Security update for libtcnative-1-0 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1308 | Security update for mariadb | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1309 | Security update for wget | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1310 | Recommended update for apparmor | patch
| SUSE-SLE-SERVER-12-SP1-2016-1313 | Recommended update for apache2 | patch
| SUSE-SLE-SERVER-12-SP1-2016-1325 | Recommended update for fetchmail | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1326 | Security update for perl | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1327 | Recommended update for yast2-storage | patch
i | SUSE-SLE-SERVER-12-SP1-2016-133 | Recommended update for cairo | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1330 | Security update for tiff | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1331 | Recommended update for cairo | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1332 | Security update for openssh | patch
| SUSE-SLE-SERVER-12-SP1-2016-1335 | Security update for apache2-mod_nss | patch
i | SUSE-SLE-SERVER-12-SP1-2016-134 | Recommended update for aaa_base | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1342 | Recommended update for dracut | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1344 | Recommended update for kbd | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1347 | Security update for gd | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1350 | Security update for samba | patch
| SUSE-SLE-SERVER-12-SP1-2016-1351 | Security update for wpa_supplicant | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1352 | Recommended update for libspectre | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1356 | Recommended update for zypper-migration-plugin | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1358 | Optional update for gcc6 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-136 | Security update for giflib | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1362 | Recommended update for gdb | patch
| SUSE-SLE-SERVER-12-SP1-2016-1363 | Recommended update for libguestfs | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1364 | Security update for curl | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1367 | Recommended update for nfs-utils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1370 | Security update for libgcrypt | patch
| SUSE-SLE-SERVER-12-SP1-2016-1372 | Security update for java-1_7_1-ibm | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1374 | Recommended update for gconf-editor | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1375 | Recommended update for aaa_base | patch
| SUSE-SLE-SERVER-12-SP1-2016-1379 | Recommended update for ceph | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1383 | Recommended update for mutt | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1388 | Recommended update for flac | patch
i | SUSE-SLE-SERVER-12-SP1-2016-139 | Security update for openldap2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1390 | Security update for flex, at, bogofilter, cyrus-imapd, kdelibs4, libQtWebKit4, libb-> | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1393 | Security update for openssl | patch
| SUSE-SLE-SERVER-12-SP1-2016-1395 | Recommended update for lftp | patch
| SUSE-SLE-SERVER-12-SP1-2016-1396 | Recommended update for smt | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1397 | Security update for mariadb | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1399 | Security update for bind | patch
i | SUSE-SLE-SERVER-12-SP1-2016-140 | Security update for gdk-pixbuf | patch
| SUSE-SLE-SERVER-12-SP1-2016-1404 | Recommended update for kiwi | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1406 | Optional update for DirectFB, fltk, libgnomecups, libgsm, mlocate, vlan | patch
| SUSE-SLE-SERVER-12-SP1-2016-1409 | Security update for postgresql94 | patch
| SUSE-SLE-SERVER-12-SP1-2016-1410 | Recommended update for seccheck | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1418 | Recommended update for ding-libs | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1419 | Recommended update for autofs | patch
| SUSE-SLE-SERVER-12-SP1-2016-142 | Security update for apache-commons-collections | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1421 | Security update for MozillaFirefox | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1424 | Recommended update for rsync | patch
| SUSE-SLE-SERVER-12-SP1-2016-1429 | Security update for wireshark | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1430 | Recommended update for gnome-shell | patch
| SUSE-SLE-SERVER-12-SP1-2016-1435 | Recommended update for python-rtslib | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1445 | Recommended update for speech-dispatcher | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1448 | Security update for systemd | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1452 | Recommended update for lsof | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1454 | Recommended update for timezone | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1456 | Recommended update for gdm | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1458 | Security update for ghostscript-library | patch
| SUSE-SLE-SERVER-12-SP1-2016-1460 | Recommended update for ipsec-tools | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1461 | Security update for tiff | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1464 | Security update for X Window System client libraries | patch
| SUSE-SLE-SERVER-12-SP1-2016-1465 | Security update for squidGuard | patch
| SUSE-SLE-SERVER-12-SP1-2016-1469 | Recommended update for openvswitch | patch
| SUSE-SLE-SERVER-12-SP1-2016-1470 | Recommended update for tuned | patch
| SUSE-SLE-SERVER-12-SP1-2016-1474 | Recommended update for libcgroup | patch
| SUSE-SLE-SERVER-12-SP1-2016-1479 | Recommended update for sapconf | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1487 | Recommended update for libgnomesu | patch
| SUSE-SLE-SERVER-12-SP1-2016-1488 | Recommended update for smt | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1490 | Security update for gtk2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1492 | Security update for kdump | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1493 | Recommended update for release-notes-sles | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1502 | Security update for dbus-1 | patch
| SUSE-SLE-SERVER-12-SP1-2016-1508 | Recommended update for gtkhtml | patch
| SUSE-SLE-SERVER-12-SP1-2016-1509 | Recommended update for python-cliff, python-setuptools, python-mock | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1510 | Recommended update for boost | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1513 | Security update for sssd | patch
| SUSE-SLE-SERVER-12-SP1-2016-1515 | Recommended update for the Software Update Stack | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1519 | Recommended update for nfs-utils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1520 | Recommended update for lvm2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1522 | Security update for the Linux Kernel | patch
| SUSE-SLE-SERVER-12-SP1-2016-1523 | Security update for qemu | patch
| SUSE-SLE-SERVER-12-SP1-2016-153 | Security update for ecryptfs-utils | patch
| SUSE-SLE-SERVER-12-SP1-2016-1537 | Security update for quagga | patch
i | SUSE-SLE-SERVER-12-SP1-2016-155 | Recommended update for polkit | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1555 | Security update for libxml2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1557 | Security update for ghostscript | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1558 | Security update for python3 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1560 | Recommended update for multipath-tools | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1565 | Security update for openslp | patch
i | SUSE-SLE-SERVER-12-SP1-2016-157 | Recommended update for ruby-common | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1571 | Security update for gd | patch
| SUSE-SLE-SERVER-12-SP1-2016-1572 | Security update for ImageMagick | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1588 | Security update for bind | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1591 | Security update for curl | patch
i | SUSE-SLE-SERVER-12-SP1-2016-16 | Security update for libpng16 | patch
| SUSE-SLE-SERVER-12-SP1-2016-160 | Security update for java-1_8_0-openjdk | patch
| SUSE-SLE-SERVER-12-SP1-2016-1602 | Recommended update for yast2-migration | patch
| SUSE-SLE-SERVER-12-SP1-2016-1606 | Security update for java-1_8_0-ibm | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1613 | Recommended update for shadow | patch
| SUSE-SLE-SERVER-12-SP1-2016-1615 | Recommended update for python-keyring | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1617 | Recommended update for libesmtp | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1621 | Recommended update for timezone | patch
| SUSE-SLE-SERVER-12-SP1-2016-1623 | Recommended update for python-M2Crypto | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1630 | Security update for util-linux | patch
| SUSE-SLE-SERVER-12-SP1-2016-1631 | Recommended update for squid | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1634 | Recommended update for pciutils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1639 | Security update for jasper | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1644 | Recommended update for vsftpd | patch
| SUSE-SLE-SERVER-12-SP1-2016-1654 | Recommended update for pcsc-ccid | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1655 | Recommended update for parted | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1657 | Security update for ghostscript | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1663 | Recommended update for yast2-core | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1669 | Security update for eog | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1672 | Recommended update for cloud-init | patch
| SUSE-SLE-SERVER-12-SP1-2016-1680 | Security update for libtcnative-1-0 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1681 | Security update for bash | patch
| SUSE-SLE-SERVER-12-SP1-2016-1683 | Security update for java-1_8_0-openjdk | patch
| SUSE-SLE-SERVER-12-SP1-2016-169 | Security update for java-1_7_0-openjdk | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1690 | Security update for tar | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1692 | Security update for sudo | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1697 | Recommended update for open-iscsi | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1698 | Security update for libarchive | patch
| SUSE-SLE-SERVER-12-SP1-2016-1699 | Optional update for cglib, geronimo-specs-poms, geronimo-jta-1_1-api | patch
| SUSE-SLE-SERVER-12-SP1-2016-17 | Recommended update for libnet | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1700 | Security update for the Linux Kernel | patch
| SUSE-SLE-SERVER-12-SP1-2016-1703 | Security update for dovecot22 | patch
| SUSE-SLE-SERVER-12-SP1-2016-171 | Recommended update for python-netaddr | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1717 | Recommended update for mariadb | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1721 | Security update for vim | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1723 | Recommended update for yast2-network | patch
| SUSE-SLE-SERVER-12-SP1-2016-1726 | Security update for ImageMagick | patch
| SUSE-SLE-SERVER-12-SP1-2016-1727 | Security update for java-1_7_0-openjdk | patch
| SUSE-SLE-SERVER-12-SP1-2016-1731 | Optional update apache-commons-pool2, apache-commons-dbcp | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1734 | Recommended update for timezone | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1735 | Recommended update for sg3_utils | patch
| SUSE-SLE-SERVER-12-SP1-2016-1743 | Initial release of libmemcached, memcached, php5-memcached | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1744 | Security update for pcre | patch
| SUSE-SLE-SERVER-12-SP1-2016-1746 | Recommended update for libpciaccess | patch
| SUSE-SLE-SERVER-12-SP1-2016-1748 | Security update for qemu | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1749 | Security update for libX11 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1754 | Security update for MozillaFirefox, mozilla-nss | patch
| SUSE-SLE-SERVER-12-SP1-2016-1756 | Initial release of sapinit-systemd-compat | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1762 | Security update for the Linux Kernel | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1767 | Security update for libXi | patch
| SUSE-SLE-SERVER-12-SP1-2016-1770 | Security update for java-1_7_1-ibm | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1771 | Security update for MozillaFirefox | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1774 | Security update for w3m | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1775 | Security update for gc | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1788 | Recommended update for systemd | patch
| SUSE-SLE-SERVER-12-SP1-2016-1791 | Security update for tomcat | patch
| SUSE-SLE-SERVER-12-SP1-2016-1792 | Security update for java-1_8_0-ibm | patch
i | SUSE-SLE-SERVER-12-SP1-2016-18 | Recommended update for release-notes-sles | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1804 | Security update for libass | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1827 | Security update for pcre | patch
i | SUSE-SLE-SERVER-12-SP1-2016-183 | Security update for mariadb | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1831 | Recommended update for tar | patch
| SUSE-SLE-SERVER-12-SP1-2016-184 | Recommended update for libzip | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1841 | Recommended update for suse-build-key | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1845 | Security update for the Linux Kernel | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1850 | Recommended update for wicked | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1853 | Security update for ntp | patch
i | SUSE-SLE-SERVER-12-SP1-2016-186 | Recommended update for SUSEConnect | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1863 | Recommended updated for pth | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1868 | Security update for gd | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1880 | Security update for MozillaFirefox | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1883 | Recommended update for supportutils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1898 | Security update for libgme | patch
| SUSE-SLE-SERVER-12-SP1-2016-1905 | Security update for ImageMagick | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1908 | Recommended update for pciutils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1911 | Security update for wget | patch
| SUSE-SLE-SERVER-12-SP1-2016-1912 | Security update for dnsmasq | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1917 | Security update for samba | patch
| SUSE-SLE-SERVER-12-SP1-2016-192 | Recommended update for ibus-pinyin | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1921 | Recommended update for release-notes-sles | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1922 | Security update for gstreamer-plugins-good | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1924 | Security update for libcares2 | patch
| SUSE-SLE-SERVER-12-SP1-2016-193 | Recommended update for targetcli, python-rtslib | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1931 | Recommended update for hwinfo | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1932 | Security update for gstreamer-plugins-bad | patch
i | SUSE-SLE-SERVER-12-SP1-2016-1937 | Security update for tiff | patch
i | SUSE-SLE-SERVER-12-SP1-2016-194 | Recommended update for gnome-control-center | patch
| SUSE-SLE-SERVER-12-SP1-2016-1940 | Recommended update for shibboleth-sp | patch
i | SUSE-SLE-SERVER-12-SP1-2016-197 | Recommended update for permissions | patch
i | SUSE-SLE-SERVER-12-SP1-2016-199 | Security update for MozillaFirefox, MozillaFirefox-branding-SLE, mozilla-nss | patch
| SUSE-SLE-SERVER-12-SP1-2016-2 | Security update for libmspack | patch
i | SUSE-SLE-SERVER-12-SP1-2016-201 | Security update for curl | patch
i | SUSE-SLE-SERVER-12-SP1-2016-207 | Optional update for libXaw7, libXaw3d8 | patch
| SUSE-SLE-SERVER-12-SP1-2016-209 | Security update for socat | patch
i | SUSE-SLE-SERVER-12-SP1-2016-210 | Recommended update for release-notes-sles | patch
i | SUSE-SLE-SERVER-12-SP1-2016-213 | Recommended update for xorg-x11-server | patch
i | SUSE-SLE-SERVER-12-SP1-2016-22 | Recommended update for libXfont | patch
i | SUSE-SLE-SERVER-12-SP1-2016-225 | Recommended update for gdm | patch
| SUSE-SLE-SERVER-12-SP1-2016-227 | Security update for java-1_8_0-ibm | patch
| SUSE-SLE-SERVER-12-SP1-2016-237 | Security update for java-1_7_1-ibm | patch
| SUSE-SLE-SERVER-12-SP1-2016-241 | Recommended update for wayland | patch
i | SUSE-SLE-SERVER-12-SP1-2016-243 | Security update for krb5 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-252 | Recommended update for timezone | patch
| SUSE-SLE-SERVER-12-SP1-2016-253 | Recommended update for squashfs | patch
i | SUSE-SLE-SERVER-12-SP1-2016-255 | Recommended update for btrfsprogs | patch
i | SUSE-SLE-SERVER-12-SP1-2016-259 | Security update for libnettle | patch
| SUSE-SLE-SERVER-12-SP1-2016-263 | Security update for qemu | patch
i | SUSE-SLE-SERVER-12-SP1-2016-267 | Recommended update for gnome-keyring | patch
| SUSE-SLE-SERVER-12-SP1-2016-269 | Recommended update for libsolv, libzypp, zypper | patch
i | SUSE-SLE-SERVER-12-SP1-2016-270 | Recommended update for shared-mime-info | patch
i | SUSE-SLE-SERVER-12-SP1-2016-271 | Security update for glibc | patch
i | SUSE-SLE-SERVER-12-SP1-2016-280 | Recommended update for libpeas | patch
| SUSE-SLE-SERVER-12-SP1-2016-281 | Recommended update for yast2-smt | patch
i | SUSE-SLE-SERVER-12-SP1-2016-286 | Recommended update for inst-source-utils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-291 | Recommended update for openslp | patch
i | SUSE-SLE-SERVER-12-SP1-2016-294 | Security update for dhcp | patch
| SUSE-SLE-SERVER-12-SP1-2016-297 | Recommended update for clamav | patch
| SUSE-SLE-SERVER-12-SP1-2016-299 | Recommended update for cpuset | patch
i | SUSE-SLE-SERVER-12-SP1-2016-300 | Recommended update for gnome-desktop | patch
i | SUSE-SLE-SERVER-12-SP1-2016-302 | Recommended update for google-cloud-sdk | patch
i | SUSE-SLE-SERVER-12-SP1-2016-304 | Recommended update for libspectre | patch
| SUSE-SLE-SERVER-12-SP1-2016-305 | Recommended update for python-sip | patch
| SUSE-SLE-SERVER-12-SP1-2016-306 | Security update for postgresql94 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-307 | Security update for MozillaFirefox | patch
| SUSE-SLE-SERVER-12-SP1-2016-31 | Recommended update for os-prober | patch
| SUSE-SLE-SERVER-12-SP1-2016-318 | Recommended update for yast2-packager, yast2-update | patch
| SUSE-SLE-SERVER-12-SP1-2016-326 | Recommended update for openvswitch | patch
i | SUSE-SLE-SERVER-12-SP1-2016-329 | Security update for the Linux Kernel | patch
| SUSE-SLE-SERVER-12-SP1-2016-33 | Security update for libpng15 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-330 | Recommended update for systemd | patch
i | SUSE-SLE-SERVER-12-SP1-2016-333 | Recommended update for jack | patch
i | SUSE-SLE-SERVER-12-SP1-2016-334 | Recommended update for suse-module-tools | patch
i | SUSE-SLE-SERVER-12-SP1-2016-349 | Recommended update for xorg-x11-server | patch
i | SUSE-SLE-SERVER-12-SP1-2016-353 | Security update for openssl | patch
| SUSE-SLE-SERVER-12-SP1-2016-364 | Recommended update for spice-gtk | patch
| SUSE-SLE-SERVER-12-SP1-2016-37 | Security update for libpng12 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-370 | Recommended update for grub2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-371 | Recommended update for insserv-compat | patch
| SUSE-SLE-SERVER-12-SP1-2016-372 | Recommended update for sapconf | patch
i | SUSE-SLE-SERVER-12-SP1-2016-373 | Recommended update for gnome-shell | patch
i | SUSE-SLE-SERVER-12-SP1-2016-374 | Recommended update for Qt5 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-375 | Recommended update for grub2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-379 | Recommended update for wicked | patch
i | SUSE-SLE-SERVER-12-SP1-2016-38 | Security update for libxml2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-382 | Recommended update for SDL | patch
i | SUSE-SLE-SERVER-12-SP1-2016-384 | Recommended update for sles-manuals_en | patch
i | SUSE-SLE-SERVER-12-SP1-2016-386 | Recommended update for nfs-utils | patch
| SUSE-SLE-SERVER-12-SP1-2016-389 | Recommended update for yast2-firstboot | patch
| SUSE-SLE-SERVER-12-SP1-2016-391 | Recommended update for seccheck | patch
i | SUSE-SLE-SERVER-12-SP1-2016-394 | Recommended update for systemd-presets-branding-SLE | patch
| SUSE-SLE-SERVER-12-SP1-2016-396 | Recommended update for dnsmasq | patch
i | SUSE-SLE-SERVER-12-SP1-2016-398 | Recommended update for release-notes-sles | patch
| SUSE-SLE-SERVER-12-SP1-2016-401 | Recommended update for lio-utils | patch
| SUSE-SLE-SERVER-12-SP1-2016-404 | Security update for libotr | patch
i | SUSE-SLE-SERVER-12-SP1-2016-408 | Optional update for libwebp | patch
i | SUSE-SLE-SERVER-12-SP1-2016-413 | Security update for libssh2_org | patch
i | SUSE-SLE-SERVER-12-SP1-2016-414 | Recommended update for desktop-data-SLE | patch
i | SUSE-SLE-SERVER-12-SP1-2016-419 | Security update for MozillaFirefox, mozilla-nspr, mozilla-nss | patch
| SUSE-SLE-SERVER-12-SP1-2016-420 | Recommended update for python-rtslib | patch
i | SUSE-SLE-SERVER-12-SP1-2016-44 | Recommended update for sg3_utils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-443 | Recommended update for libqt5-qtbase | patch
i | SUSE-SLE-SERVER-12-SP1-2016-444 | Security update for bind | patch
| SUSE-SLE-SERVER-12-SP1-2016-448 | Security update for tomcat | patch
i | SUSE-SLE-SERVER-12-SP1-2016-456 | Security update for graphite2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-46 | Recommended update for gcr, gnome-keyring, libgcrypt, libsecret | patch
i | SUSE-SLE-SERVER-12-SP1-2016-462 | Recommended update for libcap | patch
i | SUSE-SLE-SERVER-12-SP1-2016-463 | Recommended update for yast2 | patch
| SUSE-SLE-SERVER-12-SP1-2016-464 | Recommended update for autoyast2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-465 | Recommended update for yast2-network | patch
| SUSE-SLE-SERVER-12-SP1-2016-466 | Recommended update for yast2-installation | patch
| SUSE-SLE-SERVER-12-SP1-2016-467 | Security update for git | patch
i | SUSE-SLE-SERVER-12-SP1-2016-470 | Recommended update for sssd | patch
i | SUSE-SLE-SERVER-12-SP1-2016-476 | Security update for samba | patch
i | SUSE-SLE-SERVER-12-SP1-2016-479 | Recommended update for supportutils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-487 | Recommended update for SUSEConnect | patch
i | SUSE-SLE-SERVER-12-SP1-2016-490 | Recommended update for timezone | patch
i | SUSE-SLE-SERVER-12-SP1-2016-491 | Security update for libqt4 | patch
| SUSE-SLE-SERVER-12-SP1-2016-497 | Recommended update for YaST2 modules | patch
i | SUSE-SLE-SERVER-12-SP1-2016-498 | Recommended update for gnome-keyring | patch
i | SUSE-SLE-SERVER-12-SP1-2016-503 | Recommended update for ipmitool | patch
i | SUSE-SLE-SERVER-12-SP1-2016-509 | Security update for ghostscript | patch
i | SUSE-SLE-SERVER-12-SP1-2016-510 | Recommended update for timezone | patch
| SUSE-SLE-SERVER-12-SP1-2016-526 | Recommended update for sysstat | patch
| SUSE-SLE-SERVER-12-SP1-2016-527 | Recommended update for SMT | patch
| SUSE-SLE-SERVER-12-SP1-2016-531 | Security update for libvirt | patch
| SUSE-SLE-SERVER-12-SP1-2016-532 | Recommended update for libzypp, zypper | patch
| SUSE-SLE-SERVER-12-SP1-2016-536 | Recommended update for virt-manager, libosinfo | patch
| SUSE-SLE-SERVER-12-SP1-2016-540 | Security update for quagga | patch
i | SUSE-SLE-SERVER-12-SP1-2016-543 | Recommended update for libgcrypt | patch
| SUSE-SLE-SERVER-12-SP1-2016-551 | Security update for quagga | patch
| SUSE-SLE-SERVER-12-SP1-2016-552 | Recommended update for nfs4-acl-tools | patch
| SUSE-SLE-SERVER-12-SP1-2016-555 | Security update for java-1_8_0-openjdk | patch
| SUSE-SLE-SERVER-12-SP1-2016-556 | Security update for java-1_7_0-openjdk | patch
i | SUSE-SLE-SERVER-12-SP1-2016-565 | Security update for gcc5 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-567 | Recommended update for open-iscsi | patch
i | SUSE-SLE-SERVER-12-SP1-2016-575 | Recommended update for at | patch
| SUSE-SLE-SERVER-12-SP1-2016-576 | Recommended update for systemd-rpm-macros | patch
i | SUSE-SLE-SERVER-12-SP1-2016-578 | Recommended update for libical | patch
| SUSE-SLE-SERVER-12-SP1-2016-583 | Recommended update for yast2-users | patch
i | SUSE-SLE-SERVER-12-SP1-2016-586 | Security update for krb5 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-587 | Recommended update for ca-certificates-mozilla | patch
| SUSE-SLE-SERVER-12-SP1-2016-592 | Recommended update for python-M2Crypto | patch
i | SUSE-SLE-SERVER-12-SP1-2016-599 | Recommended update for release-notes-sles | patch
i | SUSE-SLE-SERVER-12-SP1-2016-600 | Security update for the Linux Kernel | patch
| SUSE-SLE-SERVER-12-SP1-2016-602 | Recommended update for clamav | patch
i | SUSE-SLE-SERVER-12-SP1-2016-604 | Security update for samba | patch
| SUSE-SLE-SERVER-12-SP1-2016-606 | Security update for xerces-c | patch
i | SUSE-SLE-SERVER-12-SP1-2016-61 | Recommended update for deltarpm | patch
i | SUSE-SLE-SERVER-12-SP1-2016-62 | Recommended update for gnome-shell | patch
i | SUSE-SLE-SERVER-12-SP1-2016-624 | Recommended update for grub2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-634 | Recommended update for multipath-tools | patch
i | SUSE-SLE-SERVER-12-SP1-2016-636 | Security update for libgcrypt | patch
i | SUSE-SLE-SERVER-12-SP1-2016-643 | Recommended update for bzip2 | patch
| SUSE-SLE-SERVER-12-SP1-2016-644 | Recommended update for yast2-registration, yast2-firstboot | patch
i | SUSE-SLE-SERVER-12-SP1-2016-646 | Security update for cairo | patch
i | SUSE-SLE-SERVER-12-SP1-2016-648 | Recommended update for yast2-s390 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-659 | Recommended update for aaa_base | patch
i | SUSE-SLE-SERVER-12-SP1-2016-66 | Security update for cups-filters | patch
i | SUSE-SLE-SERVER-12-SP1-2016-661 | Recommended update for supportutils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-663 | Recommended update for timezone | patch
i | SUSE-SLE-SERVER-12-SP1-2016-667 | Security update for giflib | patch
| SUSE-SLE-SERVER-12-SP1-2016-669 | Security update for yast2-users | patch
i | SUSE-SLE-SERVER-12-SP1-2016-67 | Recommended update for gnome-shell-extensions | patch
i | SUSE-SLE-SERVER-12-SP1-2016-675 | Recommended update for postfix | patch
i | SUSE-SLE-SERVER-12-SP1-2016-683 | Recommended update for nfs-utils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-684 | Recommended update for autofs | patch
| SUSE-SLE-SERVER-12-SP1-2016-686 | Recommended update for openscap | patch
i | SUSE-SLE-SERVER-12-SP1-2016-689 | Recommended update for ruby2.1 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-691 | Recommended update for wicked | patch
| SUSE-SLE-SERVER-12-SP1-2016-693 | Recommended update for sapconf | patch
i | SUSE-SLE-SERVER-12-SP1-2016-694 | Security update for ntp | patch
i | SUSE-SLE-SERVER-12-SP1-2016-697 | Recommended update for libssh2_org | patch
i | SUSE-SLE-SERVER-12-SP1-2016-699 | Recommended update for hwinfo | patch
i | SUSE-SLE-SERVER-12-SP1-2016-70 | Recommended update for zypper-migration-plugin | patch
| SUSE-SLE-SERVER-12-SP1-2016-701 | Recommended update for openssl-ibmca | patch
| SUSE-SLE-SERVER-12-SP1-2016-704 | Recommended update for autoyast2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-709 | Security update for libxml2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-71 | Recommended update for polkit-default-privs | patch
i | SUSE-SLE-SERVER-12-SP1-2016-713 | Recommended update for Mesa, libGLw | patch
i | SUSE-SLE-SERVER-12-SP1-2016-717 | Security update for openssl | patch
i | SUSE-SLE-SERVER-12-SP1-2016-722 | Recommended update for tigervnc | patch
| SUSE-SLE-SERVER-12-SP1-2016-724 | Security update for java-1_8_0-openjdk | patch
| SUSE-SLE-SERVER-12-SP1-2016-725 | Security update for java-1_7_0-openjdk | patch
i | SUSE-SLE-SERVER-12-SP1-2016-728 | Recommended update for rsyslog | patch
i | SUSE-SLE-SERVER-12-SP1-2016-729 | Recommended update for pciutils-ids | patch
| SUSE-SLE-SERVER-12-SP1-2016-731 | Recommended update for apache2-mod_nss | patch
i | SUSE-SLE-SERVER-12-SP1-2016-732 | Security update for MozillaFirefox | patch
| SUSE-SLE-SERVER-12-SP1-2016-733 | Security update for ImageMagick | patch
| SUSE-SLE-SERVER-12-SP1-2016-743 | Recommended update for Software Update Stack | patch
i | SUSE-SLE-SERVER-12-SP1-2016-756 | Recommended update for augeas | patch
| SUSE-SLE-SERVER-12-SP1-2016-757 | Recommended update for fetchmail | patch
| SUSE-SLE-SERVER-12-SP1-2016-76 | Security update for wireshark | patch
i | SUSE-SLE-SERVER-12-SP1-2016-761 | Recommended update for lvm2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-762 | Recommended update for s390-tools, qclib-devel | patch
i | SUSE-SLE-SERVER-12-SP1-2016-764 | Security update for ntp | patch
| SUSE-SLE-SERVER-12-SP1-2016-766 | Security update for java-1_7_1-ibm | patch
i | SUSE-SLE-SERVER-12-SP1-2016-781 | Optional update for flac | patch
| SUSE-SLE-SERVER-12-SP1-2016-788 | Security update for wireshark | patch
i | SUSE-SLE-SERVER-12-SP1-2016-790 | Security update for systemd | patch
| SUSE-SLE-SERVER-12-SP1-2016-80 | Security update for python-requests | patch
i | SUSE-SLE-SERVER-12-SP1-2016-801 | Recommended update for curl | patch
i | SUSE-SLE-SERVER-12-SP1-2016-803 | Recommended update for open-iscsi | patch
i | SUSE-SLE-SERVER-12-SP1-2016-812 | Recommended update for tcpdump | patch
i | SUSE-SLE-SERVER-12-SP1-2016-818 | Security update for openssh | patch
i | SUSE-SLE-SERVER-12-SP1-2016-82 | Recommended update for SUSEConnect | patch
| SUSE-SLE-SERVER-12-SP1-2016-831 | Recommended update for kiwi | patch
i | SUSE-SLE-SERVER-12-SP1-2016-834 | Recommended update for gdb | patch
i | SUSE-SLE-SERVER-12-SP1-2016-835 | Recommended update for libgcrypt | patch
i | SUSE-SLE-SERVER-12-SP1-2016-841 | Recommended update for bash | patch
i | SUSE-SLE-SERVER-12-SP1-2016-845 | Recommended update for yast2-trans | patch
i | SUSE-SLE-SERVER-12-SP1-2016-85 | Security update for openssh | patch
i | SUSE-SLE-SERVER-12-SP1-2016-863 | Recommended update for autofs | patch
| SUSE-SLE-SERVER-12-SP1-2016-864 | Security update for cyrus-imapd | patch
i | SUSE-SLE-SERVER-12-SP1-2016-869 | Recommended update for systemd | patch
| SUSE-SLE-SERVER-12-SP1-2016-876 | Security update for java-1_8_0-ibm | patch
| SUSE-SLE-SERVER-12-SP1-2016-877 | Recommended update for clamav | patch
i | SUSE-SLE-SERVER-12-SP1-2016-879 | Recommended update for samba | patch
i | SUSE-SLE-SERVER-12-SP1-2016-880 | Recommended update for supportutils | patch
| SUSE-SLE-SERVER-12-SP1-2016-882 | Security update for quagga | patch
i | SUSE-SLE-SERVER-12-SP1-2016-885 | Recommended update for SUSEConnect and zypper-migration-plugin | patch
i | SUSE-SLE-SERVER-12-SP1-2016-890 | Recommended update for mailx | patch
| SUSE-SLE-SERVER-12-SP1-2016-892 | Recommended update for openCryptoki | patch
| SUSE-SLE-SERVER-12-SP1-2016-894 | Optional update for wayland | patch
i | SUSE-SLE-SERVER-12-SP1-2016-897 | Security update for supportutils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-898 | Security update for expat | patch
i | SUSE-SLE-SERVER-12-SP1-2016-9 | Recommended update for poppler | patch
i | SUSE-SLE-SERVER-12-SP1-2016-900 | Security update for libksba | patch
i | SUSE-SLE-SERVER-12-SP1-2016-905 | Recommended update for bash-completion, util-linux | patch
i | SUSE-SLE-SERVER-12-SP1-2016-907 | Recommended update for Mesa | patch
i | SUSE-SLE-SERVER-12-SP1-2016-911 | Recommended update for gnome-packagekit | patch
i | SUSE-SLE-SERVER-12-SP1-2016-912 | Recommended update for vsftpd | patch
| SUSE-SLE-SERVER-12-SP1-2016-914 | Recommended update for xrdp | patch
i | SUSE-SLE-SERVER-12-SP1-2016-915 | Security update for libxml2 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-916 | Recommended update for util-linux | patch
i | SUSE-SLE-SERVER-12-SP1-2016-920 | Recommended update for sysconfig | patch
i | SUSE-SLE-SERVER-12-SP1-2016-922 | Security update for poppler | patch
| SUSE-SLE-SERVER-12-SP1-2016-929 | Recommended update for mtools | patch
i | SUSE-SLE-SERVER-12-SP1-2016-930 | Security update for ntp | patch
i | SUSE-SLE-SERVER-12-SP1-2016-932 | Recommended update for nautilus | patch
| SUSE-SLE-SERVER-12-SP1-2016-935 | Security update for ImageMagick | patch
| SUSE-SLE-SERVER-12-SP1-2016-937 | Recommended update for lio-utils | patch
i | SUSE-SLE-SERVER-12-SP1-2016-940 | Security update for libarchive | patch
i | SUSE-SLE-SERVER-12-SP1-2016-941 | Recommended update for gcc48 | patch
i | SUSE-SLE-SERVER-12-SP1-2016-943 | Security update for p7zip | patch
| SUSE-SLE-SERVER-12-SP1-2016-945 | Recommended update for indic-fonts | patch
i | SUSE-SLE-SERVER-12-SP1-2016-946 | Recommended update for man-pages | patch
i | SUSE-SLE-SERVER-12-SP1-2016-949 | Security update for libtasn1 | patch
| SUSE-SLE-SERVER-12-SP1-2016-953 | Recommended update for libcap1 | patch
| SUSE-SLE-SERVER-12-SP1-2016-954 | Recommended update for python-dateutil | patch
| SUSE-SLE-SERVER-12-SP1-2016-956 | Recommended update for nethogs | patch
i | SUSE-SLE-SERVER-12-SP1-2016-96 | Recommended update for snapper | patch
| SUSE-SLE-SERVER-12-SP1-2016-961 | Recommended update for kiwi | patch
i | SUSE-SLE-SERVER-12-SP1-2016-962 | Recommended update for perl-Net-SSLeay | patch
i | SUSE-SLE-SERVER-12-SP1-2016-963 | Security update for mariadb | patch
i | SUSE-SLE-SERVER-12-SP1-2016-967 | Recommended update for timezone | patch
i | SUSE-SLE-SERVER-12-SP1-2016-969 | Recommended update for release-notes-sles | patch
i | SUSE-SLE-SERVER-12-SP1-2016-973 | Security update for libimobiledevice, usbmuxd | patch
| SUSE-SLE-SERVER-12-SP1-2016-979 | Recommended update for postgresql-init | patch
i | SUSE-SLE-SERVER-12-SP1-2016-98 | Security update for mozilla-nss | patch
i | SUSE-SLE-SERVER-12-SP1-2016-982 | Recommended update for mdadm | patch
i | SUSE-SLE-SERVER-12-SP1-2016-987 | Recommended update for procps | patch
i | SUSE-SLE-SERVER-12-SP1-2016-992 | Recommended update for yast2-dns-server | patch
i | SUSE-SLE-SERVER-12-SP1-2016-996 | Recommended update for bind | patch
i | SUSE-SLE-SERVER-12-SP1-2017-101 | Recommended update for rsyslog | patch
| SUSE-SLE-SERVER-12-SP1-2017-102 | Recommended update for libvirt | patch
i | SUSE-SLE-SERVER-12-SP1-2017-11 | Recommended update for gnome-session | patch
| SUSE-SLE-SERVER-12-SP1-2017-122 | Recommended update for virt-manager | patch
| SUSE-SLE-SERVER-12-SP1-2017-134 | Recommended update for libpfm | patch
| SUSE-SLE-SERVER-12-SP1-2017-139 | Security update for gstreamer-0_10-plugins-base | patch
| SUSE-SLE-SERVER-12-SP1-2017-143 | Recommended update for yum | patch
i | SUSE-SLE-SERVER-12-SP1-2017-144 | Recommended update for yast2-network | patch
i | SUSE-SLE-SERVER-12-SP1-2017-150 | Security update for pcsc-lite | patch
i | SUSE-SLE-SERVER-12-SP1-2017-156 | Recommended update for yast2-ruby-bindings | patch
i | SUSE-SLE-SERVER-12-SP1-2017-173 | Security update for policycoreutils | patch
| SUSE-SLE-SERVER-12-SP1-2017-176 | Security update for java-1_8_0-openjdk | patch
i | SUSE-SLE-SERVER-12-SP1-2017-177 | Security update for gnutls | patch
i | SUSE-SLE-SERVER-12-SP1-2017-18 | Recommended update for ipmitool | patch
i | SUSE-SLE-SERVER-12-SP1-2017-185 | Security update for cpio | patch
| SUSE-SLE-SERVER-12-SP1-2017-19 | Recommended update for kiwi | patch
i | SUSE-SLE-SERVER-12-SP1-2017-196 | Security update for guile | patch
i | SUSE-SLE-SERVER-12-SP1-2017-207 | Security update for mariadb | patch
| SUSE-SLE-SERVER-12-SP1-2017-22 | Recommended update for emacs | patch
| SUSE-SLE-SERVER-12-SP1-2017-24 | Recommended update for sblim-sfcb | patch
i | SUSE-SLE-SERVER-12-SP1-2017-25 | Recommended update for star | patch
i | SUSE-SLE-SERVER-12-SP1-2017-27 | Security update for jasper | patch
i | SUSE-SLE-SERVER-12-SP1-2017-3 | Security update for zlib | patch
i | SUSE-SLE-SERVER-12-SP1-2017-31 | Recommended update for dracut | patch
i | SUSE-SLE-SERVER-12-SP1-2017-32 | Recommended update for dirmngr | patch
| SUSE-SLE-SERVER-12-SP1-2017-37 | Recommended update for smt | patch
| SUSE-SLE-SERVER-12-SP1-2017-44 | Security update for freeradius-server | patch
| SUSE-SLE-SERVER-12-SP1-2017-45 | Security update for rrdtool | patch
i | SUSE-SLE-SERVER-12-SP1-2017-48 | Recommended update for gstreamer-plugins-good | patch
i | SUSE-SLE-SERVER-12-SP1-2017-5 | Recommended update for alsa, pulseaudio | patch
i | SUSE-SLE-SERVER-12-SP1-2017-54 | Security update for bind | patch
| SUSE-SLE-SERVER-12-SP1-2017-57 | Security update for squid | patch
| SUSE-SLE-SERVER-12-SP1-2017-58 | Recommended update for amavisd-new | patch
i | SUSE-SLE-SERVER-12-SP1-2017-62 | Recommended update for yast2 | patch
| SUSE-SLE-SERVER-12-SP1-2017-65 | Security update for perl-DBD-mysql | patch
i | SUSE-SLE-SERVER-12-SP1-2017-71 | Recommended update for bash-completion | patch
i | SUSE-SLE-SERVER-12-SP1-2017-89 | Security update for gstreamer-plugins-base | patch
i | SUSE-SLE-SERVER-12-SP1-2017-94 | Recommended update for dpkg | patch
i | SUSE-SLE-SERVER-12-SP1-2017-95 | Recommended update for polkit-gnome | patch
i | SUSE-SLE-SERVER-12-SP1-2017-98 | Recommended update for kmod | patch

malcolmlewis
08-Feb-2017, 15:36
On Wed 08 Feb 2017 02:14:02 PM CST, mikenash wrote:

Greetings Malcolm, thank you for your response. On /mnt is a copy of
the SLES12 SP1 repository. I also connect the SLES12 SP1 Update
repository. When I drop the /mnt repository I receive 1 less package
that will not be updated. I enable both repositories and they are set
to refresh.
Code:
--------------------
linux140:~ # zypper ref -s
All services have been refreshed.
Repository 'SLES12SP1-Update' is up to date.
Repository 'mnt' is up to date.
All repositories have been refreshed.
--------------------
There is a lot of output from the command "zypper se -t patch

<snip>


Hi
Oops mean zypper lu -t patch (looks like there are a few not
installed... [ no i by them]), look at installing those and see if
things clear up...

It should also be looking at installing libzypp-15.23.1-30.1.s390x not
libzypp-15.21.1-7.1.s390x.

Maybe clean up zypper and rpm db's with;


zypper clean -a
zypper ref -f
rpmdb --rebuilddb


--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

mikenash
08-Feb-2017, 16:11
Greetings Malcolm, I thank you again. I included the base SLES12 ahd SLES12 update repositories. I successfully executed the three command provided but the problem remains. I do notice a slight discrepancy with the message when I try one of the packages.
linux140:/ # zypper update PackageKit-backend-zypp
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: PackageKit-backend-zypp-0.8.16-15.1.s390x requires libzypp.so.1519()(64bit), but this requirement cannot be provided
uninstallable providers: libzypp-15.21.1-7.1.s390x[SLES12SP1-Update]
libzypp-15.21.4-10.2.s390x[SLES12SP1-Update]
libzypp-15.22.0-19.1.s390x[SLES12SP1-Update]
libzypp-15.22.2-25.1.s390x[SLES12SP1-Update]
libzypp-15.23.1-30.1.s390x[SLES12SP1-Update]
libzypp-15.19.5-1.14.s390x[mnt]
Solution 1: Following actions will be done:
deinstallation of libyui-ncurses-pkg6-2.46.1-3.4.s390x
deinstallation of libyui-qt-pkg6-2.44.7-3.2.s390x
Solution 2: do not install PackageKit-backend-zypp-0.8.16-15.1.s390x
Solution 3: break PackageKit-backend-zypp-0.8.16-15.1.s390x by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c): cThe message specifies libzypp.so.1519 and not libzypp.so.15.19!

malcolmlewis
08-Feb-2017, 16:35
On Wed 08 Feb 2017 03:14:02 PM CST, mikenash wrote:

Greetings Malcolm, I thank you again. I included the base SLES12 ahd
SLES12 update repositories. I successfully executed the three command
provided but the problem remains. I do notice a slight discrepancy with
the message when I try one of the packages.
Code:
--------------------
linux140:/ # zypper update PackageKit-backend-zypp
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: PackageKit-backend-zypp-0.8.16-15.1.s390x requires
libzypp.so.1519()(64bit), but this requirement cannot be provided
uninstallable providers: libzypp-15.21.1-7.1.s390x[SLES12SP1-Update]
libzypp-15.21.4-10.2.s390x[SLES12SP1-Update]
libzypp-15.22.0-19.1.s390x[SLES12SP1-Update]
libzypp-15.22.2-25.1.s390x[SLES12SP1-Update]
libzypp-15.23.1-30.1.s390x[SLES12SP1-Update]
libzypp-15.19.5-1.14.s390x[mnt] Solution 1: Following actions will be
done: deinstallation of libyui-ncurses-pkg6-2.46.1-3.4.s390x
deinstallation of libyui-qt-pkg6-2.44.7-3.2.s390x
Solution 2: do not install PackageKit-backend-zypp-0.8.16-15.1.s390x
Solution 3: break PackageKit-backend-zypp-0.8.16-15.1.s390x by
ignoring some of its dependencies
Choose from above solutions by number or cancel [1/2/3/c] (c): c
--------------------
The message specifies libzypp.so.1519 and not libzypp.so.15.19!




Hi
OK, lets see where this package is and also try a dup against the update
repo...


zypper if PackageKit-backend-zypp
zypper dup --from SLES12SP1-Update


But it might be time to raise an SR if you can, there does seem
something strange going on...

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

mikenash
08-Feb-2017, 17:08
Greetings Malcolm, I appreciate your help. The problem remains so I will report this thru the process we have here. Here are the latest results.
linux140:~ # zypper if PackageKit-backend-zypp
Loading repository data...
Reading installed packages...


Information for package PackageKit-backend-zypp:
------------------------------------------------
Repository: mnt
Name: PackageKit-backend-zypp
Version: 0.8.16-15.1
Arch: s390x
Vendor: SUSE LLC <https://www.suse.com/>
Support Level: unknown
Installed: Yes
Status: out-of-date (version 0.8.16-13.3.10 installed)
Installed Size: 286.8 KiB
Summary: Simple software installation management software -- Zypp Backend
Description:
PackageKit is a system designed to make installing and updating
software on your computer easier. The primary design goal is to unify
all the software graphical tools used in different distributions, and
use some of the latest technology like PolicyKit to make the process
suck less.
linux140:~ # zypper dup --from SLES12SP1-Update
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
2 Problems:
Problem: libyui-qt-pkg6-2.44.7-3.2.s390x requires libzypp.so.1439()(64bit), but this requirement cannot be provided
Problem: yast2-pkg-bindings-3.1.31.1-2.3.1.s390x requires libzypp.so.1519()(64bit), but this requirement cannot be provided

Problem: libyui-qt-pkg6-2.44.7-3.2.s390x requires libzypp.so.1439()(64bit), but this requirement cannot be provided
uninstallable providers: libzypp-14.39.0-10.1.s390x[SLES!@-Update]
libzypp-14.42.3-2.31.1.s390x[SLES!@-Update]
libzypp-14.42.5-2.36.1.s390x[SLES!@-Update]
Solution 1: deinstallation of libyui-qt-pkg6-2.44.7-3.2.s390x
Solution 2: keep obsolete libzypp-14.43.0-2.43.1.s390x
Solution 3: break libyui-qt-pkg6-2.44.7-3.2.s390x by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c):
Thank you.

mikenash
08-Feb-2017, 21:15
For completeness: I read one of the previous post requesting more information that I did not supply.
linux140:~ # zypper lu -t patch
Loading repository data...
Reading installed packages...
The following software management updates will be installed first:

Repository | Name | Category | Severity | Status | Summary
-----------------+----------------------------------+-------------+----------+--------+---------------------------------------------
SLES12SP1-Update | SUSE-SLE-SERVER-12-SP1-2016-1051 | recommended | moderate | needed | Recommended update for libsolv, libzypp, z->
SLES12SP1-Update | SUSE-SLE-SERVER-12-SP1-2016-1515 | recommended | moderate | needed | Recommended update for the Software Update->
SLES12SP1-Update | SUSE-SLE-SERVER-12-SP1-2016-1602 | recommended | low | needed | Recommended update for yast2-migration
SLES12SP1-Update | SUSE-SLE-SERVER-12-SP1-2016-269 | recommended | moderate | needed | Recommended update for libsolv, libzypp, z->
SLES12SP1-Update | SUSE-SLE-SERVER-12-SP1-2016-532 | recommended | moderate | needed | Recommended update for libzypp, zypper
SLES12SP1-Update | SUSE-SLE-SERVER-12-SP1-2016-743 | recommended | moderate | needed | Recommended update for Software Update Stack

The following updates are also available:

Repository | Name | Category | Severity | Status | Summary
-----------------+---------------------------------+-------------+-----------+--------+---------------------------------------------
SLES12SP1-Update | SUSE-SLE-SERVER-12-SP1-2016-318 | recommended | moderate | needed | Recommended update for yast2-packager, yas->
SLES12SP1-Update | SUSE-SLE-SERVER-12-SP1-2016-464 | recommended | moderate | needed | Recommended update for autoyast2
SLES12SP1-Update | SUSE-SLE-SERVER-12-SP1-2016-466 | recommended | moderate | needed | Recommended update for yast2-installation
SLES12SP1-Update | SUSE-SLE-SERVER-12-SP1-2016-497 | recommended | low | needed | Recommended update for YaST2 modules
SLES12SP1-Update | SUSE-SLE-SERVER-12-SP1-2016-583 | recommended | low | needed | Recommended update for yast2-users
SLES12SP1-Update | SUSE-SLE-SERVER-12-SP1-2016-644 | recommended | low | needed | Recommended update for yast2-registration,->
SLES12SP1-Update | SUSE-SLE-SERVER-12-SP1-2016-669 | security | important | needed | Security update for yast2-users
SLES12SP1-Update | SUSE-SLE-SERVER-12-SP1-2016-704 | recommended | moderate | needed | Recommended update for autoyast2
SLES12SP1-Update | SUSE-SLE-SERVER-12-SP1-2017-212 | security | moderate | needed | Security update for expat

I created defect bug 151315 on the LTC website. https://bugzilla.linux.ibm.com/show_bug.cgi?id=151315

malcolmlewis
08-Feb-2017, 22:21
Hi
So in the first list, I would skip the yast2 migration one for the moment but try them in order one at a time, eg;


zypper in -t patch SUSE-SLE-SERVER-12-SP1-2016-743
zypper in -t patch SUSE-SLE-SERVER-12-SP1-2016-532
etc


I think it's just picking the latest, before the others are installed...

mikenash
08-Feb-2017, 22:44
Greeting Malcolm, thank you for the reply. I am not sure I understand what you are suggesting.
When you state "yast2 migration" is that the second block of updates that are available?
With the first block I think you are suggesting to start at the bottom of the list and work my way up. Is this correct?

malcolmlewis
08-Feb-2017, 23:54
On Wed 08 Feb 2017 09:54:02 PM CST, mikenash wrote:

Greeting Malcolm, thank you for the reply. I am not sure I understand
what you are suggesting.
When you state "yast2 migration" is that the second block of updates
that are available?
With the first block I think you are suggesting to start at the bottom
of the list and work my way up. Is this correct?




Hi
Yes, skip the migration one for the moment, oldest (smallest number)
up.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

mikenash
15-Feb-2017, 15:32
Hello Malcolm, thanks again. The update was unsuccessful. I noticed something strange. The error referenced repository SLES!@-Update which does not exist. It did at one time because of a typo. I changed it to SLES12-Update. I change it back to SLES!@-Update but I receive the same failure. I tried zypper clean and zypper -f but there was no change. The repository in now named SLES12-Update. The files referenced do exist in the repository. Should I try to install them separately?
linux140:~ # zypper ref -s
All services have been refreshed.
Repository 'SLES12-Update' is up to date.
Repository 'SLES12SP1-Update' is up to date.
Repository 'SLES12 12-0' is up to date.
Repository 'SLES12' is up to date.
All repositories have been refreshed.
linux140:~ # zypper in -t patch SUSE-SLE-SERVER-12-SP1-2016-743
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: libyui-qt-pkg6-2.44.7-3.2.s390x requires libzypp.so.1439()(64bit), but this requirement cannot be provided
uninstallable providers: libzypp-14.39.0-10.1.s390x[SLES!@-Update]
libzypp-14.42.3-2.31.1.s390x[SLES!@-Update]
libzypp-14.42.5-2.36.1.s390x[SLES!@-Update]
Solution 1: Following actions will be done:
deinstallation of libyui-qt-pkg6-2.44.7-3.2.s390x
deinstallation of libyui-ncurses-pkg6-2.46.1-3.4.s390x
Solution 2: do not install patch:SUSE-SLE-SERVER-12-SP1-2016-743-1.noarch
Solution 3: break libyui-qt-pkg6-2.44.7-3.2.s390x by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c): c

malcolmlewis
15-Feb-2017, 16:05
On Wed 15 Feb 2017 02:34:02 PM CST, mikenash wrote:

Hello Malcolm, thanks again. The update was unsuccessful. I noticed
something strange. The error referenced repository SLES!@-Update which
does not exist. It did at one time because of a typo. I changed it to
SLES12-Update. I change it back to SLES!@-Update but I receive the same
failure. I tried zypper clean and zypper -f but there was no change.
The repository in now named SLES12-Update. The files referenced do
exist in the repository. Should I try to install them separately?
linux140:~ # zypper ref -s
All services have been refreshed.
Repository 'SLES12-Update' is up to date.
Repository 'SLES12SP1-Update' is up to date.
Repository 'SLES12 12-0' is up to date.
Repository 'SLES12' is up to date.
All repositories have been refreshed.
linux140:~ # zypper in -t patch SUSE-SLE-SERVER-12-SP1-2016-743
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: libyui-qt-pkg6-2.44.7-3.2.s390x requires
libzypp.so.1439()(64bit), but this requirement cannot be provided
uninstallable providers: libzypp-14.39.0-10.1.s390x[SLES!@-Update]
libzypp-14.42.3-2.31.1.s390x[SLES!@-Update]
libzypp-14.42.5-2.36.1.s390x[SLES!@-Update]
Solution 1: Following actions will be done:
deinstallation of libyui-qt-pkg6-2.44.7-3.2.s390x
deinstallation of libyui-ncurses-pkg6-2.46.1-3.4.s390x
Solution 2: do not install
patch:SUSE-SLE-SERVER-12-SP1-2016-743-1.noarch
Solution 3: break libyui-qt-pkg6-2.44.7-3.2.s390x by ignoring some of
its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c): c




Hi
OK, lets have another look at your full repos and run a verification
check;


zypper lr -d
zypper ve


Also look down in /etc/zypp/*.d at the files present in the *.d
directories and compare the your zypper lr list, anything out of place?

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

mikenash
15-Feb-2017, 17:00
Greetings Malcolm, I found the repository "SLES!@-Update" in directory "linux140:/etc/zypp/repos.d". I was unable to rename it or delete it. I renamed the directory and rebuilt the repositories.
linux140:/etc/zypp/repos.d # ls
SLES12DVD1.repo SLES12SP1DVD1.repo SLES12SP1Update.repo SLES12Update.repo
I ran your commands:
linux140:~ # zypper lr -d
# | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
--+-----------------+-----------------+---------+-----------+---------+----------+----------+-----------------------------------------------------------------------------------------------+--------
1 | SLES12DVD1 | SLES12DVD1 | Yes | ( p) Yes | Yes | 99 | plaindir | dir:///mnt2 |
2 | SLES12SP1DVD1 | SLES12SP1DVD1 | Yes | ( p) Yes | Yes | 99 | plaindir | dir:///mnt |
3 | SLES12SP1Update | SLES12SP1Update | Yes | (r ) Yes | Yes | 99 | rpm-md | ftp://mikenash2@ftp3install.linux.ibm.com/%2fsuse/scc/Updates/SLE-SERVER/12-SP1/s390x/update/ |
4 | SLES12Update | SLES12Update | Yes | (r ) Yes | Yes | 99 | rpm-md | ftp://mikenash2@ftp3install.linux.ibm.com/%2fsuse/scc/Updates/SLE-SERVER/12/s390x/update/ |
linux140:~ # zypper ve
Loading repository data...
Reading installed packages...

Dependencies of all installed packages are satisfied.
Then I repeated the following commands which failed.
linux140:/etc/zypp/repos.d # zypper ref -s
All services have been refreshed.
Repository 'SLES12DVD1' is up to date.
Repository 'SLES12SP1DVD1' is up to date.
Repository 'SLES12SP1Update' is up to date.
Repository 'SLES12Update' is up to date.
All repositories have been refreshed.
linux140:/etc/zypp/repos.d # zypper in -t patch SUSE-SLE-SERVER-12-SP1-2016-743
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: libyui-qt-pkg6-2.44.7-3.2.s390x requires libzypp.so.1439()(64bit), but this requirement cannot be provided
uninstallable providers: libzypp-14.39.0-10.1.s390x[SLES12Update]
libzypp-14.42.3-2.31.1.s390x[SLES12Update]
libzypp-14.42.5-2.36.1.s390x[SLES12Update]
Solution 1: Following actions will be done:
deinstallation of libyui-qt-pkg6-2.44.7-3.2.s390x
deinstallation of libyui-ncurses-pkg6-2.46.1-3.4.s390x
Solution 2: do not install patch:SUSE-SLE-SERVER-12-SP1-2016-743-1.noarch
Solution 3: break libyui-qt-pkg6-2.44.7-3.2.s390x by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c): c

mikenash
15-Feb-2017, 17:23
Update: I downloaded the /usr/lib64/libzypp.so.1439.rpm and looked into the file and I did find the file "/usr/lib64/libzypp.so.1439" using the command rpm -qpl libzypp-14.39.0-10.1.s390x.rpm.

mikenash
15-Feb-2017, 17:34
Update: Strange! I do find the file "libzypp.so.1439" already exist on the system!
linux140:/rpmdump # find / -name libzypp.so.1439
/usr/lib64/libzypp.so.1439

malcolmlewis
15-Feb-2017, 19:16
On Wed 15 Feb 2017 04:04:01 PM CST, mikenash wrote:

Greetings Malcolm, I found the repository "SLES!@-Update" in directory
"linux140:/etc/zypp/repos.d". I was unable to rename it or delete it.
I renamed the directory and rebuilt the repositories.


linux140:~ # zypper lr -d
# | Alias | Name | Enabled | GPG Check | Refresh
| Priority | Type |
URI
| Service
--+-----------------+-----------------+---------+-----------+---------+----------+----------+-----------------------------------------------------------------------------------------------+--------
1 | SLES12DVD1 | SLES12DVD1 | Yes | ( p) Yes | Yes
| 99 | plaindir |
dir:///mnt2
| 2 | SLES12SP1DVD1 | SLES12SP1DVD1 | Yes | ( p) Yes | Yes
| 99 | plaindir |
dir:///mnt
| 3 | SLES12SP1Update | SLES12SP1Update | Yes | (r ) Yes | Yes
| 99 | rpm-md |
ftp://mikenash2@ftp3install.linux.ibm.com/%2fsuse/scc/Updates/SLE-SERVER/12-SP1/s390x/update/
| 4 | SLES12Update | SLES12Update | Yes | (r ) Yes | Yes
| 99 | rpm-md |
ftp://mikenash2@ftp3install.linux.ibm.com/%2fsuse/scc/Updates/SLE-SERVER/12/s390x/update/


Hi
OK, so you should not have the previous release repos active, I'm
guessing they are fighting each other. You need to disable the 1 and 4
and then do a dry run of zypper dup to switch to completely to SP1.


--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

mikenash
15-Feb-2017, 21:21
Greetings Malcolm. I executed zypper lr -d.
linux140:/etc/zypp/repos.d # zypper lr -d
# | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
--+-----------------+-----------------+---------+-----------+---------+----------+----------+-----------------------------------------------------------------------------------------------+--------
1 | SLES12DVD1 | SLES12DVD1 | No | ---- | No | 99 | plaindir | dir:///mnt2 |
2 | SLES12SP1DVD1 | SLES12SP1DVD1 | Yes | ( p) Yes | Yes | 99 | plaindir | dir:///mnt |
3 | SLES12SP1Update | SLES12SP1Update | Yes | (r ) Yes | Yes | 99 | rpm-md | ftp://mikenash2@ftp3install.linux.ibm.com/%2fsuse/scc/Updates/SLE-SERVER/12-SP1/s390x/update/ |
4 | SLES12Update | SLES12Update | No | ---- | No | 99 | rpm-md | ftp://mikenash2@ftp3install.linux.ibm.com/%2fsuse/scc/Updates/SLE-SERVER/12/s390x/update/ |
I checked the zypper repo directory.
linux140:/etc/zypp/repos.d # ls /etc/zypp/repos.d/
SLES12DVD1.repo SLES12SP1DVD1.repo SLES12SP1Update.repo SLES12Update.repo
I ran the test case.
linux140:/etc/zypp/repos.d # zypper clean
All repositories have been cleaned up.
linux140:/etc/zypp/repos.d # zypper ref -f
Forcing raw metadata refresh
Retrieving repository 'SLES12SP1DVD1' metadata .................................................. .............................[done]
Forcing building of repository cache
Building repository 'SLES12SP1DVD1' cache .................................................. ..................................[done]
Forcing raw metadata refresh
Retrieving repository 'SLES12SP1Update' metadata .................................................. ...........................[done]
Forcing building of repository cache
Building repository 'SLES12SP1Update' cache .................................................. ................................[done]
All repositories have been refreshed.
linux140:/etc/zypp/repos.d # zypper ref -s
All services have been refreshed.
Repository 'SLES12SP1DVD1' is up to date.
Repository 'SLES12SP1Update' is up to date.
All repositories have been refreshed.
linux140:/etc/zypp/repos.d # zypper in -t patch SUSE-SLE-SERVER-12-SP1-2016-743
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: libyui-ncurses-pkg6-2.46.1-3.4.s390x requires libzypp.so.1439()(64bit), but this requirement cannot be provided
deleted providers: libzypp-14.43.0-2.43.1.s390x
Solution 1: Following actions will be done:
deinstallation of libyui-ncurses-pkg6-2.46.1-3.4.s390x
deinstallation of libyui-qt-pkg6-2.44.7-3.2.s390x
Solution 2: do not install patch:SUSE-SLE-SERVER-12-SP1-2016-743-1.noarch
Solution 3: break libyui-ncurses-pkg6-2.46.1-3.4.s390x by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c): c
This rpm: libzypp-14.43.0-2.43.1.s390x is in the SLES12 Update repository. The file: libzypp.so.1439 in on the system.
linux140:/rpmdump # rpm -qlp libzypp-14.43.0-2.43.1.s390x.rpm | grep libzypp.so.1439
/usr/lib64/libzypp.so.1439
/usr/lib64/libzypp.so.1439.4.0
linux140:/rpmdump # find / -name libzypp.so.1439*
/usr/lib64/libzypp.so.1439
/usr/lib64/libzypp.so.1439.4.0

malcolmlewis
15-Feb-2017, 22:19
On Wed 15 Feb 2017 08:24:02 PM CST, mikenash wrote:

Greetings Malcolm. I executed zypper lr -d.
Code:
--------------------
linux140:/etc/zypp/repos.d # zypper lr -d
# | Alias | Name | Enabled | GPG Check | Refresh
| Priority | Type |
URI
| Service
--+-----------------+-----------------+---------+-----------+---------+----------+----------+-----------------------------------------------------------------------------------------------+--------
1 | SLES12DVD1 | SLES12DVD1 | No | ---- | No
| 99 | plaindir |
dir:///mnt2
| 2 | SLES12SP1DVD1 | SLES12SP1DVD1 | Yes | ( p) Yes | Yes
| 99 | plaindir |
dir:///mnt
| 3 | SLES12SP1Update | SLES12SP1Update | Yes | (r ) Yes | Yes
| 99 | rpm-md |
ftp://mikenash2@ftp3install.linux.ibm.com/%2fsuse/scc/Updates/SLE-SERVER/12-SP1/s390x/update/
| 4 | SLES12Update | SLES12Update | No | ---- | No
| 99 | rpm-md |
ftp://mikenash2@ftp3install.linux.ibm.com/%2fsuse/scc/Updates/SLE-SERVER/12/s390x/update/
| --------------------

I checked the zypper repo directory.
Code:
--------------------
linux140:/etc/zypp/repos.d # ls /etc/zypp/repos.d/
SLES12DVD1.repo SLES12SP1DVD1.repo SLES12SP1Update.repo
SLES12Update.repo --------------------

I ran the test case.
Code:
--------------------
linux140:/etc/zypp/repos.d # zypper clean
All repositories have been cleaned up.
linux140:/etc/zypp/repos.d # zypper ref -f
Forcing raw metadata refresh
Retrieving repository 'SLES12SP1DVD1'
metadata .................................................. .............................[done]
Forcing building of repository cache Building repository
'SLES12SP1DVD1'
cache .................................................. ..................................[done]
Forcing raw metadata refresh Retrieving repository 'SLES12SP1Update'
metadata .................................................. ...........................[done]
Forcing building of repository cache Building repository
'SLES12SP1Update'
cache .................................................. ................................[done]
All repositories have been refreshed. linux140:/etc/zypp/repos.d #
zypper ref -s All services have been refreshed. Repository
'SLES12SP1DVD1' is up to date. Repository 'SLES12SP1Update' is up to
date. All repositories have been refreshed. linux140:/etc/zypp/repos.d
# zypper in -t patch SUSE-SLE-SERVER-12-SP1-2016-743 Loading repository
data... Reading installed packages...
Resolving package dependencies...

Problem: libyui-ncurses-pkg6-2.46.1-3.4.s390x requires
libzypp.so.1439()(64bit), but this requirement cannot be provided
deleted providers: libzypp-14.43.0-2.43.1.s390x Solution 1: Following
actions will be done: deinstallation of
libyui-ncurses-pkg6-2.46.1-3.4.s390x deinstallation of
libyui-qt-pkg6-2.44.7-3.2.s390x Solution 2: do not install
patch:SUSE-SLE-SERVER-12-SP1-2016-743-1.noarch Solution 3: break
libyui-ncurses-pkg6-2.46.1-3.4.s390x by ignoring some of its
dependencies Choose from above solutions by number or cancel [1/2/3/c]
(c): c --------------------

This rpm: libzypp-14.43.0-2.43.1.s390x is in the SLES12 Update
repository. The file: libzypp.so.1439 in on the system.
Code:
--------------------
linux140:/rpmdump # rpm -qlp libzypp-14.43.0-2.43.1.s390x.rpm |
grep libzypp.so.1439 /usr/lib64/libzypp.so.1439
/usr/lib64/libzypp.so.1439.4.0
linux140:/rpmdump # find / -name libzypp.so.1439*
/usr/lib64/libzypp.so.1439
/usr/lib64/libzypp.so.1439.4.0
--------------------




\Hi
You need to choose solution 1 so the patch from SP1 gets installed...

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

mikenash
15-Feb-2017, 22:49
Greetings Malcolm and thank you. I selected option one "1". This removed two (2) packages, upgraded four(4) packages, and installed three (3) new packages. I then executed zypper update and this updated eleven (11) more packages and their dependencies. Great work Malcolm. I truly appreciate the your expert assistance.

malcolmlewis
15-Feb-2017, 23:10
On Wed 15 Feb 2017 09:54:02 PM CST, mikenash wrote:

Greetings Malcolm and thank you. I selected option one "1". This
removed two (2) packages, upgraded four(4) packages, and installed three
(3) new packages. I then executed zypper update and this updated eleven
(11) more packages and their dependencies. Great work Malcolm. I truly
appreciate the your expert assistance.




Hi Mike
Excellent stuff :) Although should have picked up on the old release
repositories still present earlier ;)

Now you need to consider your update path to SP2, think there is only a
few months left for SP1...

For that you can use the YaST Service Pack Migration and the dry run to
see what will happen...

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

mikenash
16-Feb-2017, 15:09
Greetings Malcolm, good morning. I am not quite sure what you mean by "should have picked up on the old release repositories still present earlier"? Is this the output from the command: "zypper lu -t patch"? I executed this command and it looks clean. However when I execute the command: "zypper dup --from SLES12SP1Update" the output wants me to downgrade three (3) packages. Now sure what to do and why! Is there other commands that I should execute to evaluate the status of this system?

linux140:~ # zypper lu -t patch
Loading repository data...
Reading installed packages...
No updates found.
linux140:~ # zypper dup --from SLES12SP1Update
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

The following 3 packages are going to be downgraded:
libldb1 libldb1-32bit zypper-migration-plugin

3 packages to downgrade.
Overall download size: 214.0 KiB. Already cached: 0 B. No additional space will be used or freed after the operation.
Continue? [y/n/? shows all options] (y): n

malcolmlewis
16-Feb-2017, 15:41
On Thu 16 Feb 2017 02:14:01 PM CST, mikenash wrote:

Greetings Malcolm, good morning. I am not quite sure what you mean by
"should have picked up on the old release repositories still present
earlier"? Is this the output from the command: "zypper lu -t patch"? I
executed this command and it looks clean. However when I execute the
command: "zypper dup --from SLES12SP1Update" the output wants me to
downgrade three (3) packages. Now sure what to do and why! Is there
other commands that I should execute to evaluate the status of this
system?

Code:
--------------------
linux140:~ # zypper lu -t patch
Loading repository data...
Reading installed packages...
No updates found.
linux140:~ # zypper dup --from SLES12SP1Update
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

The following 3 packages are going to be downgraded:
libldb1 libldb1-32bit zypper-migration-plugin

3 packages to downgrade.
Overall download size: 214.0 KiB. Already cached: 0 B. No additional
space will be used or freed after the operation. Continue? [y/n/? shows
all options] (y): n --------------------




Hi
The fact that you had the old release repos active ;)

You should only need to use zypper up now that things have been cleaned
up, the dup was only to get things switched that needed to be to the
new repos.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

mikenash
16-Feb-2017, 15:59
Greetings Malcolm, I still have a question about the output from the command: "zypper lu -t patch". This command asks to downgrade three (3) packages. What reasons would there be for the downgrade. A bad upgrade maybe that has been pulled? Should I downgrade these three (3) packages?

malcolmlewis
16-Feb-2017, 16:07
Greetings Malcolm, I still have a question about the output from the command: "zypper lu -t patch". This command asks to downgrade three (3) packages. What reasons would there be for the downgrade. A bad upgrade maybe that has been pulled? Should I downgrade these three (3) packages?
Hi
Run zypper if on each package name, I suspect they are from the non SP1 repo (and probably different version numbering) hence the downgrade is just to get them to the SP1 versions.

mikenash
16-Feb-2017, 17:19
Greetings Malcolm, thank you very much for the explanation. Took a bit of investigation to check the rpms on each of the repositories and verify that your explanation spot on! You have been a great help! Have a great day!