PDA

View Full Version : SLES12SP2 AMI fails cloud registration



jlreate03
13-Feb-2017, 09:57
Using the official SLES 12 AWS AMI (e.g. in eu-central-1: ami-c425e4ab) I can't see the SLES12 repositories.

Digging further, I see the following under /var/log/cloudregister:


2017-02-13 08:30:02,549 INFO:Using API: regionInfo
2017-02-13 08:30:02,550 INFO:Using region server: 50.17.208.31
2017-02-13 08:30:02,554 INFO:Starting new HTTPS connection (1): 50.17.208.31
2017-02-13 08:30:18,106 ERROR:No response from: 50.17.208.31
2017-02-13 08:30:18,106 INFO:Using region server: 54.247.166.75
2017-02-13 08:30:18,107 INFO:Starting new HTTPS connection (1): 54.247.166.75
2017-02-13 08:30:33,200 ERROR:No response from: 54.247.166.75
2017-02-13 08:30:33,200 INFO:Using region server: 54.244.244.107
2017-02-13 08:30:33,201 INFO:Starting new HTTPS connection (1): 54.244.244.107
2017-02-13 08:30:48,696 ERROR:No response from: 54.244.244.107
2017-02-13 08:30:48,696 INFO:Using region server: 54.253.118.149
2017-02-13 08:30:48,697 INFO:Starting new HTTPS connection (1): 54.253.118.149
2017-02-13 08:31:04,651 ERROR:No response from: 54.253.118.149
2017-02-13 08:31:04,651 ERROR:None of the servers responded
2017-02-13 08:31:04,651 ERROR: Attempted: ['50.17.208.31', '54.247.166.75', '54.244.244.107', '54.253.118.149']
2017-02-13 08:31:04,651 ERROR:Exiting without registration


I tried to re-trigger `registercloudguest` and see the following errors:


ip-172-31-7-8:~ # /usr/sbin/registercloudguest --force-new
/usr/lib/python2.7/site-packages/requests/packages/urllib3/connection.py:264: SubjectAltNameWarning: Certificate for 54.244.244.107 has no `subjectAltName`, falling back to check for a `commonName` for now. This feature is being removed by major browsers and deprecated by RFC 2818. (See https://github.com/shazow/urllib3/issues/497 for details.)
SubjectAltNameWarning
/usr/lib/python2.7/site-packages/requests/packages/urllib3/connection.py:264: SubjectAltNameWarning: Certificate for 50.17.208.31 has no `subjectAltName`, falling back to check for a `commonName` for now. This feature is being removed by major browsers and deprecated by RFC 2818. (See https://github.com/shazow/urllib3/issues/497 for details.)
SubjectAltNameWarning
/usr/lib/python2.7/site-packages/requests/packages/urllib3/connection.py:264: SubjectAltNameWarning: Certificate for 54.247.166.75 has no `subjectAltName`, falling back to check for a `commonName` for now. This feature is being removed by major browsers and deprecated by RFC 2818. (See https://github.com/shazow/urllib3/issues/497 for details.)
SubjectAltNameWarning
/usr/lib/python2.7/site-packages/requests/packages/urllib3/connection.py:264: SubjectAltNameWarning: Certificate for 54.253.118.149 has no `subjectAltName`, falling back to check for a `commonName` for now. This feature is being removed by major browsers and deprecated by RFC 2818. (See https://github.com/shazow/urllib3/issues/497 for details.)
SubjectAltNameWarning


Launching instances (and getting registered correctly) used to work a few weeks ago.

Is some wrong with the registration servers?

I tried the same process in us-east-1 without luck and also with an older AMI.

rjschwei
13-Feb-2017, 12:53
The issue is that the instance is not getting a response from any of the region servers. Thus this is an all-region problem. I am working on the issue.

rjschwei
13-Feb-2017, 13:23
The issue is resolved.

The problem was that the region servers ran out of memory. While we have memory limit monitoring on these systems our alarms were obviously not triggered. We will investigate the alarms and make appropriate improvements.

Sorry for the inconvenience.

jlreate03
13-Feb-2017, 16:29
Many thanks for the quick resolution. I can confirm that it is working now.

jlreate03
13-Feb-2017, 17:27
It seems there are still issues with the cloud repositories I am seeing errors like:


amazon-ebs: Retrieving repository 'Various software for easier management of multiple [done]
Building repository 'Various software for easier management of multiple sy[done]
All repositories have been refreshed.
Refreshing service 'cloud_update'.
Repository 'SLE-Module-Containers12-Pool' is up to date.
Timeout exceeded when accessing 'http://smt-ec2.susecloud.net/repo/SUSE/Updates/SLE-Module-Containers/12/x86_64/update/repodata/repomd.xml?credentials=SMT-http_smt-ec2_susecloud_net'.

Abort, retry, ignore? [a/r/i] (r):
ABORT request: Aborting requested by user
Problem retrieving the repository index file for service 'SMT-http_smt-ec2_susecloud_net':
Timeout exceeded when accessing 'http://smt-ec2.susecloud.net/repo/repoindex.xml?cookies=0&credentials=SMT-http_smt-ec2_susecloud_net'.

rjschwei
15-Feb-2017, 22:52
Sorry I cannot reproduce the issue. I just updated an instances started from the same ami in eu-central-1.

# zypper ref
Refreshing service 'cloud_update'.
Repository 'SLE-Module-Adv-Systems-Management12-Pool' is up to date.
Repository 'SLE-Module-Adv-Systems-Management12-Updates' is up to date.
Repository 'SLE-Module-Containers12-Pool' is up to date.
Repository 'SLE-Module-Containers12-Updates' is up to date.
Repository 'SLE-Module-HPC12-Pool' is up to date.
Repository 'SLE-Module-HPC12-Updates' is up to date.
Repository 'SLE-Module-Legacy12-Pool' is up to date.
Repository 'SLE-Module-Legacy12-Updates' is up to date.
Repository 'SLE-Module-Public-Cloud12-Pool' is up to date.
Repository 'SLE-Module-Public-Cloud12-Updates' is up to date.
Repository 'SLE-Module-Toolchain12-Pool' is up to date.
Repository 'SLE-Module-Toolchain12-Updates' is up to date.
Repository 'SLE-Module-Web-Scripting12-Pool' is up to date.
Repository 'SLE-Module-Web-Scripting12-Updates' is up to date.
Repository 'SLE-SDK12-SP2-Pool' is up to date.
Repository 'SLE-SDK12-SP2-Updates' is up to date.
Repository 'SLES12-SP2-Pool' is up to date.
Repository 'SLES12-SP2-Updates' is up to date.
All repositories have been refreshed.
ip-172-31-10-167:~ # time zypper ref
Refreshing service 'cloud_update'.
Repository 'SLE-Module-Adv-Systems-Management12-Pool' is up to date.
Repository 'SLE-Module-Adv-Systems-Management12-Updates' is up to date.
Repository 'SLE-Module-Containers12-Pool' is up to date.
Repository 'SLE-Module-Containers12-Updates' is up to date.
Repository 'SLE-Module-HPC12-Pool' is up to date.
Repository 'SLE-Module-HPC12-Updates' is up to date.
Repository 'SLE-Module-Legacy12-Pool' is up to date.
Repository 'SLE-Module-Legacy12-Updates' is up to date.
Repository 'SLE-Module-Public-Cloud12-Pool' is up to date.
Repository 'SLE-Module-Public-Cloud12-Updates' is up to date.
Repository 'SLE-Module-Toolchain12-Pool' is up to date.
Repository 'SLE-Module-Toolchain12-Updates' is up to date.
Repository 'SLE-Module-Web-Scripting12-Pool' is up to date.
Repository 'SLE-Module-Web-Scripting12-Updates' is up to date.
Repository 'SLE-SDK12-SP2-Pool' is up to date.
Repository 'SLE-SDK12-SP2-Updates' is up to date.
Repository 'SLES12-SP2-Pool' is up to date.
Repository 'SLES12-SP2-Updates' is up to date.
All repositories have been refreshed.

real 0m0.398s
user 0m0.246s
sys 0m0.036s


What server are you pointing to?

grep susecloud /etc/hosts ?

jlreate03
17-Feb-2017, 08:51
I think we can consider this a transient issue as I haven't seen it happen again. Thank you for taking a look at it!

TheNeb
10-May-2017, 14:30
Hi,

I am facing the same issue today with a newly provisioned SLES12 SP2 EC2 instance, launched from the official AMI. My instance is launched to a public subnet in a VPC, in which other SLES12 SP2 instances have been launched (a couple of weeks back) and have registered without issue.

Here's the output of /var/log/cloudregister:


2017-05-09 10:39:51,380 INFO:Using API: regionInfo
2017-05-09 10:39:51,381 INFO:Using region server: 54.253.118.149
2017-05-09 10:39:51,385 INFO:Starting new HTTPS connection (1): 54.253.118.149
2017-05-09 10:39:53,041 INFO:Starting new HTTP connection (1): 54.75.232.245
2017-05-09 10:39:53,866 INFO:Modified /etc/hosts, added: 54.75.232.245 smt-ec2.susecloud.net smt-ec2

2017-05-09 10:40:00,281 INFO:Writing SMT rootCA: /usr/share/pki/trust/anchors
2017-05-09 10:40:00,284 INFO:Starting new HTTP connection (1): 54.75.232.245
2017-05-09 10:40:00,287 INFO:Updating CA certificates: update-ca-certificates
2017-05-09 10:41:15,540 INFO:Registration: /usr/sbin/SUSEConnect --url https://smt-ec2.susecloud.net --product sle-module-hpc/12.2/x86_64 --instance-data /
var/lib/cloudregister/219a2077-bf6a-4055-a672-8ebef0b210db
2017-05-09 10:42:15,820 INFO:Registration: /usr/sbin/SUSEConnect --url https://smt-ec2.susecloud.net --product sle-module-toolchain/12/x86_64 --instance-da
ta /var/lib/cloudregister/219a2077-bf6a-4055-a672-8ebef0b210db
2017-05-09 10:43:16,109 INFO:Registration: /usr/sbin/SUSEConnect --url https://smt-ec2.susecloud.net --product sle-module-containers/12/x86_64 --instance-d
ata /var/lib/cloudregister/219a2077-bf6a-4055-a672-8ebef0b210db
2017-05-09 10:44:16,340 INFO:Registration: /usr/sbin/SUSEConnect --url https://smt-ec2.susecloud.net --product sle-module-web-scripting/12/x86_64 --instanc
e-data /var/lib/cloudregister/219a2077-bf6a-4055-a672-8ebef0b210db
2017-05-09 10:45:16,620 INFO:Registration: /usr/sbin/SUSEConnect --url https://smt-ec2.susecloud.net --product sle-module-legacy/12/x86_64 --instance-data
/var/lib/cloudregister/219a2077-bf6a-4055-a672-8ebef0b210db
2017-05-09 10:46:16,902 INFO:Registration: /usr/sbin/SUSEConnect --url https://smt-ec2.susecloud.net --product sle-module-adv-systems-management/12/x86_64
--instance-data /var/lib/cloudregister/219a2077-bf6a-4055-a672-8ebef0b210db
2017-05-09 10:47:17,185 INFO:Registration: /usr/sbin/SUSEConnect --url https://smt-ec2.susecloud.net --product sle-module-public-cloud/12/x86_64 --instance
-data /var/lib/cloudregister/219a2077-bf6a-4055-a672-8ebef0b210db
2017-05-09 10:48:17,469 INFO:Registration: /usr/sbin/SUSEConnect --url https://smt-ec2.susecloud.net --product sle-sdk/12.2/x86_64 --instance-data /var/lib
/cloudregister/219a2077-bf6a-4055-a672-8ebef0b210db
2017-05-09 16:11:09,861 INFO:Using API: regionInfo
2017-05-09 16:11:09,864 INFO:Using region server: 50.17.208.31
2017-05-09 16:11:09,871 INFO:Starting new HTTPS connection (1): 50.17.208.31
2017-05-09 16:11:24,886 ERROR:No response from: 50.17.208.31
2017-05-09 16:11:24,887 INFO:Using region server: 54.244.244.107
2017-05-09 16:11:24,888 INFO:Starting new HTTPS connection (1): 54.244.244.107
2017-05-09 16:11:39,903 ERROR:No response from: 54.244.244.107
2017-05-09 16:11:39,903 INFO:Using region server: 54.247.166.75
2017-05-09 16:11:39,904 INFO:Starting new HTTPS connection (1): 54.247.166.75
2017-05-09 16:11:54,920 ERROR:No response from: 54.247.166.75
2017-05-09 16:11:54,920 INFO:Using region server: 54.253.118.149
2017-05-09 16:11:54,920 INFO:Starting new HTTPS connection (1): 54.253.118.149
2017-05-09 16:12:09,936 ERROR:No response from: 54.253.118.149
2017-05-09 16:12:09,936 ERROR:None of the servers responded
2017-05-09 16:12:09,936 ERROR: Attempted: ['50.17.208.31', '54.244.244.107', '54.247.166.75', '54.253.118.149']
2017-05-09 16:12:09,936 ERROR:Exiting without registration
2017-05-10 10:15:04,277 INFO:Using API: regionInfo
2017-05-10 10:15:04,278 INFO:Using region server: 54.244.244.107
2017-05-10 10:15:04,285 INFO:Starting new HTTPS connection (1): 54.244.244.107
2017-05-10 10:15:19,290 ERROR:No response from: 54.244.244.107
2017-05-10 10:15:19,290 INFO:Using region server: 50.17.208.31
2017-05-10 10:15:19,291 INFO:Starting new HTTPS connection (1): 50.17.208.31
2017-05-10 10:15:34,306 ERROR:No response from: 50.17.208.31
2017-05-10 10:15:34,307 INFO:Using region server: 54.247.166.75
2017-05-10 10:15:34,307 INFO:Starting new HTTPS connection (1): 54.247.166.75
2017-05-10 10:15:49,323 ERROR:No response from: 54.247.166.75
2017-05-10 10:15:49,323 INFO:Using region server: 54.253.118.149
2017-05-10 10:15:49,324 INFO:Starting new HTTPS connection (1): 54.253.118.149
2017-05-10 10:16:04,339 ERROR:No response from: 54.253.118.149
2017-05-10 10:16:04,339 ERROR:None of the servers responded
2017-05-10 10:16:04,339 ERROR: Attempted: ['54.244.244.107', '50.17.208.31', '54.247.166.75', '54.253.118.149']
2017-05-10 10:16:04,340 ERROR:Exiting without registration
2017-05-10 13:02:25,128 INFO:Using API: regionInfo
2017-05-10 13:02:25,129 INFO:Using region server: 54.244.244.107
2017-05-10 13:02:25,137 INFO:Starting new HTTPS connection (1): 54.244.244.107
2017-05-10 13:02:40,153 ERROR:No response from: 54.244.244.107
2017-05-10 13:02:40,153 INFO:Using region server: 54.253.118.149
2017-05-10 13:02:40,154 INFO:Starting new HTTPS connection (1): 54.253.118.149
2017-05-10 13:02:55,170 ERROR:No response from: 54.253.118.149
2017-05-10 13:02:55,170 INFO:Using region server: 54.247.166.75
2017-05-10 13:02:55,171 INFO:Starting new HTTPS connection (1): 54.247.166.75
2017-05-10 13:03:10,186 ERROR:No response from: 54.247.166.75
2017-05-10 13:03:10,186 INFO:Using region server: 50.17.208.31
2017-05-10 13:03:10,187 INFO:Starting new HTTPS connection (1): 50.17.208.31
2017-05-10 13:03:25,203 ERROR:No response from: 50.17.208.31
2017-05-10 13:03:25,203 ERROR:None of the servers responded
2017-05-10 13:03:25,203 ERROR: Attempted: ['54.244.244.107', '54.253.118.149', '54.247.166.75', '50.17.208.31']
2017-05-10 13:03:25,203 ERROR:Exiting without registration
2017-05-10 13:34:57,018 INFO:Using API: regionInfo
2017-05-10 13:34:57,019 INFO:Using region server: 54.244.244.107
2017-05-10 13:34:57,026 INFO:Starting new HTTPS connection (1): 54.244.244.107
2017-05-10 13:35:12,042 ERROR:No response from: 54.244.244.107
2017-05-10 13:35:12,042 INFO:Using region server: 50.17.208.31
2017-05-10 13:35:12,043 INFO:Starting new HTTPS connection (1): 50.17.208.31
2017-05-10 13:35:27,058 ERROR:No response from: 50.17.208.31
2017-05-10 13:35:27,058 INFO:Using region server: 54.253.118.149
2017-05-10 13:35:27,059 INFO:Starting new HTTPS connection (1): 54.253.118.149
2017-05-10 13:35:42,075 ERROR:No response from: 54.253.118.149
2017-05-10 13:35:42,075 INFO:Using region server: 54.247.166.75
2017-05-10 13:35:42,076 INFO:Starting new HTTPS connection (1): 54.247.166.75
2017-05-10 13:35:57,091 ERROR:No response from: 54.247.166.75
2017-05-10 13:35:57,091 ERROR:None of the servers responded
2017-05-10 13:35:57,092 ERROR: Attempted: ['54.244.244.107', '50.17.208.31', '54.253.118.149', '54.247.166.75']
2017-05-10 13:35:57,092 ERROR:Exiting without registration
2017-05-10 13:44:12,286 INFO:Forced new registration
2017-05-10 13:44:12,286 INFO:Using API: regionInfo
2017-05-10 13:44:12,286 INFO:Using region server: 54.247.166.75
2017-05-10 13:44:12,289 INFO:Starting new HTTPS connection (1): 54.247.166.75
2017-05-10 13:44:27,305 ERROR:No response from: 54.247.166.75
2017-05-10 13:44:27,305 INFO:Using region server: 54.244.244.107
2017-05-10 13:44:27,306 INFO:Starting new HTTPS connection (1): 54.244.244.107
2017-05-10 13:44:42,321 ERROR:No response from: 54.244.244.107
2017-05-10 13:44:42,322 INFO:Using region server: 54.253.118.149
2017-05-10 13:44:42,322 INFO:Starting new HTTPS connection (1): 54.253.118.149
2017-05-10 13:44:57,338 ERROR:No response from: 54.253.118.149
2017-05-10 13:44:57,338 INFO:Using region server: 50.17.208.31
2017-05-10 13:44:57,339 INFO:Starting new HTTPS connection (1): 50.17.208.31
2017-05-10 13:45:12,354 ERROR:No response from: 50.17.208.31
2017-05-10 13:45:12,354 ERROR:None of the servers responded
2017-05-10 13:45:12,355 ERROR: Attempted: ['54.247.166.75', '54.244.244.107', '54.253.118.149', '50.17.208.31']
2017-05-10 13:45:12,355 ERROR:Exiting without registration
2017-05-10 13:59:20,050 INFO:Forced new registration
2017-05-10 13:59:20,050 INFO:Using API: regionInfo
2017-05-10 13:59:20,051 INFO:Using region server: 54.244.244.107
2017-05-10 13:59:20,053 INFO:Starting new HTTPS connection (1): 54.244.244.107
2017-05-10 13:59:35,069 ERROR:No response from: 54.244.244.107
2017-05-10 13:59:35,069 INFO:Using region server: 54.247.166.75
2017-05-10 13:59:35,070 INFO:Starting new HTTPS connection (1): 54.247.166.75
2017-05-10 13:59:50,085 ERROR:No response from: 54.247.166.75
2017-05-10 13:59:50,086 INFO:Using region server: 50.17.208.31
2017-05-10 13:59:50,086 INFO:Starting new HTTPS connection (1): 50.17.208.31
2017-05-10 14:00:05,102 ERROR:No response from: 50.17.208.31
2017-05-10 14:00:05,102 INFO:Using region server: 54.253.118.149
2017-05-10 14:00:05,103 INFO:Starting new HTTPS connection (1): 54.253.118.149
2017-05-10 14:00:20,118 ERROR:No response from: 54.253.118.149
2017-05-10 14:00:20,119 ERROR:None of the servers responded
2017-05-10 14:00:20,119 ERROR: Attempted: ['54.244.244.107', '54.247.166.75', '50.17.208.31', '54.253.118.149']
2017-05-10 14:00:20,119 ERROR:Exiting without registration
2017-05-10 14:01:00,293 INFO:Using API: regionInfo
2017-05-10 14:01:00,293 INFO:Using region server: 54.247.166.75
2017-05-10 14:01:00,296 INFO:Starting new HTTPS connection (1): 54.247.166.75
2017-05-10 14:01:15,312 ERROR:No response from: 54.247.166.75
2017-05-10 14:01:15,312 INFO:Using region server: 50.17.208.31
2017-05-10 14:01:15,313 INFO:Starting new HTTPS connection (1): 50.17.208.31
2017-05-10 14:01:30,328 ERROR:No response from: 50.17.208.31
2017-05-10 14:01:30,329 INFO:Using region server: 54.253.118.149
2017-05-10 14:01:30,329 INFO:Starting new HTTPS connection (1): 54.253.118.149
2017-05-10 14:01:45,345 ERROR:No response from: 54.253.118.149
2017-05-10 14:01:45,345 INFO:Using region server: 54.244.244.107
2017-05-10 14:01:45,346 INFO:Starting new HTTPS connection (1): 54.244.244.107
2017-05-10 14:02:00,361 ERROR:No response from: 54.244.244.107
2017-05-10 14:02:00,362 ERROR:None of the servers responded
2017-05-10 14:02:00,362 ERROR: Attempted: ['54.247.166.75', '50.17.208.31', '54.253.118.149', '54.244.244.107']
2017-05-10 14:02:00,362 ERROR:Exiting without registration
2017-05-10 14:17:34,869 INFO:Forced new registration
2017-05-10 14:17:34,869 INFO:Using API: regionInfo
2017-05-10 14:17:34,869 INFO:Using region server: 50.17.208.31
2017-05-10 14:17:34,872 INFO:Starting new HTTPS connection (1): 50.17.208.31
2017-05-10 14:17:49,888 ERROR:No response from: 50.17.208.31
2017-05-10 14:17:49,888 INFO:Using region server: 54.244.244.107
2017-05-10 14:17:49,889 INFO:Starting new HTTPS connection (1): 54.244.244.107
2017-05-10 14:18:04,904 ERROR:No response from: 54.244.244.107
2017-05-10 14:18:04,904 INFO:Using region server: 54.253.118.149
2017-05-10 14:18:04,905 INFO:Starting new HTTPS connection (1): 54.253.118.149
2017-05-10 14:18:19,921 ERROR:No response from: 54.253.118.149
2017-05-10 14:18:19,921 INFO:Using region server: 54.247.166.75
2017-05-10 14:18:19,922 INFO:Starting new HTTPS connection (1): 54.247.166.75
2017-05-10 14:18:34,937 ERROR:No response from: 54.247.166.75
2017-05-10 14:18:34,937 ERROR:None of the servers responded
2017-05-10 14:18:34,937 ERROR: Attempted: ['50.17.208.31', '54.244.244.107', '54.253.118.149', '54.247.166.75']
2017-05-10 14:18:34,937 ERROR:Exiting without registration

Is it possible that the same issue re availability of the SMT servers for the eu-west-1 region has occurred?

Thanks..

smflood
10-May-2017, 16:14
On 10/05/17 14:34, TheNeb wrote:

> I am facing the same issue today with a newly provisioned SLES12 (albeit
> SP4) EC2 instance.

There is no SP4 for SLES12 - SLES12 SP2 is the current release with SP3
in beta. Perhaps you mean SLES11 SP4? Please can you post the output
from "cat /etc/*release" which will clarify/confirm.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

jlreate03
23-May-2017, 12:40
There seems to be an issue on my side too.

I launched an ec2 instance based on the suse-sles-12-sp2-v20161104-hvm-ssd-x86_64 (ami-e4a30084) and the SLES12 repositories are unavailable due to cloudregister failures.



ip-172-30-2-41:/var/log # cat cloudregister
2017-05-23 08:41:43,809 INFO:Using API: regionInfo
2017-05-23 08:41:43,809 INFO:Using region server: 50.17.208.31
2017-05-23 08:41:43,813 INFO:Starting new HTTPS connection (1): 50.17.208.31
2017-05-23 08:41:58,828 ERROR:No response from: 50.17.208.31
2017-05-23 08:41:58,829 INFO:Using region server: 54.253.118.149
2017-05-23 08:41:58,830 INFO:Starting new HTTPS connection (1): 54.253.118.149
2017-05-23 08:41:59,486 INFO:Starting new HTTP connection (1): 54.245.112.93
2017-05-23 08:44:44,492 INFO:[Service] No SMT server found, nothing to do
2017-05-23 08:49:52,118 INFO:[Service] No SMT server found, nothing to do


Attempting to re-run
registercloudguest --force-new just hangs with similar errors under /var/log/cloudregister.

Are the region servers having issues?

jlreate03
24-May-2017, 09:29
The issue seems to be resolved today, just tried launching
suse-sles-12-sp2-v20161214-hvm-ssd-x86_64 (ami-c425e4ab) on eu-central-1 and the instance was able to register and access the SUSE repos successfully.