PDA

View Full Version : SLES 12 SP2 Xen Windows 10 Pro guest won't update to Windows 1607



capekeppel
15-Feb-2017, 04:51
I have an SLES12 SP2 host machine with 3 guests - two are Windows 10 Professional, the third is an SLES12 SP2 Samba server.
For the most part, the system is working perfectly.

However, both of the Windows 10 guests have the same problem - they are trying to update to the latest major Windows 10 build (1607) and they fail every time.
Note that normal Windows updates have all worked fine - just the major ones seem to choke.

I've had this problem since I installed the Windows guests. I installed the original Windows 10 and then the update to Windows 10 build 1511 did the same thing under SLES11 SP4.
I installed a new clean copy of SLES12 and ran the old guest machines, tried to update, but that made no difference.
I then reinstalled the new Windows build 1511 from scratch in new guest machines for both systems.
That worked just fine and everything has been humming along ever since.

However, now it's trying very hard to force the update to 1607, and for these machines I'd like to keep them up to date.
I'd also prefer not to start from scratch again. And I'm expecting another major Windows build soon - I'm sure it will have the same problem.

The host machine is running a fully updated copy of SLES12 SP2 (I just updated from SP1 to see if it would solve the problem).
Both Windows machines are clean installs of Windows 10 build 1511 with a single application running in each.
I also installed Suse VMDP 2.4 in both Windows machines.
They are both Xen (fullvirt) X86_64 machines.

The failure has happened a couple of different ways
1. Update runs normally for a while, and then freezes with cpu utilization at about 25% and never stops.
If I force the machine off and reboot, it says 'Restoring your previous version of Windows'.
2. Update runs normally to 32%, then reboots and says 'Restoring your previous version of Windows'.

Has anyone else seen this problem?

The logs in /var/log/xen don't appear to have any useful information in them.
The windows update logs are also useless - no real indication of what went wrong.

Since Microsoft isn't much help (not supported), does anyone have any suggestions?

Thanks,

Al

Automatic Reply
20-Feb-2017, 06:30
capekeppel,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- Open a service request: https://www.suse.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot..

Good luck!

Your SUSE Forums Team
http://forums.suse.com

KBOYLE
20-Feb-2017, 17:16
capekeppel wrote:

> However, both of the Windows 10 guests have the same problem - they
> are trying to update to the latest major Windows 10 build (1607) and
> they fail every time.

Windows 10 does have a few quirks. :(

Have you considered that this may have nothing to do with running as a
Xen DomU?

A quick Google search returns many results for this issue. You may want
to check there for a solution.

Here are a couple I found:
http://www.redmondpie.com/fix-windows-10-anniversary-update-install-stuck-issue-heres-how/
http://www.easeus.com/partition-manager-software/windows-10-1607-update-stuck.html

The "fix" will depend on what is preventing your update from completing
and you haven't yet determined that.

I would first look for a "Windows" solution. If you find something in
the logs that suggests it's SLES related, someone here may be able to
offer some suggestions.

Please let us know what you learn.


--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below this post.
Thank you.

mmccaffe
11-May-2017, 18:56
I have an SLES12 SP2 host machine with 3 guests - two are Windows 10 Professional, the third is an SLES12 SP2 Samba server.
For the most part, the system is working perfectly.

However, both of the Windows 10 guests have the same problem - they are trying to update to the latest major Windows 10 build (1607) and they fail every time.
Note that normal Windows updates have all worked fine - just the major ones seem to choke.

I've had this problem since I installed the Windows guests. I installed the original Windows 10 and then the update to Windows 10 build 1511 did the same thing under SLES11 SP4.
I installed a new clean copy of SLES12 and ran the old guest machines, tried to update, but that made no difference.
I then reinstalled the new Windows build 1511 from scratch in new guest machines for both systems.
That worked just fine and everything has been humming along ever since.

However, now it's trying very hard to force the update to 1607, and for these machines I'd like to keep them up to date.
I'd also prefer not to start from scratch again. And I'm expecting another major Windows build soon - I'm sure it will have the same problem.

The host machine is running a fully updated copy of SLES12 SP2 (I just updated from SP1 to see if it would solve the problem).
Both Windows machines are clean installs of Windows 10 build 1511 with a single application running in each.
I also installed Suse VMDP 2.4 in both Windows machines.
They are both Xen (fullvirt) X86_64 machines.

The failure has happened a couple of different ways
1. Update runs normally for a while, and then freezes with cpu utilization at about 25% and never stops.
If I force the machine off and reboot, it says 'Restoring your previous version of Windows'.
2. Update runs normally to 32%, then reboots and says 'Restoring your previous version of Windows'.

Has anyone else seen this problem?

The logs in /var/log/xen don't appear to have any useful information in them.
The windows update logs are also useless - no real indication of what went wrong.

Since Microsoft isn't much help (not supported), does anyone have any suggestions?

Thanks,

Al

I believe you need to temporarily change your Windows 10 guest VM's CPU to CoreDuo for the upgrade to complete.
After the upgrade is complete you can reset the CPU back to what is was.

-Marty-