PDA

View Full Version : SLES 12 SP2 creating a repository and publishing it with SMT



philiphaupt
15-Feb-2017, 14:29
HI,

we are currently trying to configure a custom repository for our SMT Server runing on SLES 12 SP2.
I have followed this guide: https://www.suse.com/communities/blog/creating-yum-repository-and-publishing-it-smt/

Everything seems to be fine until I try to integrate the repository in our SMT.

After using:

smt-setup-custom-catalogs --productid 100642 \
--name "Internal_SLES11_SP4_UPDATES" \
--exturl "https://internal/bw_repo" \
--description "BW SLES Updates"

I get:

15d3415fead1170df43a99e1f8f6a3d50bf63f52 is not a valid custom repository
Adding repository failed.

Please tell me what I am missing.
Thx!

timstein
16-Feb-2017, 13:11
Same here on SLES 11 SP4 fully patched:


# smt-setup-custom-repos --name 'SLES11-SP3-VMwareTools-5_5latest-x86_64' --description 'SLES11-SP3-VMwareTools-5_5latest-x86_64' --exturl 'http://packages.vmware.com/tools/esx/5.5latest/sles11sp3/x86_64/' --target sle-11-x86_64 --productid 100877
c7abdff267242a47a053440223cfcee4ebaed037 is not a valid custom repository
Adding repository failed.

ataschner
16-Feb-2017, 15:54
Hi

That is clearly a bug in the latest SMT update.
I have reproduced and opened https://bugzilla.suse.com/show_bug.cgi?id=1025682

(I am happy my document was not broken)
Thanks
//Andreas

ataschner
20-Feb-2017, 10:22
In the end this turned out to be a duplicate of another issue.
The fix is included in smt-3.0.23, which was released for SLES 12 SP2 a few days ago - https://download.suse.com/Download?buildid=qxm_O_G_U_E~
The update for SLES 11 SP3 (4) is still in QA testing and expected to hit the street soon.
//Andreas