PDA

View Full Version : SLES 12 SP1 Missing Simplified Chinese font on Firefox ESR 45.6 on SUSE



clsweeney
21-Feb-2017, 15:08
First time on a forum so hoping this might be the right place to ask this question as I've researched for days online without a solution.

I'm not sure if it relates to the Firefox that came with SUSE, or SUSE itself, or something else.

I have a Virtual machine with SUSE Linux Enterprise Server 12, Patchlevel 1. It installed with Firefox ESR 45.6.0. The Virtual Machine is an NVR which has it's own UI. In viewing a dropdown for languages, the font for Simplified Chinese shows boxes instead of Chinese characters. If I view the VM via it's URL in any browser, the characters are fine. I have tried various language settings via YAST for the virtual machine, as well as toggling various settings for Firefox through preferences and about:config. Character encoding is UTF-8. I then started searching down the SUSE path - could I be missing a font in /usr/share/fonts/truetype. I tried to find a ttf file for arphic fonts but unable to do so. I have compared various language/font settings with another Virtual Machine with the same SUSE version but it has Firefox 38.8.0. Chinese characters show up fine on this second VM.

Would this be a question for this forum and if so, would anyone have advice?

Many thanks

KBOYLE
21-Feb-2017, 19:10
First time on a forum
Welcome to the SUSE forums...


so hoping this might be the right place to ask this question as I've researched for days online without a solution.

You are running a visualized SLES 12 so this is an appropriate forum for virtualization issues. The other forum that may have been appropriate is SLES Configure-Administer (https://forums.suse.com/forumdisplay.php?16-SLES-Configure-Administer). We're here now so let's continue.


I'm not sure if it relates to the Firefox that came with SUSE, or SUSE itself, or something else.

I have a Virtual machine with SUSE Linux Enterprise Server 12, Patchlevel 1.
What hypervisor are you using? (It may or may not be relevant.)


It installed with Firefox ESR 45.6.0. The Virtual Machine is an NVR which has it's own UI.
Okay.

You have an application running on your virtual SLES 12 server.
The application has it's own UI.


In viewing a dropdown for languages, the font for Simplified Chinese shows boxes instead of Chinese characters. If I view the VM via it's URL in any browser, the characters are fine.
This is where I'm a bit confused.

To which dropdown are you referring? Is it part of the application? YaST?
How do you view the VM in a browser? Is this the UI to which you referred?
If you login to the server from the system console, are you able to view any Chinese characters in any file using any application?
If you open Firefox on the server from the system console (assuming you have a GUI installed), can you view any Chinese characters using the URL you mention?


Please provide this additional information. Others may also respond with helpful suggestions.

clsweeney
23-Feb-2017, 12:22
[QUOTE=KBOYLE;36664]Welcome to the SUSE forums...

Thank you!

You are running a visualized SLES 12 so this is an appropriate forum for virtualization issues. The other forum that may have been appropriate is SLES Configure-Administer (https://forums.suse.com/forumdisplay.php?16-SLES-Configure-Administer). We're here now so let's continue.


What hypervisor are you using? (It may or may not be relevant.)
I installed virt-manager - I am new to virtual machines too so I believe hypervisor is the manager.


Okay.

You have an application running on your virtual SLES 12 server.
The application has it's own UI.
Correct, the NVR VM has it's own local Admin UI. I'll call this the NVR UI.



This is where I'm a bit confused.

To which dropdown are you referring? Is it part of the application? YaST?
Apologies - it's a dropdown selection on our NVR UI screen - the UI automatically uses the Firefox that comes with the SUSE Operating system.

How do you view the VM in a browser? Is this the UI to which you referred?
My VM NVR has an IP - so if I type in that IP to any browser standalone (outside of the NVR) then the same dropdown selection on the NVR's UI does show the Chinese characters correctly. The issue I see is if I run up the 'local' UI from within the NVR (this uses Firefox).

If you login to the server from the system console, are you able to view any Chinese characters in any file using any application?
Ah very good point and if I understand it correctly I think it shows it is not an issue with SUSE : so I tried the following - I used the NVR UI to set the language to the 'bad' Chinese characters (via the dropdown selection I referred to above). This in turn sets a default file on our linux system to be in the language I've just chosen. If I cat this file on the linux filesystem - it shows the Chinese characters correctly.

If you open Firefox on the server from the system console (assuming you have a GUI installed), can you view any Chinese characters using the URL you mention?
If i try a general search on Chinese characters from within the NVR UI, I see the same issue - I am not able to see Chinese characters on any web site from within the system.


So from working through the responses above I think maybe it points more towards Firefox than SUSE - would you agree?

Please provide this additional information. Others may also respond with helpful suggestions.

Thanks for all the help.

KBOYLE
23-Feb-2017, 17:54
So from working through the responses above I think maybe it points more towards Firefox than SUSE - would you agree?

Yes, it appears to be an issue with Firefox.

I did a quick Google search and found this Firefox AddOn.
Chinese Simplified (zh-CN) Language Pack (https://addons.mozilla.org/en-US/firefox/addon/chinese-simplified-zh-cn-la)

Please let us know if it resolves your issue.

clsweeney
23-Feb-2017, 18:18
Thank you! The language pack was one of the first things I tried. Thanks for helping me step through the issue to redirect me back to Firefox.
Much appreciated!

clsweeney
08-Mar-2017, 15:14
Thank you! The language pack was one of the first things I tried. Thanks for helping me step through the issue to redirect me back to Firefox.
Much appreciated!

I just wanted to add a follow-up in case anyone else finds this thread, looking for the same issue. I found a solution for my issue as follows:
- on my Ubuntu host: chose System Settings -> Language Support -> Install/Remove Languages -> selected Chinese (Simplified)
- this installed /usr/share/fonts/truetype/arphic dir on my Ubuntu host with two font files: ukai.ttc and uming.ttc
- copied these files over onto my NVR Virtual Machine into /usr/share/fonts/truetype
- Chinese characters now display correctly after an NVR reboot.

Getting it to work this way raised other questions for me - but this provides a solution.

malcolmlewis
08-Mar-2017, 15:40
On Wed 08 Mar 2017 02:24:02 PM CST, clsweeney wrote:

clsweeney;36717 Wrote:
> Thank you! The language pack was one of the first things I tried.
> Thanks for helping me step through the issue to redirect me back to
> Firefox.
> Much appreciated!

I just wanted to add a follow-up in case anyone else finds this thread,
looking for the same issue. I found a solution for my issue as
follows:
- on my Ubuntu host: chose System Settings -> Language Support ->
Install/Remove Languages -> selected Chinese (Simplified)
- this installed /usr/share/fonts/truetype/arphic dir on my Ubuntu host
with two font files: ukai.ttc and uming.ttc
- copied these files over onto my NVR Virtual Machine into
/usr/share/fonts/truetype
- Chinese characters now display correctly after an NVR reboot.

Getting it to work this way raised other questions for me - but this
provides a solution.




Hi
Both those fonts are available in the distribution as supported
packages, no need for manual transfer?

- arphic-ukai-fonts
- arphic-uming-fonts

Plus, if manually transferring fonts, either system wide or at user
level (~/.fonts) remember to run fc-cache to rebuild the fonts database.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

KBOYLE
08-Mar-2017, 16:02
I just wanted to add a follow-up in case anyone else finds this thread, looking for the same issue. I found a solution for my issue as follows:
- on my Ubuntu host: chose System Settings -> Language Support -> Install/Remove Languages -> selected Chinese (Simplified)
- this installed /usr/share/fonts/truetype/arphic dir on my Ubuntu host with two font files: ukai.ttc and uming.ttc
- copied these files over onto my NVR Virtual Machine into /usr/share/fonts/truetype
- Chinese characters now display correctly after an NVR reboot.

Getting it to work this way raised other questions for me - but this provides a solution.

In one of your earlier posts you say:

so I tried the following - I used the NVR UI to set the language to the 'bad' Chinese characters (via the dropdown selection I referred to above). This in turn sets a default file on our linux system to be in the language I've just chosen. If I cat this file on the linux filesystem - it shows the Chinese characters correctly.

I understood that to mean that you had Chinese character support working on your SLES system and the language pack provided Chinese character support within Firefox. I thought your issue had been resolved.

Did I miss something?

clsweeney
08-Mar-2017, 18:50
Hi
Both those fonts are available in the distribution as supported
packages, no need for manual transfer?

- arphic-ukai-fonts
- arphic-uming-fonts

Plus, if manually transferring fonts, either system wide or at user
level (~/.fonts) remember to run fc-cache to rebuild the fonts database.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

Hello, thanks for responding Malcolm.
I did run fc-cache -f -v after bringing over the two new fonts - thanks for the reminder here.

I tried to check for arphic-ukai-fonts and arphic-uming-fonts on my Virtual machine (linux) but don't appear to be there. I am using the following to check:
zypper -n search arphic*
rpm -qa | grep arphic

which don't show the packages. Is there a way to check if I have those packages available to me on my linux system?

thanks
Clare

clsweeney
08-Mar-2017, 19:03
Hello - sorry I didn't explain that very well. What I meant was, that even though I couldn't see the Chinese characters on my NVR UI - that I could view Chinese characters correctly within a file on my linux system. This brought me to the conclusion at that time, that my linux system was fine (and so sent me back to look at firefox). The Firefox language pack did not provide a solution.

Now that I have added two new font files manually, my NVR UI correctly displays Chinese characters. The reason I said 'Getting it to work this way raised other questions for me' - was that I expected that, if I could originally view a file correctly with the characters on my linux system, that I should not be missing any font file from my system. However, my solution has been to add new font files.

thanks
Clare

malcolmlewis
08-Mar-2017, 19:11
Hello, thanks for responding Malcolm.
I did run fc-cache -f -v after bringing over the two new fonts - thanks for the reminder here.

I tried to check for arphic-ukai-fonts and arphic-uming-fonts on my Virtual machine (linux) but don't appear to be there. I am using the following to check:
zypper -n search arphic*
rpm -qa | grep arphic

which don't show the packages. Is there a way to check if I have those packages available to me on my linux system?

thanks
Clare
Hi
All available via the 'Pool' repo in SLES and SLED;



SLES 12 SP1

zypper --no-refresh se arphic

S | Name | Summary | Type
--+-----------------------+----------------------------------------------------------------+--------
| arphic-bkai00mp-fonts | AR PL KaitiM Big5 Chinese TrueType font by Arphic Technology | package
| arphic-bsmi00lp-fonts | AR PL Mingti2L Big5 Chinese TrueType font by Arphic Technology | package
| arphic-fonts | Chinese TrueType Fonts (Contains Only the License Text) | package
| arphic-gbsn00lp-fonts | AR PL SungtiL GB Chinese TrueType font by Arphic Technology | package
| arphic-gkai00mp-fonts | AR PL KaitiM GB Chinese TrueType font by Arphic Technology | package
| arphic-ukai-fonts | CJK Unicode Font Kai Style | package
| arphic-uming-fonts | CJK Unicode Font Ming Style | package
| texlive-arphic | Arphic (Chinese) font packages | package
| texlive-arphic-fonts | Severed fonts for texlive-arphic | package
zypper --no-refresh if arphic-ukai-fonts

Information for package arphic-ukai-fonts:
------------------------------------------
Repository: SLES12-SP1-Pool for x86_64
Name: arphic-ukai-fonts
Version: 0.2.20080216.1-97.171
Arch: noarch
Vendor: SUSE LLC <https://www.suse.com/>
Support Level: Level 2
Installed: No
Status: not installed
Installed Size: 16.9 MiB
Summary: CJK Unicode Font Kai Style
Description:
This font was taken from the from the TrueType fonts generously
released by Arphic Technologies Taiwan under the Arphic Public License.
It was modified with Fontforge by Arne Goetje <arne@linux.org.tw> to
contain both Big5 and GB2312 charsets plus some european characters.

Currently it fully supports the following charsets:
ISO8859-1,2,3,4,7,9,10,13,14,15 Big5 GB2312-80 Bopomofo Extensions for
Hakka, Minnan (Unicode 4.0) and MBE variants using the Stylistic
Alternatives (salt) feature from the OTF spec.

Partly support is implemented for: HKSCS CNS 11643 GB18030 Japanese
Korean

SLED 12 SP1

zypper --no-refresh se arphic

S | Name | Summary | Type
--+-----------------------+----------------------------------------------------------------+--------
| arphic-bkai00mp-fonts | AR PL KaitiM Big5 Chinese TrueType font by Arphic Technology | package
| arphic-bsmi00lp-fonts | AR PL Mingti2L Big5 Chinese TrueType font by Arphic Technology | package
| arphic-fonts | Chinese TrueType Fonts (Contains Only the License Text) | package
| arphic-gbsn00lp-fonts | AR PL SungtiL GB Chinese TrueType font by Arphic Technology | package
| arphic-gkai00mp-fonts | AR PL KaitiM GB Chinese TrueType font by Arphic Technology | package
| arphic-ukai-fonts | CJK Unicode Font Kai Style | package
| arphic-uming-fonts | CJK Unicode Font Ming Style | package
| texlive-arphic | Arphic (Chinese) font packages | package
| texlive-arphic-fonts | Severed fonts for texlive-arphic | package

zypper --no-refresh if arphic-ukai-fonts

Information for package arphic-ukai-fonts:
------------------------------------------
Repository: SLED12-SP1-Pool for x86_64
Name: arphic-ukai-fonts
Version: 0.2.20080216.1-97.171
Arch: noarch
Vendor: SUSE LLC <https://www.suse.com/>
Support Level: Level 2
Installed: No
Status: not installed
Installed Size: 16.9 MiB
Summary: CJK Unicode Font Kai Style
Description:
This font was taken from the from the TrueType fonts generously
released by Arphic Technologies Taiwan under the Arphic Public License.
It was modified with Fontforge by Arne Goetje <arne@linux.org.tw> to
contain both Big5 and GB2312 charsets plus some european characters.

Currently it fully supports the following charsets:
ISO8859-1,2,3,4,7,9,10,13,14,15 Big5 GB2312-80 Bopomofo Extensions for
Hakka, Minnan (Unicode 4.0) and MBE variants using the Stylistic
Alternatives (salt) feature from the OTF spec.

Partly support is implemented for: HKSCS CNS 11643 GB18030 Japanese
Korean

KBOYLE
08-Mar-2017, 19:26
The Firefox language pack did not provide a solution.

Hi Clare,

I understood that the language pack did resolve your issue and that you no longer needed assistance. I apologize for the misunderstanding.

I appreciate the follow-up. It will help others who might encounter this issue.

clsweeney
09-Mar-2017, 11:53
Hi Clare,

I understood that the language pack did resolve your issue and that you no longer needed assistance. I apologize for the misunderstanding.

I appreciate the follow-up. It will help others who might encounter this issue.

Thanks for all the advice Kevin - this forum was great help!
Clare

clsweeney
09-Mar-2017, 11:59
thank you Malcolm - great information.

Clare