PDA

View Full Version : SLES 11 SP3 Can not resolve QLogic driver dependencies on sles11sp3



wernaun
09-Mar-2017, 09:35
Hi all,

our HPE Proliant DL360p Gen8 Server need the latest QLogic HBA Drivers, but we can't install this because there are unresolved packet dependencies.

All other updates from PSP 2016.10 installed successfully.

Error message: (manual install)

rpm -Uvh qlgc-qla2xxx-kmp-default-8.07.00.34.11.3_k_3.0.76_0.11-3.sles11sp3.x86_64.rpm
warning: qlgc-qla2xxx-kmp-default-8.07.00.34.11.3_k_3.0.76_0.11-3.sles11sp3.x86_64.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID b1275ea3
error: Failed dependencies:
kernel(default:drivers_pci_pcie_aer_aerdriver) = 8552524c70e5aa06 is needed by qlgc-qla2xxx-kmp-default-8.07.00.34.11.3_k_3.0.76_0.11-3.sles11sp3.x86_64

The update via HP SUM (7.6.0) is also not possible:

Component:
qlgc-qla2xxx-kmp-default-8.07.00.34.11.3_k_3.0.76_0.11-3.sles11sp3.x86_64 SUSE Linux Enterprise Server 11 (AMD64/EM64T) FCoE/FC Driver Kit for HPE Qlogic CNAs, HBAs and mezzanine HBAs (qlgc-qla2xxx-kmp-default-8.07.00.34.11.3_k_3.0.76_0.11-3.sles11sp3.x86_64)

Failed dependency details:
kernel(default:drivers_pci_pcie_aer_aerdriver)

I hope anyone can help me.

Thanks!

Kind regards

Nils

Massimo Rosen
09-Mar-2017, 14:27
Am 09.03.2017 um 09:44 schrieb wernaun:
>
> Hi all,
>
> our HPE Proliant DL360p Gen8 Server need the latest QLogic HBA Drivers,
> but we can't install this because there are unresolved packet
> dependencies.
>
> All other updates from PSP 2016.10 installed successfully.
>
> ERROR MESSAGE: (MANUAL INSTALL)
>
> rpm -Uvh
> qlgc-qla2xxx-kmp-default-8.07.00.34.11.3_k_3.0.76_0.11-3.sles11sp3.x86_64.rpm
> warning:
> qlgc-qla2xxx-kmp-default-8.07.00.34.11.3_k_3.0.76_0.11-3.sles11sp3.x86_64.rpm:
> Header V3 RSA/SHA1 signature: NOKEY, key ID b1275ea3
> error: Failed dependencies:
> kernel(default:drivers_pci_pcie_aer_aerdriver) =
> 8552524c70e5aa06 is needed by
> qlgc-qla2xxx-kmp-default-8.07.00.34.11.3_k_3.0.76_0.11-3.sles11sp3.x86_64
>
> THE UPDATE VIA HP SUM (7.6.0) IS ALSO NOT POSSIBLE:
>
> Component:
> qlgc-qla2xxx-kmp-default-8.07.00.34.11.3_k_3.0.76_0.11-3.sles11sp3.x86_64
> SUSE Linux Enterprise Server 11 (AMD64/EM64T) FCoE/FC Driver Kit for HPE
> Qlogic CNAs, HBAs and mezzanine HBAs
> (qlgc-qla2xxx-kmp-default-8.07.00.34.11.3_k_3.0.76_0.11-3.sles11sp3.x86_64)
>
> Failed dependency details:
> kernel(default:drivers_pci_pcie_aer_aerdriver)
>
> I hope anyone can help me.

Do you happen to have more than one server? Does it happen on all of them?

The possible reasons I can think of:

1. You run a non-standard kernel.
2. Your RPM database is severely sick.
3. The rpm HP provides is broken.

Go into yast, software management check "provides" in the search box and
search for default:drivers_pci_pcie_aer_aerdriver

You should get your kernel-default-base package reported as result.

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de

wernaun
09-Mar-2017, 15:21
Hello Massimo,

thanks for your answer!
We have another server of that model with the same patch level, but this one is productive.
I can test it if the first server is fixed. :(

1. the kernel is default kernel from the distribution
2. that might be -i'll try to check it
3. this is not very likely, but I'll check that too

If i search for default:drivers_pci_pcie_aer_aerdriver
yast is showing this one:

│Name │Summary │Avail. Vers.│Inst. Vers. │Size
│kernel-default-base│The Standard Kernel - base modules│3.0.101 │3.0.93 │ 22.9 MiB

Version: 3.0.101-0.47.71.1 Installed: 3.0.93-0.8.2
Size: 22.9 MiB Media No.: 0
License: GPL v2 only
Package Group: System/Kernel
Source Package: kernel-default-3.0.101-0.47.71.1

Should I install the latest outstanding updates and patches?
I will do so if the chance is available to fix that issue, but if it unlikely -better not. (there is a lot of critical 3rd party software installed...)

Kind regards,

Nils

Massimo Rosen
09-Mar-2017, 15:54
Am 09.03.2017 um 15:24 schrieb wernaun:
>
> Hello Massimo,
>
> thanks for your answer!
> We have another server of that model with the same patch level, but this
> one is productive.
> I can test it if the first server is fixed. :(
>
> 1. the kernel is default kernel from the distribution
> 2. that might be -i'll try to check it
> 3. this is not very likely, but I'll check that too
>
> If i search for default:drivers_pci_pcie_aer_aerdriver
> yast is showing this one:
>
> │Name │Summary
> │Avail. Vers.│Inst. Vers. │Size
> │kernel-default-base│The Standard Kernel - base
> modules│3.0.101 │3.0.93 │ 22.9 MiB
>
> Version: 3.0.101-0.47.71.1 Installed: 3.0.93-0.8.2
> Size: 22.9 MiB Media No.: 0
> License: GPL v2 only
> Package Group: System/Kernel
> Source Package: kernel-default-3.0.101-0.47.71.1
>
> Should I install the latest outstanding updates and patches?
> I will do so if the chance is available to fix that issue, but if it
> unlikely -better not. (there is a lot of critical 3rd party software
> installed...)


Well, your server seems rather seriously outdated, so patching is
certainly a good idea. At any rate, your running kernel looks clearly
much older than the HP driver you try to install. Your running kernel is
dated Sep. 2013!

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de

wernaun
10-Mar-2017, 07:40
Hi Massimo,

now the server is up to date and the driver was installed successfully! :)
I'll hope the 3rd party software still works...

Thank you very much!

Kind regards,

Nils

Susie2017
05-Jun-2017, 02:03
Hi

We have SLES-11-SP3-DVD-x86_64-GM-DVD1.iso installed in our HP server and planning to upgrading the QHM2672 by replacing it with the one (8.07.00.34.11.3-k) downloaded from HP site.

However, in case any problems occur with 8.07.00.34.11.3-k, we'd like to make sure the current qlogic driver (8.04.00.13.11.3-k) that came with SLES-11-SP3-DVD-x86_64-GM-DVD1.iso can be re-installed.

Current:
kernel: kernel-default-3.0.76-0.11.1.x86_64.rpm
qlogic driver: QHM2672 8.04.00.13.11.3-k

Here's the question:

Can I simply re-install qla2xxx.ko (8.04.00.13.11.3-k from SLES-11-SP3-DVD-x86_64-GM-DVD1.iso) to replace with the driver from HP (8.07.00.34.11.3-k)?

thanks,
Susie