PDA

View Full Version : Google Earth



AlexDudko
07-Apr-2012, 10:48
Google Earth stopped working in SLED-11 SP2. A week ago it worked just fine, but now it doesn't start giving this error in terminal:

/opt/google/earth/free/googleearth-bin
/opt/google/earth/free/googleearth-bin: error while loading shared libraries: libgoogleearth_free.so: cannot open shared object file: No such file or directory

This library is there in this directory:

locate libgoogleearth_free.so
/opt/google/earth/free/libgoogleearth_free.so

Google Earth version is:

zypper if google-earth-stable
Refreshing service 'nu_novell_com'.
Retrieving repository 'google-earth' metadata [done]
Loading repository data...
Reading installed packages...


Information for package google-earth-stable:

Repository: @System
Name: google-earth-stable
Version: 6.2.1.6014-0
Arch: i386
Vendor: Google Inc.
Support Level: unknown
Installed: Yes
Status: up-to-date
Installed Size: 102.5 MiB
Summary: Google Earth
Description:
Explore, search and discover the planet

Google Earth lets you fly anywhere to see satellite imagery, 3D buildings, 3D trees, terrain, Street View, planets and much more.


Any suggestions are welcome.

malcolmlewis
10-Apr-2012, 14:19
Google Earth stopped working in SLED-11 SP2. A week ago it worked just
fine, but now it doesn't start giving this error in terminal:
> /opt/google/earth/free/googleearth-bin
> /opt/google/earth/free/googleearth-bin: error while loading shared
> libraries: libgoogleearth_free.so: cannot open shared object file: No
> such file or directory

This library is there in this directory:
> locate libgoogleearth_free.so
> /opt/google/earth/free/libgoogleearth_free.so

Google Earth version is:
> zypper if google-earth-stable
> Refreshing service 'nu_novell_com'.
> Retrieving repository 'google-earth' metadata [done]
> Loading repository data...
> Reading installed packages...
>
>
> Information for package google-earth-stable:
>
> Repository: @System
> Name: google-earth-stable
> Version: 6.2.1.6014-0
> Arch: i386
> Vendor: Google Inc.
> Support Level: unknown
> Installed: Yes
> Status: up-to-date
> Installed Size: 102.5 MiB
> Summary: Google Earth
> Description:
> Explore, search and discover the planet
>
> Google Earth lets you fly anywhere to see satellite imagery, 3D
> buildings, 3D trees, terrain, Street View, planets and much more.
>

Any suggestions are welcome.



Hi
Just tried that version here (x86_64) and it's fine. I would try a
re-install;


zypper in -f google-earth



--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 0:29, 3 users, load average: 0.03, 0.08, 0.11
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

mikewillis
10-Apr-2012, 16:31
I've got 6.2.1.6014-0 running on x86_64 too.

I've not got the rpm installed though. I used


$ rpm2cpio google-earth-stable_current_x86_64.rpm | cpio -idmv
to extract the contents of the rpm to a directory and run Google Earth from there. That way I know it's not going to get automatically updated to a version which doesn't work with SLED or something annoying like that.

AlexDudko
10-Apr-2012, 18:55
I've got 6.2.1.6014-0 running on x86_64 too.

I've not got the rpm installed though. I used


$ rpm2cpio google-earth-stable_current_x86_64.rpm | cpio -idmv
to extract the contents of the rpm to a directory and run Google Earth from there. That way I know it's not going to get automatically updated to a version which doesn't work with SLED or something annoying like that.

I've got a 32-bit system here with pae kernel. Google Earth was installed and worked great, but recently it stopped starting with the provided above error message. A reinstall didn't help.

mikewillis
10-Apr-2012, 22:01
I realised I have a 32bit install in a virtual machine so I tried Google Earth on that using the same method I described in my previous post with extracting the contents of the rpm rather than installing it. It works fine. So you could give that a go.

If you look through /var/log/zypp/history does it show Google Earth has having been updated since it last worked? One of the reasons I don't install the Google Earth rpm is because of seeing complaints from people who had installed Google Chrome then found that it automatically updated itself to a version which didn't work with SLED. They were unable to revert to a version which did work. If I don't install the rpm then I don't get Google's repo added.

malcolmlewis
10-Apr-2012, 22:11
I realised I have a 32bit install in a virtual machine so I tried Google
Earth on that using the same method I described in my previous post with
extracting the contents of the rpm rather than installing it. It works
fine. So you could give that a go.

If you look through /var/log/zypp/history does it show Google Earth has
having been updated since it last worked? One of the reasons I don't
install the Google Earth rpm is because of seeing complaints from people
who had installed Google Chrome then found that it automatically updated
itself to a version which didn't work with SLED. They were unable to
revert to a version which did work. If I don't install the rpm then I
don't get Google's repo added.



Hi
They add a at and cron job....


atq
atrm <num from above>
rm /etc/cron.daily/google*
zypper lr
zypper rr <google repo number>


--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 8:19, 3 users, load average: 0.24, 0.07, 0.06
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

AlexDudko
11-Apr-2012, 03:25
Hi
They add a at and cron job....


atq
atrm <num from above>
rm /etc/cron.daily/google*
zypper lr
zypper rr <google repo number>


--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 8:19, 3 users, load average: 0.24, 0.07, 0.06
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

I've tried your method - the same error.
I've found there are bug reports, here's one of them:

Major Version 6
Minor Version 2
Build Number 0001
Build Date Feb 3 2012
Build Time 15:28:07
OS Type 3
OS Major Version 3
OS Minor Version 0
OS Build Version 13
OS Patch Version 27
Crash Signal 11
Crash Time 1333981298
Up Time 4.91519

Stacktrace from glibc:
./libgoogleearth_free.so(+0xc1583)[0xb7729583]
./libgoogleearth_free.so(+0xc1703)[0xb7729703]
[0xffffe400]
/opt/google/earth/free/libmeasure.so(_ZN5earth7measure5state19MeasureStat eContext10OnLoggedInERKNS_4evll11StatusEventE+0x22 )[0xa98f2372]
/opt/google/earth/free/libevll.so(_ZN5earth4evll21ConnectionContextImpl11 FinishLoginEv+0x4b6)[0xb1805586]
/opt/google/earth/free/libevll.so(_ZN5earth4evll7APIImpl17NotifyInitializ edEv+0x165)[0xb14e64b5]
/opt/google/earth/free/libevll.so(_ZN5earth4evll17RenderContextImpl4initE RKNS0_8InitInfoE+0x362)[0xb14551b2]
./librender.so(_ZN12RenderWidget6SetApiEPN5earth4evl l3APIE+0x83)[0xb49c14c3]
./librender.so(_ZN5earth6render12RenderWindow12creat eWidgetEv+0x148)[0xb49a8b28]
./libgoogleearth_free.so(_ZN5earth6client12ModuleWid get9showEventEP10QShowEvent+0x85)[0xb76f94f5]
./libQtGui.so.4(_ZN7QWidget5eventEP6QEvent+0x770)[0xb6a9fa60]
./libQtGui.so.4(_ZN19QApplicationPrivate13notify_hel perEP7QObjectP6QEvent+0xac)[0xb6a3c69c]
./libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6 QEvent+0x484)[0xb6a476c4]
./libQtCore.so.4(_ZN16QCoreApplication14notifyIntern alEP7QObjectP6QEvent+0x78)[0xb74d3ba8]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x145)[0xb6aa16d5]
./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveE v+0x7d)[0xb6aa13cd]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0xc5)[0xb6aa14b5]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x61)[0xb6aa15f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0xb6aa1a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x170)[0xb6aa1560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x61)[0xb6aa15f1]
./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveE v+0x7d)[0xb6aa13cd]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0xc5)[0xb6aa14b5]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x61)[0xb6aa15f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0xb6aa1a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x170)[0xb6aa1560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x61)[0xb6aa15f1]
./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveE v+0x7d)[0xb6aa13cd]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0xc5)[0xb6aa14b5]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x61)[0xb6aa15f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0xb6aa1a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x170)[0xb6aa1560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x61)[0xb6aa15f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0xb6aa1a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x170)[0xb6aa1560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x61)[0xb6aa15f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0xb6aa1a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x170)[0xb6aa1560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x61)[0xb6aa15f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0xb6aa1a2b]
./libQtGui.so.4(_ZN7QWidget10showNormalEv+0x5c)[0xb6a8f16c]
./libgoogleearth_free.so(_ZN10MainWindow18readScreen sizeInfoEv+0xd37)[0xb76f2287]
./libgoogleearth_free.so(_ZN5earth6client11Applicati on12SetupMainWinENS0_3Kvw7ProductEb+0x39c)[0xb773079c]
./libgoogleearth_free.so(_ZN5earth6client11Applicati on3runEv+0x7ca)[0xb77377fa]
./libgoogleearth_free.so(+0xc005b)[0xb772805b]
./libgoogleearth_free.so(earthmain+0x249)[0xb77291b9]
./googleearth-bin[0x804878b]
/lib/libc.so.6(__libc_start_main+0xe5)[0xb524ac25]
./googleearth-bin[0x80486d1]