PDA

View Full Version : SLES 11 SP3 Building Erlang on SLES 11 SP3 s390x



gokkrishh
06-Apr-2017, 07:50
The following are the build time dependencies for Erlang

libopenssl-devel
libssh-devel
ncurses-devel
unixODBC
unixODBC-devel

Using SLES SDK Repository, I have installed ncurses-devel,unixODBC and unixODBC-devel packages. But while trying to install the other two packages, I am facing issue due to incompatibility in dependent packages.

Error:

libopenssl0_9_8 = 0.9.8h is needed by libopenssl-devel-0.9.8h-30.11.s390x
libssh2 = 0.2 is needed by libssh-devel-0.2-5.14.s390x

Below are the installed packages in my SLES 11 SP3 environment

libopenssl0_9_8 is available
libssh2 - 1.2.9 is available

I tried looking for those packages in patch finder but in vain.

Kindly request you to share your insights in overcoming this issue.

Thanks in advance.

Regards
Gokul
SUSE - Certified Linux Admin

ab
06-Apr-2017, 08:23
My SLES 11 SP3 x86_64 system has openssl 0.9.8j, which I would think has
what was there in 'h' plus a bit more. Which exact version do you have
installed?



rpm -qi libopenssl0_9_8 lissh2


Also, are you building this using 'configure' and 'make' and such, or are
you trying to build an RPM which is doing those steps for you? I am no
familiar with Erlang enough to understand this without a bit more from
you. Perhaps the build code is a bit too restrictive with regard to
versions, not allowing for newer ones like 0.9.8j or something.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

gokkrishh
06-Apr-2017, 10:14
Thanks a lot for taking my query to consideration.

https://github.com/linux-on-ibm-z/docs/wiki/Building-Erlang-on-SLES12

I would say I am at the early stage of build. Please refer the above link (Step 2). Those are the five dependencies and I have installed 3 of them

I have libopenssl0_9_8 installed in my system and I am trying to install libopenssl-devel-0.9.8h and I am in need of libopenssl0_9_8h
I have libssh2 - 1.2.9 installed in my system and I am trying to install libssh-devel-0.2-5.14.s390x and I am in need of libssh2 -0.2

I need the below things

libopenssl and corresponding devel package
libssh and corresponding devel package

At this stage building erlang is not the priority but getting its dependencies are important.
Thanks in advance.

Regards
Gokul