PDA

View Full Version : Replacing IBM's java 1.6.0 with openJDK?



kborecky
12-Apr-2012, 18:07
Hello -

I am running a Shibboleth IdP on a SLES 11 SP1 server. I need to compile an extension to the IdP to do delegation, and for that I need the SDK version of Java (a JRE won't work.) But the installation of the dev/JDK package for the IBM Java 1.6.0 would require a) downgrading the Java version, and b) would remove the JDBC drivers. (I don't know what might be using those database connectors, if anything.)

Since the Shib folks recommended using the Sun or OpenJDK over the IBM version for other reasons, I'm thinking about just installing that instead. So...if I install the OpenJDK, will it replace the IBM one, or do I have to un-install that one first? Will the JDK (whichever version) do what the non-JDK version does, in addition to adding the full Java compiler? I already had to revert to a server snapshot over this issue: I tried adding an installation of the IBM Java 1.4.2 JDK because I stupidly thought I could just point my JAVA_HOME to *that* java compiler, but... no. Bad. :-P

I'm sorry to be so clueless, but the world of Java is a bit opaque to me. I just don't want to break what is already working, and I'd rather not have to reinstall the whole IdP and run it on RHEL (which is a more familiar OS for my colleague, a longtime Linux systems-user.)

Thanks for any advice -

Karla B

Automatic reply
19-Apr-2012, 13:30
kborecky,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

jmozdzen
19-Apr-2012, 16:01
Karla,

you ought to be able to install several alternative JREs/JDKs - but of each (Sun/IBM/open/...) only a single version. JDK is only an add-on to JRE, so you can't have i.e. IBM JRE 1.4.2 and IBM JDK 1.6.0.

If you want to switch the "default version" to use, there's the "update-alternatives" command. for that (i.e. "update-alternatives --display java" to list all available Java installs).

Regards,
Jens

kborecky
19-Apr-2012, 19:16
Hi Jens,

Thank you! I did manage to install openJDK, and it kindly updated all the update-alternatives for me. (Thank goodness!) I kept the IBM one on there in case something might want to use that java some day (and can have its java_home set!)

best,
Karla