PDA

View Full Version : SuMa3 susemanager_setup fails



x10050614
24-May-2017, 12:52
Hello,

after installing SuMa3 Packages on SLES12 SP2 and running "yast susemanager_setup" following errors occuring:

- /var/log/susemanager_setup.err
Synchronizing state of postfix.service with SysV init with /usr/lib/systemd/systemd-sysv-install...
Executing /usr/lib/systemd/systemd-sysv-install enable postfix
ERROR: spacewalk-setup failed

- /var/log/susemanager_setup.log
/var/spacewalk already exists. Leaving it untouched.
.....
....
* Restarting services.
Tomcat failed to start properly or the installer ran out of tries. Please check /var/log/tomcat*/catalina.out for errors.

-/var/log/tomcat/catalina.2017-05-24.log
....
...
24-May-2017 09:12:26.101 INFO [localhost-startStop-1] org.apache.catalina.startup.HostConfig.deployDescr iptor Deployment of configuration descriptor /var/cache/tomcat/Catalina/localhost/rhn.xml has finished in 701 ms
24-May-2017 09:12:26.130 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["http-apr-127.0.0.1-8080"]
24-May-2017 09:12:26.253 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["ajp-apr-127.0.0.1-8009"]
24-May-2017 09:12:26.297 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in 1016 ms

Do you have any ideas ?

BR u10t010

malcolmlewis
24-May-2017, 14:07
Hi
Was this a pre setup system and just added the SuMA product?

Normally it's a fresh install and then select SuMA extension during install so it can do it's thing, then run the setup.

Ref: https://www.suse.com/documentation/suse-manager/book_suma3_quickstart_3/data/quickstart3_sec_suma_installation_sles12_sp1_sumae xt.html

x10050614
24-May-2017, 14:29
Hi Malcolm,

thank you for your reply.
This is a SLES12 SP2 installation from scratch (SLE-12-SP2-Server-DVD-x86_64-GM-DVD1) running on VMware. After finished this basic installation, the SUSE Manager 3 extension was added.
Then tried several times the SUSE MAnager setup procedure ( "yast susemanager_setup" ) without success.

Cheers u10t010
P.S. i'm out of office on 25.May until 29.May

malcolmlewis
24-May-2017, 14:49
On Wed 24 May 2017 01:34:01 PM CDT, x10050614 wrote:

Hi Malcolm,

thank you for your reply.
This is a SLES12 SP2 installation from scratch
(SLE-12-SP2-Server-DVD-x86_64-GM-DVD1) running on VMware. After finished
this basic installation, the SUSE Manager 3 extension was added.
Then tried several times the SUSE MAnager setup procedure ( "yast
susemanager_setup" ) without success.

Cheers u10t010
P.S. i'm out of office on 25.May until 29.May




Hi
Did it not ask to add the extension during install? Or was the system
installed offline and registered later?

Can you do an install with system online?

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.2|GNOME 3.20.2|4.4.62-18.6-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

x10050614
24-May-2017, 15:27
Hi Malcolm,

this VM was created from a VMware Template (including our standard users, configs, cronjobs, etc). Then this SLES12 SP2 has been re-registered on scc. After that the extension SUSE Manager 3 has been added and installed.
If we do a online installation it is much more effort. Is there no other way to solve the problem?
If there is no other way to solve the problem, the online installation could be done not before next week.

thank you for your help and best regards,
u10t010

malcolmlewis
24-May-2017, 15:51
Hi Malcolm,

this VM was created from a VMware Template (including our standard users, configs, cronjobs, etc). Then this SLES12 SP2 has been re-registered on scc. After that the extension SUSE Manager 3 has been added and installed.
If we do a online installation it is much more effort. Is there no other way to solve the problem?
If there is no other way to solve the problem, the online installation could be done not before next week.

thank you for your help and best regards,
u10t010
Hi
AFAIK during the install it does some postfix tweaking etc which maybe your standard configs touch this?

So in the setup log, the database, tomact configuration, ssl gets completed?

u10t010
29-May-2017, 14:48
Hi Malcom,

now we've installed the VM again from scratch (SLE-12-SP2-Server-DVD-x86_64-GM-DVD1) and have included the extension SUSE Manager 3 while the installation.
After running "yast susemanager_setup" following errors occuring (it looks similar like before):

- /var/log/susemanager_setup.log
/var/spacewalk already exists. Leaving it untouched.
Filesystem type for /var/cache is ext4 - ok.
Open needed firewall ports...
* Loading answer file: /root/spacewalk-answers.
** Database: Setting up database connection for PostgreSQL backend.
** Database: Populating database.
** Database: --clear-db option used. Clearing database.
** Database: Shutting down spacewalk services that may be using DB.
** Database: Services stopped. Clearing DB.
*** Progress: #
* Configuring tomcat.
* Setting up users and groups.
** GPG: Initializing GPG and importing key.
* Performing initial configuration.
* Configuring apache SSL virtual host.
** /etc/apache2/vhosts.d/vhost-ssl.conf has been backed up to vhost-ssl.conf-swsave
* Configuring jabberd.
* Creating SSL certificates.
** SSL: Generating CA certificate.
** SSL: Deploying CA certificate.
** SSL: Generating server certificate.
** SSL: Storing SSL certificates.
* Deploying configuration files.
* Update configuration in database.
* Setting up Cobbler..
atftpd.service is not a native service, redirecting to systemd-sysv-install
Executing /usr/lib/systemd/systemd-sysv-install enable atftpd
* Restarting services.
Tomcat failed to start properly or the installer ran out of tries. Please check /var/log/tomcat*/catalina.out for errors.


- /var/log/susemanager_setup.err
Synchronizing state of postfix.service with SysV init with /usr/lib/systemd/systemd-sysv-install...
Executing /usr/lib/systemd/systemd-sysv-install enable postfix
createdb: database creation failed: ERROR: database "susemanager" already exists
ERROR: role "susemanager" already exists
ERROR: spacewalk-setup failed


Maybe there is another basic error ?

Cheers, Samuel

malcolmlewis
29-May-2017, 16:37
On Mon 29 May 2017 01:54:02 PM CDT, u10t010 wrote:

Hi Malcom,

now we've installed the VM again from scratch
(SLE-12-SP2-Server-DVD-x86_64-GM-DVD1) and have included the extension
SUSE Manager 3 while the installation.
After running "yast susemanager_setup" following errors occuring (it
looks similar like before):

- /var/log/susemanager_setup.log
/var/spacewalk already exists. Leaving it untouched.
Filesystem type for /var/cache is ext4 - ok.
Open needed firewall ports...
* Loading answer file: /root/spacewalk-answers.
** Database: Setting up database connection for PostgreSQL backend.
** Database: Populating database.
** Database: --clear-db option used. Clearing database.
** Database: Shutting down spacewalk services that may be using DB.
** Database: Services stopped. Clearing DB.
*** Progress: #
* Configuring tomcat.
* Setting up users and groups.
** GPG: Initializing GPG and importing key.
* Performing initial configuration.
* Configuring apache SSL virtual host.
** /etc/apache2/vhosts.d/vhost-ssl.conf has been backed up to
vhost-ssl.conf-swsave
* Configuring jabberd.
* Creating SSL certificates.
** SSL: Generating CA certificate.
** SSL: Deploying CA certificate.
** SSL: Generating server certificate.
** SSL: Storing SSL certificates.
* Deploying configuration files.
* Update configuration in database.
* Setting up Cobbler..
atftpd.service is not a native service, redirecting to
systemd-sysv-install
Executing /usr/lib/systemd/systemd-sysv-install enable atftpd
* Restarting services.
Tomcat failed to start properly or the installer ran out of tries.
Please check /var/log/tomcat*/catalina.out for errors.


- /var/log/susemanager_setup.err
Synchronizing state of postfix.service with SysV init with
/usr/lib/systemd/systemd-sysv-install...
Executing /usr/lib/systemd/systemd-sysv-install enable postfix
createdb: database creation failed: ERROR: database "susemanager"
already exists
ERROR: role "susemanager" already exists
ERROR: spacewalk-setup failed


Maybe there is another basic error ?

Cheers, Samuel




Hi
No custom configuration during install (well add users etc), just a
stock SP2 install and SuMA?

I know this might be a pain, but can you try SLES 12 SP1 instead of SP2?

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.2|GNOME 3.20.2|4.4.62-18.6-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

jmozdzen
30-May-2017, 17:10
Hi Samuel,

what catches the eye:


Hi Malcom,

now we've installed the VM again from scratch
[...]
createdb: database creation failed: ERROR: database "susemanager" already exists
ERROR: role "susemanager" already exists
ERROR: spacewalk-setup failed


Do you happen to place things (i.e. database storage) on a network share you didn't clean out? Because else I'd been asking myself where the database did come from, if you set up the system from scratch?

Regards,
J

kwk
31-May-2017, 13:30
On PostgreSQL (which is the preferred DB) you can clean it with these commands:
su - postgres -c "dropdb $MANAGER_DB_NAME" 2> /dev/null
su - postgres -c "dropuser $MANAGER_USER" 2> /dev/null
su - postgres -c "dropdb $MANAGER_DB_NAME" 2> /dev/null
su - postgres -c "dropuser $MANAGER_USER" 2> /dev/null

x10050614
31-May-2017, 14:17
Hi Malcolm, J and kwk,

thanks a lot for your kind help and patience.

Now SuSE Manager 3 Installation has been successfully finished, with a SLES12 SP1 installation from scratch and selecting SUSE Manager Extension and without any custom configuration.

Best Regards, u10t010

malcolmlewis
31-May-2017, 14:25
Hi Malcolm, J and kwk,

thanks a lot for your kind help and patience.

Now SuSE Manager 3 Installation has been successfully finished, with a SLES12 SP1 installation from scratch and selecting SUSE Manager Extension and without any custom configuration.

Best Regards, u10t010
Hi
So all working ok? What I did after mirroring down a few repos and adding some systems was run zypper migration to move to SP2 ;)

x10050614
31-May-2017, 15:10
Hi Malcolm,

yes, thanky you, all working ok now :)
Migration to SP2 will be done later.

Cheers, u10t010