PDA

View Full Version : HA SBD Failure / System Reboot - SAP Business One



rkumar509
25-May-2017, 07:25
Hi Expert,

I have a typical situation. SAP

I have SBD configured on 2 VM machine, Server Tolls runs on third machine.

Issue : System replication works fine but every week I have a system shutdown happening and unable to trace why? We do have any auto reboot setup on VM machine. It happens like this: All system working fine, suddenly SAP on client hangs, close and open database missing. When I check VM it say Linux rebooted. On reboot SBD device is missing. Then through Partitioner system admin brings in SBD. Then we follow the standard steps - i.e. define primary & secondary, stop/start SBD, stop /start HDB. Now it is ready to work.
The problem is that this get repeated every week minimum one time or more. I am in a very typical situation as I am unable to track what is happening.
commands like sbd -d /dev/SDB dump results in "== disk /dev/SBD unreadeable!".
Unable to understand whether it is Linux configuration or Cluster configuration causing system fail on regular basis.

Any Support/Help in this regards is highly appreciated.
Regards
Kumar

rkumar509
30-May-2017, 04:55
:( No body to help.......

jmozdzen
30-May-2017, 13:30
Hi rkumar509,

> No body to help.......

no details to work on ;)

Which SLES, which Hypervisor? SUSE Openstack Cloud 7 and SLES10 VMs? ;)

Concerning troubleshooting, for a starter, what's in the logs right before the reboot? "logs" as in "VM-internal logs", "VM-specific logs from the Hypervisor", BMC logs from the hardware server your Hypervisor is running on. Any info from your monitoring/management tools?

Regards,
J