PDA

View Full Version : repquota not working in SP2



emanuele_lombardi
17-Apr-2012, 16:42
After SP1 to SP2 update done by yast2 wagon (followed by a "repair" boot from DVD to solve a boot problem)
I face the problem that repquota doesn't show any value.

My file systems are all xfs (except / which is ext3), and they have quota enabled in /etc/fstab as it follows:

/dev/disk/by-id/cciss-3600508b1001cd0aa0c5915e462045dd1-part3 /home xfs nobarrier,usrquota,grpquota,defaults 1 2

In SP1 the command repquota -u /home
gave the right info but now in SP2 it only prints its heading:

$ repquota -u /home

*** Report for user quotas on device /dev/cciss/c0d0p3
Block grace time: 7days; Inode grace time: 7days
Block limits File limits
User used soft hard grace used soft hard grace
----------------------------------------------------------------------

The strange is that xfs_quota works properly:

$ xfs_quota -x -c "report" /home

User quota on /home (/dev/cciss/c0d0p3)
Blocks
User ID Used Soft Hard Warn/Grace
---------- --------------------------------------------------
root 132444680 0 0 00 [--------]
ernes 28 0 0 00 [--------]
lele 258124 0 0 00 [--------]
medco 64 0 0 00 [--------]


The problem is probably that quotaon doesn't work properly. Infact:

$ quotaon -a
$ quotaon -ap
group quota on /home (/dev/cciss/c0d0p3) is off
user quota on /home (/dev/cciss/c0d0p3) is off
group quota on /f (/dev/sdb) is off
user quota on /f (/dev/sdb) is off

I also added xfs_quota in the INITRD_MODULES in /etc/sysconfig/kernel (and rebooted the machine) but without any result.

This is the ouptut of the mount command:

$ mount

/dev/cciss/c0d0p2 on / type ext3 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devtmpfs on /dev type devtmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,mode=1777)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/cciss/c0d0p3 on /home type xfs (rw,nobarrier,usrquota,grpquota)
/dev/sdb on /f type xfs (rw,nobarrier,usrquota,grpquota)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
securityfs on /sys/kernel/security type securityfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
none on /var/lib/ntp/proc type proc (ro,nosuid,nodev)
nfsd on /proc/fs/nfsd type nfsd (rw)
rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)


Can you please help me?

Thanks from Italy,
Emanuele

Automatic reply
26-Apr-2012, 13:30
emanuele,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com