PDA

View Full Version : SLES11SP4: fence-agent ipmilan from HAE channel not working



berndgsflinux
16-Jun-2017, 16:19
Hi,
i have a two node cluster with HP servers. For fencing i'd like to use the ipmilan fence-agent from the RHCS. They are included in the HAE update repository. I managed to run them on the first node, but before i know that everything is available on the HAE repository. I downloaded the fence-agents and the respective python packages from http://software.opensuse.org/search and installed the rpm's manually. It's working. As said, i find out afterwards that everything is on the repository. For the 2nd node i installed everything via the update repository, the dependencies were solved automatically. But the agent refused to work. There seems to be s.th. wrong with the python packages:


ha-idg-2:~ # stonith -vt rhcs/ipmilan ipaddr=146.107.235.15 login=root passwd=******** auth=password lanplus=1 -S

CRIT: rhcs_run_cmd: fence agent exit code: 1
CRIT: rhcs_status: 'ipmilan monitor' failed with rc -1
ERROR: rhcs/ipmilan device not accessible.


/var/log/messages says:
Jun 16 16:54:30 ha-idg-2 python: Failed: Unable to obtain correct plug status or plug is not available

The python packages fence-agents need are installed.


ha-idg-2:~ # rpm -qR fence-agents
python-curl
python-openssl
python-pexpect
python-requests
python-suds
...

ha-idg-2:~ # rpm -qa|grep -i python
...
python-requests-2.0.1-0.9.37
python-pexpect-3.1-0.7.1
python-curl-7.19.0-5.2.1.2
python-2.6.9-39.1
python-suds-0.4-0.20.1
python-openssl-0.7.0-1.17.2
...

The packages i installed manually on the first node have different version numbers. But i would expect that the needed packages from the HAE repository work fine.

Any ideas ?

Thanks.

Bernd

berndgsflinux
16-Jun-2017, 19:19
I doublechecked it. Using fence-agents from HAE repository does not work with ipmilan, using an elder version from http://ftp.gwdg.de/pub/opensuse/repositories/home:/qvd:/fence-agents/SLE_11_SP2/x86_64/fence-agents-3.1.11-7.17.x86_64.rpm works.
Is it really possible that the official version from the HAE repository does not work, but an elder one i found in the internet, which is intended to be for SLES 11 SP2 ?
When i run now a zypper up my working fencing configuration is lost :-((.

Bernd