PDA

View Full Version : NVIDIA Video Driver



ASesoria_IT
04-Aug-2017, 01:44
I installed Suse Enterprise Desktop 12 SP2 on my Lenovo W540 computer.
I have tried to install the NVIDIA video driver but it does not work for me.
Have you tried?

malcolmlewis
04-Aug-2017, 05:00
Hi and welcome to the forum :)
It's not a dual graphics setup is it?

Can you post the output from;


/sbin/lspci -nnk | egrep -A3 "Display|3D|VGA"

ASesoria_IT
04-Aug-2017, 05:28
================================================== =========================================
EChachagua@echachagua-ltop:~> /sbin/lspci -nnk | egrep -A3 "Display|3D|VGA"
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
Subsystem: Lenovo Device [17aa:221e]
Kernel driver in use: i915
Kernel modules: i915
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK106GLM [Quadro K2100M] [10de:11fc] (rev a1)
Subsystem: Lenovo Device [17aa:221e]
Kernel driver in use: nvidia
Kernel modules: nouveau, nvidia
================================================== =================================================

malcolmlewis
04-Aug-2017, 14:55
On Fri 04 Aug 2017 04:34:01 AM CDT, ASesoria IT wrote:

================================================== =========================================
EChachagua@echachagua-ltop:~> /sbin/lspci -nnk | egrep -A3
"Display|3D|VGA"
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core
Processor Integrated Graphics Controller [8086:0416] (rev 06)
Subsystem: Lenovo Device [17aa:221e]
Kernel driver in use: i915
Kernel modules: i915
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK106GLM
[Quadro K2100M] [10de:11fc] (rev a1)
Subsystem: Lenovo Device [17aa:221e]
Kernel driver in use: nvidia
Kernel modules: nouveau, nvidia
================================================== =================================================




Hi
Ahh, OK, so it is, then you need to look at Bumblebee then;
https://en.opensuse.org/SDB:NVIDIA_Bumblebee

And use this repository;
http://download.opensuse.org/repositories/X11:/Bumblebee/SLE_12_SP2_Backports/

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.2|GNOME 3.20.2|4.4.74-18.20-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!