PDA

View Full Version : SLE 11 SP2 - libgomp1-32bit is missing



sharfuddin
26-Apr-2012, 07:53
SLES 11 SP2 x864

I was doing

/media/SLES-11-SP2-DVD-x86_6407551/suse/x86_64 # rpm -ivh gcc43-32bit-4.3.4_20091019-0.22.17.x86_64.rpm
error: Failed dependencies:
libgomp1-32bit >= 4.3.4_20091019-0.22.17 is needed by gcc43-32bit-4.3.4_20091019-0.22.17.x86_64


then search 'libgomp1-32bit' without luck

/media/SLES-11-SP2-DVD-x86_6407551/suse/x86_64 # ls -l libgo*
-r--r--r-- 3 root root 130636 May 9 2010 libgobject-2_0-0-2.22.5-0.2.23.x86_64.rpm
-r--r--r-- 6 root root 124306 May 9 2010 libgobject-2_0-0-32bit-2.22.5-0.2.23.x86_64.rpm
-r--r--r-- 4 root root 30813 Feb 3 21:46 libgomp46-32bit-4.6.1_20110701-0.13.9.x86_64.rpm
-r--r--r-- 3 root root 28208 Feb 3 21:46 libgomp46-4.6.1_20110701-0.13.9.x86_64.rpm

/media/SLES-11-SP2-DVD-x86_6407551 # find ./suse/ -name "libgomp1-32bit*"
/media/SLES-11-SP2-DVD-x86_6407551 #


strange, "gcc43-32bit-4.3.4_20091019-0.22.17.x86_64.rpm" is part of media, but its dependency 'libgomp1-32bit' is not.

Regards
Muhammad Sharfuddin

sharfuddin
26-Apr-2012, 10:58
installing libgomp46-32bit is the solution