# General

**URL:** https://forums.suse.com/c/general/1.md?page=44

[Latest](https://forums.suse.com/latest.md) · [Categories](https://forums.suse.com/categories.md)

**Page:** 45

---

## [Interceptor API - Stack](https://forums.suse.com/t/interceptor-api-stack/10434)

<div class="topic-metadata">

**Author:** [@thiagohernandes](https://forums.suse.com/u/thiagohernandes)\
**Replies:** 2\
**Last updated:** [May 15, 2018, 4:56pm UTC](https://forums.suse.com/t/interceptor-api-stack/10434 "2018-05-15T16:56:42Z")

</div>

I’m trying to intercept requests from a Stack especific using API Intercetor keep bellow configuration: api.interceptor.config “requestInterceptors”: \[ { “type”: “http”, “paths”: \["/v2-beta/projects/1221222/hosts/3h…

---

## [Unable to add hosts in Rancher 1.6.17( Windows Environment)](https://forums.suse.com/t/unable-to-add-hosts-in-rancher-1-6-17-windows-environment/10425)

<div class="topic-metadata">

**Author:** [@vishnuvpotty](https://forums.suse.com/u/vishnuvpotty)\
**Replies:** 0\
**Last updated:** [May 15, 2018, 7:13am UTC](https://forums.suse.com/t/unable-to-add-hosts-in-rancher-1-6-17-windows-environment/10425 "2018-05-15T07:13:57Z")

</div>

Hi All, I installed rancher server 1.6.17 version, created a windows templates and tried adding hosts. hosts not getting added and seeing this error in event logs. “Error while downloading error: Get /scripts/api.crt: u…

---

## [Not able create same restored Rancher server from committed Rancher server container in Docker host](https://forums.suse.com/t/not-able-create-same-restored-rancher-server-from-committed-rancher-server-container-in-docker-host/10378)

<div class="topic-metadata">

**Author:** [@ranjith](https://forums.suse.com/u/ranjith)\
**Replies:** 3\
**Last updated:** [May 15, 2018, 6:59am UTC](https://forums.suse.com/t/not-able-create-same-restored-rancher-server-from-committed-rancher-server-container-in-docker-host/10378 "2018-05-15T06:59:12Z")

</div>

I have created rancher server with this command below: sudo docker run -d --restart=unless-stopped -p 8080:8080 rancher/server I have worked on the rancher server for some time. Now I want to backup this rancher contai…

---

## [Stack: Last activity Stack / without use](https://forums.suse.com/t/stack-last-activity-stack-without-use/10416)

<div class="topic-metadata">

**Author:** [@thiagohernandes](https://forums.suse.com/u/thiagohernandes)\
**Replies:** 0\
**Last updated:** [May 14, 2018, 8:10pm UTC](https://forums.suse.com/t/stack-last-activity-stack-without-use/10416 "2018-05-14T20:10:03Z")

</div>

How can I tell if a Stack is idle or unused? My intention is to disable the Stack in this case by REST Service.

---

## [Can i start Rancher without connection to public repository?](https://forums.suse.com/t/can-i-start-rancher-without-connection-to-public-repository/10394)

<div class="topic-metadata">

**Author:** [@kuburoman](https://forums.suse.com/u/kuburoman)\
**Replies:** 1\
**Last updated:** [May 13, 2018, 5:20pm UTC](https://forums.suse.com/t/can-i-start-rancher-without-connection-to-public-repository/10394 "2018-05-13T17:20:27Z")

</div>

Hi i am trying to set up k8s cluster on host that don’t have connection to public docker repository. Currently my node is stuck in status Registering with following error in log. I am assuming that rancher agent is try…

---

## [Monitoring options for ETCD](https://forums.suse.com/t/monitoring-options-for-etcd/10064)

<div class="topic-metadata">

**Author:** [@StoneFury](https://forums.suse.com/u/StoneFury)\
**Replies:** 1\
**Last updated:** [May 12, 2018, 4:00am UTC](https://forums.suse.com/t/monitoring-options-for-etcd/10064 "2018-05-12T04:00:34Z")

</div>

The version we’re at doesn’t register etcd as pods. I suppose this means it is an external deployment. My understanding is that etcd should be listening on port 2379, which is the endpoint it uses for metrics. I’d like…

---

## [Enable prometheus alerts](https://forums.suse.com/t/enable-prometheus-alerts/5399)

<div class="topic-metadata">

**Author:** [@mitkaua](https://forums.suse.com/u/mitkaua)\
**Replies:** 3\
**Last updated:** [May 10, 2018, 10:19am UTC](https://forums.suse.com/t/enable-prometheus-alerts/5399 "2018-05-10T10:19:31Z")

</div>

hi, I instaled Prometheus in my environment. Add IP http://:8080/v1/settings/graphite.host. I can't find alerts list in Pmotenteus http://:9090/alerts. How I can enable or attach alert.conf to prometheus ?

---

## [Migrating from Docker Cloud to Rancher Tutorial](https://forums.suse.com/t/migrating-from-docker-cloud-to-rancher-tutorial/9861)

<div class="topic-metadata">

**Author:** [@oliverhausler](https://forums.suse.com/u/oliverhausler)\
**Replies:** 3\
**Last updated:** [May 9, 2018, 7:41am UTC](https://forums.suse.com/t/migrating-from-docker-cloud-to-rancher-tutorial/9861 "2018-05-09T07:41:14Z")

</div>

Docker Cloud will be shutting down in 60 days. Thanks Docker. Googling “move docker cloud to rancher” did not reveal any results, and nobody there even speaks about Rancher. Somebody may want to write a tutorial how we…

---

## [Rancher 1.6.x service upgrade issues](https://forums.suse.com/t/rancher-1-6-x-service-upgrade-issues/10264)

<div class="topic-metadata">

**Author:** [@Thomas\_Hansen](https://forums.suse.com/u/Thomas_Hansen)\
**Replies:** 1\
**Last updated:** [May 9, 2018, 6:05am UTC](https://forums.suse.com/t/rancher-1-6-x-service-upgrade-issues/10264 "2018-05-09T06:05:50Z")

</div>

Is anyone else having problems with upgrading services in their stacks on Rancher 1.6? I often get errors like this: “Failed to allocate instance \[container:1i113198\]: Bad instance \[container:1i113198\] in state \[error\]…

---

## [Missing community catalog](https://forums.suse.com/t/missing-community-catalog/10295)

<div class="topic-metadata">

**Author:** [@StoneFury](https://forums.suse.com/u/StoneFury)\
**Replies:** 2\
**Last updated:** [May 8, 2018, 6:29pm UTC](https://forums.suse.com/t/missing-community-catalog/10295 "2018-05-08T18:29:01Z")

</div>

Running rancher 1.6.17. I was looking for the aws ELB from the community catalog and it is not there. Other items are there and when I look at info it says “community”, so does that mean I am successfully importing the …

---

## [Elastic cattle for rancher 2.0](https://forums.suse.com/t/elastic-cattle-for-rancher-2-0/10333)

<div class="topic-metadata">

**Author:** [@itman](https://forums.suse.com/u/itman)\
**Replies:** 0\
**Last updated:** [May 8, 2018, 12:08pm UTC](https://forums.suse.com/t/elastic-cattle-for-rancher-2-0/10333 "2018-05-08T12:08:53Z")

</div>

Dear community, we had so far with rancher 1.x the possibility to deploy ready-to-use elasticsearch nodes using cattles. I did not find anything similar in the new rancher 2.0. Is this possibility still there, meanin…

---

## [Better to have big fat host or not so fat host](https://forums.suse.com/t/better-to-have-big-fat-host-or-not-so-fat-host/10302)

<div class="topic-metadata">

**Author:** [@Andrew\_Tan](https://forums.suse.com/u/Andrew_Tan)\
**Replies:** 0\
**Last updated:** [May 7, 2018, 12:04am UTC](https://forums.suse.com/t/better-to-have-big-fat-host-or-not-so-fat-host/10302 "2018-05-07T00:04:19Z")

</div>

Hello all, I have a question in regards to peoples strategy in allocating resources. Is it wise to get say a single 32GB host then run all your services in that one host vs getting say 4 hosts at 8GB each and run the app…

---

## [Deploying host vm using rancher](https://forums.suse.com/t/deploying-host-vm-using-rancher/10283)

<div class="topic-metadata">

**Author:** [@rvkrthk](https://forums.suse.com/u/rvkrthk)\
**Replies:** 1\
**Last updated:** [May 4, 2018, 9:29am UTC](https://forums.suse.com/t/deploying-host-vm-using-rancher/10283 "2018-05-04T09:29:05Z")

</div>

To add a host, I am using vsphere machine driver. My company uses proxy and using the boot2docker image URL, I get a timed out error. Hence I want to download the ISO manually and use it. If I upload it onto the datast…

---

## [Rancher services updating by itself](https://forums.suse.com/t/rancher-services-updating-by-itself/10276)

<div class="topic-metadata">

**Author:** [@rodrigopsasaki](https://forums.suse.com/u/rodrigopsasaki)\
**Replies:** 0\
**Last updated:** [May 4, 2018, 12:13am UTC](https://forums.suse.com/t/rancher-services-updating-by-itself/10276 "2018-05-04T00:13:02Z")

</div>

I am using rancher v1.6.10 and am running into a few issues. I am running nodejs dockerized apps, and I’ve been having issues with intermittent 503 status codes. I put in some external monitoring, and I saw that I got …

---

## [Centralized Log set up for Windows Containers](https://forums.suse.com/t/centralized-log-set-up-for-windows-containers/9832)

<div class="topic-metadata">

**Author:** [@vishnuvpotty](https://forums.suse.com/u/vishnuvpotty)\
**Replies:** 4\
**Last updated:** [May 2, 2018, 6:27am UTC](https://forums.suse.com/t/centralized-log-set-up-for-windows-containers/9832 "2018-05-02T06:27:56Z")

</div>

Hi all, I know this may have been asked earlier, but didnt found any valid solutions. I am just trying to get some docker containers to production and using Rancher for orchestration. I am now involved to retrieve app…

---

## [Your Documentation Website Is Down](https://forums.suse.com/t/your-documentation-website-is-down/10237)

<div class="topic-metadata">

**Author:** [@christopher\_clark](https://forums.suse.com/u/christopher_clark)\
**Replies:** 2\
**Last updated:** [May 2, 2018, 3:20am UTC](https://forums.suse.com/t/your-documentation-website-is-down/10237 "2018-05-02T03:20:29Z")

</div>

The title is self explanatory. https://rancher.com/docs/os/v1.0/en/ is down. 404 not found on all pages

---

## [Issue while adding cluster using custom](https://forums.suse.com/t/issue-while-adding-cluster-using-custom/10232)

<div class="topic-metadata">

**Author:** [@shirgaveranjeet](https://forums.suse.com/u/shirgaveranjeet)\
**Replies:** 0\
**Last updated:** [May 1, 2018, 4:55am UTC](https://forums.suse.com/t/issue-while-adding-cluster-using-custom/10232 "2018-05-01T04:55:48Z")

</div>

\[workerPlane\] Failed to bring up Worker Plane: Failed to verify healthcheck: Failed to check https://localhost:10250/healthz for service \[kubelet\] on host \[xxxxxxx\]: Get https://localhost:10250/healthz: dial tcp \[::1\]:10…

---

## [Rancher gui issue](https://forums.suse.com/t/rancher-gui-issue/10218)

<div class="topic-metadata">

**Author:** [@shirgaveranjeet](https://forums.suse.com/u/shirgaveranjeet)\
**Replies:** 0\
**Last updated:** [April 30, 2018, 8:49am UTC](https://forums.suse.com/t/rancher-gui-issue/10218 "2018-04-30T08:49:58Z")

</div>

I am unable to open Rancher Server UI root@ip-ID ~\]# curl -vk https://IP About to connect() to IP port 443 (#0) Trying IP… Connected to IP (IP) port 443 (#0) Initializing NSS with certpath: sql:/etc/pki/nssdb skipping…

---

## [Version 2 : server high availability](https://forums.suse.com/t/version-2-server-high-availability/10207)

<div class="topic-metadata">

**Author:** [@fadomire](https://forums.suse.com/u/fadomire)\
**Replies:** 3\
**Last updated:** [April 29, 2018, 3:10am UTC](https://forums.suse.com/t/version-2-server-high-availability/10207 "2018-04-29T03:10:11Z")

</div>

i read that rancher 2.0 does not use mysql anymore “Rancher server is now 100% written in Go and no longer requires a MySQL database.” https://rancher.com/announcing-rancher-2-0-tech-preview-2/ i have 3 physical serve…

---

## [Changing Haproxy configuration in loadbalancer](https://forums.suse.com/t/changing-haproxy-configuration-in-loadbalancer/10181)

<div class="topic-metadata">

**Author:** [@Aravind](https://forums.suse.com/u/Aravind)\
**Replies:** 1\
**Last updated:** [April 26, 2018, 4:24pm UTC](https://forums.suse.com/t/changing-haproxy-configuration-in-loadbalancer/10181 "2018-04-26T16:24:43Z")

</div>

Hi, I am trying to change haproxy configuration in load balancer using haproxy custom config option. And also i edit the haproxy config file using container shell after restarting load balancer, container port get reset…

---

## [Not able to open Rancher server UI](https://forums.suse.com/t/not-able-to-open-rancher-server-ui/10163)

<div class="topic-metadata">

**Author:** [@shirgaveranjeet](https://forums.suse.com/u/shirgaveranjeet)\
**Replies:** 3\
**Last updated:** [April 26, 2018, 5:38am UTC](https://forums.suse.com/t/not-able-to-open-rancher-server-ui/10163 "2018-04-26T05:38:07Z")

</div>

I have set up rancher server but not able to see rancher UI , its showing blank page . root@xxxxx ~\]# curl http://xxxxx:9925 -v About to connect() to proxy xxxxx port xxx (#0) Trying 1xxxxx. Connected to xxxxx (xxxx) …

---

## [Private message from alanShadow](https://forums.suse.com/t/private-message-from-alanshadow/35858)

<div class="topic-metadata">

**Author:** [@alanShadow](https://forums.suse.com/u/alanShadow)\
**Replies:** 0\
**Last updated:** [April 25, 2018, 10:33am UTC](https://forums.suse.com/t/private-message-from-alanshadow/35858 "2018-04-25T10:33:57Z")

</div>

Hi RK\_gobinath1452, in a few weeks I want to pass the 050-747 SCA Exam. You wrote in one of the threads, that you want to pass the exam, too. Do you have some experience to share? (Level of difficulty, questions no or…

---

## [Unable to run rancher server on custom port](https://forums.suse.com/t/unable-to-run-rancher-server-on-custom-port/10153)

<div class="topic-metadata">

**Author:** [@shirgaveranjeet](https://forums.suse.com/u/shirgaveranjeet)\
**Replies:** 5\
**Last updated:** [April 24, 2018, 9:36am UTC](https://forums.suse.com/t/unable-to-run-rancher-server-on-custom-port/10153 "2018-04-24T09:36:07Z")

</div>

Hello team , I am new to rancher , I have started rancher using port 9925 , but when I see rancher process inside docker container it is showing running on default port \[root@xxxxx \_data\]# docker ps CONTAINER ID …

---

## [Rancher Healthcheck removes container after initializing](https://forums.suse.com/t/rancher-healthcheck-removes-container-after-initializing/10145)

<div class="topic-metadata">

**Author:** [@Aravind](https://forums.suse.com/u/Aravind)\
**Replies:** 1\
**Last updated:** [April 23, 2018, 3:55pm UTC](https://forums.suse.com/t/rancher-healthcheck-removes-container-after-initializing/10145 "2018-04-23T15:55:28Z")

</div>

Hi, I created a sample container tomcat it works in host\_ip:port. host\_ip:port/example works fine. I gave an health check http url ‘/example’ when cloning the same container. Expectation is that health check should …

---

## [Replacing kube-dns](https://forums.suse.com/t/replacing-kube-dns/10137)

<div class="topic-metadata">

**Author:** [@StoneFury](https://forums.suse.com/u/StoneFury)\
**Replies:** 0\
**Last updated:** [April 21, 2018, 3:02am UTC](https://forums.suse.com/t/replacing-kube-dns/10137 "2018-04-21T03:02:05Z")

</div>

How would one replace kube-dns with coredns using rancher? The upgrade procedure involves running kubeadm upgrade, but that seems off limits when deployed with rancher, is that true? I’m a new user, so maybe I’m thinking…

---

## [Rancher agent registration failing](https://forums.suse.com/t/rancher-agent-registration-failing/7429)

<div class="topic-metadata">

**Author:** [@pkaramol](https://forums.suse.com/u/pkaramol)\
**Replies:** 1\
**Last updated:** [April 18, 2018, 4:31am UTC](https://forums.suse.com/t/rancher-agent-registration-failing/7429 "2018-04-18T04:31:07Z")

</div>

I am setting up a private network of 3 VMs (1 rancher agent + 2 nodes) on my workstation using vagrant and docker provisioning. Here is the Vagrantfile used: Vagrant.configure("2") do |config| config.…

---

## [Duplicate Key Violations](https://forums.suse.com/t/duplicate-key-violations/10066)

<div class="topic-metadata">

**Author:** [@mota\_nginya](https://forums.suse.com/u/mota_nginya)\
**Replies:** 1\
**Last updated:** [April 12, 2018, 4:38pm UTC](https://forums.suse.com/t/duplicate-key-violations/10066 "2018-04-12T16:38:30Z")

</div>

Hello Maestros, Full disclosure, I am extremely green on Rancher and I find it really promising. However, I am seeing too many constraint errors in the log. Is this normal? I have a fresh install and currently running v…

---

## [Put Up A free Udemy](https://forums.suse.com/t/put-up-a-free-udemy/10057)

<div class="topic-metadata">

**Author:** [@Valmach](https://forums.suse.com/u/Valmach)\
**Replies:** 0\
**Last updated:** [April 12, 2018, 1:03am UTC](https://forums.suse.com/t/put-up-a-free-udemy/10057 "2018-04-12T01:03:16Z")

</div>

My advice put up a free tutorial on Udemy . .

---

## [Using yml using the webinterface](https://forums.suse.com/t/using-yml-using-the-webinterface/10039)

<div class="topic-metadata">

**Author:** [@rprengel](https://forums.suse.com/u/rprengel)\
**Replies:** 0\
**Last updated:** [April 10, 2018, 4:26am UTC](https://forums.suse.com/t/using-yml-using-the-webinterface/10039 "2018-04-10T04:26:53Z")

</div>

Hallo, I m using Rancher 1.6.14. My question: Is there a way to use yml files like the one in this tutorial https://www.jeffgeerling.com/blog/2017/get-started-using-ansible-awx-open-source-tower-version-one-minute …

---

## [How to set external DNS](https://forums.suse.com/t/how-to-set-external-dns/10030)

<div class="topic-metadata">

**Author:** [@Phoel](https://forums.suse.com/u/Phoel)\
**Replies:** 0\
**Last updated:** [April 9, 2018, 12:42pm UTC](https://forums.suse.com/t/how-to-set-external-dns/10030 "2018-04-09T12:42:02Z")

</div>

Hello there, So I’m really new in this rancher world, so please be kind :slight\_smile: I have currently 4 servers : 1 with Rancher 2 containers hosts connected to the rancher server 1 for DNS purpose only, not connec…

[Previous page](https://forums.suse.com/c/general/1.md?page=43)

[Next page](https://forums.suse.com/c/general/1.md?page=45)
