# General

**URL:** https://forums.suse.com/c/general/1.md?page=47

[Latest](https://forums.suse.com/latest.md) · [Categories](https://forums.suse.com/categories.md)

**Page:** 48

---

## [Rancher 2.0 preview2 availability?](https://forums.suse.com/t/rancher-2-0-preview2-availability/8002)

<div class="topic-metadata">

**Author:** [@aderumier](https://forums.suse.com/u/aderumier)\
**Replies:** 3\
**Last updated:** [January 5, 2018, 5:09pm UTC](https://forums.suse.com/t/rancher-2-0-preview2-availability/8002 "2018-01-05T17:09:19Z")

</div>

Hi, Is it planned to release the 2.0 preview2 soon ? (Seem that changes are quite huge since preview1, can’t wait to test it :slight\_smile:

---

## [K8s service (LoadBalancer) only accessible from within cluster](https://forums.suse.com/t/k8s-service-loadbalancer-only-accessible-from-within-cluster/8160)

<div class="topic-metadata">

**Author:** [@pkaramol](https://forums.suse.com/u/pkaramol)\
**Replies:** 0\
**Last updated:** [January 5, 2018, 3:55pm UTC](https://forums.suse.com/t/k8s-service-loadbalancer-only-accessible-from-within-cluster/8160 "2018-01-05T15:55:10Z")

</div>

I have a service endpoint in a k8s cluster, that is exposing 80 and 443 ports. In the k8s dashboard, it indicates that these are the external endpoints: (the k8s has been deployed using rancher and the service is of ty…

---

## [Newbie question - adding first Host need public ip](https://forums.suse.com/t/newbie-question-adding-first-host-need-public-ip/8084)

<div class="topic-metadata">

**Author:** [@vikozo](https://forums.suse.com/u/vikozo)\
**Replies:** 2\
**Last updated:** [January 5, 2018, 11:48am UTC](https://forums.suse.com/t/newbie-question-adding-first-host-need-public-ip/8084 "2018-01-05T11:48:47Z")

</div>

hello I have a FreeNAS 11.1 Server and into a VM I added Rancher. I have access to the Rancher GUI - now I need to add a host, but when I do copy the code into my Terminal - the Problem is he request a Public IP Addre…

---

## [Need to buy a HP Computer](https://forums.suse.com/t/need-to-buy-a-hp-computer/8154)

<div class="topic-metadata">

**Author:** [@shiyamini](https://forums.suse.com/u/shiyamini)\
**Replies:** 1\
**Last updated:** [January 4, 2018, 11:12pm UTC](https://forums.suse.com/t/need-to-buy-a-hp-computer/8154 "2018-01-04T23:12:59Z")

</div>

where can i buy a HP 8100 I5 Computer intel core I5 3.3Ghz PC SFF?

---

## [Move data from volume to mysql (solved)](https://forums.suse.com/t/move-data-from-volume-to-mysql-solved/8141)

<div class="topic-metadata">

**Author:** [@paulohms](https://forums.suse.com/u/paulohms)\
**Replies:** 2\
**Last updated:** [January 4, 2018, 8:04pm UTC](https://forums.suse.com/t/move-data-from-volume-to-mysql-solved/8141 "2018-01-04T20:04:54Z")

</div>

Hi everyone, I started my Rancher Server saving the data in a volume, but now I would like transfer the data from this volume to one mysql database. How can I do this?

---

## [What doing each system container (solved)](https://forums.suse.com/t/what-doing-each-system-container-solved/8111)

<div class="topic-metadata">

**Author:** [@paulohms](https://forums.suse.com/u/paulohms)\
**Replies:** 3\
**Last updated:** [January 3, 2018, 3:42pm UTC](https://forums.suse.com/t/what-doing-each-system-container-solved/8111 "2018-01-03T15:42:46Z")

</div>

Hi Everyone, I would like know what doing each system rancher container to understanding better the rancher behavior healthcheck ipsec cni-driver network-manager metadata rancher-agent

---

## [Rancher unable to find vpc/subnets when adding host on AWS](https://forums.suse.com/t/rancher-unable-to-find-vpc-subnets-when-adding-host-on-aws/7871)

<div class="topic-metadata">

**Author:** [@rxkaul](https://forums.suse.com/u/rxkaul)\
**Replies:** 1\
**Last updated:** [January 3, 2018, 7:44am UTC](https://forums.suse.com/t/rancher-unable-to-find-vpc-subnets-when-adding-host-on-aws/7871 "2018-01-03T07:44:50Z")

</div>

I tried to install Rancher 1.6.10 on a public subnet in VPC in AWS. Everything went smoothly until I tried to add a host. It accepted the AWS key and secret key but failed to populate the VPN/subnet field. I tried to i…

---

## [Add certificate when creating a k8s load balancer](https://forums.suse.com/t/add-certificate-when-creating-a-k8s-load-balancer/8120)

<div class="topic-metadata">

**Author:** [@pkaramol](https://forums.suse.com/u/pkaramol)\
**Replies:** 0\
**Last updated:** [December 29, 2017, 3:01pm UTC](https://forums.suse.com/t/add-certificate-when-creating-a-k8s-load-balancer/8120 "2017-12-29T15:01:46Z")

</div>

I am using Rancher 1.6.12 to create my k8s stack on aws. What is the proper way of adding a certificate when creating a LoadBalancer service (which in our rancher-k8s case will translate to the launch of a HAProxy conta…

---

## [Unable to get logs from kubernetes](https://forums.suse.com/t/unable-to-get-logs-from-kubernetes/8119)

<div class="topic-metadata">

**Author:** [@pkaramol](https://forums.suse.com/u/pkaramol)\
**Replies:** 1\
**Last updated:** [December 29, 2017, 1:15pm UTC](https://forums.suse.com/t/unable-to-get-logs-from-kubernetes/8119 "2017-12-29T13:15:00Z")

</div>

I have set up a k8s cluster via Rancher UI on aws. I have deployed my app using several services and deployments. However, I am completely unable to get access to the pod/container logs. $ kubectl logs -f \<pod\_id\> Un…

---

## [Unable to authenticate into k8s cluster](https://forums.suse.com/t/unable-to-authenticate-into-k8s-cluster/8118)

<div class="topic-metadata">

**Author:** [@pkaramol](https://forums.suse.com/u/pkaramol)\
**Replies:** 1\
**Last updated:** [December 29, 2017, 11:48am UTC](https://forums.suse.com/t/unable-to-authenticate-into-k8s-cluster/8118 "2017-12-29T11:48:20Z")

</div>

Using Rancher 1.6.12, I have set up a three-node k8s cluster on aws. The k8s dashboard and cli are both available and responding. From the Rancher ui, I have downloaded the kubectl config file, so I can interact with k…

---

## [How to upgrade service using the shell command](https://forums.suse.com/t/how-to-upgrade-service-using-the-shell-command/8094)

<div class="topic-metadata">

**Author:** [@GavenHwang](https://forums.suse.com/u/GavenHwang)\
**Replies:** 0\
**Last updated:** [December 22, 2017, 7:05am UTC](https://forums.suse.com/t/how-to-upgrade-service-using-the-shell-command/8094 "2017-12-22T07:05:00Z")

</div>

curl -u “${CATTLE\_ACCESS\_KEY}:${CATTLE\_SECRET\_KEY}” -X POST -H ‘Accept: application/json’ -H ‘Content-Type: application/json’ -d ‘{“inServiceStrategy”:null, “toServiceStrategy”:null}’ ‘http://192.168.99.100:808…

---

## [Send a signal via rancher api?](https://forums.suse.com/t/send-a-signal-via-rancher-api/7913)

<div class="topic-metadata">

**Author:** [@pwFoo](https://forums.suse.com/u/pwFoo)\
**Replies:** 5\
**Last updated:** [December 20, 2017, 3:44pm UTC](https://forums.suse.com/t/send-a-signal-via-rancher-api/7913 "2017-12-20T15:44:54Z")

</div>

I try to replace my docker-gen (single host) with rancher-gen (multi host, rancher environment). With the docker-gen I have a simple shell script to send a sigusr1 signal to a docker container via docker.sock. #!/bin/sh…

---

## [Consul and Rancher](https://forums.suse.com/t/consul-and-rancher/8078)

<div class="topic-metadata">

**Author:** [@Evgeniy](https://forums.suse.com/u/Evgeniy)\
**Replies:** 0\
**Last updated:** [December 20, 2017, 12:39pm UTC](https://forums.suse.com/t/consul-and-rancher/8078 "2017-12-20T12:39:07Z")

</div>

Hi, we use consul for autodiscovery for our apps running in docker. App run on docker hosts and register service in consul (with IP address of docker host). Consul agent running with “advertise\_addr”: “\<docker\_host\_ip\>…

---

## [Kubectl exec command fails](https://forums.suse.com/t/kubectl-exec-command-fails/8071)

<div class="topic-metadata">

**Author:** [@pkaramol](https://forums.suse.com/u/pkaramol)\
**Replies:** 1\
**Last updated:** [December 19, 2017, 3:43pm UTC](https://forums.suse.com/t/kubectl-exec-command-fails/8071 "2017-12-19T15:43:10Z")

</div>

I have set up a Rancher k8s environment. Rancher server lies behind a classic ELB with ssl termination and is accessible via e.g https://my.rancher.server. I have deployed a simple pod via the command line by running k…

---

## [Using Rancher as LEMP stack for Development environment](https://forums.suse.com/t/using-rancher-as-lemp-stack-for-development-environment/8057)

<div class="topic-metadata">

**Author:** [@gonzi76](https://forums.suse.com/u/gonzi76)\
**Replies:** 0\
**Last updated:** [December 15, 2017, 10:29am UTC](https://forums.suse.com/t/using-rancher-as-lemp-stack-for-development-environment/8057 "2017-12-15T10:29:31Z")

</div>

As DEV is not PROD :slight\_smile: I need that nginx docker container whole time see the fresh version of my app as during development there is a need to see results and test them (debug as well) very often… basically eve…

---

## [Private message from system](https://forums.suse.com/t/private-message-from-system/35852)

<div class="topic-metadata">

**Author:** [@system](https://forums.suse.com/u/system)\
**Replies:** 0\
**Last updated:** [December 8, 2017, 8:32pm UTC](https://forums.suse.com/t/private-message-from-system/35852 "2017-12-08T20:32:03Z")

</div>

Could I know why you mentioned if it always fail on the oefd-kmp package install , It need to check the md5sum of the image before copying to your install medium (which was USB or DVD) The same medium use for SATA HD…

---

## [Rename container hostname](https://forums.suse.com/t/rename-container-hostname/8003)

<div class="topic-metadata">

**Author:** [@galioy](https://forums.suse.com/u/galioy)\
**Replies:** 0\
**Last updated:** [December 6, 2017, 2:16pm UTC](https://forums.suse.com/t/rename-container-hostname/8003 "2017-12-06T14:16:20Z")

</div>

I have Dev, Stage and Prod environments with the same setup (but different hosts, obviously) and the containers of the app are launched with the same name/hostname, so when I send logs to my log service, I cannot disting…

---

## [Running dockers in different hosts](https://forums.suse.com/t/running-dockers-in-different-hosts/7998)

<div class="topic-metadata">

**Author:** [@Navya](https://forums.suse.com/u/Navya)\
**Replies:** 0\
**Last updated:** [December 6, 2017, 7:36am UTC](https://forums.suse.com/t/running-dockers-in-different-hosts/7998 "2017-12-06T07:36:29Z")

</div>

We have a docker running in our rancher stack (deployed with scale = 4) in cattle environment .We see that the docker which is scaled to 4 is being deployed in the same host even though we have 4 hosts registered to the …

---

## [K8s UI with RKE](https://forums.suse.com/t/k8s-ui-with-rke/7977)

<div class="topic-metadata">

**Author:** [@flaccid](https://forums.suse.com/u/flaccid)\
**Replies:** 5\
**Last updated:** [December 5, 2017, 5:57am UTC](https://forums.suse.com/t/k8s-ui-with-rke/7977 "2017-12-05T05:57:17Z")

</div>

How do we add on https://kubernetes.io/docs/tasks/access-application-cluster/web-ui-dashboard/#deploying-the-dashboard-ui to RKE? I’ve created https://github.com/flaccid/rke-vagrant to stand up RKE in a single virtualbo…

---

## [Enabling HealthCheck in container slows down container initialization](https://forums.suse.com/t/enabling-healthcheck-in-container-slows-down-container-initialization/7981)

<div class="topic-metadata">

**Author:** [@Navya](https://forums.suse.com/u/Navya)\
**Replies:** 0\
**Last updated:** [December 4, 2017, 12:44pm UTC](https://forums.suse.com/t/enabling-healthcheck-in-container-slows-down-container-initialization/7981 "2017-12-04T12:44:53Z")

</div>

Upgradation and initialization of the docker container takes a long time when health check is enabled . Please find the screenshot of our configuration .How can this issue be resolved .

---

## [Installing AWSCLI in RancherOS](https://forums.suse.com/t/installing-awscli-in-rancheros/7936)

<div class="topic-metadata">

**Author:** [@arunkaliappan](https://forums.suse.com/u/arunkaliappan)\
**Replies:** 0\
**Last updated:** [November 30, 2017, 7:36am UTC](https://forums.suse.com/t/installing-awscli-in-rancheros/7936 "2017-11-30T07:36:55Z")

</div>

Can anyone help me to install awscli in RancherOS?

---

## [Load balancer (haproxy) option http-keep-alive problem](https://forums.suse.com/t/load-balancer-haproxy-option-http-keep-alive-problem/7612)

<div class="topic-metadata">

**Author:** [@Joel\_MARTIN](https://forums.suse.com/u/Joel_MARTIN)\
**Replies:** 5\
**Last updated:** [November 29, 2017, 9:30pm UTC](https://forums.suse.com/t/load-balancer-haproxy-option-http-keep-alive-problem/7612 "2017-11-29T21:30:05Z")

</div>

Hello, I’m on Rancher/server 1.6.8 and I’m trying to add custom options on haproxy.cfg for the load-balancer. I want to replace : option http-server-close by option http-keep-alive But when I add option http-keep-aliv…

---

## [How to use ELB in AWS with kubernetes](https://forums.suse.com/t/how-to-use-elb-in-aws-with-kubernetes/7931)

<div class="topic-metadata">

**Author:** [@didho](https://forums.suse.com/u/didho)\
**Replies:** 0\
**Last updated:** [November 29, 2017, 7:47pm UTC](https://forums.suse.com/t/how-to-use-elb-in-aws-with-kubernetes/7931 "2017-11-29T19:47:42Z")

</div>

Hi, I have a environment kubernetes in rancher and it’s running, but my doubt is how to use with aws ELB. I need to When I create an ingress in kubernetes the rancher will automatically register in aws ELB, because I ne…

---

## [Rancher DB on RDS Aurora?](https://forums.suse.com/t/rancher-db-on-rds-aurora/7804)

<div class="topic-metadata">

**Author:** [@stormerider](https://forums.suse.com/u/stormerider)\
**Replies:** 1\
**Last updated:** [November 29, 2017, 5:40pm UTC](https://forums.suse.com/t/rancher-db-on-rds-aurora/7804 "2017-11-29T17:40:10Z")

</div>

Aurora claims to be MySQL compatible (and in some regions Postgresql compatible as well). However, certain things like compressed tables are not supported. Has anyone tried taking a MySQL RDS that contains the Rancher DB…

---

## [MariaDB Galera issue](https://forums.suse.com/t/mariadb-galera-issue/2332)

<div class="topic-metadata">

**Author:** [@gerwim](https://forums.suse.com/u/gerwim)\
**Replies:** 2\
**Last updated:** [November 27, 2017, 3:20pm UTC](https://forums.suse.com/t/mariadb-galera-issue/2332 "2017-11-27T15:20:59Z")

</div>

Hi there, First, thanks for the awesome product. I started using it a couple of days ago and it's very awesome. Now, on to the actual issue: I have deployed the MariaDB Galera cluster (from the catalog) and I was try…

---

## [Docker loophole restart because of no tls key](https://forums.suse.com/t/docker-loophole-restart-because-of-no-tls-key/7868)

<div class="topic-metadata">

**Author:** [@boistordu](https://forums.suse.com/u/boistordu)\
**Replies:** 2\
**Last updated:** [November 27, 2017, 1:17am UTC](https://forums.suse.com/t/docker-loophole-restart-because-of-no-tls-key/7868 "2017-11-27T01:17:47Z")

</div>

Hi, So I was investigating a problem of docker permission and why even in root I couldn’t reach the docker socket. I discover in the logs that time="2017-11-22T17:23:13.591442492Z" level=warning msg="Could not get ope…

---

## [There are no compatible templates error](https://forums.suse.com/t/there-are-no-compatible-templates-error/7887)

<div class="topic-metadata">

**Author:** [@jkull](https://forums.suse.com/u/jkull)\
**Replies:** 0\
**Last updated:** [November 23, 2017, 4:04pm UTC](https://forums.suse.com/t/there-are-no-compatible-templates-error/7887 "2017-11-23T16:04:43Z")

</div>

Full disclosure. I am new to rancher and containers. I am not a developer - I am an IT systems guy and I am trying to build a SIEM solution using SIEMONSTER. Their build guide has me adding a catalog to rancher. When I o…

---

## [How to integrate calico into Rancher+K8s environment?](https://forums.suse.com/t/how-to-integrate-calico-into-rancher-k8s-environment/7875)

<div class="topic-metadata">

**Author:** [@Gary\_Huang](https://forums.suse.com/u/Gary_Huang)\
**Replies:** 0\
**Last updated:** [November 23, 2017, 7:30am UTC](https://forums.suse.com/t/how-to-integrate-calico-into-rancher-k8s-environment/7875 "2017-11-23T07:30:42Z")

</div>

I would like to set up an K8s environment by Rancher with network isolated. How can i do it? Any tutorial?

---

## [I'm getting "Timeout getting IP address " error rancher v1.4.1](https://forums.suse.com/t/im-getting-timeout-getting-ip-address-error-rancher-v1-4-1/5568)

<div class="topic-metadata">

**Author:** [@ayman2nov](https://forums.suse.com/u/ayman2nov)\
**Replies:** 7\
**Last updated:** [November 21, 2017, 9:55pm UTC](https://forums.suse.com/t/im-getting-timeout-getting-ip-address-error-rancher-v1-4-1/5568 "2017-11-21T21:55:55Z")

</div>

getting "Timeout getting IP address" when trying to run any container , most of infrastructure containers are not working now . any fix or root cause for that ?

---

## [Rancher plugin error stop the docker to come online after rebooting hosts](https://forums.suse.com/t/rancher-plugin-error-stop-the-docker-to-come-online-after-rebooting-hosts/7645)

<div class="topic-metadata">

**Author:** [@Listener\_me](https://forums.suse.com/u/Listener_me)\
**Replies:** 4\
**Last updated:** [November 21, 2017, 4:24pm UTC](https://forums.suse.com/t/rancher-plugin-error-stop-the-docker-to-come-online-after-rebooting-hosts/7645 "2017-11-21T16:24:25Z")

</div>

Hello, After rebooting the rancher hosts, it takes almost an hour for docker to become online since it is having trouble finding the volume rancher-secrets. Guess, plugins gets up only after the agent connect to rancher…

[Previous page](https://forums.suse.com/c/general/1.md?page=46)

[Next page](https://forums.suse.com/c/general/1.md?page=48)
