# General

**URL:** https://forums.suse.com/c/general/1.md?page=50

[Latest](https://forums.suse.com/latest.md) · [Categories](https://forums.suse.com/categories.md)

**Page:** 51

---

## [Recommended way to add custom nodes behind router?](https://forums.suse.com/t/recommended-way-to-add-custom-nodes-behind-router/7297)

<div class="topic-metadata">

**Author:** [@LonnieTC](https://forums.suse.com/u/LonnieTC)\
**Replies:** 1\
**Last updated:** [September 10, 2017, 7:40am UTC](https://forums.suse.com/t/recommended-way-to-add-custom-nodes-behind-router/7297 "2017-09-10T07:40:43Z")

</div>

Greetings All, Hope that your day is going well. I am work a bit more with RancherOS & Rancher lately as there are may good qualities to the platform and ran across this question. I can see how to add custom nodes thr…

---

## [Missing catalog item in Rancher UI menu](https://forums.suse.com/t/missing-catalog-item-in-rancher-ui-menu/7270)

<div class="topic-metadata">

**Author:** [@Parth6288](https://forums.suse.com/u/Parth6288)\
**Replies:** 2\
**Last updated:** [September 7, 2017, 7:22am UTC](https://forums.suse.com/t/missing-catalog-item-in-rancher-ui-menu/7270 "2017-09-07T07:22:20Z")

</div>

Hi, I just installed Rancher server with kubernetes environment and planning to set up monitoring with it. However i do not see the catalog item in the menu bar. Also when doing add from catalog in the infrastructure st…

---

## [Rancher NFS for Windows?](https://forums.suse.com/t/rancher-nfs-for-windows/7248)

<div class="topic-metadata">

**Author:** [@vishnuvpotty](https://forums.suse.com/u/vishnuvpotty)\
**Replies:** 0\
**Last updated:** [September 4, 2017, 1:58am UTC](https://forums.suse.com/t/rancher-nfs-for-windows/7248 "2017-09-04T01:58:13Z")

</div>

Hi All, Is there any plan for getting Rancher-NFS for windows ? I have been trying out Rancher NFS in linux containers and works pretty well. One of our requirement is to develop windows based containers and some thin…

---

## [Unable to reach a single rancher container from a particular host](https://forums.suse.com/t/unable-to-reach-a-single-rancher-container-from-a-particular-host/7247)

<div class="topic-metadata">

**Author:** [@pradeepchhetri](https://forums.suse.com/u/pradeepchhetri)\
**Replies:** 0\
**Last updated:** [September 3, 2017, 6:30pm UTC](https://forums.suse.com/t/unable-to-reach-a-single-rancher-container-from-a-particular-host/7247 "2017-09-03T18:30:07Z")

</div>

Hello Folks !! I am experiencing a strange issue where i am unable to reach a particular rancher container from another host. # ping 10.42.228.97 PING 10.42.228.97 (10.42.228.97): 56 data bytes ^C --- 10.42.228.97 ping…

---

## [Https on rancher OS on new rancher provided AMI in markedplace](https://forums.suse.com/t/https-on-rancher-os-on-new-rancher-provided-ami-in-markedplace/7235)

<div class="topic-metadata">

**Author:** [@the\_left\_moose](https://forums.suse.com/u/the_left_moose)\
**Replies:** 0\
**Last updated:** [September 1, 2017, 7:56am UTC](https://forums.suse.com/t/https-on-rancher-os-on-new-rancher-provided-ami-in-markedplace/7235 "2017-09-01T07:56:18Z")

</div>

Hi great gents I hope you would help me decide the best strategy for deploying https for my rancher setup in AWS. I have deployed a rancher master server via the new Rancher provided AMI in the marked place. It is up a…

---

## [Upgrade to v1.6.7 failed](https://forums.suse.com/t/upgrade-to-v1-6-7-failed/7226)

<div class="topic-metadata">

**Author:** [@mathuin](https://forums.suse.com/u/mathuin)\
**Replies:** 1\
**Last updated:** [August 31, 2017, 6:44pm UTC](https://forums.suse.com/t/upgrade-to-v1-6-7-failed/7226 "2017-08-31T18:44:30Z")

</div>

I fear that my database may be corrupted. Can someone who understands Rancher server logs help me out? 170831 18:04:24 \[Note\] /usr/sbin/mysqld (mysqld 5.5.55-0ubuntu0.14.04.1) starting as process 24 ... Uptime: 2 Thre…

---

## [Error listen tcp 0.0.0.0:5432: bind: address already in use](https://forums.suse.com/t/error-listen-tcp-0-0-0-0-5432-bind-address-already-in-use/7225)

<div class="topic-metadata">

**Author:** [@sigfrid](https://forums.suse.com/u/sigfrid)\
**Replies:** 0\
**Last updated:** [August 31, 2017, 8:04am UTC](https://forums.suse.com/t/error-listen-tcp-0-0-0-0-5432-bind-address-already-in-use/7225 "2017-08-31T08:04:17Z")

</div>

Hi everyone, What is the reason why when I try to start a PostgreSQL container I get the error below? postgres (Expected state running but got error: Error response from daemon: driver failed programming external conn…

---

## [Default Tiller version](https://forums.suse.com/t/default-tiller-version/7218)

<div class="topic-metadata">

**Author:** [@Moshe\_Nadler](https://forums.suse.com/u/Moshe_Nadler)\
**Replies:** 0\
**Last updated:** [August 30, 2017, 6:19am UTC](https://forums.suse.com/t/default-tiller-version/7218 "2017-08-30T06:19:36Z")

</div>

Hi, How can I changed the default Tiller version that gets deployed as part of the Kubernetes stack? Thanks! Moshe

---

## [Help on getting NFS working - it seems impossible](https://forums.suse.com/t/help-on-getting-nfs-working-it-seems-impossible/6361)

<div class="topic-metadata">

**Author:** [@leabdalla](https://forums.suse.com/u/leabdalla)\
**Replies:** 3\
**Last updated:** [August 30, 2017, 5:42am UTC](https://forums.suse.com/t/help-on-getting-nfs-working-it-seems-impossible/6361 "2017-08-30T05:42:56Z")

</div>

I've installed NFS 0.30 (last version) stack using catalog. The options are: MOUNT\_DIR / MOUNT\_OPTS proto=tcp,port=2049,nfsvers=4 NFS\_SERVER xxx.xxx.xxx.xxx (digitalocean droplet public ip) The container starts …

---

## [Client.Timeout exceeded (connecting to gitlab docker registry)](https://forums.suse.com/t/client-timeout-exceeded-connecting-to-gitlab-docker-registry/7206)

<div class="topic-metadata">

**Author:** [@busla](https://forums.suse.com/u/busla)\
**Replies:** 2\
**Last updated:** [August 28, 2017, 2:32pm UTC](https://forums.suse.com/t/client-timeout-exceeded-connecting-to-gitlab-docker-registry/7206 "2017-08-28T14:32:35Z")

</div>

(Expected state running but got error: Error response from daemon: Get https://gitlab.\[mydomain\]:5001/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)) I´m tr…

---

## [User interface isolation for individual users](https://forums.suse.com/t/user-interface-isolation-for-individual-users/7160)

<div class="topic-metadata">

**Author:** [@Htet\_Naing\_Aung](https://forums.suse.com/u/Htet_Naing_Aung)\
**Replies:** 2\
**Last updated:** [August 28, 2017, 6:36am UTC](https://forums.suse.com/t/user-interface-isolation-for-individual-users/7160 "2017-08-28T06:36:21Z")

</div>

How can we do user interface isolation individually on rancher server per user account ? For instance, there have 2 hosts on rancher server and 3 user accounts (user01, user02 & user03) Host A \> 2 web containers & 1 d…

---

## [Load balancing canaries](https://forums.suse.com/t/load-balancing-canaries/7198)

<div class="topic-metadata">

**Author:** [@stormerider](https://forums.suse.com/u/stormerider)\
**Replies:** 1\
**Last updated:** [August 27, 2017, 2:30am UTC](https://forums.suse.com/t/load-balancing-canaries/7198 "2017-08-27T02:30:09Z")

</div>

Is there a way with the native RancherOS HAProxy load balancer to direct most of the traffic to one service, but send a percentage of traffic to a different service? I’m thinking of when I go to move my stormerider/ranch…

---

## [Internal Server Error Authenticate with GitHub](https://forums.suse.com/t/internal-server-error-authenticate-with-github/7195)

<div class="topic-metadata">

**Author:** [@gomaster-me](https://forums.suse.com/u/gomaster-me)\
**Replies:** 0\
**Last updated:** [August 26, 2017, 7:07am UTC](https://forums.suse.com/t/internal-server-error-authenticate-with-github/7195 "2017-08-26T07:07:58Z")

</div>

when i click the try rancher. I use github authoriztion way,but the page return internal server error. So please the developer of rancher shoot the bug…

---

## [Catalog Launching Issue](https://forums.suse.com/t/catalog-launching-issue/7140)

<div class="topic-metadata">

**Author:** [@Listener\_me](https://forums.suse.com/u/Listener_me)\
**Replies:** 1\
**Last updated:** [August 25, 2017, 2:16pm UTC](https://forums.suse.com/t/catalog-launching-issue/7140 "2017-08-25T14:16:45Z")

</div>

Hello, I am struggling to fix the issue related to catalog, it sometimes fail with following error, not all time. Can someone give a clue? Just want to know what is wrong! I have 20 containers in single catalog, is it c…

---

## [How Agents identify/communicate with new Rancher server](https://forums.suse.com/t/how-agents-identify-communicate-with-new-rancher-server/7175)

<div class="topic-metadata">

**Author:** [@rmahimalur](https://forums.suse.com/u/rmahimalur)\
**Replies:** 1\
**Last updated:** [August 23, 2017, 7:48pm UTC](https://forums.suse.com/t/how-agents-identify-communicate-with-new-rancher-server/7175 "2017-08-23T19:48:20Z")

</div>

Hello, I have setup Rancher environment in AWS and added hosts to my environment. By i have question here, what happens if hosts running rancher servers is terminated and new one is built. For example: there will be n…

---

## [rancher-NFS and databases](https://forums.suse.com/t/rancher-nfs-and-databases/7094)

<div class="topic-metadata">

**Author:** [@thoth](https://forums.suse.com/u/thoth)\
**Replies:** 3\
**Last updated:** [August 22, 2017, 5:29am UTC](https://forums.suse.com/t/rancher-nfs-and-databases/7094 "2017-08-22T05:29:41Z")

</div>

Now I know that databases have always had a stigma about being in a docker container, and even moreso about being on an NFS share. But I keep trying it out just to punish myself with lot’s of pain. And I find myself wo…

---

## [How to create a generic host via CLI](https://forums.suse.com/t/how-to-create-a-generic-host-via-cli/7145)

<div class="topic-metadata">

**Author:** [@blsaws](https://forums.suse.com/u/blsaws)\
**Replies:** 0\
**Last updated:** [August 18, 2017, 4:38pm UTC](https://forums.suse.com/t/how-to-create-a-generic-host-via-cli/7145 "2017-08-18T16:38:43Z")

</div>

The docs are not clear on how to create a generic driver host via the CLI. It references the docker generic params (https://docs.docker.com/machine/drivers/generic/) RANCHER HOSTS CREATE The rancher hosts create comman…

---

## [Upgrade Fails Due to Table Already Exists](https://forums.suse.com/t/upgrade-fails-due-to-table-already-exists/7131)

<div class="topic-metadata">

**Author:** [@evfurman](https://forums.suse.com/u/evfurman)\
**Replies:** 1\
**Last updated:** [August 17, 2017, 4:48pm UTC](https://forums.suse.com/t/upgrade-fails-due-to-table-already-exists/7131 "2017-08-17T16:48:29Z")

</div>

\`Query is : CREATE TABLE cattle.account (id BIGINT AUTO\_INCREMENT NOT NULL, name VARCHAR(255) NULL, kind VARCHAR(255) NOT NULL, uuid VARCHAR(128) NOT NULL, description VARCHAR(1024) NULL, state VARCHAR(128) NOT NULL, cre…

---

## [Rancher UI Split](https://forums.suse.com/t/rancher-ui-split/5432)

<div class="topic-metadata">

**Author:** [@badams](https://forums.suse.com/u/badams)\
**Replies:** 8\
**Last updated:** [August 17, 2017, 7:58am UTC](https://forums.suse.com/t/rancher-ui-split/5432 "2017-08-17T07:58:29Z")

</div>

Rancher server v1.1.4 Rancher ui v1.1.14 I’m splitting the static UI apart from the server to make some cosmetic changes, and I can’t seem to get the server to load it correctly. I’m using an nginx container to host t…

---

## [Random host(s) getting disconnected from Rancher UI](https://forums.suse.com/t/random-host-s-getting-disconnected-from-rancher-ui/7108)

<div class="topic-metadata">

**Author:** [@auxiLum\_Support](https://forums.suse.com/u/auxiLum_Support)\
**Replies:** 0\
**Last updated:** [August 14, 2017, 10:01pm UTC](https://forums.suse.com/t/random-host-s-getting-disconnected-from-rancher-ui/7108 "2017-08-14T22:01:59Z")

</div>

Hello: I can see that hosts are getting disconnected from Rancher UI. It does not matter they are part of which Orch later, i.e. Kubernetes, Swam and native Cattle. I have latest Rancher UI 1.6.5 with latest agent 1.2.5 …

---

## [How are databases for distributed applications scaled?](https://forums.suse.com/t/how-are-databases-for-distributed-applications-scaled/7036)

<div class="topic-metadata">

**Author:** [@Nokan24](https://forums.suse.com/u/Nokan24)\
**Replies:** 4\
**Last updated:** [August 14, 2017, 2:53pm UTC](https://forums.suse.com/t/how-are-databases-for-distributed-applications-scaled/7036 "2017-08-14T14:53:23Z")

</div>

Hello, This question isn’t specific to using Rancher. It’s just a general question. I’m trying to understand how applications scale across AWS regions. The part that I don’t get is the database. For example, if I have a…

---

## [How to pass the shell/python script while adding an EC2 Host to my environment](https://forums.suse.com/t/how-to-pass-the-shell-python-script-while-adding-an-ec2-host-to-my-environment/7080)

<div class="topic-metadata">

**Author:** [@rmahimalur](https://forums.suse.com/u/rmahimalur)\
**Replies:** 1\
**Last updated:** [August 11, 2017, 1:58am UTC](https://forums.suse.com/t/how-to-pass-the-shell-python-script-while-adding-an-ec2-host-to-my-environment/7080 "2017-08-11T01:58:59Z")

</div>

I can pass shell/python script as user date in AWS CloudFormation and as well as in Console. Similarly, how can i pass a shell/python script while adding EC2 Host to my environment.

---

## [K8s environment cannot be initiated](https://forums.suse.com/t/k8s-environment-cannot-be-initiated/6276)

<div class="topic-metadata">

**Author:** [@funkydorian](https://forums.suse.com/u/funkydorian)\
**Replies:** 11\
**Last updated:** [August 10, 2017, 6:36pm UTC](https://forums.suse.com/t/k8s-environment-cannot-be-initiated/6276 "2017-08-10T18:36:56Z")

</div>

I want to initiate a k8s cluster. Steps: Opened UDP500/4500 ingress/egress Rancher Server installation: docker run -d -p 8080:8080 rancher/server:stable Installed k8s supported docker on host: curl https://rele…

---

## [Rancher Agent issue](https://forums.suse.com/t/rancher-agent-issue/6344)

<div class="topic-metadata">

**Author:** [@klezer](https://forums.suse.com/u/klezer)\
**Replies:** 3\
**Last updated:** [August 10, 2017, 8:38am UTC](https://forums.suse.com/t/rancher-agent-issue/6344 "2017-08-10T08:38:37Z")

</div>

Hi, I re-installed the Rancher latest version but the problem is still going on. Container stats does not work also view logs and execute shell commands also do not work. When i look at the rancher-agent logs, I get t…

---

## [Create a topic on kafka when deployed on Rancher](https://forums.suse.com/t/create-a-topic-on-kafka-when-deployed-on-rancher/7069)

<div class="topic-metadata">

**Author:** [@bschulzro](https://forums.suse.com/u/bschulzro)\
**Replies:** 0\
**Last updated:** [August 9, 2017, 4:13pm UTC](https://forums.suse.com/t/create-a-topic-on-kafka-when-deployed-on-rancher/7069 "2017-08-09T16:13:44Z")

</div>

Hello, I am new to Rancher and Kafka and I want to know how to create a topic on Kafka once it is deployed on Rancher. I have two services : one with 3 kafka brokers and another one with 3 zookeeper nodes. The Kafka se…

---

## [Error Deploying the catalog](https://forums.suse.com/t/error-deploying-the-catalog/7003)

<div class="topic-metadata">

**Author:** [@Listener\_me](https://forums.suse.com/u/Listener_me)\
**Replies:** 1\
**Last updated:** [August 9, 2017, 11:07am UTC](https://forums.suse.com/t/error-deploying-the-catalog/7003 "2017-08-09T11:07:48Z")

</div>

We had some trouble deploying a catalog across three hosts. Firstly deployment went fine. Then we removed that stack and redeployed it again. As the images are already present in the host, containers got created, but the…

---

## [Cloning Service Issue](https://forums.suse.com/t/cloning-service-issue/7044)

<div class="topic-metadata">

**Author:** [@Listener\_me](https://forums.suse.com/u/Listener_me)\
**Replies:** 2\
**Last updated:** [August 9, 2017, 10:50am UTC](https://forums.suse.com/t/cloning-service-issue/7044 "2017-08-09T10:50:35Z")

</div>

I have an application with service1 and service2 , service1 is linked to service2 with another name. service2: links: service1:myservice I have the following issue while upgrading During an upgrade fail scenario…

---

## [Benefit of Secret in rancher](https://forums.suse.com/t/benefit-of-secret-in-rancher/7060)

<div class="topic-metadata">

**Author:** [@Shilakha](https://forums.suse.com/u/Shilakha)\
**Replies:** 0\
**Last updated:** [August 9, 2017, 9:39am UTC](https://forums.suse.com/t/benefit-of-secret-in-rancher/7060 "2017-08-09T09:39:51Z")

</div>

What are the benefits of using secrets in Rancher ? How can we do the same ?

---

## [Load balancer issues](https://forums.suse.com/t/load-balancer-issues/5275)

<div class="topic-metadata">

**Author:** [@thrinay](https://forums.suse.com/u/thrinay)\
**Replies:** 3\
**Last updated:** [August 8, 2017, 4:23pm UTC](https://forums.suse.com/t/load-balancer-issues/5275 "2017-08-08T16:23:17Z")

</div>

When am trying to setup load balancer in rancher, I get "Failed to apply lb config on provider: error loading == reloading haproxy config with the new config changes \\n\[ALERT\] 017/113443 (42) : parsing \[/etc/haproxy/hapr…

---

## [Creating Private Registries](https://forums.suse.com/t/creating-private-registries/7052)

<div class="topic-metadata">

**Author:** [@B\_Au](https://forums.suse.com/u/B_Au)\
**Replies:** 1\
**Last updated:** [August 8, 2017, 3:21pm UTC](https://forums.suse.com/t/creating-private-registries/7052 "2017-08-08T15:21:43Z")

</div>

Hi, I’m new in rancher and have created my first Rancher environment. The Rancher healthcheck, network-services, ipsec, portainer, scheduler and Swarm Containers are all failing to install. The reason it fail to insta…

[Previous page](https://forums.suse.com/c/general/1.md?page=49)

[Next page](https://forums.suse.com/c/general/1.md?page=51)
