# k3s, k3OS, and k3d

**URL:** https://forums.suse.com/c/k3s-k3os-k3d/19.md

[Latest](https://forums.suse.com/latest.md) · [Categories](https://forums.suse.com/categories.md)

---

## [About the k3s, k3OS, and k3d category](https://forums.suse.com/t/about-the-k3s-k3os-and-k3d-category/14272)

<div class="topic-metadata">

**Author:** [@JasonvanBrackel](https://forums.suse.com/u/JasonvanBrackel)\
**Replies:** 0\
**Last updated:** [May 15, 2019, 5:48pm UTC](https://forums.suse.com/t/about-the-k3s-k3os-and-k3d-category/14272 "2019-05-15T17:48:55Z")

</div>

Discussion around k3s, k3OS, and k3d.

---

## ["Tunnel Proxy" on k3s](https://forums.suse.com/t/tunnel-proxy-on-k3s/17281)

<div class="topic-metadata">

**Author:** [@Akito](https://forums.suse.com/u/Akito)\
**Replies:** 5\
**Last updated:** [June 26, 2026, 8:45am UTC](https://forums.suse.com/t/tunnel-proxy-on-k3s/17281 "2026-06-26T08:45:24Z")

</div>

https://k3s.io/images/how-it-works-k3s.svg I’m new to k3s and I am trying to understand it properly. How does the “Tunnel Proxy” element shown in above picture work in the Kubernetes and its Network Overlay context exac…

---

## [Imported RKE2 downstream cluster connects to Rancher, then disconnects with websocket close 1006 unexpected EOF](https://forums.suse.com/t/imported-rke2-downstream-cluster-connects-to-rancher-then-disconnects-with-websocket-close-1006-unexpected-eof/46294)

<div class="topic-metadata">

**Author:** [@nostromoAlien](https://forums.suse.com/u/nostromoAlien)\
**Replies:** 0\
**Last updated:** [April 30, 2026, 11:02am UTC](https://forums.suse.com/t/imported-rke2-downstream-cluster-connects-to-rancher-then-disconnects-with-websocket-close-1006-unexpected-eof/46294 "2026-04-30T11:02:05Z")

</div>

Hello, I need help with an imported downstream RKE2 cluster that does not stay connected in Rancher. Setup: Rancher server version: v2.14.0 Rancher URL: https://mycompany-rancher Rancher ingress class: traefik Ranche…

---

## [Custom routing rules for specific services](https://forums.suse.com/t/custom-routing-rules-for-specific-services/45851)

<div class="topic-metadata">

**Author:** [@andy\_dandy](https://forums.suse.com/u/andy_dandy)\
**Replies:** 0\
**Last updated:** [September 4, 2025, 1:33pm UTC](https://forums.suse.com/t/custom-routing-rules-for-specific-services/45851 "2025-09-04T13:33:27Z")

</div>

Good Day! In our K3S cluster hosten on Hetzner we have a service that produces outbound traffic to reach an external Postgres DB. The database server expects that the IP will stay the same for whitelisting traffic. To …

---

## [Issues creating k3s cluster](https://forums.suse.com/t/issues-creating-k3s-cluster/45848)

<div class="topic-metadata">

**Author:** [@catsup2548](https://forums.suse.com/u/catsup2548)\
**Replies:** 0\
**Last updated:** [September 3, 2025, 1:22am UTC](https://forums.suse.com/t/issues-creating-k3s-cluster/45848 "2025-09-03T01:22:12Z")

</div>

I am working standing up a k3s cluster in my org. We are planning to move from 1 server to 3 in 1 datacenter and 3 more in another datacenter. However all of this is behind a forward proxy and nexus repo manager. I am…

---

## [K3s overrides firewalld rules](https://forums.suse.com/t/k3s-overrides-firewalld-rules/45212)

<div class="topic-metadata">

**Author:** [@polpmpn1](https://forums.suse.com/u/polpmpn1)\
**Replies:** 1\
**Last updated:** [March 4, 2025, 3:08pm UTC](https://forums.suse.com/t/k3s-overrides-firewalld-rules/45212 "2025-03-04T15:08:22Z")

</div>

We have firewalld configured (via salt, of course) to open all ports only to trusted networks (a mix of public IPs and private nets). A few ports like 80 and 443 are open to all IPs. When k3s starts, traefik inserts a t…

---

## [K3S Traefik 3 installation missing ClusterRoles](https://forums.suse.com/t/k3s-traefik-3-installation-missing-clusterroles/45128)

<div class="topic-metadata">

**Author:** [@andy\_dandy](https://forums.suse.com/u/andy_dandy)\
**Replies:** 0\
**Last updated:** [February 13, 2025, 9:26am UTC](https://forums.suse.com/t/k3s-traefik-3-installation-missing-clusterroles/45128 "2025-02-13T09:26:03Z")

</div>

Good Day, Friends! After upgrading my Traefik installation to v3, all ingresses were broken and cluster services not available. Traefik started to serve default certificates and every page were 404. apiVersion: helm.ca…

---

## [K3S - 2 nodes HA possible?](https://forums.suse.com/t/k3s-2-nodes-ha-possible/44908)

<div class="topic-metadata">

**Author:** [@Adam\_Obuchowski](https://forums.suse.com/u/Adam_Obuchowski)\
**Replies:** 0\
**Last updated:** [January 5, 2025, 11:49am UTC](https://forums.suse.com/t/k3s-2-nodes-ha-possible/44908 "2025-01-05T11:49:03Z")

</div>

Hello. Is it possible to setup HA with 2 master nodes ? I need to achieve a setup, that second node would work only as standby until first node for any reason goes down. These would be Raspberry PI machines and no othe…

---

## [Should I disable swap memory on K3s?](https://forums.suse.com/t/should-i-disable-swap-memory-on-k3s/42613)

<div class="topic-metadata">

**Author:** [@neu7ron](https://forums.suse.com/u/neu7ron)\
**Replies:** 2\
**Last updated:** [December 19, 2024, 9:00am UTC](https://forums.suse.com/t/should-i-disable-swap-memory-on-k3s/42613 "2024-12-19T09:00:29Z")

</div>

I’ve seen on all the base Kubernetes install instructions they recommend disabling swap memory on each server. But I don’t see any similar recommendation to disable swap with K3s instructions. Does anyone know if swap s…

---

## [Oracle Linux - latest supported?](https://forums.suse.com/t/oracle-linux-latest-supported/43492)

<div class="topic-metadata">

**Author:** [@SteveCliff](https://forums.suse.com/u/SteveCliff)\
**Replies:** 1\
**Last updated:** [December 19, 2024, 3:38am UTC](https://forums.suse.com/t/oracle-linux-latest-supported/43492 "2024-12-19T03:38:44Z")

</div>

I can see in the support matrix that for K3s 1.29, Oracle Linux is supported for 8.7-8.9. Is 8.10 officially supported as well please? Or if not, do we know if there is any plans/timescales to support it? Thanks!

---

## [Replace master node](https://forums.suse.com/t/replace-master-node/44644)

<div class="topic-metadata">

**Author:** [@elronzo](https://forums.suse.com/u/elronzo)\
**Replies:** 1\
**Last updated:** [December 5, 2024, 6:55pm UTC](https://forums.suse.com/t/replace-master-node/44644 "2024-12-05T18:55:52Z")

</div>

I do have a testcluster with three masters (etcd). All of them are VMs. One of them has some kind of problem that does not allow me to start the VM. How can I properly decommission this master node and add another one pr…

---

## [Nodeport conflicts](https://forums.suse.com/t/nodeport-conflicts/44451)

<div class="topic-metadata">

**Author:** [@mehiatt](https://forums.suse.com/u/mehiatt)\
**Replies:** 1\
**Last updated:** [November 7, 2024, 10:27am UTC](https://forums.suse.com/t/nodeport-conflicts/44451 "2024-11-07T10:27:18Z")

</div>

We have a k3s pod that is a daemonset with a rolling update. It has host network connection though a nodeport (443). However when we go to update, it conflicts because the old pod is still on 443 and the new pod needs it…

---

## [Run k3s in Incus container](https://forums.suse.com/t/run-k3s-in-incus-container/44172)

<div class="topic-metadata">

**Author:** [@catav](https://forums.suse.com/u/catav)\
**Replies:** 1\
**Last updated:** [September 30, 2024, 10:02am UTC](https://forums.suse.com/t/run-k3s-in-incus-container/44172 "2024-09-30T10:02:13Z")

</div>

Hello, I am trying to install k3s in an Incus container. Creating an Incus container without security.nesting and security.priviliged set to true or not does not solve the problem. The command I used for installing K3s…

---

## [K3S and IPTables Woes: How to IP whitelist on firewall level?](https://forums.suse.com/t/k3s-and-iptables-woes-how-to-ip-whitelist-on-firewall-level/41318)

<div class="topic-metadata">

**Author:** [@WhizzWr](https://forums.suse.com/u/WhizzWr)\
**Replies:** 1\
**Last updated:** [September 3, 2024, 7:21am UTC](https://forums.suse.com/t/k3s-and-iptables-woes-how-to-ip-whitelist-on-firewall-level/41318 "2024-09-03T07:21:24Z")

</div>

Hi, I have a very simple use case, I need to whitelist certain IPs (and reject the rest) so it can access traefik on a k3s node. I want it to be blocked on firewall level, not on the ingress, nor in pod level. I assu…

---

## [How to fix default search domain for pods in cluster?](https://forums.suse.com/t/how-to-fix-default-search-domain-for-pods-in-cluster/43921)

<div class="topic-metadata">

**Author:** [@majorgear](https://forums.suse.com/u/majorgear)\
**Replies:** 1\
**Last updated:** [September 2, 2024, 10:03pm UTC](https://forums.suse.com/t/how-to-fix-default-search-domain-for-pods-in-cluster/43921 "2024-09-02T22:03:51Z")

</div>

During my migration of apps from docker to kubernetes, I ran into the issue where the apps could not resolved external hostnames, ie hosts not in the cluster. The app tried to resolve “news.newshosting.com” and could no…

---

## [K3sup join unable to get token](https://forums.suse.com/t/k3sup-join-unable-to-get-token/43885)

<div class="topic-metadata">

**Author:** [@uek67](https://forums.suse.com/u/uek67)\
**Replies:** 0\
**Last updated:** [August 20, 2024, 4:29pm UTC](https://forums.suse.com/t/k3sup-join-unable-to-get-token/43885 "2024-08-20T16:29:01Z")

</div>

Hi folks, after I fixed my ssh problem with k3sup install setting PasswordAthentication on no and PermitRootLogin without-password in the destination node sshd\_config I have another similar problem with the k3s join com…

---

## [Connecting cluster to Rancher - help](https://forums.suse.com/t/connecting-cluster-to-rancher-help/39556)

<div class="topic-metadata">

**Author:** [@Finn](https://forums.suse.com/u/Finn)\
**Replies:** 2\
**Last updated:** [July 13, 2024, 6:21am UTC](https://forums.suse.com/t/connecting-cluster-to-rancher-help/39556 "2024-07-13T06:21:55Z")

</div>

Hey there, I have a k3s cluster (v1.25.4) on my local network for mini-projects and have opted to run Rancher (v2.5.16) on an Oracle Cloud VM (Ubuntu 20.04). I have accessed the Rancher UI via a dedicated IP and port an…

---

## [Kubectl top pods fails](https://forums.suse.com/t/kubectl-top-pods-fails/43572)

<div class="topic-metadata">

**Author:** [@ptrader01](https://forums.suse.com/u/ptrader01)\
**Replies:** 0\
**Last updated:** [July 10, 2024, 4:18am UTC](https://forums.suse.com/t/kubectl-top-pods-fails/43572 "2024-07-10T04:18:22Z")

</div>

I have a k3s deployment on 3 Ubuntu nodes. I need to find which of the pods are taking too much CPU resources, but I get the following error: kubectl top pods error: Metrics not available for pod default/argo-cron-test…

---

## [404 on git.rancher.io](https://forums.suse.com/t/404-on-git-rancher-io/20049)

<div class="topic-metadata">

**Author:** [@stefanop](https://forums.suse.com/u/stefanop)\
**Replies:** 1\
**Last updated:** [July 9, 2024, 6:09am UTC](https://forums.suse.com/t/404-on-git-rancher-io/20049 "2024-07-09T06:09:10Z")

</div>

Hi all, I have a running k3s (v1.20.5+k3s1) cluster in HA with 3 master and 2 nodes. When I go to Cluster Explorer → Apps I see the message “There are no charts available, have you added any repos?”. The chart reposit…

---

## [Traefik CrashLoopBackOff](https://forums.suse.com/t/traefik-crashloopbackoff/43551)

<div class="topic-metadata">

**Author:** [@xrt009](https://forums.suse.com/u/xrt009)\
**Replies:** 0\
**Last updated:** [July 4, 2024, 8:23pm UTC](https://forums.suse.com/t/traefik-crashloopbackoff/43551 "2024-07-04T20:23:18Z")

</div>

i installed k3s in 3 nodes I get this error kube-system helm-install-traefik-nb5dc 0/1 CrashLoopBackOff 352 (24s ago) 47h helm\_v3 repo remove stable Error: no repositories configured Error: …

---

## [Switching to containerd from docker causes intermittent pod networking connection refused](https://forums.suse.com/t/switching-to-containerd-from-docker-causes-intermittent-pod-networking-connection-refused/43424)

<div class="topic-metadata">

**Author:** [@Daniel\_Barron](https://forums.suse.com/u/Daniel_Barron)\
**Replies:** 1\
**Last updated:** [June 19, 2024, 3:03pm UTC](https://forums.suse.com/t/switching-to-containerd-from-docker-causes-intermittent-pod-networking-connection-refused/43424 "2024-06-19T15:03:52Z")

</div>

I need to move to containerd instead of docker. Currently k3s is started with: ExecStart=/usr/local/bin/k3s server\\ --write-kubeconfig-mode 640 \\ --disable traefik --disable metrics-server --disable-cloud-controller \\…

---

## [Localhost:8080 was refused](https://forums.suse.com/t/localhost-8080-was-refused/18434)

<div class="topic-metadata">

**Author:** [@Pete\_Noto](https://forums.suse.com/u/Pete_Noto)\
**Replies:** 10\
**Last updated:** [June 11, 2024, 7:50am UTC](https://forums.suse.com/t/localhost-8080-was-refused/18434 "2024-06-11T07:50:44Z")

</div>

Hello all, I am a total noob regarding Kubernetes so please forgive me if this is an obvious one and I’m just not seeing it. I’ve been following this GUIDE to set up a cluster of Raspberry Pi’s. I believe I have the s…

---

## [How do rename an existing cluster?](https://forums.suse.com/t/how-do-rename-an-existing-cluster/38198)

<div class="topic-metadata">

**Author:** [@nemonik](https://forums.suse.com/u/nemonik)\
**Replies:** 1\
**Last updated:** [June 2, 2024, 11:38pm UTC](https://forums.suse.com/t/how-do-rename-an-existing-cluster/38198 "2024-06-02T23:38:05Z")

</div>

Please, how do I rename an existing cluster? It is a single node “cluster”, so it ain’t much of a cluster. Thank you in advanced.

---

## [Traefik dashbord responds with "404 page not found"](https://forums.suse.com/t/traefik-dashbord-responds-with-404-page-not-found/43198)

<div class="topic-metadata">

**Author:** [@dburszty](https://forums.suse.com/u/dburszty)\
**Replies:** 0\
**Last updated:** [May 21, 2024, 10:24am UTC](https://forums.suse.com/t/traefik-dashbord-responds-with-404-page-not-found/43198 "2024-05-21T10:24:12Z")

</div>

Hello, I got stuck in making Traefik dashbord accessible. I know this topic is not new, so briefly: I run k3s 1.28.9+k3s1 on Raspbbery Pi 4/Ubuntu 20.04 cluster with Traefik onboarded by the default install. After a rat…

---

## [Can't join additional master nodes to single-node cluster with embedded etcd](https://forums.suse.com/t/cant-join-additional-master-nodes-to-single-node-cluster-with-embedded-etcd/43150)

<div class="topic-metadata">

**Author:** [@Joseph\_Montanaro](https://forums.suse.com/u/Joseph_Montanaro)\
**Replies:** 1\
**Last updated:** [May 15, 2024, 4:58pm UTC](https://forums.suse.com/t/cant-join-additional-master-nodes-to-single-node-cluster-with-embedded-etcd/43150 "2024-05-15T16:58:45Z")

</div>

I have a single-node cluster that I was always planning on upgrading to a 3-node cluster once I got it all set up and could migrate existing workloads into the cluster. To bring up the cluster originally, I used the fol…

---

## [Single node k3s - connect to guest host in Fleet - DNS issue](https://forums.suse.com/t/single-node-k3s-connect-to-guest-host-in-fleet-dns-issue/36897)

<div class="topic-metadata">

**Author:** [@mjs](https://forums.suse.com/u/mjs)\
**Replies:** 1\
**Last updated:** [May 6, 2024, 2:44pm UTC](https://forums.suse.com/t/single-node-k3s-connect-to-guest-host-in-fleet-dns-issue/36897 "2024-05-06T14:44:31Z")

</div>

For testing purposes, I started a Docker single node Rancher container and now I want to connect Fleet to my git repo via git protocol (git://), which is running as daemon on my local machine. Is there a special name I …

---

## [Kube-proxy healthz probe fails despite it's running](https://forums.suse.com/t/kube-proxy-healthz-probe-fails-despite-its-running/43052)

<div class="topic-metadata">

**Author:** [@Badrmoh](https://forums.suse.com/u/Badrmoh)\
**Replies:** 0\
**Last updated:** [April 29, 2024, 8:13am UTC](https://forums.suse.com/t/kube-proxy-healthz-probe-fails-despite-its-running/43052 "2024-04-29T08:13:39Z")

</div>

I have a new installation of RKE2 cluster of 1 master node and 1 worker node that’re running rke2 v1.29.3. The problem is that healthcheck of kube-proxy of the node is failing with connection refused Startup probe faile…

---

## [When installing k3s in HA mode does the first master get setup as standalone control plane?](https://forums.suse.com/t/when-installing-k3s-in-ha-mode-does-the-first-master-get-setup-as-standalone-control-plane/42916)

<div class="topic-metadata">

**Author:** [@Lance\_Lyons](https://forums.suse.com/u/Lance_Lyons)\
**Replies:** 0\
**Last updated:** [April 10, 2024, 12:41am UTC](https://forums.suse.com/t/when-installing-k3s-in-ha-mode-does-the-first-master-get-setup-as-standalone-control-plane/42916 "2024-04-10T00:41:27Z")

</div>

when installing k3s in HA mode does the first master get setup as standalone control plane in all cases? I see how control plane 2 and 3 are setup to communicate back through the loadbalancer vip but how is control plan…

---

## [K3s control planes behind an loadbalancer](https://forums.suse.com/t/k3s-control-planes-behind-an-loadbalancer/42895)

<div class="topic-metadata">

**Author:** [@Lance\_Lyons](https://forums.suse.com/u/Lance_Lyons)\
**Replies:** 0\
**Last updated:** [April 3, 2024, 4:22pm UTC](https://forums.suse.com/t/k3s-control-planes-behind-an-loadbalancer/42895 "2024-04-03T16:22:55Z")

</div>

I am trying to bring up 3 k3s control planes that are all using a load balancer vIP that load balances the 3 control planes. we are trying to configure the first control plane like this curl -sfL https://get.k3s.io | K…

---

## [What version of k3s, docker and rancher are compatible with each other?](https://forums.suse.com/t/what-version-of-k3s-docker-and-rancher-are-compatible-with-each-other/42842)

<div class="topic-metadata">

**Author:** [@oslonn](https://forums.suse.com/u/oslonn)\
**Replies:** 9\
**Last updated:** [March 30, 2024, 1:47pm UTC](https://forums.suse.com/t/what-version-of-k3s-docker-and-rancher-are-compatible-with-each-other/42842 "2024-03-30T13:47:23Z")

</div>

I want to learn it, I keep getting 404 not found when I install it.

[Next page](https://forums.suse.com/c/k3s-k3os-k3d/19.md?page=1)
