# SUSE Storage

**URL:** https://forums.suse.com/c/longhorn/14.md

[Latest](https://forums.suse.com/latest.md) · [Categories](https://forums.suse.com/categories.md)

---

## [About the SUSE Storage category](https://forums.suse.com/t/about-the-suse-storage-category/6160)

<div class="topic-metadata">

**Author:** [@denise](https://forums.suse.com/u/denise)\
**Replies:** 0

</div>

Longhorn is an open source project for microservices-based distributed block storage. It is built from containers, for containers.

---

## [How to assign user permission for accessing Rancher proxying Longhorn UI](https://forums.suse.com/t/how-to-assign-user-permission-for-accessing-rancher-proxying-longhorn-ui/43054)

<div class="topic-metadata">

**Author:** [@agnesyangwei](https://forums.suse.com/u/agnesyangwei)\
**Replies:** 1\
**Last updated:** [March 20, 2025, 10:19am UTC](https://forums.suse.com/t/how-to-assign-user-permission-for-accessing-rancher-proxying-longhorn-ui/43054 "2025-03-20T10:19:45Z")

</div>

Rancher UI access can be secured by integrating with LDAP MFA. Thus accessing Longhorn UI would be safer via Rancher proxying Longhorn UI than via creating an NGINX Ingress controller with basic authentication. A user, …

---

## [AttachVolume.Attach failed for volume pvc is not ready for workloads](https://forums.suse.com/t/attachvolume-attach-failed-for-volume-pvc-is-not-ready-for-workloads/45035)

<div class="topic-metadata">

**Author:** [@Hanamant\_Goud\_VK](https://forums.suse.com/u/Hanamant_Goud_VK)\
**Replies:** 0\
**Last updated:** [January 28, 2025, 5:59am UTC](https://forums.suse.com/t/attachvolume-attach-failed-for-volume-pvc-is-not-ready-for-workloads/45035 "2025-01-28T05:59:59Z")

</div>

I am using Longhorn in my on-prem k8s cluster … I have many applications using longhorn volumes such as mongodb , efk etc… I have set defaultClassReplicaCount = 1 as i dont need replicas of volume. I get below error for …

---

## [MountVolume.MountDevice failed after Node restart](https://forums.suse.com/t/mountvolume-mountdevice-failed-after-node-restart/44863)

<div class="topic-metadata">

**Author:** [@gunther\_alfred](https://forums.suse.com/u/gunther_alfred)\
**Replies:** 3\
**Last updated:** [January 27, 2025, 9:35am UTC](https://forums.suse.com/t/mountvolume-mountdevice-failed-after-node-restart/44863 "2025-01-27T09:35:53Z")

</div>

Hello together, I hope I can find some help here: Every once and then I stumble upon the issue, that a pod can not mount a longhorn volume (encrypted) after a node restart / update of a node. I receive the following me…

---

## [Help me understand instance-manager pods](https://forums.suse.com/t/help-me-understand-instance-manager-pods/45028)

<div class="topic-metadata">

**Author:** [@linucksrox](https://forums.suse.com/u/linucksrox)\
**Replies:** 0\
**Last updated:** [January 26, 2025, 8:37pm UTC](https://forums.suse.com/t/help-me-understand-instance-manager-pods/45028 "2025-01-26T20:37:53Z")

</div>

I deployed Longhorn 1.8.0 on Talos Linux 1.9.2 using Helm and for the most part, default options. I’m using the v2 engine and I have 3 dedicated storage nodes and followed the Talos specific setup for the bind mounts, hu…

---

## [Longhorn-UI on CrashLoopBack and Error in Longhorn-Manager](https://forums.suse.com/t/longhorn-ui-on-crashloopback-and-error-in-longhorn-manager/44761)

<div class="topic-metadata">

**Author:** [@RockD](https://forums.suse.com/u/RockD)\
**Replies:** 0\
**Last updated:** [December 19, 2024, 8:43pm UTC](https://forums.suse.com/t/longhorn-ui-on-crashloopback-and-error-in-longhorn-manager/44761 "2024-12-19T20:43:29Z")

</div>

Hello I’m having problems with my instalation of longhorn in a cluster, de longhorn-ui get stuck in CrashLoopBack with exit error code 127, and doesn’t generate any logs Searching for posible debuguing options, I cross…

---

## [Faulted Longhorn Volumes After Kubernetes Upgrade on DigitalOcean](https://forums.suse.com/t/faulted-longhorn-volumes-after-kubernetes-upgrade-on-digitalocean/44650)

<div class="topic-metadata">

**Author:** [@bluejeff](https://forums.suse.com/u/bluejeff)\
**Replies:** 0\
**Last updated:** [December 5, 2024, 12:56pm UTC](https://forums.suse.com/t/faulted-longhorn-volumes-after-kubernetes-upgrade-on-digitalocean/44650 "2024-12-05T12:56:43Z")

</div>

Hi, I’m encountering a critical issue with my Longhorn setup, and I would greatly appreciate any guidance or suggestions. I’m running a Kubernetes cluster on DigitalOcean Managed Kubernetes (DOKS), and my storage backe…

---

## [How to create a Longhorn StorageClass for cnpg](https://forums.suse.com/t/how-to-create-a-longhorn-storageclass-for-cnpg/44539)

<div class="topic-metadata">

**Author:** [@Nine\_to\_one](https://forums.suse.com/u/Nine_to_one)\
**Replies:** 4\
**Last updated:** [November 27, 2024, 7:33pm UTC](https://forums.suse.com/t/how-to-create-a-longhorn-storageclass-for-cnpg/44539 "2024-11-27T19:33:56Z")

</div>

For cnpg postgres cluster, they already did replication, so from the idea in this blog: I tried multiple ways to create a longhorn sc that : 1 replica only, that means one copy only, no need replicate need to create…

---

## [Cannot delete longhorn namespace](https://forums.suse.com/t/cannot-delete-longhorn-namespace/42129)

<div class="topic-metadata">

**Author:** [@jack.chuong](https://forums.suse.com/u/jack.chuong)\
**Replies:** 4\
**Last updated:** [November 9, 2024, 11:56pm UTC](https://forums.suse.com/t/cannot-delete-longhorn-namespace/42129 "2024-11-09T23:56:46Z")

</div>

Hi all, I have a k8s cluster internal setup by k3s. I have installed longhorn by helm helm install longhorn longhorn/longhorn --namespace longhorn -f values.yaml Then I uninstall longhorn a few seconds later helm -n…

---

## [Longhorn helm upgrade to 1.7.1 stuck](https://forums.suse.com/t/longhorn-helm-upgrade-to-1-7-1-stuck/44137)

<div class="topic-metadata">

**Author:** [@timvdh](https://forums.suse.com/u/timvdh)\
**Replies:** 5\
**Last updated:** [November 7, 2024, 5:26pm UTC](https://forums.suse.com/t/longhorn-helm-upgrade-to-1-7-1-stuck/44137 "2024-11-07T17:26:55Z")

</div>

My upgrade job in ns kube-system is stuck with the below log messages. The pods in ns longhorn-system still look intact. However, the failed upgrade degraded longhorn somehow and many pvcs are not working anymore. Maybe…

---

## [How to interrupt endless attaching?](https://forums.suse.com/t/how-to-interrupt-endless-attaching/44331)

<div class="topic-metadata">

**Author:** [@Marx\_N](https://forums.suse.com/u/Marx_N)\
**Replies:** 0\
**Last updated:** [October 18, 2024, 8:47am UTC](https://forums.suse.com/t/how-to-interrupt-endless-attaching/44331 "2024-10-18T08:47:19Z")

</div>

Hello After disk failure I exchange disk which stores longhorn replicas. I have problem with one volume, which is stuck at attaching. How can I stop it from trying to attach? Custom resource editing?

---

## [\[Recovery\] Cannot mount simple-longhorn block device](https://forums.suse.com/t/recovery-cannot-mount-simple-longhorn-block-device/42235)

<div class="topic-metadata">

**Author:** [@Honzapat](https://forums.suse.com/u/Honzapat)\
**Replies:** 1\
**Last updated:** [October 8, 2024, 1:51am UTC](https://forums.suse.com/t/recovery-cannot-mount-simple-longhorn-block-device/42235 "2024-10-08T01:51:25Z")

</div>

Hello I was using Harvester for a few months until a power failure struck our invertor, which rendered the supposedly HA cluster(2 nodes tho) unusable(starts, but the rke2 never boots). Fortunately I can access the ssh…

---

## [Volume is stuck in creating state after server reboot](https://forums.suse.com/t/volume-is-stuck-in-creating-state-after-server-reboot/44041)

<div class="topic-metadata">

**Author:** [@KyuWoo\_Choi](https://forums.suse.com/u/KyuWoo_Choi)\
**Replies:** 1\
**Last updated:** [September 25, 2024, 4:21pm UTC](https://forums.suse.com/t/volume-is-stuck-in-creating-state-after-server-reboot/44041 "2024-09-25T16:21:16Z")

</div>

Several volumes are stuck in Creating State(Health: Faulted, Ready for workload: Not Ready). It is after server reboot. and I suspect wrong longhorn engine caused the problem. I was using longhorn-engine:master-head …

---

## [Longhorn showing disk as 0 bytes](https://forums.suse.com/t/longhorn-showing-disk-as-0-bytes/44072)

<div class="topic-metadata">

**Author:** [@Mark\_Weaver](https://forums.suse.com/u/Mark_Weaver)\
**Replies:** 1\
**Last updated:** [September 18, 2024, 7:31pm UTC](https://forums.suse.com/t/longhorn-showing-disk-as-0-bytes/44072 "2024-09-18T19:31:30Z")

</div>

I’ve added nodes 4,5,6 and one of them shows the correct disk size but the others show zero bytes. I’m not sure how to proceed with diagnosing this and would like some advice. I do get this: time=“2024-09-17T15:19:2…

---

## [Error after migration](https://forums.suse.com/t/error-after-migration/21426)

<div class="topic-metadata">

**Author:** [@Marx\_N](https://forums.suse.com/u/Marx_N)\
**Replies:** 9\
**Last updated:** [August 15, 2024, 1:27pm UTC](https://forums.suse.com/t/error-after-migration/21426 "2024-08-15T13:27:15Z")

</div>

Hello, some time in the past after one of upgrade migration (I’m using currently 1.2.2) backup tab stopped to work, showing an error: error listing backup volume names: Failed to execute: /var/lib/longhorn/engine-binar…

---

## [Longhorn split-brain quorum](https://forums.suse.com/t/longhorn-split-brain-quorum/43723)

<div class="topic-metadata">

**Author:** [@frran24](https://forums.suse.com/u/frran24)\
**Replies:** 1\
**Last updated:** [July 29, 2024, 9:31am UTC](https://forums.suse.com/t/longhorn-split-brain-quorum/43723 "2024-07-29T09:31:19Z")

</div>

Hey community, how does longhorn deal with split-brain at storage level? The following scenario: a 3 node K8s cluster (1x ControlPlane and 2x ControlPlane + Worker Nodes combined) The ControlPlane-only runs on a less…

---

## [Unable to drain node because of stric-local volume](https://forums.suse.com/t/unable-to-drain-node-because-of-stric-local-volume/43391)

<div class="topic-metadata">

**Author:** [@ranchom](https://forums.suse.com/u/ranchom)\
**Replies:** 2\
**Last updated:** [June 14, 2024, 8:34am UTC](https://forums.suse.com/t/unable-to-drain-node-because-of-stric-local-volume/43391 "2024-06-14T08:34:57Z")

</div>

Hi, I am running some pods with strict-local onereplica volumes because they take part in a cluster of three pods. Redundancy is provided by the pod cluster. The problem is that I can’t drain the nodes because longhorn…

---

## [Advanced scheduling for Share Manager](https://forums.suse.com/t/advanced-scheduling-for-share-manager/19717)

<div class="topic-metadata">

**Author:** [@awelsman](https://forums.suse.com/u/awelsman)\
**Replies:** 3\
**Last updated:** [June 8, 2024, 11:44am UTC](https://forums.suse.com/t/advanced-scheduling-for-share-manager/19717 "2024-06-08T11:44:03Z")

</div>

I have a cluster with a number of nodes (EC2 instances) which, under considerable load, can die and be cycled back into the cluster by RKE. I want to run Longhorn on both those nodes and a few other, much more reliable o…

---

## [Missing engine image means broken images](https://forums.suse.com/t/missing-engine-image-means-broken-images/43283)

<div class="topic-metadata">

**Author:** [@jurgenweber](https://forums.suse.com/u/jurgenweber)\
**Replies:** 1\
**Last updated:** [May 29, 2024, 10:58am UTC](https://forums.suse.com/t/missing-engine-image-means-broken-images/43283 "2024-05-29T10:58:00Z")

</div>

So I was looking at my cluster nodes and wondering why I had so little compute to realise on my little 3 node home cluster I had 5 imagine engine’s running, so two nodes had two. I found the CR and deleted the older one…

---

## [Restore/bind a deleted dynamically provisioned PV/PVC](https://forums.suse.com/t/restore-bind-a-deleted-dynamically-provisioned-pv-pvc/43281)

<div class="topic-metadata">

**Author:** [@crazyelectron](https://forums.suse.com/u/crazyelectron)\
**Replies:** 1\
**Last updated:** [May 28, 2024, 5:28pm UTC](https://forums.suse.com/t/restore-bind-a-deleted-dynamically-provisioned-pv-pvc/43281 "2024-05-28T17:28:59Z")

</div>

Is there an easy automated workflow possible to restore deleted volumes and reuse them when doing a workload or cluster rebuild. I use Ansible to provision my workloads and accompanying storage with dynamically provisio…

---

## [Error Message: replica scheduling failed](https://forums.suse.com/t/error-message-replica-scheduling-failed/43208)

<div class="topic-metadata">

**Author:** [@tonit](https://forums.suse.com/u/tonit)\
**Replies:** 2\
**Last updated:** [May 21, 2024, 10:26pm UTC](https://forums.suse.com/t/error-message-replica-scheduling-failed/43208 "2024-05-21T22:26:40Z")

</div>

Hello, I have a single-node k3s cluster installed on Azure VM. On the cluster I have installed Longhorn using kubectl. I have made a PersistentVolumeClaim and Deployment for Clickhouse but I guess this does not matter. O…

---

## [Longhorn PVC Bound but associated PV Terminating](https://forums.suse.com/t/longhorn-pvc-bound-but-associated-pv-terminating/42807)

<div class="topic-metadata">

**Author:** [@agnesyangwei](https://forums.suse.com/u/agnesyangwei)\
**Replies:** 3\
**Last updated:** [April 29, 2024, 8:14pm UTC](https://forums.suse.com/t/longhorn-pvc-bound-but-associated-pv-terminating/42807 "2024-04-29T20:14:36Z")

</div>

On Longhorn \> Volume board, a Longhorn volume shows Healthy, Bound, and Attached to a pod. However, ‘kubectl get pv’ shows the PV status is Terminating. Any idea what is happening and any suggestion on how to fix? Thank…

---

## [Mounted NFS share as a volume](https://forums.suse.com/t/mounted-nfs-share-as-a-volume/39050)

<div class="topic-metadata">

**Author:** [@psvitz](https://forums.suse.com/u/psvitz)\
**Replies:** 2\
**Last updated:** [April 29, 2024, 3:42pm UTC](https://forums.suse.com/t/mounted-nfs-share-as-a-volume/39050 "2024-04-29T15:42:35Z")

</div>

I’m trying to use a volume to a mounted NFS share. I’ve added a disk to each node pointing to a mounted NFS path on the node I’ve added the volume and the PVC All of the above works fine, however when i try to spin up…

---

## [Accessing external longhorn from separate Kubernetes cluster](https://forums.suse.com/t/accessing-external-longhorn-from-separate-kubernetes-cluster/17252)

<div class="topic-metadata">

**Author:** [@kyle](https://forums.suse.com/u/kyle)\
**Replies:** 3\
**Last updated:** [April 25, 2024, 10:19am UTC](https://forums.suse.com/t/accessing-external-longhorn-from-separate-kubernetes-cluster/17252 "2024-04-25T10:19:38Z")

</div>

Hey all, I’m working on setting up a home lab, and have a couple of Kubernetes clusters running in virtualbox. I have successfully tested deploying Longhorn in one of the clusters, which was very exciting to see it just…

---

## [Readiness probe failedsh: /data/longhorn: Permission denied - DaemonSet/engine-image-ei](https://forums.suse.com/t/readiness-probe-failedsh-data-longhorn-permission-denied-daemonset-engine-image-ei/39927)

<div class="topic-metadata">

**Author:** [@anthonyb](https://forums.suse.com/u/anthonyb)\
**Replies:** 1\
**Last updated:** [April 6, 2024, 9:13am UTC](https://forums.suse.com/t/readiness-probe-failedsh-data-longhorn-permission-denied-daemonset-engine-image-ei/39927 "2024-04-06T09:13:39Z")

</div>

I have set up a K3s+Longhorn cluster with 4x nodes and 2x 1Tb Samsung SSDs attached to 2 of the nodes. However when I plug an SSD into one of the nodes longhornio/longhorn-engine:v1.4.0 does not have permission to write …

---

## [General questions about Longhorn and scale](https://forums.suse.com/t/general-questions-about-longhorn-and-scale/16836)

<div class="topic-metadata">

**Author:** [@anthonysnielsen](https://forums.suse.com/u/anthonysnielsen)\
**Replies:** 20\
**Last updated:** [February 24, 2024, 2:16pm UTC](https://forums.suse.com/t/general-questions-about-longhorn-and-scale/16836 "2024-02-24T14:16:56Z")

</div>

Hi! I am pretty new to Kubernetes in general, and I’ve been tinkering with a 3 worker node Rancher cluster for the last two months. Lab use, just to learn. I have had a lot of trouble with NFS for PVC (specifically per…

---

## [Output: mount.nfs: Protocol not supported](https://forums.suse.com/t/output-mount-nfs-protocol-not-supported/42572)

<div class="topic-metadata">

**Author:** [@Rodrigo\_Vale](https://forums.suse.com/u/Rodrigo_Vale)\
**Replies:** 0\
**Last updated:** [February 16, 2024, 2:54am UTC](https://forums.suse.com/t/output-mount-nfs-protocol-not-supported/42572 "2024-02-16T02:54:06Z")

</div>

Hi folks, Any help would be really appreciated I have the following environment: kubectl version Client Version: v1.28.6 Kustomize Version: v5.0.4-0.20230601165947-6ce0bf390ce3 Server Version: v1.28.5+k3s1 4 nodes, …

---

## [Are snapshots point-in-time of the entire disk?](https://forums.suse.com/t/are-snapshots-point-in-time-of-the-entire-disk/42541)

<div class="topic-metadata">

**Author:** [@MikeC](https://forums.suse.com/u/MikeC)\
**Replies:** 1\
**Last updated:** [February 13, 2024, 7:58am UTC](https://forums.suse.com/t/are-snapshots-point-in-time-of-the-entire-disk/42541 "2024-02-13T07:58:21Z")

</div>

I’m using Longhorn encrypted volumes with Rancher to run a Postgres database. We are questioning weather we need to pause disk writes in the database before creating a snapshot of the disk. Postgres is good at recovering…

---

## [Longhorn with 2 ethernet interfaces](https://forums.suse.com/t/longhorn-with-2-ethernet-interfaces/42506)

<div class="topic-metadata">

**Author:** [@ppcm](https://forums.suse.com/u/ppcm)\
**Replies:** 2\
**Last updated:** [February 8, 2024, 1:11pm UTC](https://forums.suse.com/t/longhorn-with-2-ethernet-interfaces/42506 "2024-02-08T13:11:47Z")

</div>

Hello there, My hosts have 2 ethernet interfaces, to optimize the network traffic, it could be a good idea to use one interface only for Longhorn (I think it is a good idea, let me know if I am wrong) I guess I should …

---

## [addrConn.createTransport failed to connect to Instance Manager](https://forums.suse.com/t/addrconn-createtransport-failed-to-connect-to-instance-manager/42161)

<div class="topic-metadata">

**Author:** [@des](https://forums.suse.com/u/des)\
**Replies:** 2\
**Last updated:** [December 19, 2023, 11:32pm UTC](https://forums.suse.com/t/addrconn-createtransport-failed-to-connect-to-instance-manager/42161 "2023-12-19T23:32:46Z")

</div>

I’m currently experiencing an issue where the Longhorn Manager is unable to connect to the Instance Manager on the same node. Or at the very least it has transient failures to connect. Here’s an example of a log I’m se…

[Next page](https://forums.suse.com/c/longhorn/14.md?page=1)
