# SLES High Availability Extension

**URL:** https://forums.suse.com/c/suse-linux-enterprise-extensions/sles-high-availability-extension/53.md

[Latest](https://forums.suse.com/latest.md) · [Categories](https://forums.suse.com/categories.md)

---

## [About the SLES High Availability Extension category](https://forums.suse.com/t/about-the-sles-high-availability-extension-category/21523)

<div class="topic-metadata">

**Author:** [@system](https://forums.suse.com/u/system)\
**Replies:** 0

</div>

---

## [Unable to join the node in cluster](https://forums.suse.com/t/unable-to-join-the-node-in-cluster/45903)

<div class="topic-metadata">

**Author:** [@kommina](https://forums.suse.com/u/kommina)\
**Replies:** 1\
**Last updated:** [September 30, 2025, 11:55am UTC](https://forums.suse.com/t/unable-to-join-the-node-in-cluster/45903 "2025-09-30T11:55:11Z")

</div>

Hi Team, When I try to join the another node in cluster, I’m getting below error. I’ve entered correct password of primary node, however still I’m getting this error. Can some one please help me on it. loninengvm263:~…

---

## [Sles kvm virtualization](https://forums.suse.com/t/sles-kvm-virtualization/45533)

<div class="topic-metadata">

**Author:** [@jgorospe](https://forums.suse.com/u/jgorospe)\
**Replies:** 0\
**Last updated:** [May 21, 2025, 5:13am UTC](https://forums.suse.com/t/sles-kvm-virtualization/45533 "2025-05-21T05:13:51Z")

</div>

Hi, I’m trying to set up KVM virtualization with the High Availability Extension. I have created a cluster with two nodes and shared storage. However, every time we test the High Availability feature, the cluster resour…

---

## [Can't add third node in the new cluster](https://forums.suse.com/t/cant-add-third-node-in-the-new-cluster/45247)

<div class="topic-metadata">

**Author:** [@ivancheng](https://forums.suse.com/u/ivancheng)\
**Replies:** 2\
**Last updated:** [March 7, 2025, 8:17am UTC](https://forums.suse.com/t/cant-add-third-node-in-the-new-cluster/45247 "2025-03-07T08:17:12Z")

</div>

I would like to create 3 nodes cluster using SUSE 15 SP5. The second node could be joined to the new cluster. However, the third node can’t be joined with the below error. Please advise how I can fix it. Thanks in ad…

---

## [Cluster join error](https://forums.suse.com/t/cluster-join-error/44028)

<div class="topic-metadata">

**Author:** [@Ernest](https://forums.suse.com/u/Ernest)\
**Replies:** 0\
**Last updated:** [September 9, 2024, 9:51am UTC](https://forums.suse.com/t/cluster-join-error/44028 "2024-09-09T09:51:28Z")

</div>

I am getting an error of cluster.join: /dev/sda4 doesn’t look like a block device. Attached is the configuration of my SBD. Kind Regards, Ernest.

---

## [Upgrade SLES in HA from 12.5 to 15.X (SAP HANA usage)](https://forums.suse.com/t/upgrade-sles-in-ha-from-12-5-to-15-x-sap-hana-usage/42381)

<div class="topic-metadata">

**Author:** [@Ganimede77](https://forums.suse.com/u/Ganimede77)\
**Replies:** 1\
**Last updated:** [April 18, 2024, 5:40pm UTC](https://forums.suse.com/t/upgrade-sles-in-ha-from-12-5-to-15-x-sap-hana-usage/42381 "2024-04-18T17:40:00Z")

</div>

Hi, we would like to upgrade our SuSE 12.5 two-nodes cluster to SuSE 15.5 (or any more recent release). This cluster is used as SAP HANA database server and it was already upgraded from 12.3, 12.4 and 12.5 in the past.…

---

## [Pacemaker: setting two fencing sbd devices to prevent spilt brain in the case that 1 sbd device is disconnected, the linux will reboot by itself](https://forums.suse.com/t/pacemaker-setting-two-fencing-sbd-devices-to-prevent-spilt-brain-in-the-case-that-1-sbd-device-is-disconnected-the-linux-will-reboot-by-itself/42838)

<div class="topic-metadata">

**Author:** [@user1983](https://forums.suse.com/u/user1983)\
**Replies:** 0\
**Last updated:** [March 26, 2024, 8:43am UTC](https://forums.suse.com/t/pacemaker-setting-two-fencing-sbd-devices-to-prevent-spilt-brain-in-the-case-that-1-sbd-device-is-disconnected-the-linux-will-reboot-by-itself/42838 "2024-03-26T08:43:53Z")

</div>

0 I set up two suse 12 sp5 linux os vm and 1 window 2019 NAS vm. Each vm has 2 network interface (10.10.10.x, 11.11.11.x). I am trying to set up stonith( fencing) for eg two sbd devices (sbd 10.10.10.x and sdc 11.11.11.…

---

## [Where to get Registration Code for SLES 15.4 HA?](https://forums.suse.com/t/where-to-get-registration-code-for-sles-15-4-ha/42112)

<div class="topic-metadata">

**Author:** [@MMax](https://forums.suse.com/u/MMax)\
**Replies:** 2\
**Last updated:** [December 8, 2023, 5:40pm UTC](https://forums.suse.com/t/where-to-get-registration-code-for-sles-15-4-ha/42112 "2023-12-08T17:40:47Z")

</div>

I wanted to setup a 2-node cluster with SLES 15.4 for educational purposes. I received an evaluation license for the OS, but installation of HA requires additional registration code. I searched for hours, reading all r…

---

## [SBD Partition creation for SAP Business One, HANA HA with Auto Fail over](https://forums.suse.com/t/sbd-partition-creation-for-sap-business-one-hana-ha-with-auto-fail-over/35609)

<div class="topic-metadata">

**Author:** [@Robeth\_John](https://forums.suse.com/u/Robeth_John)\
**Replies:** 2\
**Last updated:** [November 26, 2023, 11:47am UTC](https://forums.suse.com/t/sbd-partition-creation-for-sap-business-one-hana-ha-with-auto-fail-over/35609 "2023-11-26T11:47:22Z")

</div>

Hi Experts, We are trying to setup SAP B1 HA Auto fail over and one of the requirements is to create a shared storage with conditions below. No partition exists on these blocks. The size of each block is no less than …

---

## [Crm cluster join](https://forums.suse.com/t/crm-cluster-join/40461)

<div class="topic-metadata">

**Author:** [@towe](https://forums.suse.com/u/towe)\
**Replies:** 0\
**Last updated:** [April 13, 2023, 10:00am UTC](https://forums.suse.com/t/crm-cluster-join/40461 "2023-04-13T10:00:16Z")

</div>

Has any encountered this error when joining a cluster ? ERROR: 2: cluster.join: Failed to run “ssh -o StrictHostKeyChecking=no root@xxx.xxx.xx.xxx “corosync-quorumtool -s””: Running cmd as root manually works fine. …

---

## [SLES Cluster IP](https://forums.suse.com/t/sles-cluster-ip/39562)

<div class="topic-metadata">

**Author:** [@towe](https://forums.suse.com/u/towe)\
**Replies:** 0\
**Last updated:** [November 29, 2022, 2:23pm UTC](https://forums.suse.com/t/sles-cluster-ip/39562 "2022-11-29T14:23:24Z")

</div>

Hi, Is it possible to use SLES HA Cluster for handling only IP address move ? We want to move an IP between 2 VM’s but both are still active and have applications running. Input and guidelines are appreciated

---

## [SLES15 SP3 ctdb startup fails on 1 node](https://forums.suse.com/t/sles15-sp3-ctdb-startup-fails-on-1-node/37106)

<div class="topic-metadata">

**Author:** [@Richard\_Shepherd](https://forums.suse.com/u/Richard_Shepherd)\
**Replies:** 0\
**Last updated:** [February 25, 2022, 4:33am UTC](https://forums.suse.com/t/sles15-sp3-ctdb-startup-fails-on-1-node/37106 "2022-02-25T04:33:49Z")

</div>

Hi all, we have recently installed a pair of hosts with SLES15 SP3, HA extension. The basics (clustered admin IP and SBD) are running fine. Also the clustered OCFS2 FS is created and mounted (from a shared LUN on backen…

---

## [Integrate SAP Convergent Mediation into SUSE pacemaker HA](https://forums.suse.com/t/integrate-sap-convergent-mediation-into-suse-pacemaker-ha/36963)

<div class="topic-metadata">

**Author:** [@Belhassen](https://forums.suse.com/u/Belhassen)\
**Replies:** 0\
**Last updated:** [February 11, 2022, 2:14pm UTC](https://forums.suse.com/t/integrate-sap-convergent-mediation-into-suse-pacemaker-ha/36963 "2022-02-11T14:14:28Z")

</div>

Hi all, Is there a way to integrate SAP Convergent Mediation -by DigitalRoute- into SUSE HA (pacemaker) ? I have found some SAP Notes for CM High Availability, but that’s a very high level note : https://launchpad.supp…

---

## [How to get package of SAPstartSrv agent](https://forums.suse.com/t/how-to-get-package-of-sapstartsrv-agent/35690)

<div class="topic-metadata">

**Author:** [@jodi](https://forums.suse.com/u/jodi)\
**Replies:** 2\
**Last updated:** [July 24, 2021, 2:21am UTC](https://forums.suse.com/t/how-to-get-package-of-sapstartsrv-agent/35690 "2021-07-24T02:21:50Z")

</div>

Hi Support kindly let me know how to get and download SAPstartSrv agent for SLES 15 SP1 i tried to execute the following commad but no package where found : zypper in sapstartsrv-resource-agents Loading repository dat…

---

## [symantec antivirus disturbs normal cluster process](https://forums.suse.com/t/symantec-antivirus-disturbs-normal-cluster-process/35672)

<div class="topic-metadata">

**Author:** [@kees](https://forums.suse.com/u/kees)\
**Replies:** 2\
**Last updated:** [July 16, 2021, 2:57pm UTC](https://forums.suse.com/t/symantec-antivirus-disturbs-normal-cluster-process/35672 "2021-07-16T14:57:29Z")

</div>

can anyone tell me which processes/directories I can add to the antivirus exclusions list, so that clustering is not interferred with ?

---

## [SAP ascs service can not be started  by cluster](https://forums.suse.com/t/sap-ascs-service-can-not-be-started-by-cluster/35650)

<div class="topic-metadata">

**Author:** [@jodi](https://forums.suse.com/u/jodi)\
**Replies:** 6\
**Last updated:** [July 16, 2021, 3:53am UTC](https://forums.suse.com/t/sap-ascs-service-can-not-be-started-by-cluster/35650 "2021-07-16T03:53:35Z")

</div>

\*\*Hi Support \*\* installed SAP+oracle 19c on sles-ha 15 SP1 currently we have problem when integrate instances ASCS as new cluster resource. if we use SAPinstance agent", the ascs service in cluster still can not be s…

---

## [Seeing TOTEM msgs(Totem is unable to form a cluster because of an operating system or network fault)](https://forums.suse.com/t/seeing-totem-msgs-totem-is-unable-to-form-a-cluster-because-of-an-operating-system-or-network-fault/35607)

<div class="topic-metadata">

**Author:** [@PRIYANKA](https://forums.suse.com/u/PRIYANKA)\
**Replies:** 1\
**Last updated:** [July 2, 2021, 7:41pm UTC](https://forums.suse.com/t/seeing-totem-msgs-totem-is-unable-to-form-a-cluster-because-of-an-operating-system-or-network-fault/35607 "2021-07-02T19:41:17Z")

</div>

Hello, We have a use case where we have configured both SLES HA 15 as well as strongswan service. While initially setting up these services in particular order we do not see any issues in HA services coming up. But in …

---

## [ha-cluster-join script error](https://forums.suse.com/t/ha-cluster-join-script-error/35597)

<div class="topic-metadata">

**Author:** [@Oleksii](https://forums.suse.com/u/Oleksii)\
**Replies:** 0\
**Last updated:** [May 13, 2021, 3:20pm UTC](https://forums.suse.com/t/ha-cluster-join-script-error/35597 "2021-05-13T15:20:32Z")

</div>

Hello, We have a cluster second node join problem. In log we se the following error: Marking file as dirty: /etc/corosync/corosync.conf Connecting to host nctcspci01phs (SSL) … Connect to 10.145.2.28:30865 (nctcspci…

---

## [SLES 12.3 conflicts with HA patches](https://forums.suse.com/t/sles-12-3-conflicts-with-ha-patches/35578)

<div class="topic-metadata">

**Author:** [@Oscar.AlvarezParedes](https://forums.suse.com/u/Oscar.AlvarezParedes)\
**Replies:** 1\
**Last updated:** [May 7, 2021, 9:15am UTC](https://forums.suse.com/t/sles-12-3-conflicts-with-ha-patches/35578 "2021-05-07T09:15:47Z")

</div>

Dear all, I’m trying to evaluate SLES 12.3 with the HA extension. The problem I’m facing is that the HA patches require newer versions of the packages provided by SLES 12.3, so I cannot install such patches, so it look…

---

## [corosync   \[TOTEM \] Type of received message is wrong...  ignoring](https://forums.suse.com/t/corosync-totem-type-of-received-message-is-wrong-ignoring/35447)

<div class="topic-metadata">

**Author:** [@johngoutbeck](https://forums.suse.com/u/johngoutbeck)\
**Replies:** 1\
**Last updated:** [February 5, 2021, 6:45pm UTC](https://forums.suse.com/t/corosync-totem-type-of-received-message-is-wrong-ignoring/35447 "2021-02-05T18:45:11Z")

</div>

SLES 15 SP2 + HA 3 host cluster (1 on standby to give quorum) first I had a Faulty corosync ring 1 \*\* nss-vmh01:~ # corosync-cfgtool -s Printing ring status. Local node ID 1084755185 RING ID 0 id = 192.168.1…

---

## [Running  an RA script manually from the prompt](https://forums.suse.com/t/running-an-ra-script-manually-from-the-prompt/35364)

<div class="topic-metadata">

**Author:** [@julianrogan](https://forums.suse.com/u/julianrogan)\
**Replies:** 1\
**Last updated:** [November 9, 2020, 8:30pm UTC](https://forums.suse.com/t/running-an-ra-script-manually-from-the-prompt/35364 "2020-11-09T20:30:08Z")

</div>

Is it possible to to run an RA script manually. Specifically the SAPHana script. I have executed it with start command as an option but SAP settings were not picked up.

---

## [Node states](https://forums.suse.com/t/node-states/35309)

<div class="topic-metadata">

**Author:** [@Smash](https://forums.suse.com/u/Smash)\
**Replies:** 3\
**Last updated:** [October 14, 2020, 4:43am UTC](https://forums.suse.com/t/node-states/35309 "2020-10-14T04:43:12Z")

</div>

Hello experts, As of now we see bare minimum states for the nodes in the cluster, like online, offline or under maintenance… but is there a way to have user defined states for each node, which any other node in the clus…

---

## [Stacked DRBD (DR Node) not Syncing Back to Primary Site](https://forums.suse.com/t/stacked-drbd-dr-node-not-syncing-back-to-primary-site/35313)

<div class="topic-metadata">

**Author:** [@tooreplyram](https://forums.suse.com/u/tooreplyram)\
**Replies:** 1\
**Last updated:** [October 10, 2020, 4:04pm UTC](https://forums.suse.com/t/stacked-drbd-dr-node-not-syncing-back-to-primary-site/35313 "2020-10-10T16:04:06Z")

</div>

We have following Situation here, We have 3 nodes with DRBD Setup. 2 Nodes are part of pacemaker clustering and 1 node is DR Node. As part of DR testing we have shutdown 2 Nodes (Pacemaker), and mounted DRBD drive on DR…

---

## [Automatic failback of cluster resources after reboot](https://forums.suse.com/t/automatic-failback-of-cluster-resources-after-reboot/35298)

<div class="topic-metadata">

**Author:** [@PRIYANKA](https://forums.suse.com/u/PRIYANKA)\
**Replies:** 1\
**Last updated:** [September 26, 2020, 6:33pm UTC](https://forums.suse.com/t/automatic-failback-of-cluster-resources-after-reboot/35298 "2020-09-26T18:33:01Z")

</div>

Hello There, I have noticed a use case in SLES15 that on a two-node cluster when a node was rebooted, the resources failed over to next node. But as soon as Node1 came up, the resources automatically failed back to node…

---

## [Opinion Needed: OCFS2 or GFS2 without any (Like Pacemaker) Cluster Components](https://forums.suse.com/t/opinion-needed-ocfs2-or-gfs2-without-any-like-pacemaker-cluster-components/35185)

<div class="topic-metadata">

**Author:** [@tooreplyram](https://forums.suse.com/u/tooreplyram)\
**Replies:** 3\
**Last updated:** [September 2, 2020, 3:42am UTC](https://forums.suse.com/t/opinion-needed-ocfs2-or-gfs2-without-any-like-pacemaker-cluster-components/35185 "2020-09-02T03:42:32Z")

</div>

We have one requirement for installing one of the software on two nodes by using shared file system (block). However, as we are running SLES 12.x VMs on Azure platform, we don’t have option of using centralized shared s…

---

## [xen locking](https://forums.suse.com/t/xen-locking/35148)

<div class="topic-metadata">

**Author:** [@warper2](https://forums.suse.com/u/warper2)\
**Replies:** 3\
**Last updated:** [July 19, 2020, 7:39pm UTC](https://forums.suse.com/t/xen-locking/35148 "2020-07-19T19:39:15Z")

</div>

I am moving from sles 11 with HA to sles 12 HA. Under 11 with xen we would specify a directory for creating locks so the machine does not start on 2 machines at once. How do I accomplish the same in sles 12 so that machi…

---

## [Virsh and xl](https://forums.suse.com/t/virsh-and-xl/35147)

<div class="topic-metadata">

**Author:** [@warper2](https://forums.suse.com/u/warper2)\
**Replies:** 5\
**Last updated:** [July 19, 2020, 2:04pm UTC](https://forums.suse.com/t/virsh-and-xl/35147 "2020-07-19T14:04:10Z")

</div>

I am migrating from Sles 11 xen xm to sles12 xen xl. Both use Sles HA. I have succeeded in converting all the files to the new format . The issue I am running into when I setup for starting the vm’s is that virsh and xl …

---

## [Colocation with one-way failover dependency](https://forums.suse.com/t/colocation-with-one-way-failover-dependency/35144)

<div class="topic-metadata">

**Author:** [@PRIYANKA](https://forums.suse.com/u/PRIYANKA)\
**Replies:** 4\
**Last updated:** [July 19, 2020, 5:49am UTC](https://forums.suse.com/t/colocation-with-one-way-failover-dependency/35144 "2020-07-19T05:49:19Z")

</div>

Hi Folks! I have a query related to SLES HA crm constraints. I have a use case where there needs to be a colocation constraint between two resources (let’s say A and B ) The restrictions are that B should be colocat…

---

## [SUSE High Availability Extension for SAP HANA](https://forums.suse.com/t/suse-high-availability-extension-for-sap-hana/35123)

<div class="topic-metadata">

**Author:** [@Shawn1](https://forums.suse.com/u/Shawn1)\
**Replies:** 1\
**Last updated:** [July 3, 2020, 4:04pm UTC](https://forums.suse.com/t/suse-high-availability-extension-for-sap-hana/35123 "2020-07-03T16:04:25Z")

</div>

Hello experts, I am handling my newly built landscape on my SAP HANA with System Replication using HAE resource agents. Recently my system had some issue and we had no choice but to keep maintenance-mode=true for the ti…

---

## [Query for bringup and startup of resources on just one node of the cluster?](https://forums.suse.com/t/query-for-bringup-and-startup-of-resources-on-just-one-node-of-the-cluster/35063)

<div class="topic-metadata">

**Author:** [@PRIYANKA](https://forums.suse.com/u/PRIYANKA)\
**Replies:** 1\
**Last updated:** [June 16, 2020, 8:18pm UTC](https://forums.suse.com/t/query-for-bringup-and-startup-of-resources-on-just-one-node-of-the-cluster/35063 "2020-06-16T20:18:02Z")

</div>

Hi Folks! We have a 4-node SLES 12 SP3 cluster setup which has gone bad and now I want to recover the setup. So First we bring up only one node by starting corosync and pacemaker, and want to start the resources on thi…

[Next page](https://forums.suse.com/c/suse-linux-enterprise-extensions/sles-high-availability-extension/53.md?page=1)
