XEN VMs won't open

For several days now I have had immense difficulty logging into any of my 3 XEN VMs. By way of background, this is an IBM X Series server with only 8GB of RAM. I'm running SLES11 SP4 as the host DOM0, and have three XEN VMs (OES, Groupwise, and Groupwise Mobility Server). I need to troubleshoot the GMS as it's not communicating with the POA, and hence syncing is not working: but I am unable to login to the VMs to try to fix this. No, I did not enable VNC.

When I try to open a VM from within the Virtual Machine Manager on the host, more often than not, I find that I'm offered a new login screen to the HOST, and not to the Guest (VM). I've followed SUSE document 3559698, and modified the minimum RAM for the host from 512 to 2048, and tried to enable 'ballooning no", but that stops me from even starting the XEN VMs ("xend err: 'not enough free memory and enable-dom0-ballooning is False, so I cannot release any more. I need 1049088 KiB but only have 219736). So I set it back to ballooning yes.

So I'm guessing I have memory issues, but am not sure what I should try as memory settings for both the Dom0 and each of the VMs. Can anyone point me to some simple instructions / guidelines for this? (The network is only for 3 user accounts, and I'm probably the main player)

Many thanks for any suggestions



  • Automatic ReplyAutomatic Reply No Reply Posting Bot

    It appears that in the past few days you have not received a response to your
    posting. That concerns us, and has triggered this automated reply.

    These forums are peer-to-peer, best effort, volunteer run and that if your issue
    is urgent or not getting a response, you might try one of the following options:

    - Visit http://www.suse.com/support and search the knowledgebase and/or check all
    the other support options available.
    - Open a service request: https://www.suse.com/support
    - You could also try posting your message again. Make sure it is posted in the
    correct newsgroup. (http://forums.suse.com)

    Be sure to read the forum FAQ about what to expect in the way of responses:

    If this is a reply to a duplicate posting or otherwise posted in error, please
    ignore and accept our apologies and rest assured we will issue a stern reprimand
    to our posting bot..

    Good luck!

    Your SUSE Forums Team
  • KEVINKEVIN Knowledge Partner
    zexec4 wrote:

    > So I'm guessing I have memory issues,

    Hi Jerome,

    That appears to be a reasonable assessment. :-)

    I have a similar setup and, while 8 GB is not a lot, you should be able
    to get it working especially on a small 3-user system.

    How much memory is assigned to each of your DomUs?

    The first thing is to try to reduce memory requirements on Dom0 and on
    the DomUs.

    - Uninstall any components that are not needed.
    - Reduce the memory assigned to each DomU. You have to find a balance.
    - Run Dom0 and DomUs at runlevel 3 (no graphics)

    If you are more comfortable using the GUI, install Xming on your
    workstation and use SSH (PuTTY?) to access your servers. That should
    reduce the memory requirements on the server while the graphics
    rendering is done on your workstation.

    > I've followed SUSE document
    > 3559698, and modified the minimum RAM for the host from 512 to 2048,
    > and tried to enable 'ballooning no", but that stops me from even
    > starting the XEN VMs ("xend err: 'not enough free memory and
    > enable-dom0-ballooning is False,

    I would follow the recommendation in SUSE document 3559698. 2048 MB is
    a reasonable amount. You may be able to get by with 1500 MB. You *will*
    have problems if the sum of the memory assigned to the Dom0 and each of
    the DomUs is greater than 8 GB!

    Kevin Boyle - Knowledge Partner
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below this post.
    Thank you.
  • Jens-U.Jens-U. Knowledge Partner
    Hi Jerome,

    sorry for jumping in this late. Kevin already has given some advice on memory consumption, but as DomU already complains at a 1 GB DomU, I'm a bit baffled.

    First of all, are you running persisted DomU configurations, or are you starting from config files? I remember having a rough time when I adjusted DomU configurations per file, but that didn't catch, as the (original) configuration was persisted.

    How much memory have you configured for each of your DomUs?

    When the "DomU won't start" problem occurs, what's in xend's log file (/var/log/xen/xend.log) or, if that just hints that the DomU was started, in the DomU's log (same directory)? What does "xm list" report (I'm lookng for the information of the then current run-time environemnt, like other DomUs running and Dom0 memory)?

    Do you receive more information when starting the DomU via command line ("xm create ..." if per config file, "xm start" for persisted configuration)?

Sign In or Register to comment.