Issue with repository for SDK

I am working on upgrading a SLES 12 SP3 host to SP4 and have run into a problem I can't figure out. When I initially tried 'zypper patch' the process complained that it couldn't access the repsitory index file for 'SUSE_Linux_Enterprise_Server_12_SP3_s390x' and 'SUSE_Linux_Enterprise_Software_Development_Kit_12_SP3_s390x'. I re-registered the server using 'SUSEConnect -r rec-code -e my-email.com'.

Now when I run 'zypper patch', it gives
app-wfr23t-830:~ # zypper patch
Refreshing service 'Legacy_Module_12_s390x'.
Refreshing service 'SUSE_Linux_Enterprise_Server_12_SP3_s390x'.
Refreshing service 'SUSE_Linux_Enterprise_Software_Development_Kit_12_SP3_s390x'.
Problem retrieving the repository index file for service 'SUSE_Linux_Enterprise_Software_Development_Kit_12_SP3_s390x':
File './repo/repoindex.xml' not found on medium 'https://scc.suse.com/access/services/1414?cookies=0&credentials=SUSE_Linux_Enterprise_Software_Development_Kit_12_SP3_s390x'
Check if the URI is valid and accessible.
Building repository 'SLES12-SP3-Pool' cache .....................................................................................................[done]
Retrieving repository 'SLES12-SP3-Updates' metadata .............................................................................................[done]
Building repository 'SLES12-SP3-Updates' cache ..................................................................................................[done]

The server is not behind a proxy. How do I resolve this?


Harley

Comments

  • x0500hlx0500hl Senior Member
    Update:

    I tried to access the SUSE site with
    curl https://scc.suse.com/access/services/1414?cookies=0&credentials=SUSE_Linux_Enterprise_Software_Development_Kit_12_SP3_s390x
    

    It resulted in
    [1] 4562
    app-wfr23t-830:~ # {"type":"error","error":"Please provide system/organization credentials.","localized_error":"Please provide system/organization credentials."}^C
    [1]+  Done                    curl https://scc.suse.com/access/services/1414?cookies=0
    

    What are the credentials that it is looking for? How do I specify them when I run 'zypper patch'?


    Harley
  • malcolmlewismalcolmlewis Knowledge Partner
    Hi
    So has it added the repositories, can you show the output from;
    zypper lr -d
    
  • x0500hlx0500hl Senior Member
    Hi Malcolm,

    I had checked that yesterday but neglected to post the output. There were 4 respositories for the SDK, with 2 enabled.

    I resolved the issue so I don't think the output from 'zypper lr -d' will be relevant now.

    Prior to SUSConnect there was a process that you needed to follow to re-register a server. The process included navigating to a certain directory, deleting certain files, etc. I thought of this while driving into the office this morning, so I did some more research.

    The issue I had was that the SDK wasn't 'Activated'. The following is the command and output.
    app-wfr23t-830:~ # SUSEConnect --list-extensions
    AVAILABLE EXTENSIONS AND MODULES
    
        Advanced Systems Management Module 12 s390x
        Activate with: SUSEConnect -p sle-module-adv-systems-management/12/s390x
    
        Containers Module 12 s390x
        Activate with: SUSEConnect -p sle-module-containers/12/s390x
    
        Legacy Module 12 s390x (Activated)
        Deactivate with: SUSEConnect -d -p sle-module-legacy/12/s390x
    
        Public Cloud Module 12 s390x
        Activate with: SUSEConnect -p sle-module-public-cloud/12/s390x
    
        SUSE Linux Enterprise High Availability Extension 12 SP3 s390x
        Activate with: SUSEConnect -p sle-ha/12.3/s390x -r ADDITIONAL REGCODE
    
            SUSE Linux Enterprise High Availability GEO Extension 12 SP3 s390x
            Activate with: SUSEConnect -p sle-ha-geo/12.3/s390x -r ADDITIONAL REGCODE
    
        SUSE Linux Enterprise Server LTSS 12 SP3 s390x
        Activate with: SUSEConnect -p SLES-LTSS/12.3/s390x -r ADDITIONAL REGCODE
    
        SUSE Linux Enterprise Software Development Kit 12 SP3 s390x
        Activate with: SUSEConnect -p sle-sdk/12.3/s390x
    
        SUSE Manager Server 3.0 s390x
        Activate with: SUSEConnect -p SUSE-Manager-Server/3.0/s390x -r ADDITIONAL REGCODE
    
        SUSE Manager Server 3.1 s390x
        Activate with: SUSEConnect -p SUSE-Manager-Server/3.1/s390x -r ADDITIONAL REGCODE
    
        SUSE Manager Server 3.2 s390x
        Activate with: SUSEConnect -p SUSE-Manager-Server/3.2/s390x -r ADDITIONAL REGCODE
    
        SUSE Package Hub 12 SP3 s390x
        Activate with: SUSEConnect -p PackageHub/12.3/s390x
    
        Toolchain Module 12 s390x
        Activate with: SUSEConnect -p sle-module-toolchain/12/s390x
    
        Web and Scripting Module 12 s390x
        Activate with: SUSEConnect -p sle-module-web-scripting/12/s390x
    
    
    REMARKS
    
    (Not available) The module/extension is not enabled on your RMT/SMT
    (Activated)     The module/extension is activated on your system
    
    MORE INFORMATION
    
    You can find more information about available modules here:
    https://www.suse.com/products/server/features/modules.html
    

    You can see that the entry for "SUSE Linux Enterprise Software Development Kit 12 SP3 s390x" is not immediately following by 'Activated' like the entry for "Legacy Module 12 s390x". The command to activate is right under the Extension name.

    Here is the command and output:
    app-wfr23t-830:~ # SUSEConnect -p sle-sdk/12.3/s390x
    Registering system to SUSE Customer Center
    
    Updating system details on https://scc.suse.com ...
    
    Activating sle-sdk 12.3 s390x ...
    -> Adding service to system ...
    -> Installing release package ...
    
    Successfully registered system
    

    After this the 'zypper patch' command ran successfully.

    I hope that this helps someone else.


    Harley
  • malcolmlewismalcolmlewis Knowledge Partner
    x0500hl wrote: »
    Hi Malcolm,

    I had checked that yesterday but neglected to post the output. There were 4 respositories for the SDK, with 2 enabled.

    I resolved the issue so I don't think the output from 'zypper lr -d' will be relevant now.

    Prior to SUSConnect there was a process that you needed to follow to re-register a server. The process included navigating to a certain directory, deleting certain files, etc. I thought of this while driving into the office this morning, so I did some more research.

    The issue I had was that the SDK wasn't 'Activated'. The following is the command and output.
    app-wfr23t-830:~ # SUSEConnect --list-extensions
    AVAILABLE EXTENSIONS AND MODULES
    
        Advanced Systems Management Module 12 s390x
        Activate with: SUSEConnect -p sle-module-adv-systems-management/12/s390x
    
        Containers Module 12 s390x
        Activate with: SUSEConnect -p sle-module-containers/12/s390x
    
        Legacy Module 12 s390x (Activated)
        Deactivate with: SUSEConnect -d -p sle-module-legacy/12/s390x
    
        Public Cloud Module 12 s390x
        Activate with: SUSEConnect -p sle-module-public-cloud/12/s390x
    
        SUSE Linux Enterprise High Availability Extension 12 SP3 s390x
        Activate with: SUSEConnect -p sle-ha/12.3/s390x -r ADDITIONAL REGCODE
    
            SUSE Linux Enterprise High Availability GEO Extension 12 SP3 s390x
            Activate with: SUSEConnect -p sle-ha-geo/12.3/s390x -r ADDITIONAL REGCODE
    
        SUSE Linux Enterprise Server LTSS 12 SP3 s390x
        Activate with: SUSEConnect -p SLES-LTSS/12.3/s390x -r ADDITIONAL REGCODE
    
        SUSE Linux Enterprise Software Development Kit 12 SP3 s390x
        Activate with: SUSEConnect -p sle-sdk/12.3/s390x
    
        SUSE Manager Server 3.0 s390x
        Activate with: SUSEConnect -p SUSE-Manager-Server/3.0/s390x -r ADDITIONAL REGCODE
    
        SUSE Manager Server 3.1 s390x
        Activate with: SUSEConnect -p SUSE-Manager-Server/3.1/s390x -r ADDITIONAL REGCODE
    
        SUSE Manager Server 3.2 s390x
        Activate with: SUSEConnect -p SUSE-Manager-Server/3.2/s390x -r ADDITIONAL REGCODE
    
        SUSE Package Hub 12 SP3 s390x
        Activate with: SUSEConnect -p PackageHub/12.3/s390x
    
        Toolchain Module 12 s390x
        Activate with: SUSEConnect -p sle-module-toolchain/12/s390x
    
        Web and Scripting Module 12 s390x
        Activate with: SUSEConnect -p sle-module-web-scripting/12/s390x
    
    
    REMARKS
    
    (Not available) The module/extension is not enabled on your RMT/SMT
    (Activated)     The module/extension is activated on your system
    
    MORE INFORMATION
    
    You can find more information about available modules here:
    https://www.suse.com/products/server/features/modules.html
    

    You can see that the entry for "SUSE Linux Enterprise Software Development Kit 12 SP3 s390x" is not immediately following by 'Activated' like the entry for "Legacy Module 12 s390x". The command to activate is right under the Extension name.

    Here is the command and output:
    app-wfr23t-830:~ # SUSEConnect -p sle-sdk/12.3/s390x
    Registering system to SUSE Customer Center
    
    Updating system details on https://scc.suse.com ...
    
    Activating sle-sdk 12.3 s390x ...
    -> Adding service to system ...
    -> Installing release package ...
    
    Successfully registered system
    

    After this the 'zypper patch' command ran successfully.

    I hope that this helps someone else.


    Harley
    Hi
    Yes, that's where I was heading to ;) Thanks for the feedback and good to see you back on track :)
Sign In or Register to comment.