Kernel update to 5.5.6-195 reports invalid signature

I tried to install new version of linux-5.5.6-195 on my SLES 15sp1, which current kernel version is linux-4.12.14-195. The kernel package is from https://www.kernel.org/.

The source package is in path /usr/src/linux-5.5.6, and I built new kernel image with below commands.
# cd /usr/src/linux-5.5.6
# make menuconfig
# make
# make modules_install
# make install
# make headers_install
# rm /usr/src/linux
# ln -s /usr/src/linux-5.5.6 /usr/src/linux

# cd /boot
# rm /boot/initrd
# ln -s initrd-5.5.6-195-default initrd
# rm /boot/vmlinuz
# ln -s vmlinuz-5.5.6-195-default vmlinuz

After that, the system could not be up with new kernel due of invalid signature of ramdisk. Could you please advise on how to handle it?

Thanks in advance.

Best Regards
James

Comments

  • malcolmlewismalcolmlewis Knowledge Partner
    yuhuihu wrote: »
    I tried to install new version of linux-5.5.6-195 on my SLES 15sp1, which current kernel version is linux-4.12.14-195. The kernel package is from https://www.kernel.org/.

    The source package is in path /usr/src/linux-5.5.6, and I built new kernel image with below commands.
    # cd /usr/src/linux-5.5.6
    # make menuconfig
    # make
    # make modules_install
    # make install
    # make headers_install
    # rm /usr/src/linux
    # ln -s /usr/src/linux-5.5.6 /usr/src/linux
    
    # cd /boot
    # rm /boot/initrd
    # ln -s initrd-5.5.6-195-default initrd
    # rm /boot/vmlinuz
    # ln -s vmlinuz-5.5.6-195-default vmlinuz
    

    After that, the system could not be up with new kernel due of invalid signature of ramdisk. Could you please advise on how to handle it?

    Thanks in advance.

    Best Regards
    James
    Hi
    Disable secure boot, or why not use the kernel for SLE 15 SP2 Beta (5.3.x), I would suggest using the system config (zcat /proc/config.gz) rather than any menuconfig.

    Joint the public Beta for SLE 15 SP2 and look at asking for kernel features to be back ported to the 5.3.x series if there is something specific you need?
  • How to get the Beta for SLE 15sp2?
  • malcolmlewismalcolmlewis Knowledge Partner
    yuhuihu wrote: »
    How to get the Beta for SLE 15sp2?
    Hi
    Have a read here (Email at very end can be used to get Beta registration codes);
    https://www.suse.com/betaprogram/sle-beta/

    Join the mailing List as well...
    http://lists.suse.com/mailman/listinfo/sle-beta
    http://lists.suse.com/pipermail/sle-beta/2020-February/000835.html
Sign In or Register to comment.