Trying to Setup SMT on SLES 12sp5

skunkboyskunkboy Established Member
Everything seems to be working, except that when I try to register a client I get :

Activating SLES 12.5 x86_64 ...
-> Adding service to system ...
command 'zypper --non-interactive refs SMT-http_mash_emich_edu' failed
Error: zypper returned (4) with 'Problem retrieving the repository index file for service 'SMT-http_mash_emich_edu':
Timeout exceeded when accessing 'http://mash.emich.edu/repo/repoindex.xml?cookies=0&credentials=SMT-http_mash_emich_edu'.
Check if the URI is valid and accessible.
Skipping service 'SMT-http_mash_emich_edu' because of the above error.
Could not refresh the services because of errors.'


How am I supposed to get the server to generate that file?

Thanks,
Matt

Comments

  • Hi Matt

    The repoindex.xml is a "non-existing" file. It is generated upon request for each client as they contact the SMT server.

    The error above could indicate that the client is not able to reach the server for some reason or that the server simply does not respond.
    It may also be that you do not have the required repos mirrored on the SMT server (just a shot in the dark).

    //Andreas
  • skunkboyskunkboy Established Member
    Thank you for that information. Knowing that I poked around some more and discovered for some reason port 80 was not open to other boxes, when into Yast and the smt wizard setup and clicked "Open Port" ( should read ports) and now my issue has gone away!

    Thanks,
    Matt
Sign In or Register to comment.