"g++ 9" Package Dependencies Issue

PeterVargaPeterVarga New or Quiet Member
edited May 10 in SLES Updates

I ran the last update in YaST and I receive this message when I want to install g++ 9:

gcc9-c++-9.2.1+r275327-1.3.7.x86_64 requires libstdc++6-devel-gcc9 = 9.2.1+r275327-1.3.7, but this requirement cannot be provided

not installable providers: libstdc++6-devel-gcc9-9.2.1+r275327-1.3.7.x86_64[Basesystem-Module_15.1-0]

libstdc++6-devel-gcc9-9.2.1+r275327-1.3.7.x86_64[Basesystem_Module_15_SP1_x86_64:SLE-Module-Basesystem15-SP1-Updates]

As possible solution I get this:

downgrade of libstdc++6-devel-gcc9-9.3.1+git1296-1.6.1.x86_64 to libstdc++6-devel-gcc9-9.2.1+r275327-1.3.7.x86_64

When downgrade the mentioned file the next time I open Online Update I get this:

gcc9-c++-9.2.1+r275327-1.3.7.x86_64 requires libstdc++6-devel-gcc9 = 9.2.1+r275327-1.3.7, but this requirement cannot be provided

A possible solution is:

deinstallation of gcc9-c++-9.2.1+r275327-1.3.7.x86_64

What should I do when I need the g++ 9 version? Somehow it looks to me like the chicken or the egg situation.

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi

    On the system in question do you have the Development Tools repository active?

    What is the output from;

    zypper lifecycle

  • PeterVargaPeterVarga New or Quiet Member
    edited May 11


    In YaST under "Configured Software Repositories" there is an entry sle-module-development-tools which is enabled.

    Product end of support

    Codestream: SUSE Linux Enterprise Server 15       2028-07-31

      SUSE Linux Enterprise Server 15 SP1         n/a*

    Module end of support

    Public Cloud Module                  n/a*

    Server Applications Module           n/a*

    Desktop Applications Module          n/a*

    Development Tools Module             n/a*

    Basesystem Module                    n/a*

    Web and Scripting Module             n/a*

    Extension end of support

    SUSE Package Hub 15                  n/a*

    Package end of support if different from product:

    yast2                  Now, installed 4.1.75-3.16.1, update available 4.1.77-3.19.1

    yast2-logs                Now, installed 4.1.75-3.16.1, update available 4.1.77-3.19.1


    Running SUSEconnect -l or trying to select an Extension in YaST I get Error: Registration server returned 'Found' (302)


    OMG, isn't the new forum layout/functionality horrible?

    Who approved this?

    The email notifications have been reset without any notice.

    How to mark several lines as code?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi

    Things are in a bit of flux at the moment with infrastructure moves, I see the same SUSEConnect error 😕 likely be a few more days before all the dots are connected....

    This is probably why your seeing the above error.

  • PeterVargaPeterVarga New or Quiet Member
    edited May 11

    Thank you that you confirmed what I was already thinking. Because I tend to forget I wrote this short linux script so I see when it works again😎

    while :; do SUSEConnect -l | mail -s "SUSEConnect" some-monitoring@email; sleep 3600; done

  • PeterVargaPeterVarga New or Quiet Member

    I could now add the Development Tools Repository and the dependencies issue has gone and also the newest gcc 9.3.1 has been installed.

    This is very nice that SUSE apparently finally tries to keep the gcc versions up-to-date. In SLES 12 it was 4.8!

    Thank you!

Sign In or Register to comment.