mount server disk to SLED - not via smb

environment:
SLED, SYNOLOGY NAS server.
AD on Server, connection via Samba.
reason: After years I got my wife convinced to try SUSE, but she has software that run on window only and need to be on the server (database).
Run on SUSE is no problem via Wine and Playonlinux. But how to mount a serverdisk fix so it works as an internal drive?

Comments

  • malcolmlewismalcolmlewis Knowledge Partner
  • hmmm. This we had tried. I need install NFS server on the NAS server and client on my computer?
    But will there be conflicts with AD tat runs as domain server?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Yes NFS server on the SLE box, AFAIK there should be no issues with integration on AD, maybe permissions and getting the user ID's from AD.

  • It seems a server is like an old car. After 6 weeks of not use it took some time to get the server started. But network drive doesn't get mounted by smb.
    However: Now I have installed NFS server on NAS, got the drives shared. Same on my SLED.
    This line poped up in fstab:
    10.0.25.3:/volume1/drive_x /mnt/x nfs defaults 0 0
    10.0.25.3:/volume1/drive_i /mnt/i nfs defaults 0 0
    10.0.25.3:/volume1/drive_h /mnt/h nfs defaults 0 0
    Questions:
    I think the files are still shared in smb iin Files. But now, I can't save files from Libre on server.
    "The name 1.110 was not provided by any .service files
    I expected I can get the server files fix automount when the system boots?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Have you configured permissions in /etc/exports on the server? Are the users added to the group for the NFS directories you are exporting? Maybe a quick perusal on man exports may clarify....

  • Hi Malcolm, computer have their own life. Short after I posted the issue, it seems the PC got to know. Suddenly it worked - on both - SLES 12.4 and SLED15.1
    I have installed NFS - and that is easy today with GUI and support. (these NAS server are really smart)
    But one point more
    This is how it looks like - similar as a SMB link - and is a SMB link.
    I could read it is possible get the drives (as above) attached as they would be internal drives.
    I can go to /mnt/x/ and login (manually) and access the drive. But I thought I could get a kind of link as if I use SMB.

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Not sure what you mean, as in not visible in Nautilus to the user?
    If you run the command mount it will show how they are connected.

  • 10.0.25.3:/volume1/drive_h on /mnt/h type nfs4 - this looks like they are not mounted via SMB.
    But if I mouse over in Nautilus, it's shown as smb:\10.0.25.3....
    I use Nautilus (of Files) as browser and thought they can be visible as a kind of fix local drive?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    If the /etc/fstab has the user option added, then they will be unmountable (the bar/triangle) by your user, it always lists them twice (available and mounted). Else I normally just bookmark then can be used on the fly to mount via (for me ssh), this should work for NFS AFAIK.

    This seems normal to me, Nautilus knows they are mounted and just assumes it's smb:// (maybe a bug), if you use the mount command from a terminal it will show how they are mounted, where and the mount options in use.

  • 10.0.25.3:/volume1/drive_h on /mnt/h type nfs4
    This is for mount. So they are mounted but I cant access because: "you do not have the necessary permission...."
    I saw in one thread on internet the mount with NFS can be done via Fstab and it looks like a network contact - differemt symbol.
    What do I need to add in Fstab so I get both automount and the access rights from my login?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Yes, in Fstab so mounted at boot.

  • Can you help me how to code that so I get the rights as well included at mount?

  • malcolmlewismalcolmlewis Knowledge Partner

    @Hans-Christoph Can you show the entries in your current fstab file for the drives (10.0.25.3)?

    cat /etc/fstab
    
  •     10.0.25.3:/volume1/drive_x                 /mnt/x                  nfs    user, noauto                  0  0
        10.0.25.3:/volume1/drive_i                 /mnt/i                  nfs    defaults                      0  0
        10.0.25.3:/volume1/drive_h                 /mnt/h                  nfs    defaults                      0  0
    

    The entry for drive_x I made in accordance to another forum, but doesn't work. I don't get access. The passes are right.

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Likely ownership in the /mnt/x directory. If you change ownership of x to root:users

    cd /mnt
    chown root:users x
    
  • thanks, but doesn't work.
    I can see rights changes from root (still owner) to user: access files. But I can't access anyway. for x
    It works vi SMB flawless, but it should work.
    I did the same for i and h and it changed user. I could login and access the drives via /mnt/i etc.
    But when I mount the drive in Nautilus as nfs://10.0.25.3/volume1/drive_i i can see it get mount, but no access at all.

Sign In or Register to comment.