mount server disk to SLED - not via smb

environment:
SLED, SYNOLOGY NAS server.
AD on Server, connection via Samba.
reason: After years I got my wife convinced to try SUSE, but she has software that run on window only and need to be on the server (database).
Run on SUSE is no problem via Wine and Playonlinux. But how to mount a serverdisk fix so it works as an internal drive?

Comments

  • malcolmlewismalcolmlewis Knowledge Partner
  • hmmm. This we had tried. I need install NFS server on the NAS server and client on my computer?
    But will there be conflicts with AD tat runs as domain server?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Yes NFS server on the SLE box, AFAIK there should be no issues with integration on AD, maybe permissions and getting the user ID's from AD.

  • It seems a server is like an old car. After 6 weeks of not use it took some time to get the server started. But network drive doesn't get mounted by smb.
    However: Now I have installed NFS server on NAS, got the drives shared. Same on my SLED.
    This line poped up in fstab:
    10.0.25.3:/volume1/drive_x /mnt/x nfs defaults 0 0
    10.0.25.3:/volume1/drive_i /mnt/i nfs defaults 0 0
    10.0.25.3:/volume1/drive_h /mnt/h nfs defaults 0 0
    Questions:
    I think the files are still shared in smb iin Files. But now, I can't save files from Libre on server.
    "The name 1.110 was not provided by any .service files
    I expected I can get the server files fix automount when the system boots?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Have you configured permissions in /etc/exports on the server? Are the users added to the group for the NFS directories you are exporting? Maybe a quick perusal on man exports may clarify....

  • Hi Malcolm, computer have their own life. Short after I posted the issue, it seems the PC got to know. Suddenly it worked - on both - SLES 12.4 and SLED15.1
    I have installed NFS - and that is easy today with GUI and support. (these NAS server are really smart)
    But one point more
    This is how it looks like - similar as a SMB link - and is a SMB link.
    I could read it is possible get the drives (as above) attached as they would be internal drives.
    I can go to /mnt/x/ and login (manually) and access the drive. But I thought I could get a kind of link as if I use SMB.

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Not sure what you mean, as in not visible in Nautilus to the user?
    If you run the command mount it will show how they are connected.

  • 10.0.25.3:/volume1/drive_h on /mnt/h type nfs4 - this looks like they are not mounted via SMB.
    But if I mouse over in Nautilus, it's shown as smb:\10.0.25.3....
    I use Nautilus (of Files) as browser and thought they can be visible as a kind of fix local drive?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    If the /etc/fstab has the user option added, then they will be unmountable (the bar/triangle) by your user, it always lists them twice (available and mounted). Else I normally just bookmark then can be used on the fly to mount via (for me ssh), this should work for NFS AFAIK.

    This seems normal to me, Nautilus knows they are mounted and just assumes it's smb:// (maybe a bug), if you use the mount command from a terminal it will show how they are mounted, where and the mount options in use.

  • 10.0.25.3:/volume1/drive_h on /mnt/h type nfs4
    This is for mount. So they are mounted but I cant access because: "you do not have the necessary permission...."
    I saw in one thread on internet the mount with NFS can be done via Fstab and it looks like a network contact - differemt symbol.
    What do I need to add in Fstab so I get both automount and the access rights from my login?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Yes, in Fstab so mounted at boot.

  • Can you help me how to code that so I get the rights as well included at mount?

  • malcolmlewismalcolmlewis Knowledge Partner

    @Hans-Christoph Can you show the entries in your current fstab file for the drives (10.0.25.3)?

    cat /etc/fstab
    
  •     10.0.25.3:/volume1/drive_x                 /mnt/x                  nfs    user, noauto                  0  0
        10.0.25.3:/volume1/drive_i                 /mnt/i                  nfs    defaults                      0  0
        10.0.25.3:/volume1/drive_h                 /mnt/h                  nfs    defaults                      0  0
    

    The entry for drive_x I made in accordance to another forum, but doesn't work. I don't get access. The passes are right.

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Likely ownership in the /mnt/x directory. If you change ownership of x to root:users

    cd /mnt
    chown root:users x
    
  • thanks, but doesn't work.
    I can see rights changes from root (still owner) to user: access files. But I can't access anyway. for x
    It works vi SMB flawless, but it should work.
    I did the same for i and h and it changed user. I could login and access the drives via /mnt/i etc.
    But when I mount the drive in Nautilus as nfs://10.0.25.3/volume1/drive_i i can see it get mount, but no access at all.

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Apologies for the delay in responding, so can you post the directory ownership/permissions for x?
    ls -la /mnt/x
    Also the export file contents
    cat /etc/exports

  • edited June 2020

    inuxSLED:/home/hans-christoph # ls -la /mnt/x
    total 0
    drwxrwxr-x+ 1 root users 0 6. Jan 14:59 .
    drwxr-xr-x 1 root root 134 6. Jan 14:59 ..

    it seems there is something wrong with ownership, even I tried to change it
    I drive I can access if I login on the drive:
    linuxSLED:/home/hans-christoph # ls -la /mnt/i
    total 36
    drwxrwxrwx 1 root users 610 31. Mai 21:52 .
    drwxr-xr-x 1 root root 134 6. Jan 14:59 ..
    drwxrwxrwx 1 1709179380 1709179393 632 5. Mai 14:49 Administration
    drwxrwxrwx 1 1709179380 1709179393 324 28. Apr 21:49 _backup BP
    drwxrwxrwx 1 1709179380 1709179393 46 29. Dez 2018 Backup Hans Paul
    drwxrwxrwx 1 1709179380 1709179393 46 29. Apr 2018 Backup Katharina
    drwxrwxrwx 1 1709179380 1709179393 598 29. Apr 2018 Graphic Basis Materials
    drwxrwxrwx 1 1709179380 1709179393 90 9. Sep 2018 HCP innovation
    drwxrwxrwx 1 1709179380 1709179393 456 21. Okt 2019 HCP life science
    drwxrwxrwx 1 1709179380 1709179393 730 3. Jun 09:47 IT
    drwxrwxrwx 1 1709179380 1709179393 400 9. Sep 2018 Marketing
    drwxrwxrwx 1 1026 users 296 16. Mai 12:30 NaturSportCenter Brande
    drwxrwxrwx 1 1709179380 1709179393 530 29. Apr 2018 Old Data (HCPe)
    drwxrwxrwx 1 1709179380 1709179393 58 29. Apr 2018 Partners and CV
    drwxrwxrwx 1 1709179380 1709179393 582 16. Mär 08:41 Privat
    drwxrwxrwx 1 root root 394 6. Jun 10:11 #recycle
    drwxrwxrwx 1 1709179380 1709179393 0 7. Jan 21:09 $RECYCLE.BIN
    drwxrwxrwx 1 1026 users 24110 31. Mai 08:45 Scans
    drwxrwxrwx 1 1026 users 874 29. Apr 2018 Strategy Literatur
    drwxrwxrwx 1 1026 users 6 6. Jan 05:16 System Volume Information
    drwxrwxrwx 1 1026 users 456 9. Sep 2018 Technical Data
    drwxrwxrwx 1 1026 users 30 25. Mai 17:44 Temp
    drwxrwxrwx 1 1026 users 812 5. Mai 15:53 Templates

    cat /etc/exports -- this file is empty.

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    So on the server if you create the /etc/exports file as per the link I posted, hopefully that should get ownership sorted. The user groups/names aren't synced eg user 1026, group users (is good).

  • I found an mistake regarding permissions for user on server. This might be reason. Otherwise, the Synology server do not give any access or even visibility to root directory nor offer a bash. I need to search for it.
    Most important are that H and I drive work.
    Now I handle them via bookmark. Is it possible to automount them, so they are available from boot as drive?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Yes, have a look in Section 34.4 it explains how to add for various scenarios;
    https://documentation.suse.com/sles/15-SP1/html/SLES-all/cha-nfs.html#sec-nfs-configuring-nfs-clients

  • edited June 2020

    So, let's pull it together:
    I use SMB in past. This works smooth with all type of Systems (WIN, MAC, LINUX) via Samba, but is slower.

    I used NFS as book mark. This need setup on both server and client but works well.
    NFS bookmark looks same way.
    When NFS setup and fstab as well you might see it on your SLE as this:

    hans-christoph@LINUXSLES:/mnt> ls
    h  i  x
    hans-christoph@LINUXSLES:/mnt> 
    

    There are below mnt 3 server drives mounted h, i, x
    When you just pull them into Files (Dolphin) it looks like this:

    Your server drives are there directly. The connection is fast as if it was a local drive and mounting is automated.
    As you can see, I have still a net connection via [davs://dav.mailbox.org/] to my personal cloud at www.mailbox.org

    This is better what Windows can. :)

  • This works fine. But why does the drives (h, i, x) stick to the mouse when I klick on them? how can I avoid that?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    You need to hide them with a udev rule... I have three disk showing in Nautilus

    Before:

    lsblk
    NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    sda      8:0    1 119.2G  0 disk 
    ├─sda1   8:1    1   260M  0 part /boot/efi
    ├─sda2   8:2    1    16M  0 part 
    ├─sda3   8:3    1    60G  0 part /run/media/user/opensuse151
    ├─sda4   8:4    1     4G  0 part [SWAP]
    ├─sda5   8:5    1  54.5G  0 part /run/media/user/2E1E90951E9057A3
    └─sda6   8:6    1   519M  0 part 
    sdb      8:16   1 111.8G  0 disk 
    ├─sdb1   8:17   1    60G  0 part /
    └─sdb2   8:18   1    20G  0 part /data
    sdc      8:32   1 931.5G  0 disk 
    └─sdc1   8:33   1 931.5G  0 part /run/media/user/stuff_other
    
    vi /etc/udev/rules.d/99-hide-disks.rules
    
    KERNEL=="sdc1", ENV{UDISKS_IGNORE}="1"
    KERNEL=="sda3", ENV{UDISKS_IGNORE}="1"
    KERNEL=="sda5", ENV{UDISKS_IGNORE}="1"
    
    udevadm trigger
    
    umount /dev/sda3 /dev/sda5 /dev/sdc1
    

    After umount (or on reboot):

Sign In or Register to comment.