NFS Mount keeps throwing error (mount.nfs: access denied by server while mounting )

Hello,
My first post on the Linux community. I am trying to mount nfs share on SLES12, but I keep getting the above error. Our Isilon person confirmed that the Linux server has permissions to nfs location. I noticed the following error in /var/log/warn, so I restarted "rpc-gssd service" and tried remounting but I still get the same access denied by server error. Can anyone suggest what am I doing wrong??

2020-09-21T16:30:16.914440-05:00 server_name rpc.gssd[28559]: ERROR: unable to resolve 10.239.10.151 to hostname: Name or service not known
2020-09-21T16:30:16.914586-05:00 server_name rpc.gssd[28559]: ERROR: failed to read service info

mount xx.xx.xx.xxxx:/ifs/Isilon1/xx/Backup_External /Backup_External

Thank You!

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi and welcome to the Forum :)
    You have to specify the type;

    mkdir -p /Backup_External
    mount -t nfs xxx.xxx.xxx.xxx:/ifs/Isilon1/xx/Backup_External /Backup_External
    
  • edited September 25

    Thank you @malcolmlewis . Sorry for the delay, I didn't get notified after the comment (too much dependency on email and alerts :smile:

    Yes I tried that command:
    server_name:/ # mount -t nfs xx.xxx.xx.xxx:/ifs/Isilon1/Prod/hanaprod/BU /Backup_External
    mount.nfs: access denied by server while mounting xx.xxx.xx.xxx:/ifs/Isilon1/Prod/hanaprod/BU

    At the exact time, I noticed this error in /var/log/messages:
    ____2020-09-25T08:36:15.287194-05:00 server_name rpc.gssd[44303]: ERROR: unable to resolve 10.239.10.151 to hostname: Name or service not known
    2020-09-25T08:36:15.316866-05:00 server_name rpc.gssd[44303]: ERROR: failed to read service info___
    **Checks done so far:
    **The Isilon IP is pingeable from Linux server, made sure that "rpc.gssd" service is in running status.

    Any thoughts what else can be done?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    To me, there is perhaps a username/permissions issue at the server access denied by server you need to check at the nfs server end, likely need to add options, maybe a nfs vers/protocol issue?

  • OK, thank you . I will check with someone from the team. Thanks again for your time.

Sign In or Register to comment.