SLES12SP4 - outdated curl on repos, so i had to install it from source but openssl not detected

This is old machine inside exsi and it still running
But it unable to add repos because of tls issue

#zypper addrepo https://download.opensuse.org/repositories/network:utilities/SLE_11_SP4/network:utilities.repo
Download (curl) error for 'https://download.opensuse.org/repositories/network:utilities/SLE_11_SP4/network:utilities.repo':
Error code: Unrecognized error
Error message: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version

curl is the latest updated but in reality it really old and outdated. So i want to install curl from source but when i run ./configure, i getting

# ./configure --with-ssl
.
.
checking whether to enable Windows native SSL/TLS (Windows native builds only)... no
checking whether to enable Secure Transport... no
checking whether to enable Amiga native SSL/TLS (AmiSSL)... no
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for openssl options with pkg-config... no
checking for HMAC_Update in -lcrypto... no
checking for HMAC_Init_ex in -lcrypto... no
checking OpenSSL linking with -ldl... no
checking OpenSSL linking with -ldl and -lpthread... no
configure: OPT_SSL: yes
configure: OPENSSL_ENABLED:
configure: error: --with-ssl was given but OpenSSL could not be detected

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi and welcome to the Forum :)
    Is libopenssl development installed (maybe too old)? You can always look at grabbing the rpms you need and just create a local plain rpm repository?

  • Hi, not sure how to check libopenssl but for sure openssl is 11 years old

    $ openssl version
    OpenSSL 0.9.8j-fips 07 Jan 2009
    

    I unable to find newer rpms. I tried to install newer openssl but end up it asking me to update perl

    # cd /usr/local/src/openssl-1.1.1h
    # ./config Wl,enablenewdtags prefix=/usr/local/ssl openssldir=/usr/local/ssl
    Operating system: x86_64-whatever-linux2
    Perl v5.10.0 required--this is only v5.8.8, stopped at ./Configure line 12.
    BEGIN failed--compilation aborted at ./Configure line 12.
    Perl v5.10.0 required--this is only v5.8.8, stopped at ./Configure line 12.
    BEGIN failed--compilation aborted at ./Configure line 12.
    This system (linux-x86_64) is not supported. See file INSTALL for details.
    

    Tried perl 5.10.0 and 5.20.0 but not able to proceed because of time-local bug that set by perl make test. Currently I trying using newer perl 5.32 but seem found bugs on the perl make test script

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Heading down the rabbit hole now by the looks :(
    I meant manually download the rpms your wanting from the network:utilities repository, then just install via a local rpm plain repository?

  • ahh.. i get what you mean! well you are right <3

Sign In or Register to comment.