problems with patches and most recent kernel for SLES 12 SP4

Hi,
i want to update my boxes from SLES 12 SP4 to SP5. The relase notes recommend to run a "zypper patch" before the migration. I ran a "zypper up" and wanted to run "zypper patch" afterwards. "Zypper up" seemed to run fine. Now i have kernel 4.12.14-95.54-default. Is this the most recent one for SP4 ?
Because "zypper patch" wants to install some KMP for kernel -default-4.12.14-95.60.1 !?!

ha-idg-2:~ # uname -a
Linux ha-idg-2 4.12.14-95.54-default #1 SMP Thu Jun 4 12:49:28 UTC 2020 (892ef1f) x86_64 x86_64 x86_64 GNU/Linux

ha-idg-2:~ # zypper patch
...
Reading installed packages...
Resolving package dependencies...
3 Problems:
Problem: nothing provides libiov-buf-samba4.so(SAMBA_4.6.16_GIT.186.C6D77B0D5A63.52.1_SUSE_SLE_12_X86_64)(64bit) needed by ctdb-4.6.16+git.186.c6d77b0d5a6-3.52.1.x86_64
Problem: nothing provides kernel-default = 4.12.14-95.57 needed by ocfs2-kmp-default-4.12.14-95.57.1.x86_64
Problem: nothing provides kernel-default = 4.12.14-95.60 needed by ocfs2-kmp-default-4.12.14-95.60.1.x86_64

Problem: nothing provides libiov-buf-samba4.so(SAMBA_4.6.16_GIT.186.C6D77B0D5A63.52.1_SUSE_SLE_12_X86_64)(64bit) needed by ctdb-4.6.16+git.186.c6d77b0d5a6-3.52.1.x86_64
Solution 1: Following actions will be done:
do not install patch:SUSE-SLE-HA-12-SP4-2020-2066-1.noarch
do not install patch:SUSE-SLE-HA-12-SP4-2020-2721-1.noarch
Solution 2: deinstallation of ctdb-4.6.16+git.174.c2fd2e28c84-3.49.1.x86_64
Solution 3: break ctdb-4.6.16+git.186.c6d77b0d5a6-3.52.1.x86_64 by ignoring some of its dependencies
Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c):

The samba problem is not severe, i don't use it.
"Zypper lu" does not offer a more recent kernel. Why KMP for a kernel which isn't available ?
Bernd

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    What is your repository list?

    zypper lr -E

    I see ocfs2-kmp-default coming from SUSE Linux Enterprise High Availability Extension 12 SP4 repository, kernel-default only comes from SUSE Linux Enterprise Server LTSS 12 SP4

  • ha-idg-2:~ # zypper lr -E
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias                                                                                              | Name                                                  | Enabled | GPG Check | Refresh
    ---+----------------------------------------------------------------------------------------------------+-------------------------------------------------------+---------+-----------+--------
     1 | Advanced_Systems_Management_Module_12_x86_64:SLE-Module-Adv-Systems-Management12-Debuginfo-Pool    | SLE-Module-Adv-Systems-Management12-Debuginfo-Pool    | Yes     | (r ) Yes  | No
     2 | Advanced_Systems_Management_Module_12_x86_64:SLE-Module-Adv-Systems-Management12-Debuginfo-Updates | SLE-Module-Adv-Systems-Management12-Debuginfo-Updates | Yes     | (r ) Yes  | Yes
     3 | Advanced_Systems_Management_Module_12_x86_64:SLE-Module-Adv-Systems-Management12-Pool              | SLE-Module-Adv-Systems-Management12-Pool              | Yes     | (r ) Yes  | No
     4 | Advanced_Systems_Management_Module_12_x86_64:SLE-Module-Adv-Systems-Management12-Source-Pool       | SLE-Module-Adv-Systems-Management12-Source-Pool       | Yes     | (r ) Yes  | No
     5 | Advanced_Systems_Management_Module_12_x86_64:SLE-Module-Adv-Systems-Management12-Updates           | SLE-Module-Adv-Systems-Management12-Updates           | Yes     | (r ) Yes  | Yes
     6 | Legacy_Module_12_x86_64:SLE-Module-Legacy12-Debuginfo-Pool                                         | SLE-Module-Legacy12-Debuginfo-Pool                    | Yes     | (r ) Yes  | No
     8 | Legacy_Module_12_x86_64:SLE-Module-Legacy12-Pool                                                   | SLE-Module-Legacy12-Pool                              | Yes     | (r ) Yes  | No
    10 | Legacy_Module_12_x86_64:SLE-Module-Legacy12-Updates                                                | SLE-Module-Legacy12-Updates                           | Yes     | (r ) Yes  | Yes
    13 | SUSE_Linux_Enterprise_High_Availability_Extension_12_SP4_x86_64:SLE-HA12-SP4-Pool                  | SLE-HA12-SP4-Pool                                     | Yes     | (r ) Yes  | No
    15 | SUSE_Linux_Enterprise_High_Availability_Extension_12_SP4_x86_64:SLE-HA12-SP4-Updates               | SLE-HA12-SP4-Updates                                  | Yes     | (r ) Yes  | Yes
    17 | SUSE_Linux_Enterprise_Server_12_SP4_x86_64:SLES12-SP4-Debuginfo-Updates                            | SLES12-SP4-Debuginfo-Updates                          | Yes     | (r ) Yes  | Yes
    18 | SUSE_Linux_Enterprise_Server_12_SP4_x86_64:SLES12-SP4-Pool                                         | SLES12-SP4-Pool                                       | Yes     | (r ) Yes  | No
    19 | SUSE_Linux_Enterprise_Server_12_SP4_x86_64:SLES12-SP4-Source-Pool                                  | SLES12-SP4-Source-Pool                                | Yes     | (r ) Yes  | No
    20 | SUSE_Linux_Enterprise_Server_12_SP4_x86_64:SLES12-SP4-Updates                                      | SLES12-SP4-Updates                                    | Yes     | (r ) Yes  | Yes
    21 | SUSE_Linux_Enterprise_Software_Development_Kit_12_SP4_x86_64:SLE-SDK12-SP4-Debuginfo-Pool          | SLE-SDK12-SP4-Debuginfo-Pool                          | Yes     | (r ) Yes  | No
    22 | SUSE_Linux_Enterprise_Software_Development_Kit_12_SP4_x86_64:SLE-SDK12-SP4-Debuginfo-Updates       | SLE-SDK12-SP4-Debuginfo-Updates                       | Yes     | (r ) Yes  | Yes
    23 | SUSE_Linux_Enterprise_Software_Development_Kit_12_SP4_x86_64:SLE-SDK12-SP4-Pool                    | SLE-SDK12-SP4-Pool                                    | Yes     | (r ) Yes  | No
    24 | SUSE_Linux_Enterprise_Software_Development_Kit_12_SP4_x86_64:SLE-SDK12-SP4-Source-Pool             | SLE-SDK12-SP4-Source-Pool                             | Yes     | (r ) Yes  | No
    25 | SUSE_Linux_Enterprise_Software_Development_Kit_12_SP4_x86_64:SLE-SDK12-SP4-Updates                 | SLE-SDK12-SP4-Updates                                 | Yes     | (r ) Yes  | Yes
    27 | SUSE_Package_Hub_12_SP4_x86_64:SUSE-PackageHub-12-SP4-Pool                                         | SUSE-PackageHub-12-SP4-Pool                           | Yes     | (r ) Yes  | No
    28 | SUSE_Package_Hub_12_SP4_x86_64:SUSE-PackageHub-12-SP4-Standard-Pool                                | SUSE-PackageHub-12-SP4-Standard-Pool                  | Yes     | (r ) Yes  | No
    29 | Toolchain_Module_12_x86_64:SLE-Module-Toolchain12-Debuginfo-Pool                                   | SLE-Module-Toolchain12-Debuginfo-Pool                 | Yes     | (r ) Yes  | No
    30 | Toolchain_Module_12_x86_64:SLE-Module-Toolchain12-Debuginfo-Updates                                | SLE-Module-Toolchain12-Debuginfo-Updates              | Yes     | (r ) Yes  | Yes
    31 | Toolchain_Module_12_x86_64:SLE-Module-Toolchain12-Pool                                             | SLE-Module-Toolchain12-Pool                           | Yes     | (r ) Yes  | No
    32 | Toolchain_Module_12_x86_64:SLE-Module-Toolchain12-Updates                                          | SLE-Module-Toolchain12-Updates                        | Yes     | (r ) Yes  | Yes
    35 | Web_and_Scripting_Module_12_x86_64:SLE-Module-Web-Scripting12-Pool                                 | SLE-Module-Web-Scripting12-Pool                       | Yes     | (r ) Yes  | No
    37 | Web_and_Scripting_Module_12_x86_64:SLE-Module-Web-Scripting12-Updates                              | SLE-Module-Web-Scripting12-Updates                    | Yes     | (r ) Yes  | Yes
    
  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    The only solution I see (since no access to LTSS repository) is to skip the patches and let the system stay with the current kernel modules, so select 'Solution 1'. I think it will be fine as it will pick up the later kernel and kmps when upgraded to SP5.

Sign In or Register to comment.