Error generating bootstrap repo

We are getting permanent errors "Error generating bootstrap repo for: ..." for any product on SUMA 4.1.2. Usually it boils down to "ERROR: package 'python-asn1crypto' not found ERROR: package 'python-packaging' not found". Which non-standard repo contains these required packages?

Comments

  • malcolmlewismalcolmlewis Knowledge Partner
    edited October 20

    Hi
    Those should be python[2,3]-asn1crypto and python[2,3]-packaging depending on the repository bootstrap your creating. If the likes of SLE 12 releases, then they would be python-[name].

  • The errors are identical for every single bootstrap repo (SLES11/12/15), e.g.:
    "Error generating bootstrap repo for: SLE-12-SP3-x86_64 - ERROR: package 'python-asn1crypto' not found ERROR: package 'python-packaging' not found"
    It's definitely missing repos; I have added "SUSE Linux Enterprise Software Development Kit 12 SP3 x86_64" to what happens.
    Thank you.

  • malcolmlewismalcolmlewis Knowledge Partner
    edited October 20

    @oackerma I suspect it's a bug, in SLE 15 it should be python3... Are you in a position to open a Support Request? For SLE 12 SP3 it would be LTSS, but if you log into the SUSE Customer Center and under My Tools -> packages you can search the release, arch and seach for the package, I see 10 hits for python-asn1crypto ;)

  • You are right, the errors should complain about "python3-packaging", etc, but these are already installed. I will open a SR.
    Thank you.

Sign In or Register to comment.