vsftpd wont install properly on my system.

Hello Suse Community!
So I need to set up an ftp server and the ftp server wont load up in YaST. It says it needs the vsftpd files to be installed which I definitely need for the vsftpd.conf file aswell. I already have the yast ftp server module installed btw. Also tried sudo zypper install vsftpd and doesnt seem to get any files? It seems like it wants to load and install but then shutdown with no error. I have tried to see if its running and its not, also no vsftpd .conf in sight in the /etc directory so everytime I try to start with systemctl start, enable, it doesnt work of course cause theres no vsftpd files. I also tried service command and still not working because no vsftpd files. Anyways I need help! Just wondering what to do? Off subject, I set up an apache server which is awesome and made my own index.html file with my class labs and linux is super fun! Anyways, I keep searching the net for answers but nothing I can find. Maybe uninstall ftp server packages from yast and reinstall? Any help would be great!


  • malcolmlewismalcolmlewis Knowledge Partner
    edited November 21

    @mikearizpe4224@gmail.com Hi, likely you have not added the Server Applications Module 15 assuming your running SLES 15? Else if you do, try a forced re-install with zypper in -f vsftpd

    You can use the SUSE Customer Center to search for packages in the My Tools section ;)

  • Thank You malcomlewis for responding! I have the Server Applications Module 15.2 version installed, and I tried zypper in -f vsftpd command but still not working. Any more advice would be greatly appreciated!

  • malcolmlewismalcolmlewis Knowledge Partner

    Can you add some verbosity to the output (and the extras)?

    zypper -vvv in -f yast2-ftp-server vsftpd system-user-ftp

    I see the following;

    zypper in yast2-ftp-server vsftpd
    The following 3 NEW packages are going to be installed:
      system-user-ftp vsftpd yast2-ftp-server
    3 new packages to install.
    Overall download size: 214.6 KiB. Already cached: 0 B. After the operation, additional 507.8 KiB will be used.
    Continue? [y/n/v/...? shows all options] (y): 
    Retrieving package yast2-ftp-server-4.2.5-1.2.noarch
    (2/3) Installing: system-user-ftp-20170617-4.155.noarch
    Additional rpm output:
    useradd -r -s /sbin/nologin -c "FTP Account" -U -d /srv/ftp ftp
    groupadd -r ftp
    (3/3) Installing: vsftpd-3.0.3-7.7.9.x86_64
    ls -la /etc/vsftpd.conf
    -rw------- 1 root root 7754 Jul 26  2018 /etc/vsftpd.conf
  • malcomlewis thanks again, but its still not working. it says no provider of system-user-ftp found, same with vsftpd. It says for both, not found in package names. The reinstall did complete but with errors. This is so weird. When I do a ps -ef | grep vsftpd, it shows the process but its not running. It shouldnt be this hard right? anyways more help would be cool maybe I dont have the right modules? I can do filezilla but that defeats the purpose. Thanks again!

  • malcolmlewismalcolmlewis Knowledge Partner

    @mikearizpe4224@gmail.com Hi, well it should be there;

    Information for package system-user-ftp:
    Repository     : SLE-Module-Server-Applications15-SP2-Pool
    Name           : system-user-ftp
    Version        : 20170617-4.155
    Arch           : noarch
    Vendor         : SUSE LLC <https://www.suse.com/>
    Support Level  : Level 3
    Installed Size : 67 B
    Installed      : Yes (automatically)
    Status         : up-to-date
    Source package : system-users-20170617-4.155.src
    Summary        : System user and group ftp

    Are you sure the repositories are active?

    zypper lr -E
  • malcolmlewis you da man! :) I didnt have the SLE-Module-Server enabled. It installed vsftpd now. I still dont see the vsftpd.conf file in /etc, but its a big step closer. So happy! Im a noob! I did get a samba server going a few minutes ago before this vsftpd lab so thats cool. Im gonna use yast to set up the ftp server. Malcolmlewis THANK YOU SO MUCH!

  • Malcolmlewis your a linux god! vstpd.conf showed up and I got vsftpd installed with yast just to make it easier. Thanks Dude! Your not just a knowledge partner but also a Linux God!

Sign In or Register to comment.