Dumb question

The cheap package for SLED on the store says that it only gets updates through the Customer Center. Does that mean that I don't get repository access??

Also, half of the desktop stuff is in the workstation repository. Do you have to buy a license for that as well to effectively use my desktop?

Finally, what the heck is the high performance package? I've got a relatively high end laptop, but no idea what that package is intended for. I guess if it costs an extra pile of money, I don't need it.

Oh, wait just thought of two more questions. If I'm doing fine with 15.1 / OpenSUSE, is there any point to switching to 15.2? Usually, upgrading just creates more bugs. I need to actually be productive, not spend a month and a half on setup.

For that matter, is there any compelling reason to BUY another 15.1 year, or should I just stick with me 15.1 / OpenSUSE install? I mean, if there's no development being done on 15.1 anymore, then there's probably not much point in buying another 1 year license, right?

Thanks so much for any insight!

P.S. WHY in the HELL can't I find a way to contact the sales department with these questions?? (Of course, I'm not sure if I want to ask a salesman if I need to buy his/her product. ;) )

«13

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    @jtlong@gmx.com Hi and welcome to the Forum :)
    Once the system is registered on SCC you will get repository access as well as any optional ones you subscribe to.

    The workstation extension module (along with the likes of SUSE Package Hub) is default/free in SLED, optional for SLES, you will get everything you need for either wayland or x11 depending on your choice at install.

    openSUSE Leap 15.1 is not SLED, two different products, two different entities... If you do mean SLED 15.1, it will go EOL from a maintenance point of view, but the upgrade/migration path is painless these days and well tested. I normally wait a few months for things to settle in the repositories (esp. Package Hub) to ensure these packages are built etc.

    If you want to talk to sales, then contact a local partner? https://www.suse.com/partners/find-partner/ or use the Request a call option https://www.suse.com/support/

  • Yes, thank you Malcolm. I previously had a demo version for SLED 15.1, which I've now added the OpenSUSE repositories to, because I didn't mess with it mush, and my repository access shut off before I got done even setting up the desktop. SO, NOW I'm looking at installing tools I actually want to use. So NOW, the question is first off, is there ANY sense in buying a one year access to the SLED 15.1 repositorys if (IF?) it's not being actively developed any more anyway? Second of all. is it worth the effort to try to upgrade on my EliteBook 8560w to 15.2? I've had real bad experiances in the past from upgrading and having an nVidea driver or some such thing just stop working entirely.. which cascades and breaks half the utilities in the OS. ..or at least it used to. My gut instinct is that 'if it ain't broke, don't fix it', but if I'm going to get some benefit from accessing newer better utilities or functionality in 15.2, then I could see that being worth the effort (as long as it doesn't much up half the system).
    Thanks for your insight, much appreciated!

  • malcolmlewismalcolmlewis Knowledge Partner

    @jtlong@gmx.com the registration gives access to any of the releases, not tied to any release, so you can run with SP1 and upgrade to SP2 when general support ends (31 Jan, 2021) https://www.suse.com/lifecycle/ what tools are not available by SUSE Package Hub?

    So is this laptop an optimus one or just nvidia?

  • That's good to know! I'll wait to upgrade till about April 31st then (is 3 months long enough to see all of the bugs get ironed out, do you think?), and cross my fingers.
    I'm not sure what all packages are missing, but for instance in 15.1 I'm stuck with Lollypop 1.07, and for the life of me I can't see a way to create a playlist with certain songs, it wants to add them in bulk by artist. The current version for 15.2 if v3.2 or some such thing, and irritatingly, Leap is the only current version at v4.1 or something. SO.. I know that I would need to run Leap to get the current version, but there's no way on God's Green Earth I'm jumping on to a bleeding edge platform. I just hope that developers haven't started developing to the Leap backbone, that means that a stable OS with current patches are even further out than they used to be. That. Would suck.
    I'm not at all sure what an Optimus One is. It's certainly not an LG phone (which is what I found when I searched it). It is for all intents and purposes a 'military grade' laptop. It has the hardware encryption, fingerprint reader, and it's relatively durable. It has the nVidia graphics card.. well, it has all of the bells and whistles, except the WLAN card, which is still sitting in my old laptop, because I just never use it. The only upgrade I've done is to a really slick Samsung SSD drive. The laptop is getting old, but so far still a powerhouse. :)

  • malcolmlewismalcolmlewis Knowledge Partner

    @jtlong@gmx.com Hi, can you post the output from;

    /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    

    That will show graphics present ;)

    For Lollypop the 1.3.0 version is in SP2;

    Version
    1.3.0-bp152.1.1
    License
    GPL-3.0-or-later
    Architecture
    noarch
    Repository
    SUSE-PackageHub-15-SP2-Backports-Pool
    

    I'm sure SP3 will have at least 1.4.5 since that's what in Factory at present on the openSUSE side.

  • Sure thing:

    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108GLM [Quadro 1000M] [10de:0dfa] (rev a1)
        Subsystem: Hewlett-Packard Company Device [103c:1631]
        Kernel driver in use: nvidia
        Kernel modules: nvidia_drm, nvidia
    
  • malcolmlewismalcolmlewis Knowledge Partner

    @jtlong@gmx.com Ahh ok, pure Nvidia, should be good for a bit long, the G04 supports your card (390.138) as long as not needing a later cuda version...

  • The Lollypop thing was just an example. Basically, I want to be able to get mature software packages without risking having to move to an unstable platform. Lollypop 1.07 or whatever it is, is obviously not mature, since it can't yet create a play list properly.
    What's good for file management these days? I don't mind using something a la Midnight Commander to move stuff between two different view ports, but I'm really missing my tree view in my Linux file managers. Ideally, I'd like to have at least one tree style view, but if it has two view ports like an FTP utility, that's fine too. I'll Commend Mautilus as a full featured file explorer, but it's not so hot for rearranging mass groups of files. ;)

  • malcolmlewismalcolmlewis Knowledge Partner

    @jtlong@gmx.com well the good thing about SUSE Package Hub is if the application exists in openSUSE Tumbleweed, you can ask the maintainer to push to Backports and maintain, if so it will appear in SLE ;)

  • Gotta be honest Malcolm, I wouldn't know a G04 from a cuda. I suppose that's got something to do with the driver integration per OS / Linux core version?

  • malcolmlewismalcolmlewis Knowledge Partner

    @jtlong@gmx.com that's the version naming in the repositories used, but yes the G04 one works up to the 5.6 kernel, after that you will be on your own, normally patches to create a custom run file and install manually... I expect that to be a number of years ;) If your not using the cuda cores for rendering (eg blender) and applications that can take advantage of the 96 cores available (probably works in the background), shouldn't be an issue.
    Ref: https://www.gpuzoo.com/GPU-NVIDIA/Quadro_1000M.html

  • Well that mostly makes sense. Whatsa cuda core, and how do I avoid it / them? You know, I recall setting up Blender junk back in 10.3 and 11.2.. but I don't think I've done any of that stuff on this machine. Like I said, I left it sitting long enough that my trial just expired without me doing much with it. I guess the proper question would be, what 3d junk should I tag 'never install' and what should I install.. to get the best results?
    Did you see my question about file managers? I could use some sage advise. You seem pretty sage. :)

  • I see on your linked page that the cuda cores are some sort of core processor on the graphics card. Gotta admit though, I don't really know specifically what that means. From what you said, I could guess that those cores specifically render 3d graphics.

  • malcolmlewismalcolmlewis Knowledge Partner

    @jtlong@gmx.com Hi, for file managers, if your happy with command line, then can't really beat midnight-commander (aka mc)? Krusader (QT based), maybe XFE are both worth a look if wanting a GUI?
    1. https://build.opensuse.org/package/show/X11:FOX/xfe
    2. http://roland65.free.fr/xfe/index.php?page=home
    Depends on what your use case is for anything needing cuda cores, mainly rendering, but games would be the main use, I wouldn't worry about it, in your case if applications can use it all well and good, if not will just be stuck with using the CPU...

  • I recall in 10.3 the first good use for the blender stuff was the rotating desktop cube. That was a neat novelty. I may very well end up doing some 3d map rendering for tabletop RPG games. I may end up installing some games some day, but i'm not worried about it now. I can't think of any other reason to install any serious 3d applications at the moment.. BUT, if you can point me to the correct method to set it up with this / this series of Nvidia card, I promise to SAFELY tuck that link away for future reference. :)
    Yeah, I called Nautilus full featured before I realized that the current version can't sort by creation date / time. Can't even list the column. Lame. I'll check out XFE. Basically, I need to be able to sort masses of files in various ways, then move them around in groups from a subfolder in one location to a subfolder in another location, without browsing up and down the directory tree each and every time. I've got a.. an insane.. amount of content cataloged, and I create content as well.
    MC was state of the art when Unix was young, It was slicker than snot in a command line world. I was hoping that there was something a bit more.. modern. ;) Most modern FTP clients are designed to look like FireFTP, two view panes, with a tree and file listing on both sides. Something like that would be perfect.. if it was full featured as far as file sorting goes. I recall some modern offshoots of MC that were a bit clunky about (not) showing you the directory tree, not real interested in those.. but anything with two view panels would be better than browsing up and down folders repeatedly in the Nautilus top and side bar.
    Actually.. I JUST found where the official XFCE repository is listed, on a subpage of the official repository page. I never added that one because it wasn't listed on the main page or the additional page. HOWEVER, that X11:FOX repository is NOT listed on either page officially, that I can find! That makes me a bit trigger shy, frankly. Am I going to risk mucking anything up if I add that repository? I don't ever want to do another spiderweb mess of pulling a repository and having to force compatibility that breaks later down the road. Why the heck isn't XFE in one of the main repositories??
    NOW that I think about it.. Shouldn't I do some sort of version break, and force everything to flop over from the SLE 15.1 repositories to the OPenSUSE 15.1 repositories? Currently, I just added all of the official OpenSUSE repositories, because 90% of the stuff in the SLE repositories won't add without some package or other locked up in the SLE Desktop or WS repositories. I still have the SLE repos listed, and the Desktop / WS repos are simply disabled from updating (so they don't annoy me telling me they can't update). ..OR should I leave well enough alone until I update in April.
    I'm starting to think that I should probably bite the bullet and just do a fresh install.
    The only unofficial repository left that I trust is Packman. God bless Packman! :D ..unfortunately, he doesn't appear to have XFE listed either.. or at least if he does, it's not backported to the repository I'm using. :/
    Wow that was long, sorry about that! Too many questions, not enough answers, lol!

  • malcolmlewismalcolmlewis Knowledge Partner

    @jtlong@gmx.com Hi, the SLE 15 SP1 repository...

    zypper in https://download.opensuse.org/repositories/X11:/FOX/SLE_15_SP1/x86_64/xfe-1.43.2-2.1.x86_64.rpm https://download.opensuse.org/repositories/X11:/FOX/SLE_15_SP1/x86_64/xfe-themes-1.43.2-2.1.x86_64.rpm
    

    Or add the repository;

    zypper ar -f -g -n "repo-X11:FOX" https://download.opensuse.org/repositories/X11:/FOX/SLE_15_SP1/ repo-X11:FOX
    zypper ref
    zypper in xfe xfe-themes
    

    Seems to me Leap 15.2 would be a better choice for you? Else if wanting to stay with SLE, then look at what needs to be added to SUSE Package Hub...

  • Aw, I usually just add the repos in Yast.. er, Yast2. I forget what caused the glitch, but at one point I ended up with a bunch of duplicate repos.. I think it was from adding those one click repo links that SUSE used to have, then adding stuff manually from zyppering different database and 3d junk and stuff in to place. Anyway, these days I try to add everything in the GUI, just to keep an eye out for duplicates, unless I NEED to use a zypper feature specifically. I also like naming the repos, so I can sort them in a coherent manner as well. :) I'll go ahead and use your zypper commands and check it in the GUI after, though.

    Yeah, it just occurred to me that I may have mucked up my direct upgrade path to 15.2 when I added the OpenSUSE repos. I guess I'll just leave it alone for now until something gets weird, then I'll force a switch to OpenSUSE repos if I have to.
    I guess I'll figure out if I mucked up the upgrade path to 15.2 when I try to upgrade it in April or whatever. ;)

  • Yeah.. I'm going to have to pick your brain again. Sorry. The official XFCE instructions here:
    https://en.opensuse.org/Xfce_repositories
    Says to add the XFCE repo, then the XFCE:rat repo, then prioritize one or both of them as 70? It's not real clear about that part. I figured I would add the X11:fox repo after that..
    NOW it occurs to me that I haven't been prioritizing any of the repos I added. SO... This is my current mess:

    Ok.. that copy and paste made the post 7,888 characters too long..
    ...
    This thing says it's an interactive paste bin, let me know if it works:
    https://cryptpad.fr/pad/#/2/pad/edit/GR20ppUwdKkdupMvwkF0QVQn/

    Yeah, I know. It's crazy. If I recall, I got the pkgs.org repos as a favor when I couldn't connect to Opensuse for some reason. I recently added the Brave browser repo. Most of the rest has all been there for months and months. Not at all sure If I need to change any of those priorities first, and I'm not at all sure what order or how I should add those three XCFE / XFE repos.
    I've mucked up my whole desk doing repos wrong before, I don't want to do that again.
    Help? :/

  • Ok, I had to use the link twice to open the same pad I used.
    I had to click 'Outline' to get rid of the stupid 'Content' column.
    I had to click the 'Full Width' button to expand the document area in to a 'portrait' mode.
    THEN all of the text columns line up. :)

  • malcolmlewismalcolmlewis Knowledge Partner

    @jtlong@gmx.com Hi, the XFCE repos are for a desktop environment? You don't need XFCE to install the XFE application?

    I've never prioritized, that should not be needed anymore as vendor 'stickiness' is in place, once you switch it remains with that repository if active, the only way to switch is to ask YaST to do it, or via zypper and --allow-vendor-change.

  • Oh, I was just adding the XFCE repos because I just ran across them. They are officially ofiicial repos, posted on the OpenSUSE website, but I missed them the first time around, because they're listed on a different page. What I got confused about is the way it was worded I wasn't sure if I should add one or both as priority 70, or what the heck priority to give to the XFE repository.
    So.. if I understand you correctly, I should NOT add them as priority 70, and it doesn't make one hill of beans difference if I add them of XFE first. Is that right?
    I did an 'allow vendor change' in Yast software management last week when I had to add a package that was depending on an OpenSUSE library. Didn't seem to do much, though. I got a successful install, but it didn't seem to replace 762 different SLE packages with OpenSUSE ones. I'm not at all sure if 'Vendor Change'. Still means what it used to. IMHO, identical vendor specific packages are redundant anyway. If two packages offer the precise same service, what the heck difference does it make who zipped it up? One more example of 'if it ain't broke, don't fix it'. ;)

  • malcolmlewismalcolmlewis Knowledge Partner

    @jtlong@gmx.com Hi, the priority number is like a count-down 1 is the highest ;) Yes it will only affect that package or packages installed from repository x and keep that way unless there is user interaction for an issue.

  • Thanks so much for all of your help! XFE is a bit Win95-esque.. but at least it has a tree! It took it's fair share to get the associations working (and some other tweaking). I don't know WHY Linux can't get some core file association thing going to hang everything on. I'm actually having fun playing with the tree with two panels to move files. I think 2 trees would be more efficient, but it works well enough for what I needed. :)

  • edited December 2020

    I completely crashed the install. I'm currently working in a snapshot. Somebody else is trying to help me on the other forum, but I think I could really use your advice, since my system was/is SLED 15.1.
    At this point, I'm pretty sure I muffed it by trying to install G05 for OpenSUSE 15.1 which uninstalled the G04 for SLED 15.1. I tried to reinstall G04, but it just occurred to me that that would be the G04 for OpenSUSE 15.1, not for SLED 15.1.

    ..If my system is indeed still SLED 15.1. I dunno how to determine that.

  • malcolmlewismalcolmlewis Knowledge Partner

    @jtlong@gmx.com Hi cat /etc/os-release?

    Just add the repo manually?

    zypper lr -f -g -n "SLE-15-SP1-Desktop-NVIDIA-Driver"  https://download.nvidia.com/suse/sle15sp1 SLE-15-SP1-Desktop-NVIDIA-Driver
    
  • How do I do it that from a snapshot image? I tried to make a package change, and it told me it was read only. Pretty sure it won't let me add a repo either, but I'll try it if you think it should work.
    You know what else?? My mind is blown that that repo isn't in there. I should have added that, step 1, right after system install. I am honestly shocked that it's missing.

  • I tried the zypper command just to see what kind of error it would spit at me.
    Surpsisingly, it said
    linux-gx1p:/home/james # zypper lr -f -g -n "SLE-15-SP1-Desktop-NVIDIA-Driver" https://download.nvidia.com/suse/sle15sp1 SLE-15-SP1-Desktop-NVIDIA-Driver
    The flag f is not known.

    Sure enough, after typing help, I don't see -f in there. I don't see -g either, but I'll read the whole thing to try to be sure.

  • Verified, I don't see either -f or -g in there. I DID discover that some clever person put 'if' in there as an abbreviation for 'info', so you could type something like
    zypper patches if "nVidia G05"
    ..just to confuse the crap out of somebody. :D

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    @jtlong@gmx.com Hi, my bad, ar (add repo) not lr (list repo)

    zypper ar -f -g -n "SLE-15-SP1-Desktop-NVIDIA-Driver" https://download.nvidia.com/suse/sle15sp1 SLE-15-SP1-Desktop-NVIDIA-Driver
    
  • linux-gx1p:/home/james # zypper ar -f -g -n "SLE-15-SP1-Desktop-NVIDIA-Driver" https://download.nvidia.com/suse/sle15sp1 SLE-15-SP1-Desktop-NVIDIA-Driver
    Adding repository 'SLE-15-SP1-Desktop-NVIDIA-Driver' .......................................................................[error]
    Unknown problem when adding repository:
    Can't open file '/etc/zypp/repos.d/SLE-15-SP1-Desktop-NVIDIA-Driver.repo' for writing.
    linux-gx1p:/home/james # 
    
Sign In or Register to comment.