online update

I did an online update using zypper command "zypper in -t patch SUSE-SLE-SAP-12-SP2-2019-2984=1" and the results:
Refreshing service 'SUSE_Linux_Enterprise_Server_12_SP2_x86_64'.
Loading repository data...
Reading installed packages...
'SUSE-SLE-SAP-12-SP2-2019-2984=1' not found in package names. Trying capabilities.
No provider of 'SUSE-SLE-SAP-12-SP2-2019-2984=1' found.
Resolving package dependencies...

Nothing to do.

Please help

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    @Paulus Hi and welcome to the Forum :)
    Drop the =1 bit....

    zypper in -t patch SUSE-SLE-SAP-12-SP2-2019-2984
    
  • hi @malcolmlewis ,
    Thank you for your response.
    I've tried to remove =1 but the result is still the same.

    # zypper in -t patch SUSE-SLE-SAP-12-SP2-2018-814
    Refreshing service 'SUSE_Linux_Enterprise_Server_12_SP2_x86_64'.
    Loading repository data...
    Reading installed packages...
    'SUSE-SLE-SAP-12-SP2-2018-814' not found in package names. Trying capabilities.
    No provider of 'SUSE-SLE-SAP-12-SP2-2018-814' found.
    Resolving package dependencies...

    Nothing to do.

  • I check the list of patches in the repository, the list of available patches is only 2018 and below.
    Tried to refresh the repository but the patch list didn't change.

  • malcolmlewismalcolmlewis Knowledge Partner

    @Paulus Hi, it's in the SUSE Linux Enterprise Server for SAP Applications 12 SP2 repository, you have an active LTSS subscription?

  • Hi @malcolmlewis ,
    I just activated an unlimited license and registered 1 server with the registration code provided by the vendor. Some patches can be installed but some cannot be installed.
    I don't understand what other license to have.
    How to activate LTSS subscription?

    Thank you.

  • malcolmlewismalcolmlewis Knowledge Partner
    edited January 29

    @Paulus Hi, it's a separate subscription https://www.suse.com/products/long-term-service-pack-support/

    If you login to the vendors account at https://scc.suse.com on the My Tools section at the left under 'Patches' I see the following;

    If you scroll down further there is an option to download manually, is this possible?

  • I have tried and the results:
    1 result found
    Severity Patch name Product(s)
    Arch Release date
    importan Security update for the Linux Kernel SUSE Linux Enterprise Server for SAP Applications 12 SP2
    x86_64 May 8 2018

    So I can't do online updates for some of these patches?

  • malcolmlewismalcolmlewis Knowledge Partner

    @Paulus Hi, so if you check the 'Subscription' section, do you see and LTSS line item, if so this is the registration code to use with the system?

  • Hi @malcolmlewis ,
    Thank you for your information.
    We don't have an LTSS subscription. Does that mean we can't continue updating the patches.(?)

  • malcolmlewismalcolmlewis Knowledge Partner

    @Paulus Hi, AFAIK your correct. But your better off to confirm the issue by creating a Support Request or talking to the Vendors SUSE Partner/Sales.

Sign In or Register to comment.