Can't Install Hypervisor ... xen

Running SLED 15.1, trying to install Xen hypervisor, with yast results in error "Failed to install required packages".
Help please?
xen pattern is found, but can't install: 'No provider of 'xen' found' in spite of search success and apparent repo enabled.
# zypper se xen
Refreshing service 'Basesystem_Module_15_SP1_x86_64'. Refreshing service 'Desktop_Applications_Module_15_SP1_x86_64'. Refreshing service 'Python_2_Module_15_SP1_x86_64'. Refreshing service 'SUSE_Linux_Enterprise_Desktop_15_SP1_x86_64'. Refreshing service 'SUSE_Linux_Enterprise_Workstation_Extension_15_SP1_x86_64'. Refreshing service 'SUSE_Package_Hub_15_SP1_x86_64'. Loading repository data... Reading installed packages...

S | Name | Summary | Type ---+-----------------------+----------------------------------------------------------+----------- | libptexenc1 | Libraries of Kanji code convert library for pTeX | package | librfxencode0 | Library for the JPEG2000 codec for RDP | package | texlive-bxenclose | Enclose the document body with some pieces of code | package | texlive-ptexenc-devel | Libraries of Kanji code convert library for pTeX | package | xen | Xen Virtualization: Hypervisor (aka VMM aka Microkernel) | srcpackage i+ | xen-libs | Xen Virtualization: Libraries | package | xen-tools-domU | Xen Virtualization: Control tools for domain U | package | xengine | Reciprocating engine for X | package

then

# zypper lr 5
Alias : Basesystem_Module_15_SP1_x86_64:SLE-Module-Basesystem15-SP1-Updates Name : SLE-Module-Basesystem15-SP1-Updates URI : https://updates.suse.com/SUSE/Updates/SLE-Module-Basesystem/15-SP1/x86_64/update?9cQHTA3Mj0a2p2nM-hw6QJ7TosWe3cjqYGlFwad-Z-ZJiNGAofneqnxYiP7FvHHrybV2FZB8_Oi3ffQi0dctYwCl2gMsze1YSlWBnMY7zZ4C5tUG5rQT0m0wQWLRpYyEV-vYoHXbVAEevK6C59yd4XAtgXb5qA Enabled : Yes GPG Check : (r ) Yes Priority : 99 (default priority) Autorefresh : On Keep Packages : Off Type : rpm-md GPG Key URI : Path Prefix : Parent Service : Basesystem_Module_15_SP1_x86_64 Keywords : --- Repo Info Path : /etc/zypp/repos.d/Basesystem_Module_15_SP1_x86_64:SLE-Module-Basesystem15-SP1-Updates.repo MD Cache Path : /var/cache/zypp/raw/Basesystem_Module_15_SP1_x86_64:SLE-Module-Basesystem15-SP1-Updates

and
# zypper in xen
Refreshing service 'Basesystem_Module_15_SP1_x86_64'. Refreshing service 'Desktop_Applications_Module_15_SP1_x86_64'. Refreshing service 'Python_2_Module_15_SP1_x86_64'. Refreshing service 'SUSE_Linux_Enterprise_Desktop_15_SP1_x86_64'. Refreshing service 'SUSE_Linux_Enterprise_Workstation_Extension_15_SP1_x86_64'. Refreshing service 'SUSE_Package_Hub_15_SP1_x86_64'.`` Loading repository data... Reading installed packages... 'xen' not found in package names. Trying capabilities. No provider of 'xen' found. Resolving package dependencies...

Nothing to do.

Comments

  • Apologies for the formatting. Markdown seems broken to me, possibly my ignorance of some particular point.

  • Ugh that seems worse. At least it is short-ish.

  • malcolmlewismalcolmlewis Knowledge Partner

    @adam.ratcliff@softelsystems.com.au Hi and welcome to the Forum :)
    For a box it's three of these "`" at start/finish for inline it's just one start/finish.
    Looks like a missing repository;

    SUSEConnect -p sle-module-server-applications/15.1/x86_64
    

    If you log into SCC https://scc.suse.com and under my tools -> packages you can search here and it will show which module is required for a package...

  • @malcolmlewis
    Thanks for the welcome and for the markdown tips. I wondered for a few minutes whether SLED vs SLES was the problem and could not find any info about that.
    Running VMs locally on a workstation vs server is perhaps an advanced feature but not entirely uncommon so I dismissed that thought until your comment. Seems like the right solution to me but:

    2 Problems:
    Problem: product:sle-module-server-applications-15.1-0.x86_64 conflicts with product(SLED) >= 15.1 provided by product:SLED-15.1-0.x86_64
    Problem: product:sle-module-server-applications-15.1-0.x86_64 requires product(sle-module-server-applications) = 15.1-0, but this requirement cannot be provided
    
    Problem: product:sle-module-server-applications-15.1-0.x86_64 conflicts with product(SLED) >= 15.1 provided by product:SLED-15.1-0.x86_64
     Solution 1: do not install product:sle-module-server-applications-15.1-0.x86_64
    
    Choose the above solution using '1' or skip, retry or cancel [1/s/r/c/d/?] (c): c'
    

    Checking SCC apparently confirms SLED 15.1 can't be a hypervisor like SLES 15.1

  • malcolmlewismalcolmlewis Knowledge Partner

    @adam.ratcliff@softelsystems.com.au Hi, my bad, thought you were on SLES we have separate areas for products, happens when posted here.... :(

  • @malcolmlewis
    Thank you again for your help,
    a) The right solution seems to be to change SLED to SLES
    b) The right place to post this might have been here:
    https://forums.suse.com/categories/sled-applications

  • malcolmlewismalcolmlewis Knowledge Partner

    @adam.ratcliff@softelsystems.com.au Hi, yes to both :) For SLES AFAIK it's an option at install to install Xen as well.

Sign In or Register to comment.