Collectd Agent on SuSE Enterprise 12 SP5

Hello,
I need to install the Collectd agent on 'several 7 Suse Enterprise 12 SP5 servers that host Jira and Confluence.
For this version of SusSE, Collectd does not exist in the repositories.

What is the procedure to install it anyway please?
It is not possible to update the 7 production machines at this time.

Best Regards
Régis Duclos

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    @RegisD Hi and welcome to the Forum :)
    Looks like collectd doesn't build for SLE 12 as the libraries needed are not present.
    For example: https://build.opensuse.org/package/show/server:monitoring/collectd

    You would probably need to build an older version from source, however if there are bugs and security issues (eg CVE's) it may create more issues....

  • thanks for your answer, i will investigate and make some tests :)

  • malcolmlewismalcolmlewis Knowledge Partner
    edited April 26

    @RegisD Hi, the above build repository is the one used by SLE going to SUSE Package Hub, so you could look at the spec file as a template for an earlier release.

Sign In or Register to comment.