Upgrading SLES 15 SP2 to SP3 via SMT

MATTMATT Established Member

I have an SMT server that I've used to update and build SLES VMs. I now want to mirror the repos I need for upgrading my SLES 15 SP2 VMs to SLES 15 SP3. The workloads on these VMs are pretty basic, mostly NetIQ products. So I started adding the catalogs to mirror, trying to keep it limited to just what I need. Unfortunately, I keep adding catalogs as I cannot figure out what exactly is needed to do the migration. This is where I'm at now when I try and run a zypper migration, this shows as unavailable (and I think it is the one I want):

            SUSE Linux Enterprise Server 15 SP3 x86_64
            Basesystem Module 15 SP3 x86_64
            Desktop Applications Module 15 SP3 x86_64
            Server Applications Module 15 SP3 x86_64
            Containers Module 15 SP3 x86_64
            Python 2 Module 15 SP3 x86_64
            SUSE Package Hub 15 SP3 x86_64 (not available)
            SUSE Cloud Application Platform Tools Module 15 SP3 x86_64
            Transactional Server Module 15 SP3 x86_64
            Development Tools Module 15 SP3 x86_64
            Public Cloud Module 15 SP3 x86_64
            Web and Scripting Module 15 SP3 x86_64
            Legacy Module 15 SP3 x86_64
            NVIDIA Compute Module 15 x86_64

I still cannot figure out what is needed for "SUSE Package Hub 15". I also don't understand why I had to add some of these like "NVIDIA Compute Module". I've probably mirrored over another 100GB of stuff I don't think I really need. What's also weird is a SLES 15 SP2 migration is shown as available even though that is what this VM I'm testing with is already running:

Available migrations:

1 | SUSE Linux Enterprise Server 15 SP2 x86_64
    Desktop Applications Module 15 SP2 x86_64
    Python 2 Module 15 SP2 x86_64
    Transactional Server Module 15 SP2 x86_64
    SUSE Cloud Application Platform Tools Module 15 SP2 x86_64
    Public Cloud Module 15 SP2 x86_64
    Development Tools Module 15 SP2 x86_64
    NVIDIA Compute Module 15 x86_64
    Basesystem Module 15 SP2 x86_64 (already installed)
    Server Applications Module 15 SP2 x86_64 (already installed)
    Containers Module 15 SP2 x86_64 (already installed)
    Web and Scripting Module 15 SP2 x86_64 (already installed)
    Legacy Module 15 SP2 x86_64 (already installed)

Why does that appear as a target?

Thanks.
Matt

Comments

Sign In or Register to comment.