Failed dependencies error: Chrome linux browser install on Suse linux server.

Hi Experts,

Prior to upgrading Jaspersoft server to version 7.8, i am trying to get Chrome browser installed on our linux jaspersoft server.

Chrome install fails with following error; i a using rpm to install the rpm package as zypper is not allowed in our organisation.

Please help resolve this. thanks in advance.

user1-sles12sp3-cz1s:/tmp # rpm -ivh google-chrome-stable_current_x86_64.rpm
warning: google-chrome-stable_current_x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 7fac5991: NOKEY
error: Failed dependencies:
libXcomposite.so.1()(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libXext.so.6()(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libXfixes.so.3()(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libXrandr.so.2()(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libasound.so.2()(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libasound.so.2(ALSA_0.9)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libasound.so.2(ALSA_0.9.0rc4)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libatk-bridge-2.0.so.0()(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libcairo.so.2()(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
liberation-fonts is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libgdk-3.so.0()(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libgtk-3.so.0()(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnss3.so()(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnss3.so(NSS_3.10)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnss3.so(NSS_3.11)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnss3.so(NSS_3.12)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnss3.so(NSS_3.12.1)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnss3.so(NSS_3.12.4)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnss3.so(NSS_3.2)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnss3.so(NSS_3.22)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnss3.so(NSS_3.3)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnss3.so(NSS_3.4)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnss3.so(NSS_3.5)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnss3.so(NSS_3.6)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnss3.so(NSS_3.7)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnss3.so(NSS_3.9)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnss3.so(NSS_3.9.2)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnssutil3.so()(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnssutil3.so(NSSUTIL_3.12)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libnssutil3.so(NSSUTIL_3.12.3)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libpango-1.0.so.0()(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libsmime3.so()(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libsmime3.so(NSS_3.10)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libsmime3.so(NSS_3.2)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libssl3.so(NSS_3.28)(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libvulkan.so.1()(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
libxkbcommon.so.0()(64bit) is needed by google-chrome-stable-91.0.4472.164-1.x86_64
xdg-utils is needed by google-chrome-stable-91.0.4472.164-1.x86_64

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    @Deepu Hi and welcome to the Forum :)
    Seems strange that you can't use the package management tool designed to install/resolve dependencies? What about YaST Software Management tool?
    I suspect most are available via the original install media, eg the libnss error would be resolved by installing the mozilla-nss package, I don't think vulkan libs will be available.
    How is the system maintained for updates, or is the an air gaped system?
    Does the system have LTSS support, perhaps an upgraded to a supported release might be in order?

    As an aside, I would suggest heading over to the new Community to ask about this, only a few more days before these Forums will be read only..... https://forums.suse.com/discussion/15459/announcing-sunset-of-suse-forums-on-august-31-2021
    If you don't get any other replies in a day or so from other forum users, would suggest you head over to the new Community and ask there? Suggest https://community.suse.com/topics/3776090

Sign In or Register to comment.