Docking station stops working after update

Dell Precision 7740 with SLED 15.2. Fresh install, I can see the built-in display and three monitors connected to the WD19DC docking station. After installing updates, I only see the built-in display. xrandr --listproviders only shows one provider (before updates it showed two). Any suggestions to get the NVidia and docking station working again?


  • malcolmlewismalcolmlewis Knowledge Partner

    @Bobby Hi and welcome to the Forum :)
    I guess this system has the Quadra RTX mobile GPU.... Is the SLE-15-SP2-Desktop-NVIDIA-Driver repository enabled for the G05 (450.80.02) driver to support this card?

  • YaST Package Manager shows two SLE-15-SP2-Desktop-NVIDIA-Driver repositories and the nvidia-computeG05, nvidia-gfx05-kmp-default, nvidia-glG05 and x11-video-nvidiaG05 drivers installed.

    Running **zypper se x11-video-nvidiaG0*** shows the G05 package is installed.

    hwinfo --gfxcard | grep Model shows both nVidia and Intel cards. The NVIDIA X Server application will not launch.
    xrandr --listmonitors only shows one monitor "0: +XWAYLAND0...."

    I have reinstalled using different desktops with the same experience, everything works until I install all updates and then it breaks.

  • malcolmlewismalcolmlewis Knowledge Partner
    edited November 2020

    @Bobby Hi, can you log out and switch to X11 rather than Wayland? I would also edit /etc/gdm/custom.conf and unrem the line to set wayland to false. Then look at installing suse-prime to switch igpu/dgpu;

    On my desktop I use offloading instead to utilize the nvidia gpu.

  • Malcom, you are my hero!
    Switched to X11, disabled Wayland in the /etc/gdm/custom.conf file rebooted then ran prime-select nvidia.
    Logged out, and upon logging back in, all my screens are working!!!
    suse-prime was already installed with the Nvidia drivers.

    We use SLES for a few applications and I wanted to learn it, so we purchased SLED. Not being able to use all my monitors was depressing but I am so happy now. I cannot thank you enough!

Sign In or Register to comment.