Results 1 to 8 of 8

Thread: SLES12 SP3 auto config of init services with systemd fails

Threaded View

  1. SLES12 SP3 auto config of init services with systemd fails

    description:
    system: SLES12 SP3
    automatic start of systemd services migrated from init system does not work.
    systemd specifies that init services are migrated automatically as systemd services, this was working pretty well in SLES12 SP2.
    From SP3, they are still reported by systemd as enabled (systemctl is-enabled reports “enabled”). But they are not (systemctl start is rejected as service not existing), they must be enabled manually to be started (systemctl enable creates the related service file in /run/sytemd/generator.late, then start), and must be enabled again at next boot to be started manually again. The service files are not created automatically by systemd at installation in /run/systemd/generator.late.
    Moreover, they are suppressed from that directory at next boot (even after manual enable with systemctl enable), which does no more allow automatic start at system startup.

    The application is a 32 bit application which requires the installation of glibc-32bit package and its dependencies prior to be installed. Remark that from SP3 a systemd-32bit package is also installed with glibc-32bit.

    This is running well in SLES12 SP2. I.e. the init services are automatically enabled by systemd when they are installed and can be started directly with systemctl start (without manual enable), and they are started automatically at next boot.


    I applied all patches presently available for SLES12 SP3.


    should someone have an indication how to solve this or report this problem to developement, this would be welcome.

    thank you very much in advance,

    André
    Last edited by malcolmlewis; 03-Oct-2017 at 20:04. Reason: Fix Prefix

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •