Results 1 to 10 of 16

Thread: Unable to register servers with SMT - Download Failed. Abort

Threaded View

  1. Angry Unable to register servers with SMT - Download Failed. Abort

    I have followed everything to the T. Can't seem to get any of the servers (oes11 or oes10) to register with the SMT server.

    I try to run the clientSetup4SMT.sh on the server as so: ./clientSetup4SMT.sh https://smt.skokie68.org/center/regsvc and I get "download failed. abort."

    I tried doing ./clientSetup4SMT.sh --host smt.skokie68.org and still got "download failed. abort."

    I'm able to browse the "http://smt.skokie68.org/repo/tools/ClientSetup4SMT.sh" URL and download the clientSetup4SMT.sh file to each of my servers with no issue. My problem is registering my SLES11 and SLES10 servers to the SMT server.

    We do not have a proxy, nor do we have to use one to reach the server.

    I tried looking over the content of this TID but did not find anything that pertains to my issue: http://www.novell.com/support/kb/doc.php?id=7004748

    The only thing i noticed when I ran rcsmt status i get:

    Using apache2 conf plugin /etc/apache2/conf.d/nu_server.conf
    Using apache2 conf plugin /etc/apache2/conf.d/smt_mod_perl.conf
    Using apache2 conf plugin /etc/apache2/conf.d/smt_support.conf
    Not using apache2 vhosts plugin /etc/apache2/vhosts.d/vhost-ssl.conf (SMT not enabled)
    Using cron plugin /etc/cron.d/novell.com-smt
    Checking for httpd2: running
    Checking for service MySQL: running
    Checking for Cron: running

    The only part that doesn't look right is: Not using apache2 vhosts plugin /etc/apache2/vhosts.d/vhost-ssl.conf (SMT not enabled)

    The TID link shows this in its example: using apache2 vhosts plugin /etc/apache2/vhosts.d/vhost-ssl.conf

    I'm not sure why it wouldn't be using the vhost plugin... How do you go about enabling SMT to use the vhost plugin? Why didn't the installation enable it? Is this the cause of my problem?

    Nothing else on that page helped me or looked to be the reason to my "download failed. abort." error.

    I've tried going into yast, http server, and turning on ssl from the modules list but that didn't help.

    I downloaded SMT right off the novell site. In the notes I read, it requires SLES 11 sp2. I took a server, completely wiped it clean. I then booted off the SLES 11 sp2 dvd and began the OS install. When it gave me the option for "add on products" i put in the SMT cd in and it went from there. I did nothing custom and followed the SMT pdf step by step and it did not work right out of the box.

    Anyone have this issue and know how I can fix it?

    Thanks,

    -Paul
    Last edited by postaszewski; 01-May-2012 at 21:08.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •