Hi, I am hoping some kind soul can help with a problem here, regarding SLES 9.3
Why are we running such an old version of sles, you might ask. Well to cut a long story short
we are running some old equipment that wont run under any version greater than 9.3
Not least because some components required a recompiled kernel with the relevant patches etc added in
and no version of SLES over 9.3 would work.

Now onto the problem
We had to put some old text only serial terminals online and we we did everything necessary
to get the terminals running. That is a great success.
Now, though, whenever we start up the machine we get a situation where the keyboard
works for about 1 or two seconds at the graphical login screen for KDM (KDE).
after that we can enter no more text at the graphical screen
We have tried every edit of inittab known to humankind, we have done every edit of
KDMRC that has ever been discussed. We have tried absolutely everything
Our workaround so far has been this:

start the machine
1 wait for graphical login to appear
2 choose the option on the login page to go to console
3 At the text login use root as username and enter the password
4 at the command prompt type : exec KDM
This works

Now the questions
Is it possible to start the machine and do steps 2, 3 , and 4 automatically?
using a script or configuration file without having to type a username and password
at the console login so that we get back our ability to use the keyboard at the graphical login
For us we are sure this will work. I have spent sleepless night trying everything I know
but have had to admit defeat on this, so we have had our fill of inittab editing etc and are hoping
for a new approach

Thank you very much for any help you are able to offer