Results 1 to 4 of 4

Thread: container-suseconnect does not work on EC2 base images

Hybrid View

  1. #1

    container-suseconnect does not work on EC2 base images

    I installed docker and the image. I activated the image with sle2docker. I started the container, and tried to do stuff in it. However, it is always failing when I try to refresh the package repos.

    Code:
    ec2-user@ip-172-31-32-162:~> docker run --rm -it suse/sles11sp4-docker bash
    bash-3.2# zypper ref
    Refreshing service 'container-suseconnect'.
    Problem retrieving the repository index file for service 'container-suseconnect':
    [|]
    Skipping service 'container-suseconnect' because of the above error.
    There are no enabled repositories defined.
    Use 'zypper addrepo' or 'zypper modifyrepo' commands to add or enable repositories.
    SUSE connect says that the container module is installed:

    Code:
    ec2-user@ip-172-31-32-162:~> sudo SUSEConnect --list-extensions
    AVAILABLE EXTENSIONS AND MODULES
    
    
    FREE EXTENSIONS
    
      Toolchain Module 12 x86_64 (Installed)
      De-Install with:   SUSEConnect -d -p sle-module-toolchain/12/x86_64
    
      Legacy Module 12 x86_64 (Installed)
      De-Install with:   SUSEConnect -d -p sle-module-legacy/12/x86_64
    
      HPC Module 12 x86_64 (Installed)
      De-Install with:   SUSEConnect -d -p sle-module-hpc/12/x86_64
    
      Advanced Systems Management Module 12 x86_64 (Installed)
      De-Install with:   SUSEConnect -d -p sle-module-adv-systems-management/12/x86_64
    
      Web and Scripting Module 12 x86_64 (Installed)
      De-Install with:   SUSEConnect -d -p sle-module-web-scripting/12/x86_64
    
      SUSE Package Hub 12 SP3 x86_64 (Installed)
      De-Install with:   SUSEConnect -d -p PackageHub/12.3/x86_64
    
      Containers Module 12 x86_64 (Installed)
      De-Install with:   SUSEConnect -d -p sle-module-containers/12/x86_64
    
      SUSE Linux Enterprise Software Development Kit 12 SP3 x86_64 (Installed)
      De-Install with:   SUSEConnect -d -p sle-sdk/12.3/x86_64
    
      Public Cloud Module 12 x86_64 (Installed)
      De-Install with:   SUSEConnect -d -p sle-module-public-cloud/12/x86_64
    
    
    MORE INFORMATION
    
    You can find more information about available modules here:
    https://www.suse.com/products/server/features/modules.html
    And the images themselves install and activate just fine.

    So, what am I doing wrong? Does anyone have any advice for me? zypper works on the host system, just not on the containers.

  2. #2

    Re: container-suseconnect does not work on EC2 base images

    gregmeyer,

    It appears that in the past few days you have not received a response to your
    posting. That concerns us, and has triggered this automated reply.

    These forums are peer-to-peer, best effort, volunteer run and that if your issue
    is urgent or not getting a response, you might try one of the following options:

    - Visit http://www.suse.com/support and search the knowledgebase and/or check all
    the other support options available.
    - Open a service request: https://www.suse.com/support
    - You could also try posting your message again. Make sure it is posted in the
    correct newsgroup. (http://forums.suse.com)

    Be sure to read the forum FAQ about what to expect in the way of responses:
    http://forums.suse.com/faq.php

    If this is a reply to a duplicate posting or otherwise posted in error, please
    ignore and accept our apologies and rest assured we will issue a stern reprimand
    to our posting bot..

    Good luck!

    Your SUSE Forums Team
    http://forums.suse.com



  3. #3

    Re: container-suseconnect does not work on EC2 base images

    Sorry for the necro but I've just found this thread via google while searching for the same error message. I figured it out since then, so for anyone in the same shoes: you need to add the certificates/CAs to the image and trust them.

    Code:
    # Import the crt file of our private SMT server
    ADD http://smt.test.lan/smt.crt /etc/pki/trust/anchors/smt.crt
    RUN update-ca-certificates

  4. Re: container-suseconnect does not work on EC2 base images

    Hi enovaklbank,

    > Sorry for the necro

    no need to be sorry - solutions are always welcome, thank you for providing one!

    Regards
    J
    From the times when today's "old school" was "new school"

    If you find this post helpful and are logged into the web interface, show your appreciation and click on the star below...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •