I try to update Zabbix version from source. Now installed 3.2.1 version and Zabbix works properly. I do
Code:
/tmp/zabbix-3.4.3/configure --enable-server --enable-agent --with-mysql --with-net-snmp --with-libcurl --with-libxml2
and error appears:
Code:
... ... checking for libevent support... yes
checking for libpcre support... no
configure: error: Unable to use libpcre (libpcre check failed)
I've tried with keys --with-libpcre-include=/usr/lib64/ or/and --with-libpcre=/usr/lib64/ - the same effect. I've reinstall and update this library to newest version.
Output library folder:
Code:
zabbix:~ # ls -la /usr/lib/libpcre* /usr/lib64/libpcre*
lrwxrwxrwx 1 root root     18 Nov 10 14:44 /usr/lib64/libpcre16.so.0 -> libpcre16.so.0.2.9
-rwxr-xr-x 1 root root 555288 Oct 12 00:29 /usr/lib64/libpcre16.so.0.2.9
lrwxrwxrwx 1 root root     19 Nov 10 14:44 /usr/lib64/libpcrecpp.so.0 -> libpcrecpp.so.0.0.1
-rwxr-xr-x 1 root root  39424 Oct 12 00:29 /usr/lib64/libpcrecpp.so.0.0.1
lrwxrwxrwx 1 root root     21 Nov 10 14:45 /usr/lib64/libpcreposix.so.0 -> libpcreposix.so.0.0.5
-rwxr-xr-x 1 root root  10368 Oct 12 00:29 /usr/lib64/libpcreposix.so.0.0.5
-rwxr-xr-x 1 root root 452976 Dec  5  2016 /usr/lib64/libpcre.so.0
lrwxrwxrwx 1 root root     16 Nov 10 14:24 /usr/lib64/libpcre.so.1 -> libpcre.so.1.2.9
-rwxr-xr-x 1 root root 575784 Oct 12 00:29 /usr/lib64/libpcre.so.1.2.9
lrwxrwxrwx 1 root root     16 Nov 10 14:29 /usr/lib/libpcre.so.1 -> libpcre.so.1.2.9
-rwxr-xr-x 1 root root 579076 Oct 12 00:40 /usr/lib/libpcre.so.1.2.9
There are list of installed packages:
Code:
zabbix:~ # rpm -qa | grep libpcre
libpcrecpp0-8.41-2.3.x86_64
libpcre1-8.41-2.3.x86_64
libpcre1-32bit-8.41-2.3.x86_64
libpcre16-0-8.41-2.3.x86_64
libpcreposix0-8.41-2.3.x86_64
There are config file and log file. There isn't Internet connection on vitrual machine. SElinux and Apparmor are disabled. How can I fix the issue? Please, help me!