Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: fan noise and hot laptop

Hybrid View

  1. #1

    fan noise and hot laptop

    Hello,

    I have installed SLED 12 SP3 in my laptop.

    However, I noticed that there are a lot of noises probably from the fan. My laptop is also very hot....

    I have installed "powertop" and "GNOME Power Manager" in the machine....

    Does anybody have any advice?

    thx a lot

  2. Re: fan noise and hot laptop

    Quote Originally Posted by albumns View Post
    Hello,

    I have installed SLED 12 SP3 in my laptop.

    However, I noticed that there are a lot of noises probably from the fan. My laptop is also very hot....

    I have installed "powertop" and "GNOME Power Manager" in the machine....

    Does anybody have any advice?

    thx a lot
    Hi
    What does the output from the command sensors say?

    Can you control fans via the command pwconfig?

    What about the output from;
    Code:
    cpupower frequency-info
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Re: fan noise and hot laptop

    here it is;

    Code:
    analyzing CPU 0:
      driver: intel_pstate
      CPUs which run at the same hardware frequency: Not Available
      CPUs which need to have their frequency coordinated by software: Not Available
      maximum transition latency:  Cannot determine or is not supported.
      hardware limits: 800 MHz - 3.20 GHz
      available cpufreq governors: performance
      current policy: frequency should be within 800 MHz and 3.20 GHz.
                      The governor "powersave" may decide which speed to use
                      within this range.
      current CPU frequency: Unable to call hardware
      current CPU frequency: 3.20 GHz (asserted by call to kernel)
      boost state support:
        Supported: yes
        Active: yes


    Quote Originally Posted by malcolmlewis View Post
    Hi
    What does the output from the command sensors say?

    Can you control fans via the command pwconfig?

    What about the output from;
    Code:
    cpupower frequency-info

  4. Re: fan noise and hot laptop

    Hi
    What laptop is this again (Check label underneath for Model No:?

    So what about output as root user from;
    Code:
    sensors
    
    pwmconfig
    
    cpupower frequency-info
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Re: fan noise and hot laptop

    Hello,

    I got a Dell M3800 .

    Here is the output:

    Code:
    > sensors
    acpitz-virtual-0
    Adapter: Virtual device
    temp1:        +27.8C  (crit = +105.0C)
    temp2:       -267.1C  (crit = +105.0C)
    
    coretemp-isa-0000
    Adapter: ISA adapter
    Physical id 0:  +62.0C  (high = +84.0C, crit = +100.0C)
    Core 0:         +62.0C  (high = +84.0C, crit = +100.0C)
    Core 1:         +62.0C  (high = +84.0C, crit = +100.0C)
    Core 2:         +60.0C  (high = +84.0C, crit = +100.0C)
    Core 3:         +58.0C  (high = +84.0C, crit = +100.0C)
    Code:
    pwmconfig
    # pwmconfig revision 6243 (2014-03-20)
    This program will search your sensors for pulse width modulation (pwm)
    controls, and test each one to see if it controls a fan on
    your motherboard. Note that many motherboards do not have pwm
    circuitry installed, even if your sensor chip supports pwm.
    
    We will attempt to briefly stop each fan using the pwm controls.
    The program will attempt to restore each fan to full speed
    after testing. However, it is ** very important ** that you
    physically verify that the fans have been to full speed
    after the program has completed.
    
    /usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed
    Code:
    cpupower frequency-info
    analyzing CPU 0:
      driver: intel_pstate
      CPUs which run at the same hardware frequency: Not Available
      CPUs which need to have their frequency coordinated by software: Not Available
      maximum transition latency:  Cannot determine or is not supported.
      hardware limits: 800 MHz - 3.20 GHz
      available cpufreq governors: performance
      current policy: frequency should be within 800 MHz and 3.20 GHz.
                      The governor "powersave" may decide which speed to use
                      within this range.
      current CPU frequency: 2.99 GHz (asserted by call to hardware)
      boost state support:
        Supported: yes
        Active: yes

  6. Re: fan noise and hot laptop

    Hi
    If you (as root user) run the command sensors-detect, does it add more eg dell_smm?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7

    Re: fan noise and hot laptop

    Quote Originally Posted by malcolmlewis View Post
    Hi
    If you (as root user) run the command sensors-detect, does it add more eg dell_smm?
    here is what I have

    Code:
    sensors-detect
    # sensors-detect revision 6284 (2015-05-31 14:00:33 +0200)
    # System: Dell Inc. Dell Precision M3800 [A09] (laptop)
    # Kernel: 4.4.92-6.18-default x86_64
    # Processor: Intel(R) Core(TM) i7-4702HQ CPU @ 2.20GHz (6/60/3)
    
    This program will help you determine which kernel modules you need
    to load to use lm_sensors most effectively. It is generally safe
    and recommended to accept the default answers to all questions,
    unless you know what you're doing.
    
    Some south bridges, CPUs or memory controllers contain embedded sensors.
    Do you want to scan for them? This is totally safe. (YES/no): yes
    Module cpuid loaded successfully.
    Silicon Integrated Systems SIS5595...                       No
    VIA VT82C686 Integrated Sensors...                          No
    VIA VT8231 Integrated Sensors...                            No
    AMD K8 thermal sensors...                                   No
    AMD Family 10h thermal sensors...                           No
    AMD Family 11h thermal sensors...                           No
    AMD Family 12h and 14h thermal sensors...                   No
    AMD Family 15h thermal sensors...                           No
    AMD Family 16h thermal sensors...                           No
    AMD Family 15h power sensors...                             No
    AMD Family 16h power sensors...                             No
    Intel digital thermal sensor...                             Success!
        (driver `coretemp')
    Intel AMB FB-DIMM thermal sensor...                         No
    Intel 5500/5520/X58 thermal sensor...                       No
    VIA C7 thermal sensor...                                    No
    VIA Nano thermal sensor...                                  No
    
    Some Super I/O chips contain embedded sensors. We have to write to
    standard I/O ports to probe them. This is usually safe.
    Do you want to scan for Super I/O sensors? (YES/no): yes
    Probing for Super-I/O at 0x2e/0x2f
    Trying family `National Semiconductor/ITE'...               No
    Trying family `SMSC'...                                     No
    Trying family `VIA/Winbond/Nuvoton/Fintek'...               No
    Trying family `ITE'...                                      No
    Probing for Super-I/O at 0x4e/0x4f
    Trying family `National Semiconductor/ITE'...               No
    Trying family `SMSC'...                                     No
    Trying family `VIA/Winbond/Nuvoton/Fintek'...               No
    Trying family `ITE'...                                      No
    
    Some hardware monitoring chips are accessible through the ISA I/O ports.
    We have to write to arbitrary I/O ports to probe them. This is usually
    safe though. Yes, you do have ISA I/O ports even if you do not have any
    ISA slots! Do you want to scan the ISA I/O ports? (YES/no): y
    Probing for `National Semiconductor LM78' at 0x290...       No
    Probing for `National Semiconductor LM79' at 0x290...       No
    Probing for `Winbond W83781D' at 0x290...                   No
    Probing for `Winbond W83782D' at 0x290...                   No
    
    Lastly, we can probe the I2C/SMBus adapters for connected hardware
    monitoring devices. This is the most risky part, and while it works
    reasonably well on most systems, it has been reported to cause trouble
    on some systems.
    Do you want to probe the I2C/SMBus adapters now? (YES/no): y
    Using driver `i2c-i801' for device 0000:00:1f.3: Intel Lynx Point (PCH)
    Module i2c-dev loaded successfully.
    
    Next adapter: i915 gmbus ssc (i2c-0)
    Do you want to scan it? (yes/NO/selectively): y
    
    Next adapter: i915 gmbus vga (i2c-1)
    Do you want to scan it? (yes/NO/selectively): y
    
    Next adapter: i915 gmbus panel (i2c-2)
    Do you want to scan it? (yes/NO/selectively): y
    
    Next adapter: i915 gmbus dpc (i2c-3)
    Do you want to scan it? (yes/NO/selectively): y
    
    Next adapter: i915 gmbus dpb (i2c-4)
    Do you want to scan it? (yes/NO/selectively): y
    Client found at address 0x4a
    Probing for `National Semiconductor LM75'...                No
    Probing for `National Semiconductor LM75A'...               No
    Probing for `Dallas Semiconductor DS75'...                  No
    Probing for `National Semiconductor LM77'...                No
    Probing for `Analog Devices ADT7410/ADT7420'...             No
    Probing for `Analog Devices ADT7411'...                     No
    Probing for `Maxim MAX6642'...                              No
    Probing for `Texas Instruments TMP435'...                   No
    Probing for `National Semiconductor LM73'...                No
    Probing for `National Semiconductor LM92'...                No
    Probing for `National Semiconductor LM76'...                No
    Probing for `Maxim MAX6633/MAX6634/MAX6635'...              No
    Probing for `NXP/Philips SA56004'...                        No
    Client found at address 0x4b
    Probing for `National Semiconductor LM75'...                No
    Probing for `National Semiconductor LM75A'...               No
    Probing for `Dallas Semiconductor DS75'...                  No
    Probing for `National Semiconductor LM77'...                No
    Probing for `Analog Devices ADT7410/ADT7420'...             No
    Probing for `Analog Devices ADT7411'...                     No
    Probing for `Maxim MAX6642'...                              No
    Probing for `Texas Instruments TMP435'...                   No
    Probing for `National Semiconductor LM92'...                No
    Probing for `National Semiconductor LM76'...                No
    Probing for `Maxim MAX6633/MAX6634/MAX6635'...              No
    Probing for `NXP/Philips SA56004'...                        No
    Probing for `Analog Devices ADT7481'...                     No
    
    Next adapter: i915 gmbus dpd (i2c-5)
    Do you want to scan it? (yes/NO/selectively): y
    
    Next adapter: DPDDC-A (i2c-6)
    Do you want to scan it? (yes/NO/selectively): y
    
    Next adapter: DPDDC-C (i2c-7)
    Do you want to scan it? (yes/NO/selectively): y
    
    Next adapter: SMBus I801 adapter at f040 (i2c-8)
    Do you want to scan it? (YES/no/selectively): y
    Client found at address 0x29
    Probing for `National Semiconductor LM78'...                No
    Probing for `National Semiconductor LM79'...                No
    Probing for `National Semiconductor LM80'...                No
    Probing for `National Semiconductor LM96080'...             No
    Probing for `Winbond W83781D'...                            No
    Probing for `Winbond W83782D'...                            No
    Probing for `Nuvoton NCT7802Y'...                           No
    Probing for `Winbond W83627HF'...                           No
    Probing for `Winbond W83627EHF'...                          No
    Probing for `Winbond W83627DHG/W83667HG/W83677HG'...        No
    Probing for `Asus AS99127F (rev.1)'...                      No
    Probing for `Asus AS99127F (rev.2)'...                      No
    Probing for `Asus ASB100 Bach'...                           No
    Probing for `Analog Devices ADM1021'...                     No
    Probing for `Analog Devices ADM1021A/ADM1023'...            No
    Probing for `Maxim MAX1617'...                              No
    Probing for `Maxim MAX1617A'...                             No
    Probing for `Maxim MAX1668'...                              No
    Probing for `Maxim MAX1805'...                              No
    Probing for `Maxim MAX1989'...                              No
    Probing for `Maxim MAX6655/MAX6656'...                      No
    Probing for `TI THMC10'...                                  No
    Probing for `National Semiconductor LM84'...                No
    Probing for `Genesys Logic GL523SM'...                      No
    Probing for `Onsemi MC1066'...                              No
    Probing for `Maxim MAX1618'...                              No
    Probing for `Maxim MAX1619'...                              No
    Probing for `National Semiconductor LM82/LM83'...           No
    Probing for `Maxim MAX6654'...                              No
    Probing for `Maxim MAX6690'...                              No
    Probing for `Maxim MAX6680/MAX6681'...                      No
    Probing for `Maxim MAX6695/MAX6696'...                      No
    Probing for `Texas Instruments TMP400'...                   No
    Probing for `National Semiconductor LM95235'...             No
    Probing for `National Semiconductor LM95245'...             No
    Probing for `Analog Devices ADM1029'...                     No
    Probing for `ITE IT8712F'...                                No
    Probing for `SMSC EMC1402'...                               No
    Probing for `SMSC EMC1403'...                               No
    Probing for `SMSC EMC1404'...                               No
    
    
    Now follows a summary of the probes I have just done.
    Just press ENTER to continue: 
    
    Driver `coretemp':
      * Chip `Intel digital thermal sensor' (confidence: 9)
    
    Do you want to generate /etc/sysconfig/lm_sensors? (YES/no): y
    Created symlink from /etc/systemd/system/multi-user.target.wants/lm_sensors.service to /usr/lib/systemd/system/lm_sensors.service.
    Unloading i2c-dev... OK
    Unloading cpuid... OK

  8. #8

    Re: fan noise and hot laptop

    btw, I noticed that I always get the following messages when I boot my SUSE:

    Code:
    ERROR
    tail to load kernel

  9. #9

    Re: fan noise and hot laptop

    Code:
    sudo systemctl status systemd-modules-load.service
    [sudo] password for root: 
    ● systemd-modules-load.service - Load Kernel Modules
       Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
       Active: failed (Result: exit-code) since Tue 2017-12-05 20:19:53 CET; 2min 23s ago
         Docs: man:systemd-modules-load.service(8)
               man:modules-load.d(5)
      Process: 437 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
     Main PID: 437 (code=exited, status=1/FAILURE)
    
    Dec 05 20:19:53 dream systemd-modules-load[437]: Failed to insert 'bbswitch': N...e
    Dec 05 20:19:53 dream systemd[1]: systemd-modules-load.service: Main process e...RE
    Dec 05 20:19:53 dream systemd[1]: Failed to start Load Kernel Modules.
    Dec 05 20:19:53 dream systemd[1]: systemd-modules-load.service: Unit entered f...e.
    Dec 05 20:19:53 dream systemd[1]: systemd-modules-load.service: Failed with re...'.
    Hint: Some lines were ellipsized, use -l to show in full.

  10. Re: fan noise and hot laptop

    On Tue 05 Dec 2017 07:24:02 PM CST, albumns wrote:

    Code:
    --------------------

    sudo systemctl status systemd-modules-load.service
    [sudo] password for root:
    ● systemd-modules-load.service - Load Kernel Modules
    Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service;
    static; vendor preset: disabled) Active: failed (Result: exit-code)
    since Tue 2017-12-05 20:19:53 CET; 2min 23s ago Docs:
    man:systemd-modules-load.service(8) man:modules-load.d(5)
    Process: 437 ExecStart=/usr/lib/systemd/systemd-modules-load
    (code=exited, status=1/FAILURE) Main PID: 437 (code=exited,
    status=1/FAILURE)
    Dec 05 20:19:53 dream systemd-modules-load[437]: Failed to insert
    'bbswitch': N...e Dec 05 20:19:53 dream systemd[1]:
    systemd-modules-load.service: Main process e...RE Dec 05 20:19:53 dream
    systemd[1]: Failed to start Load Kernel Modules. Dec 05 20:19:53 dream
    systemd[1]: systemd-modules-load.service: Unit entered f...e. Dec 05
    20:19:53 dream systemd[1]: systemd-modules-load.service: Failed with
    re...'. Hint: Some lines were ellipsized, use -l to show in full.

    --------------------


    Hi
    You need to rebuild the kmp's (src rpms) from the bumblebee repo
    and install the resulting kmp since they don't match the running
    kernel...

    As your user;
    Code:
    cd ~/
    mkdir bbswitch
    cd bbswitch
    wget http://download.opensuse.org/repositories/X11:/Bumblebee/SLE_12_SP3_Backports/src/bbswitch-0.8-28.1.src.rpm
    rpmbuild --rebuild bbswitch-0.8-28.1.src.rpm
    su -
    cd /home/<username>/rpmbuild/RPMS/x86_64/
    zypper in *kmp*
    This maybe the reason for your fan issue, resolve above and see how it
    goes.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.92-18.36-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •